Bug 268823 - Plasma-desktop crashed while deconnecting from internet
Summary: Plasma-desktop crashed while deconnecting from internet
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-18 15:18 UTC by Lewkow Brigitte
Modified: 2011-03-18 22:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lewkow Brigitte 2011-03-18 15:18:09 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-26-preempt x86_64
Distribution: KXStudio 10.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I was surfing and decided to deconnect by disabling "activate Network".. That's all!

-- Backtrace:
Application: Espace de travail Plasma (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f5a54dad707 in QMetaObject::cast (this=0x7f5a3c3c9ee0, obj=0x20bb4d0) at kernel/qmetaobject.cpp:266
#7  0x00007f5a3c4143d0 in ActivatableListWidget::hoverEnter (this=<value optimized out>, uni=...) at ../../applet/activatablelistwidget.cpp:286
#8  0x00007f5a3c40be61 in ActivatableListWidget::qt_metacall (this=0x12b09b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc00bdbb0) at moc_activatablelistwidget.cpp:101
#9  0x00007f5a54dbfda7 in QMetaObject::activate (sender=0x11d99b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1265110) at kernel/qobject.cpp:3280
#10 0x00007f5a3c40b2a5 in InterfaceItem::hoverEnter (this=0x20bb4d0, _t1=<value optimized out>) at moc_interfaceitem.cpp:164
#11 0x00007f5a3c416395 in InterfaceItem::hoverEnterEvent (this=0x11d99b0, event=0x7fffc00bdc60) at ../../applet/interfaceitem.cpp:457
#12 0x00007f5a5451a4b2 in QGraphicsItem::sceneEvent (this=0x11d99c0, event=0x20bb4d0) at graphicsview/qgraphicsitem.cpp:6654
#13 0x00007f5a5452f82f in QGraphicsScenePrivate::sendHoverEvent (this=0x8d7d90, type=<value optimized out>, item=0x11d99c0, hoverEvent=0x7fffc00bddf0) at graphicsview/qgraphicsscene.cpp:1258
#14 0x00007f5a54535588 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x8d7d90, hoverEvent=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3921
#15 0x00007f5a545358a4 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=0x7fffc00be4c0) at graphicsview/qgraphicsscene.cpp:4080
#16 0x00007f5a545465ab in QGraphicsScene::event (this=0x9cb420, event=0x7fffc00be4c0) at graphicsview/qgraphicsscene.cpp:3437
#17 0x00007f5a53ef66ec in QApplicationPrivate::notify_helper (this=0x8e8d00, receiver=0x9cb420, e=0x7fffc00be4c0) at kernel/qapplication.cpp:4396
#18 0x00007f5a53efc1dd in QApplication::notify (this=0x8c8aa0, receiver=0x9cb420, e=0x7fffc00be4c0) at kernel/qapplication.cpp:4277
#19 0x00007f5a55a60926 in KApplication::notify (this=0x8c8aa0, receiver=0x9cb420, event=0x7fffc00be4c0) at ../../kdeui/kernel/kapplication.cpp:310
#20 0x00007f5a54da80ac in QCoreApplication::notifyInternal (this=0x8c8aa0, receiver=0x9cb420, event=0x7fffc00be4c0) at kernel/qcoreapplication.cpp:732
#21 0x00007f5a54564e77 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x120ea60, event=0x7fffc00bf020) at graphicsview/qgraphicsview.cpp:647
#22 0x00007f5a5456506e in QGraphicsView::mouseMoveEvent (this=0x120d620, event=0x7fffc00bf020) at graphicsview/qgraphicsview.cpp:3272
#23 0x00007f5a53f4c0eb in QWidget::event (this=0x120d620, event=0x7fffc00bf020) at kernel/qwidget.cpp:8172
#24 0x00007f5a54312e76 in QFrame::event (this=0x120d620, e=0x7fffc00bf020) at widgets/qframe.cpp:557
#25 0x00007f5a54562afb in QGraphicsView::viewportEvent (this=0x120d620, event=0x7fffc00bf020) at graphicsview/qgraphicsview.cpp:2862
#26 0x00007f5a54da78d7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1210840, event=0x7fffc00bf020) at kernel/qcoreapplication.cpp:847
#27 0x00007f5a53ef66bc in QApplicationPrivate::notify_helper (this=0x8e8d00, receiver=0x1210840, e=0x7fffc00bf020) at kernel/qapplication.cpp:4392
#28 0x00007f5a53efc9fe in QApplication::notify (this=0x8c8aa0, receiver=0x1210840, e=0x7fffc00bf020) at kernel/qapplication.cpp:3959
#29 0x00007f5a55a60926 in KApplication::notify (this=0x8c8aa0, receiver=0x1210840, event=0x7fffc00bf020) at ../../kdeui/kernel/kapplication.cpp:310
#30 0x00007f5a54da80ac in QCoreApplication::notifyInternal (this=0x8c8aa0, receiver=0x1210840, event=0x7fffc00bf020) at kernel/qcoreapplication.cpp:732
#31 0x00007f5a53efb4ae in QCoreApplication::sendEvent (receiver=0x1210840, event=0x7fffc00bf020, alienWidget=0x1210840, nativeWidget=0x120bab0, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#32 QApplicationPrivate::sendMouseEvent (receiver=0x1210840, event=0x7fffc00bf020, alienWidget=0x1210840, nativeWidget=0x120bab0, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#33 0x00007f5a53f7e4a5 in QETWidget::translateMouseEvent (this=0x120bab0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#34 0x00007f5a53f7cddc in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffc00bf940) at kernel/qapplication_x11.cpp:3536
#35 0x00007f5a53fa9012 in x11EventSourceDispatch (s=0x8ec680, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007f5a4c4108c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#37 0x00007f5a4c414748 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007f5a4c4148fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#39 0x00007f5a54dd4183 in QEventDispatcherGlib::processEvents (this=0x8ad860, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#40 0x00007f5a53fa897e in QGuiEventDispatcherGlib::processEvents (this=0x20bb4d0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f5a54da6dd2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007f5a54da71bc in QEventLoop::exec (this=0x7fffc00bfc70, flags=) at kernel/qeventloop.cpp:201
#43 0x00007f5a54dab26b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#44 0x00007f5a57a3b083 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#45 0x00007f5a57699c4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffc00c0048) at libc-start.c:226
#46 0x00000000004006c9 in _start ()

Possible duplicates by query: bug 268516, bug 267206, bug 265553, bug 263955, bug 261019.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-18 22:16:12 UTC

*** This bug has been marked as a duplicate of bug 253584 ***