Bug 106030 - Crash when retrieving mail (cachedimap)
Summary: Crash when retrieving mail (cachedimap)
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: disconnected IMAP (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash with 101 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 108030 113487 117342 119062 120270 127863 131658 132032 137381 138522 140407 143478 152602 155272 169599 171218 175825 177308 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-05-20 18:54 UTC by Josh Berry
Modified: 2009-01-03 16:14 UTC (History)
20 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
valgrind output (6.81 KB, text/plain)
2006-01-17 21:48 UTC, Christian Loose
Details
valgrind output (80.97 KB, application/octet-stream)
2008-11-23 12:00 UTC, Jaime Torres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Berry 2005-05-20 18:54:45 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.4.3 
OS:                Linux

When KMail attempts to check mail (using cachedimap against a Courier IMAP server), it sometimes will crash with the following backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1246779728 (LWP 11729)]
[KCrash handler]
#4  0x00000004 in ?? ()
#5  0xb7d382af in KMFolderImap::flagsToStatus ()
   from /opt/kdesvn/lib/libkmailprivate.so
#6  0xb7d5cb35 in KMFolderCachedImap::slotGetMessagesData ()
   from /opt/kdesvn/lib/libkmailprivate.so
#7  0xb7d5d45a in KMFolderCachedImap::qt_invoke ()
   from /opt/kdesvn/lib/libkmailprivate.so
#8  0xb6183454 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#9  0xb6cffdee in KIO::TransferJob::data () from /opt/kdesvn/lib/libkio.so.4
#10 0xb6cffe5a in KIO::TransferJob::slotData ()
   from /opt/kdesvn/lib/libkio.so.4
#11 0xb6cfff3c in KIO::TransferJob::qt_invoke ()
   from /opt/kdesvn/lib/libkio.so.4
#12 0xb6183454 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#13 0xb6ce9108 in KIO::SlaveInterface::data ()
   from /opt/kdesvn/lib/libkio.so.4
#14 0xb6ced0c0 in KIO::SlaveInterface::dispatch ()
   from /opt/kdesvn/lib/libkio.so.4
#15 0xb6ceb508 in KIO::SlaveInterface::dispatch ()
   from /opt/kdesvn/lib/libkio.so.4
#16 0xb6ce5333 in KIO::Slave::gotInput () from /opt/kdesvn/lib/libkio.so.4
#17 0xb6ce62c9 in KIO::Slave::qt_invoke () from /opt/kdesvn/lib/libkio.so.4
#18 0xb6183454 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb6183a24 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb64c224e in QSocketNotifier::activated ()
   from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb619f1ce in QSocketNotifier::event () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb6122d3e in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb6122ecd in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb674c5b4 in KApplication::notify () from /opt/kdesvn/lib/libkdecore.so.4
#25 0xb6116fde in QEventLoop::activateSocketNotifiers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb60d152c in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#27 0xb6138b75 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb6138ace in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb6122029 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#30 0x0804a7a4 in main ()
Comment 1 Carsten Burghardt 2005-05-21 12:26:11 UTC
Thanks for the report, please compile kmail with --enable-debug=full to get a 
valid backtrace.
Comment 2 Josh Berry 2005-05-23 07:29:49 UTC
D'oh ... I didn't catch the fact that debug wasn't enabled.  Sorry about that.  Here's a new backtrace for you:

Using host libthread_db library "/lib/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1246267728 (LWP 13082)]
[KCrash handler]
#4  0x00000074 in ?? ()
#5  0xb7dd87f5 in KMFolderImap::flagsToStatus (msg=0x85d4ae0, flags=1, 
    newMsg=true) at kmfolderimap.cpp:1325
#6  0xb7df150c in KMFolderCachedImap::slotGetMessagesData (this=0x8397e20, 
    job=0xb6659ee8, data=@0xbf9f6800) at kmfoldercachedimap.cpp:1402
#7  0xb7df1e2c in KMFolderCachedImap::qt_invoke (this=0x8397e20, 
    _id=137985568, _o=0x85cd8d8) at kmfoldercachedimap.moc:370
#8  0xb6200454 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#9  0xb6d337a4 in KIO::TransferJob::data (this=0x85cd8d8, t0=0x85c4328, 
    t1=@0x85c4328) at jobclasses.moc:972
#10 0xb6d33812 in KIO::TransferJob::slotData (this=0x85cd8d8, 
    _data=@0x85c4328) at job.cpp:878
#11 0xb6d33923 in KIO::TransferJob::qt_invoke (this=0x85cd8d8, 
    _id=-1080072956, _o=0xb666d03c) at jobclasses.moc:1051
#12 0xb6200454 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#13 0xb6d1db54 in KIO::SlaveInterface::data () at jobclasses.h:1142
#14 0xb6d21b0c in KIO::SlaveInterface::dispatch () at jobclasses.h:1142
#15 0xb6d1ff54 in KIO::SlaveInterface::dispatch () at jobclasses.h:1142
#16 0xb6d1afe5 in KIO::Slave::gotInput (this=0xbf9f6800) at slave.cpp:300
#17 0xb6d1b4e8 in KIO::Slave::qt_invoke (this=0x847c040, _id=4, _o=0xbf9f6940)
    at slave.moc:113
#18 0xb6200454 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb6200a24 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb653f24e in QSocketNotifier::activated ()
   from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb621c1ce in QSocketNotifier::event () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb619fd3e in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb619fecd in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb67ca114 in KApplication::notify (this=0xbf9f70c0, receiver=0x84cf350, 
    event=0xbf9f6d70) at kapplication.cpp:549
#25 0xb6193fde in QEventLoop::activateSocketNotifiers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb614e52c in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#27 0xb61b5b75 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb61b5ace in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb619f029 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#30 0x0804a9f2 in main (argc=140264232, argv=0x85c4328) at main.cpp:110
Comment 3 Antonio Larrosa 2005-05-25 12:35:47 UTC
I got this bug (with same backtrace than previously posted) after compiling kdepim on 20/05.  I tried regenerating the index and even rebuilding the cache, but even if both worked as they're supposed to, kmail continued crashing when checking mail in my inbox folder.

I tried some previous revisions to find the commit that caused the problem. svn commit number 413366 already was buggy, then I tried the previous kmail version I was using (just to see that the bug didn't happen with that one) and it worked fine (it checked and downloaded mails correctly), then I tried again one of the buggy versions, and it worked fine.

It seems using the working version somehow removed the cause of the problem when neither regenerating the indexes nor rebuilding the cache did that.

So it works now, and all I can say is that the bug was committed between the 25/03 and revision 413366. 

Btw, the crash happens at 

   if (msg->isOfUnknownStatus() || !(flags&1) ) {

(currently at kmfolderimap.cpp:1333 in svn). I run the bad kmail under valgrind and it said that the problem was that msg was already deleted.

Hope that helps.
Comment 4 Antonio Larrosa 2005-05-30 21:23:43 UTC
I got this problem again, so I tried several revisions until I found the change that introduced the bug: 409056 .
409055 works fine, so using svn diff -r 409055:409056 shows the change that breaks it.

Please CC me if you reply to this via mail

Comment 5 Josh Berry 2005-07-19 19:05:15 UTC
This bug also occurs with regular IMAP, however, it occurs when selecting a folder to see what messages are inside it.

My off-the-wall guess is that this is somehow related to the saved-search folders... I will try removing mine and see if that stops KMail from crashing.

Here is some hopefully-useful information from Valgrind and KMail's debug output:

kmail: check mail started - connections for host mail.condordes.net now is 1
...
[Qt valgrind message snipped]
...
kmail: slotCheckNamespace -
kmail: slotCheckNamespace -
kmail: capabilities:(imap4rev1,uidplus,children,namespace,thread=orderedsubject,thread=references,sort,quota,idle,auth=plain,acl,acl2=union)
kmail: processNextCheck, remaining 0
kmail: account CondorNet finished check
kmail: connections to server mail.condordes.net now 0
kmail: 7 new message(s) in .1453189113.directory/.INBOX.directory/.oss.directory/kde-devel
kmail: 83 new message(s) in .1453189113.directory/.INBOX.directory/interesting-people
kmail: 78 new message(s) in .1453189113.directory/.INBOX.directory/spam
kmail: processNextCheck, remaining 1
kmail: for host mail.condordes.net current connections=0 and limit is 0
kmail: connection limit reached: false
kmail: processing next mail check for CondorNet
kmail: processNewMail true,status=1
kmail: KMFolderImap::checkValidity of: /INBOX/
kmail: check mail started - connections for host mail.condordes.net now is 1
...
[Qt valgrind message snipped]
...
kmail: account CondorNet busy, queuing
kmail: pos[0] 0x1e47ff48 true
kmail: KMFolderImap::slotCheckValidityResult of: INBOX
...
[More Qt valgrind messages]
...
kmail: [QString KMail::SearchJob::searchStringFromPattern(const KMSearchPattern*)] ;localSearch=(match all of the following)
        "<status>" <contains> "Important"
kmail: inbox: serNum 7052 matches?false
==28883==
==28883== Invalid read of size 4
==28883==    at 0x1BC5BFEB: KMFolderImap::flagsToStatus(KMMsgBase*, int, bool) (kmfolderimap.cpp:1362)
==28883==    by 0x1BC64AB2: KMFolderImap::slotGetMessagesData(KIO::Job*, QMemArray<char> const&) (kmfolderimap.cpp:1499)
==28883==    by 0x1BC67AEA: KMFolderImap::qt_invoke(int, QUObject*) (kmfolderimap.moc:324)
==28883==    by 0x1D4FD6F5: QObject::activate_signal(QConnectionList*, QUObject*) (in /usr/qt/3/lib/libqt-mt.so.3.3.4)
==28883==    by 0x1CB0C313: KIO::TransferJob::data(KIO::Job*, QMemArray<char> const&) (jobclasses.moc:993)
==28883==    by 0x1CB0C381: KIO::TransferJob::slotData(QMemArray<char> const&) (job.cpp:900)
==28883==    by 0x1CB0C492: KIO::TransferJob::qt_invoke(int, QUObject*) (jobclasses.moc:1072)
==28883==    by 0x1D4FD6F5: QObject::activate_signal(QConnectionList*, QUObject*) (in /usr/qt/3/lib/libqt-mt.so.3.3.4)
==28883==    by 0x1CAF7EE9: KIO::SlaveInterface::data(QMemArray<char> const&) (slaveinterface.moc:194)
==28883==    by 0x1CAFA91A: KIO::SlaveInterface::dispatch(int, QMemArray<char> const&) (slaveinterface.cpp:234)
==28883==  Address 0x1EB8E8B8 is 0 bytes inside a block of size 96 free'd
==28883==    at 0x1B905DD0: operator delete(void*) (vg_replace_malloc.c:155)
==28883==    by 0x1BAF6D39: KMMessage::~KMMessage() (kmmessage.cpp:194)
==28883==    by 0x1BC376F4: KMMsgList::set(unsigned, KMMsgBase*) (kmmsglist.cpp:100)
==28883==    by 0x1BD30B3D: KMFolderIndex::setIndexEntry(int, KMMessage*) (kmfolderindex.cpp:478)
==28883==    by 0x1BBD667A: FolderStorage::unGetMsg(int) (folderstorage.cpp:541)
==28883==    by 0x1BDB97ED: KMail::SearchJob::slotSearchMessageArrived(KMMessage*) (searchjob.cpp:308)
==28883==    by 0x1BDB9D24: KMail::SearchJob::slotSearchDataSingleMessage(KIO::Job*, QString const&) (searchjob.cpp:408)
==28883==    by 0x1BDB9D94: KMail::SearchJob::searchSingleMessage() (searchjob.cpp:353)
==28883==    by 0x1BDBAE15: KMail::SearchJob::execute() (searchjob.cpp:69)
==28883==    by 0x1BD37CBC: KMail::FolderJob::start() (folderjob.cpp:109)
...
[more valgrind errors about accesses to the same structure, from the same place]
...
pure virtual method called
terminate called without an active exception
*** KMail got signal 6 (Crashing)
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kmail path = <unknown> pid = 28883
Comment 6 Josh Berry 2005-07-19 19:11:25 UTC
Sure enough, getting rid of my saved searches stopped the crash.

When I attempt to start a new search, I get the search dialog, enter in my search terms, click "Search", and ... crash.

I'm not sure if details from that crash should go into this bug, or if I should open a new one.
Comment 7 Till Adam 2005-07-21 22:44:05 UTC
SVN commit 437417 by tilladam:

Don't unget messages we did not get ourselves.

Antonio, does that help with the crash?

CCBUG: 106030


 M  +4 -2      searchjob.cpp  
 M  +1 -0      searchjob.h  


--- trunk/KDE/kdepim/kmail/searchjob.cpp #437416:437417
@@ -52,7 +52,8 @@
                       const KMSearchPattern* pattern, Q_UINT32 serNum )
  : FolderJob( 0, tOther, (folder ? folder->folder() : 0) ),
    mFolder( folder ), mAccount( account ), mSearchPattern( pattern ),
-   mSerNum( serNum ), mRemainingMsgs( 0 ), mProgress( 0 )
+   mSerNum( serNum ), mRemainingMsgs( 0 ), mProgress( 0 ),
+   mUngetCurrentMsg( false )
 {
 }
 
@@ -304,7 +305,7 @@
     int idx = -1;
     KMFolder * p = 0;
     KMMsgDict::instance()->getLocation( msg, &p, &idx );
-    if ( idx != -1 )
+    if ( idx != -1 && mUngetCurrentMsg )
       mFolder->unGetMsg( idx );
   }
   if ( mSerNum > 0 )
@@ -397,6 +398,7 @@
   KMFolder *aFolder = 0;
   KMMsgDict::instance()->getLocation( mSerNum, &aFolder, &idx );
   assert(aFolder && (idx != -1));
+  mUngetCurrentMsg = !mFolder->getMsgBase( idx )->isMessage();
   KMMessage * msg = mFolder->getMsg( idx );
   if ( needsDownload() ) {
     ImapJob *job = new ImapJob( msg );
--- trunk/KDE/kdepim/kmail/searchjob.h #437416:437417
@@ -126,6 +126,7 @@
   uint mRemainingMsgs;
   // progress item for local searches
   KPIM::ProgressItem *mProgress;
+  bool mUngetCurrentMsg;
 
 };
 
Comment 8 Josh Berry 2005-08-03 01:54:52 UTC
I can't reproduce this crash anymore, so I'm assuming Till's commit fixed it.

As the reporter, I'm going to go ahead and close this bug.
Comment 9 Till Adam 2005-08-10 09:19:17 UTC
On Wednesday 03 August 2005 01:54, Josh Berry wrote:

> As the reporter, I'm going to go ahead and close this bug.


Thanks for following up, I wish everyone did that. :)

Till
Comment 10 Josh Berry 2005-09-27 01:51:30 UTC
This bug seems to have reappeared again, at least in the past few days...

Using host libthread_db library "/lib/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1251080528 (LWP 6932)]
[KCrash handler]
#4  0xb7dac26e in KMFolderImap::flagsToStatus (msg=0x8639f40, flags=1, 
    newMsg=true)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmfolderimap.cpp:1369
#5  0xb7dc7b31 in KMFolderCachedImap::slotGetMessagesData (this=0x83a2850, 
    job=0xb7777e68, data=@0xbfbf8ae0)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmfoldercachedimap.cpp:1458
#6  0xb7dc83c0 in KMFolderCachedImap::qt_invoke (this=0x83a2850, 
    _id=138029136, _o=0x873dce0) at kmfoldercachedimap.moc:372
#7  0xb731d6f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#8  0xb6167fca in KIO::TransferJob::data (this=0x873dce0, t0=0x0, t1=@0x0)
    at jobclasses.moc:993
#9  0xb6168038 in KIO::TransferJob::slotData (this=0x873dce0, _data=@0x0)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kio/kio/job.cpp:900
#10 0xb6168149 in KIO::TransferJob::qt_invoke (this=0x873dce0, 
    _id=-1077966748, _o=0xb778afdc) at jobclasses.moc:1072
#11 0xb731d6f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#12 0xb6152e42 in KIO::SlaveInterface::data (this=0x8700390, t0=@0x0)
    at slaveinterface.moc:194
#13 0xb6155a08 in KIO::SlaveInterface::dispatch (this=0x8700390, _cmd=100, 
    rawdata=@0xbfbf8ae0)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kio/kio/slaveinterface.cpp:234
#14 0xb6154877 in KIO::SlaveInterface::dispatch (this=0x8700390)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kio/kio/slaveinterface.cpp:173
#15 0xb614fc09 in KIO::Slave::gotInput (this=0x8700390)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kio/kio/slave.cpp:300
#16 0xb615013b in KIO::Slave::qt_invoke (this=0x8700390, _id=141558672, 
    _o=0xbfbf8c30) at slave.moc:113
#17 0xb731d6f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#18 0xb731dcc6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb765df32 in QSocketNotifier::activated ()
   from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb73394de in QSocketNotifier::event () from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb72bb8de in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb72bba6d in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb78bc98c in KApplication::notify (this=0xbfbf93c0, receiver=0x86ff868, 
    event=0xbfbf9070)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kdecore/kapplication.cpp:550
#24 0xb72af662 in QEventLoop::activateSocketNotifiers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb72682f6 in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb72d1851 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#27 0xb72d17aa in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb72bab43 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#29 0x0804a6c2 in main (argc=0, argv=0x0)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/main.cpp:110
Comment 11 Tommi Tervo 2005-09-28 14:26:15 UTC
*** Bug 113487 has been marked as a duplicate of this bug. ***
Comment 12 Thiago Macieira 2005-12-01 04:05:54 UTC
*** Bug 117342 has been marked as a duplicate of this bug. ***
Comment 13 Ber Kessels 2005-12-01 10:31:21 UTC
I have tried this in a clean profile, with both Cached IMAP and ordinary IMAP. The crash still occurs. Hopefull this will help a liitle: 
* The crash happens also when I have kmail running in the background (no directories are opened/changed).
* I have no searches defined.
* It (seems to) happens only when imap is being "refreshed" or "receive messages" or when the interval check retreives new messages. 
* I did not see this crash happening when there was no new mail on the server.
* It only started happening after upgrade to 4.5 (kubuntu breezy)

Thanks, Bèr
(Kubuntu Breezy / KDE 3.5 / 2.6.12-10-386 / GCC unknown ? deb package )
Comment 14 Ber Kessels 2005-12-09 08:49:14 UTC
Is there anything I can do to help fix this bug? It is gettign annoying, having to re-start kmail at least once an hour. (thunderbird is peeking around the corner by now, shudder)
Comment 15 David Faure 2005-12-09 10:32:36 UTC
No idea about a workaround, but it would be useful if you ran kmail under valgrind,
to see why it crashes there again. Hopefully it's not like in the initial report since
that one was fixed.
Comment 16 Stephan Binner 2006-01-17 14:16:10 UTC
*** Bug 108030 has been marked as a duplicate of this bug. ***
Comment 17 Stephan Binner 2006-01-17 14:16:30 UTC
*** Bug 119062 has been marked as a duplicate of this bug. ***
Comment 18 Stephan Binner 2006-01-17 14:18:02 UTC
*** Bug 120270 has been marked as a duplicate of this bug. ***
Comment 19 Adam Porter 2006-01-17 20:22:58 UTC
Is there anything I can do to help get this fixed?  I had to downgrade to 1.8.3, and that required taking all of kdepim with it, of course.  You'd think that after all these months, it could be fixed, especially when the commit that caused it was found.  :/
Comment 20 Christian Loose 2006-01-17 21:48:45 UTC
Created attachment 14296 [details]
valgrind output

subversion revision: 499401

partial valgrind output for crash in kmail while syncing dIMAP account
Comment 21 Adam Porter 2006-04-11 05:15:21 UTC
At <http://www.kde.org/announcements/changelogs/changelog3_5_2to3_5_3.php> it says:

KMail
    * Fix crash in disconnected IMAP (rev 526818)

Does that refer to this bug?
Comment 22 Adam Porter 2006-04-12 09:16:40 UTC
FYI, I've been using KMail 1.9.1 from/with KDE 3.5.2 and haven't had this problem yet, whereas before I got it a lot.  I'm guessing that it's fixed.
Comment 23 Adam Porter 2006-04-15 07:31:56 UTC
Well, I just got the same old crash, it just didn't happen as quickly as it did before.  I sure hope it gets fixed in 3.5.3 (sure would be nice if Debian could pull it in sooner).  Here's the backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1249257792 (LWP 7843)]
[New Thread -1277289552 (LWP 8022)]
[New Thread -1268896848 (LWP 8021)]
[New Thread -1260504144 (LWP 8020)]
[New Thread -1252111440 (LWP 8019)]
[KCrash handler]
#6  0x74736e6f in ?? ()
#7  0xb7cabbe1 in KMFolderImap::flagsToStatus ()
   from /usr/lib/libkmailprivate.so
#8  0xb7cc7c8f in KMFolderCachedImap::slotGetMessagesData ()
   from /usr/lib/libkmailprivate.so
#9  0xb7cc9682 in KMFolderCachedImap::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#10 0xb704a54b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb5ab929f in KIO::TransferJob::data (this=0x91ae2d8, t0=0x9373848, 
    t1=@0x9373848) at jobclasses.moc:993
#12 0xb5ab9318 in KIO::TransferJob::slotData (this=0x91ae2d8, 
    _data=@0x9373848) at job.cpp:906
#13 0xb5b0d819 in KIO::TransferJob::qt_invoke (this=0x91ae2d8, _id=18, 
    _o=0xbfe0ce64) at jobclasses.moc:1072
#14 0xb704a54b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xb5ab6462 in KIO::SlaveInterface::data (this=0x9025ff8, t0=@0x9373848)
    at slaveinterface.moc:194
#16 0xb5b23671 in KIO::SlaveInterface::dispatch (this=0x9025ff8, _cmd=100, 
    rawdata=@0xbfe0d060) at slaveinterface.cpp:234
#17 0xb5acaa47 in KIO::SlaveInterface::dispatch (this=0x9025ff8)
    at slaveinterface.cpp:173
#18 0xb5acf95b in KIO::Slave::gotInput (this=0x9025ff8) at slave.cpp:300
#19 0xb5acfb0b in KIO::Slave::qt_invoke (this=0x9025ff8, _id=4, _o=0xbfe0d188)
    at slave.moc:113
#20 0xb704a54b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0xb704ae52 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb73dcf7f in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#23 0xb706a80a in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#24 0xb6fe087a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#25 0xb6fe0a76 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#26 0xb76ea02e in KApplication::notify (this=0xbfe0d768, receiver=0x82db448, 
    event=0xbfe0d4e0) at kapplication.cpp:550
#27 0xb6f72001 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#28 0xb6fd2435 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#29 0xb6f85d06 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#30 0xb6ff9255 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#31 0xb6ff917a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#32 0xb6fdf38d in QApplication::exec () from /usr/lib/libqt-mt.so.3
#33 0x0804a098 in ?? ()
#34 0xbfe0d768 in ?? ()
#35 0xbfe0d954 in ?? ()
#36 0x00000000 in ?? ()
Comment 24 Andreas Kling 2006-08-08 07:02:21 UTC
*** Bug 131658 has been marked as a duplicate of this bug. ***
Comment 25 Andreas Kling 2006-08-08 07:02:36 UTC
*** Bug 132032 has been marked as a duplicate of this bug. ***
Comment 26 Bram Schoenmakers 2006-11-15 14:37:42 UTC
*** Bug 137381 has been marked as a duplicate of this bug. ***
Comment 27 Bram Schoenmakers 2006-11-15 14:38:44 UTC
*** Bug 127863 has been marked as a duplicate of this bug. ***
Comment 28 Tommi Tervo 2006-12-08 09:09:42 UTC
*** Bug 138522 has been marked as a duplicate of this bug. ***
Comment 29 konold 2007-01-21 19:59:20 UTC
I just hit this same bug with Kmail 1.9.5 from KDE 3.5.5 (SUSE release 50.1)
Comment 30 konold 2007-01-21 19:59:49 UTC
*** Bug 140407 has been marked as a duplicate of this bug. ***
Comment 31 Stephan Kulow 2007-03-22 10:27:14 UTC
I'm afraid the only valgrind logs we see are for 3.5.2 - which is before Till's change
Comment 32 Tommi Tervo 2007-03-26 13:00:21 UTC
*** Bug 143478 has been marked as a duplicate of this bug. ***
Comment 33 Elias Probst 2007-04-08 03:52:34 UTC
Bug appeared in Kontact/KMail from KDE 3.5.6 on Gentoo.
Comment 34 Daniel Hahler 2007-04-24 01:46:50 UTC
Here's the bug in Kubuntu (with KDE 3.5.5): https://bugs.launchpad.net/kdepim/+bug/71640
Comment 35 Richard Homonnai 2007-04-28 18:00:01 UTC
Bug also exists in 3.5.5-r2 to 3.5.6-r3 in Gentoo, altough not using cachedimap, just "normal" IMAP.
Comment 36 Richard Homonnai 2007-05-03 01:59:26 UTC
Somehow it stopped altogether today. Maybe the mail server got updated or something....
I'm afraid I cannot provide any help in here now :(
Comment 37 Denis Zalewsky 2007-10-05 14:45:29 UTC
I have got similar crash in gentoo kmail 1.9.7 kde 3.5.7 for pop3 email account. It appears very frequently.

Can provide crash information if required.
Comment 38 Denis Zalewsky 2007-10-05 14:47:23 UTC
BTW, I am using gcc version 4.1.2 20070214 to compile it.
Comment 39 Thomas McGuire 2007-11-20 19:38:29 UTC
*** Bug 152602 has been marked as a duplicate of this bug. ***
Comment 40 Thomas McGuire 2008-01-12 16:29:19 UTC
*** Bug 155272 has been marked as a duplicate of this bug. ***
Comment 41 Boris 2008-03-05 18:37:23 UTC
I believe I am experiencing the same or a related bug. KMail crashes often but not always upon checking a (disconnected) IMAP account. Despite the mention of filtering in the backtrace, no filters at all have been configured.

Happens both on current Debian testing (amd64): 
Qt: 3.3.7
KDE: 3.5.8
KMail: 1.9.7
and on a unstable/testing mix (the backtrace was obtained with this configuration):
Qt: 3.3.8b
KDE: 3.5.9
KMail: 1.9.9

Backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x2ab525025870 (LWP 4943)]
[New Thread 0x42003950 (LWP 4947)]
[New Thread 0x41802950 (LWP 4946)]
[New Thread 0x41001950 (LWP 4945)]
[New Thread 0x40800950 (LWP 4944)]
[KCrash handler]
#5  0x0000000000000000 in ?? ()
#6  0x00002ab52b2ea0ed in KMail::MessageProperty::filtering ()
   from /usr/lib/libkmailprivate.so
#7  0x00002ab52b30a099 in KMFilterMgr::beginFiltering ()
   from /usr/lib/libkmailprivate.so
#8  0x00002ab52b30af8b in KMFilterMgr::process ()
   from /usr/lib/libkmailprivate.so
#9  0x00002ab52b283663 in KMAccount::processNewMsg ()
   from /usr/lib/libkmailprivate.so
#10 0x00002ab52b370202 in KMFolderCachedImap::addMsgInternal ()
   from /usr/lib/libkmailprivate.so
#11 0x00002ab52b437694 in KMail::CachedImapJob::slotGetNextMessage ()
   from /usr/lib/libkmailprivate.so
#12 0x00002ab52b438876 in KMail::CachedImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#13 0x00002ab51e8ef41c in QObject::activate_signal (this=0x14c7700, 
    clist=<value optimized out>, o=0x7fff8ec91430) at kernel/qobject.cpp:2359
#14 0x00002ab51f17a232 in KIO::Job::result (this=0x1675070, t0=0x14c7700)
    at ./jobclasses.moc:162
#15 0x00002ab51f1b195f in KIO::Job::emitResult (this=0x14c7700)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kio/kio/job.cpp:235
#16 0x00002ab51f1cdeea in KIO::SimpleJob::slotFinished (this=0x14c7700)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kio/kio/job.cpp:601
#17 0x00002ab51f1ce52c in KIO::TransferJob::slotFinished (this=0x14c7700)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kio/kio/job.cpp:971
#18 0x00002ab51f1b15da in KIO::TransferJob::qt_invoke (this=0x14c7700, 
    _id=17, _o=0x7fff8ec918e0) at ./jobclasses.moc:1071
#19 0x00002ab51e8ef41c in QObject::activate_signal (this=0x238e800, 
    clist=<value optimized out>, o=0x7fff8ec918e0) at kernel/qobject.cpp:2359
#20 0x00002ab51e8efbb4 in QObject::activate_signal (this=0x1675070, 
    signal=<value optimized out>) at kernel/qobject.cpp:2328
#21 0x00002ab51f1c5ee2 in KIO::SlaveInterface::dispatch (this=0x238e800, 
    _cmd=104, rawdata=@0x7fff8ec91be0)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kio/kio/slaveinterface.cpp:243
#22 0x00002ab51f1de6ce in KIO::SlaveInterface::dispatch (this=0x238e800)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kio/kio/slaveinterface.cpp:173
#23 0x00002ab51f185a86 in KIO::Slave::gotInput (this=0x1675070)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kio/kio/slave.cpp:300
#24 0x00002ab51f1bef58 in KIO::Slave::qt_invoke (this=0x238e800, _id=4, 
    _o=0x7fff8ec91ce0) at ./slave.moc:113
#25 0x00002ab51e8ef41c in QObject::activate_signal (this=0xa2a840, 
    clist=<value optimized out>, o=0x7fff8ec91ce0) at kernel/qobject.cpp:2359
#26 0x00002ab51e8efad4 in QObject::activate_signal (this=0xa2a840, 
    signal=<value optimized out>, param=<value optimized out>)
    at kernel/qobject.cpp:2452
#27 0x00002ab51e9093fb in QSocketNotifier::event (this=0xa2a840, 
    e=0x7fff8ec92080) at kernel/qsocketnotifier.cpp:261
#28 0x00002ab51e8999a3 in QApplication::internalNotify (
    this=<value optimized out>, receiver=0xa2a840, e=0x7fff8ec92080)
    at kernel/qapplication.cpp:2638
#29 0x00002ab51e89a6b8 in QApplication::notify (this=0x7fff8ec922c0, 
    receiver=0x1675070, e=0x7fff8ec92080) at kernel/qapplication.cpp:2361
#30 0x00002ab51e07bead in KApplication::notify (this=0x7fff8ec922c0, 
    receiver=0xa2a840, event=0x7fff8ec92080)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kdecore/kapplication.cpp:550
#31 0x00002ab51e88f6b3 in QEventLoop::activateSocketNotifiers (this=0x6935b0)
    at kernel/qapplication.h:523
#32 0x00002ab51e84fb46 in QEventLoop::processEvents (this=0x6935b0, 
    flags=<value optimized out>) at kernel/qeventloop_x11.cpp:386
#33 0x00002ab51e8ae051 in QEventLoop::enterLoop (this=0x1675070)
    at kernel/qeventloop.cpp:201
#34 0x00002ab51e8adf02 in QEventLoop::exec (this=0x1675070)
    at kernel/qeventloop.cpp:148
#35 0x0000000000418fba in ?? ()
#36 0x00002ab51db4c1c4 in __libc_start_main () from /lib/libc.so.6
#37 0x00000000004187a9 in ?? ()
#38 0x00007fff8ec926b8 in ?? ()
#39 0x0000000000000000 in ?? ()

Would anything else be helpful.useful?

Boris
Comment 42 Gunter Ohrner 2008-04-02 11:09:58 UTC
I got the same crash Boris did, at least according to the backtrace. I get it in a different situation however: kMail 1.9.9 with KDE 3.5.9 on Linux IA32 (Debian SID) always crashes with this SIGSEGV if I try to rebuild my inbox's dimap cache.

Does this look like the same bug, or should I open a new report so it can be tracked independantly?

[KCrash handler]
#6  0x093ccd60 in ?? ()
#7  0x4ad75120 in KMail::MessageProperty::filtering ()
   from /usr/lib/libkmailprivate.so
#8  0x4ad98c85 in KMFilterMgr::beginFiltering ()
   from /usr/lib/libkmailprivate.so
#9  0x4ad99d16 in KMFilterMgr::process () from /usr/lib/libkmailprivate.so
#10 0x4ad01e82 in KMAccount::processNewMsg () from /usr/lib/libkmailprivate.so
#11 0x4ae0a7e9 in KMFolderCachedImap::addMsgInternal ()
   from /usr/lib/libkmailprivate.so
#12 0x4aeec8c5 in KMail::CachedImapJob::slotGetNextMessage ()
   from /usr/lib/libkmailprivate.so
#13 0x4aeedc7f in KMail::CachedImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#14 0x48c474cd in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0x498779ee in KIO::Job::result () from /usr/lib/libkio.so.4
#16 0x498bd99d in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#17 0x498bdb0e in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#18 0x498be1f8 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#19 0x498bd5fd in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#20 0x48c474cd in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0x48c4804d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0x4986ffdc in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#23 0x498bc969 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#24 0x498dedba in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#25 0x49885e7c in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#26 0x498b4238 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#27 0x48c474cd in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#28 0x48c47f50 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#29 0x48f723b0 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#30 0x48c64f60 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#31 0x48be96ea in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#32 0x48bea4d6 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#33 0x492f4062 in KApplication::notify () from /usr/lib/libkdecore.so.4
#34 0x48bddfa7 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#35 0x48b98730 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#36 0x48c000e0 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#37 0x48bfff76 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#38 0x48be925f in QApplication::exec () from /usr/lib/libqt-mt.so.3
#39 0x0804a2ed in ?? ()
#40 0xbfaa19a0 in ?? ()
#41 0xbfaa1b90 in ?? ()
#42 0x00000000 in ?? ()
Comment 43 Bram Schoenmakers 2008-08-22 18:50:52 UTC
*** Bug 169599 has been marked as a duplicate of this bug. ***
Comment 44 Donatas Glodenis 2008-08-24 17:17:41 UTC
anything new about this problem? I am very disappointed, but i cannot use my time on email to try to trick it into syncing instead of working. 

I am curious, is dIMAP in Kmail maintained, or is it a leftover that no developer really understands or cares about?

I tried simple IMAP yesterday, but I cannot perform searches on those imap folders then, and it also seems to crash , maybe not as often, but still...

Is there any other decent KDE mail client with cached imap support?
Comment 45 Modestas Vainius 2008-08-24 17:51:58 UTC
kmail akonadi integration will fix this. However, that won't be earlier than KDE 4.2 or 4.3
Comment 46 Donatas Glodenis 2008-08-26 07:56:36 UTC
I noticed that a lot depends on the connection speed. Sync does not fail if connection speed is good. 

So, it is another year to wait, if it all depends on akonadi integration...
Comment 47 Unknown 2008-11-10 00:42:30 UTC
*** Bug 171218 has been marked as a duplicate of this bug. ***
Comment 48 Jaime Torres 2008-11-23 11:58:21 UTC
I hope this is more about the same bug.

What I see is:
kmail reads all the local imap folders, checks that all the local mails are still there, some of them are deleted in the imap server, and then rereads all the local imap folders, and then crash..

Aplicación: KMail (kmail), señal SIGSEGV        
[Thread debugging using libthread_db enabled]   
[Current thread is 0 (LWP 13941)]               

Thread 2 (Thread 0xb2362b90 (LWP 13942)):
#0  0xffffe424 in __kernel_vsyscall ()   
#1  0xb4d12ef1 in select () from /lib/libc.so.6
#2  0xb5a53e77 in QProcessManager::run (this=0x806ea10) at io/qprocess_unix.cpp:301                                                                       
#3  0xb598484e in QThreadPrivate::start (arg=0x806ea10) at thread/qthread_unix.cpp:185                                                                    
#4  0xb634a175 in start_thread () from /lib/libpthread.so.0                  
#5  0xb4d19dce in clone () from /lib/libc.so.6                               

Thread 1 (Thread 0xb3fd66d0 (LWP 13941)):
[KCrash Handler]                         
#6  0x6f632e6c in ?? ()                  
#7  0xb76f0e86 in KMFolderImap::flagsToStatus (msg=0x8261080, flags=5, newMsg=<value optimized out>, supportedFlags=<value optimized out>) at /g/kde4svn/kdepim/kmail/kmfolderimap.cpp:1480                                            
#8  0xb770f0d7 in KMFolderCachedImap::slotGetMessagesData (this=0x8255218, job=0x826b1c8, data=@0xbfa28b04) at /g/kde4svn/kdepim/kmail/kmfoldercachedimap.cpp:1840                                                                     
#9  0xb7712eba in KMFolderCachedImap::qt_metacall (this=0x8255218, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfa28888) at /g/build/kdepim/kmail/kmfoldercachedimap.moc:195                                                         
#10 0xb5a89740 in QMetaObject::activate (sender=0x826b1c8, from_signal_index=40, to_signal_index=40, argv=0xbfa28888) at kernel/qobject.cpp:3031          
#11 0xb5a8a4c2 in QMetaObject::activate (sender=0x826b1c8, m=0xb5e3d3d0, local_signal_index=0, argv=0xbfa28888) at kernel/qobject.cpp:3101                
#12 0xb5cc9179 in KIO::TransferJob::data (this=0x826b1c8, _t1=0x826b1c8, _t2=@0xbfa28b04) at /g/build/kdelibs/kio/jobclasses.moc:356                      
#13 0xb5cc9b7b in KIO::TransferJob::slotData (this=0x826b1c8, _data=@0xbfa28b04) at /g/kde4svn/kdelibs/kio/kio/job.cpp:917                                
#14 0xb5cd3d0d in KIO::TransferJob::qt_metacall (this=0x826b1c8, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfa289ac) at /g/build/kdelibs/kio/jobclasses.moc:337                                                                    
#15 0xb5a89740 in QMetaObject::activate (sender=0x82494e8, from_signal_index=4, to_signal_index=4, argv=0xbfa289ac) at kernel/qobject.cpp:3031            
#16 0xb5a8a4c2 in QMetaObject::activate (sender=0x82494e8, m=0xb5e3fea4, local_signal_index=0, argv=0xbfa289ac) at kernel/qobject.cpp:3101                
#17 0xb5d73b73 in KIO::SlaveInterface::data (this=0x82494e8, _t1=@0xbfa28b04) at /g/build/kdelibs/kio/slaveinterface.moc:138                              
#18 0xb5d755e4 in KIO::SlaveInterface::dispatch (this=0x82494e8, _cmd=100, rawdata=@0xbfa28b04) at /g/kde4svn/kdelibs/kio/kio/slaveinterface.cpp:163      
#19 0xb5d76146 in KIO::SlaveInterface::dispatch (this=0x82494e8) at /g/kde4svn/kdelibs/kio/kio/slaveinterface.cpp:91                                      
#20 0xb5d68667 in KIO::Slave::gotInput (this=0x82494e8) at /g/kde4svn/kdelibs/kio/kio/slave.cpp:322                                                       
#21 0xb5d69a33 in KIO::Slave::qt_metacall (this=0x82494e8, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfa28c18) at /g/build/kdelibs/kio/slave.moc:75   
#22 0xb5a89740 in QMetaObject::activate (sender=0x8268188, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3031                   
#23 0xb5a8a4c2 in QMetaObject::activate (sender=0x8268188, m=0xb5e3c980, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3101
#24 0xb5c9fce7 in KIO::Connection::readyRead (this=0x8268188) at /g/build/kdelibs/kio/connection.moc:84
#25 0xb5ca0ae6 in KIO::ConnectionPrivate::dequeue (this=0x825b420) at /g/kde4svn/kdelibs/kio/kio/connection.cpp:82
#26 0xb5ca1926 in KIO::Connection::qt_metacall (this=0x8268188, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x80978c0) at /g/build/kdelibs/kio/connection.moc:72
#27 0xb5a8288b in QMetaCallEvent::placeMetaCall (this=0x8297bd0, object=0x8268188) at kernel/qobject.cpp:529
#28 0xb5a84449 in QObject::event (this=0x8268188, e=0x8297bd0) at kernel/qobject.cpp:1155
#29 0xb507582c in QApplicationPrivate::notify_helper (this=0x806b490, receiver=0x8268188, e=0x8297bd0) at kernel/qapplication.cpp:3803
#30 0xb507d6ce in QApplication::notify (this=0xbfa29448, receiver=0x8268188,e=0x8297bd0) at kernel/qapplication.cpp:3393
#31 0xb7e83811 in KApplication::notify (this=0xbfa29448, receiver=0x8268188,event=0x8297bd0) at /g/kde4svn/kdelibs/kdeui/kernel/kapplication.cpp:307
#32 0xb5a74a71 in QCoreApplication::notifyInternal (this=0xbfa29448, receiver=0x8268188, event=0x8297bd0) at kernel/qcoreapplication.cpp:587
#33 0xb5a756e5 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x804f6a8) at kernel/qcoreapplication.h:209
#34 0xb5a758dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1091
#35 0xb5a9f5bf in postEventSourceDispatch (s=0x806d128) at kernel/qcoreapplication.h:214
#36 0xb48092d9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb480c85b in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#38 0xb480c9d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#39 0xb5a9f208 in QEventDispatcherGlib::processEvents (this=0x80651e8, flags={i = -1079864664}) at kernel/qeventdispatcher_glib.cpp:319
#40 0xb510e885 in QGuiEventDispatcherGlib::processEvents (this=0x80651e8, flags={i = -1079864616}) at kernel/qguieventdispatcher_glib.cpp:198
#41 0xb5a7314a in QEventLoop::processEvents (this=0xbfa29350, flags={i = -1079864552}) at kernel/qeventloop.cpp:143
#42 0xb5a7330a in QEventLoop::exec (this=0xbfa29350, flags={i = -1079864488}) at kernel/qeventloop.cpp:194
#43 0xb5a759a5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#44 0xb50756a7 in QApplication::exec () at kernel/qapplication.cpp:3331
#45 0x0804acaa in main (argc=) at /g/kde4svn/kdepim/kmail/main.cpp:146


I'll attach a valgrind output, but I guess it does not contains the most precious traces, because it counsumed all the memory and crashed, but contains some valuable information.
Comment 49 Jaime Torres 2008-11-23 12:00:14 UTC
Created attachment 28762 [details]
valgrind output
Comment 50 Dario Andres 2008-12-06 23:55:15 UTC
*** Bug 175825 has been marked as a duplicate of this bug. ***
Comment 51 Jaime Torres 2008-12-09 15:38:07 UTC
*** Bug 177308 has been marked as a duplicate of this bug. ***
Comment 52 Thomas McGuire 2008-12-22 22:41:07 UTC
SVN commit 900449 by tmcguire:

Fix a crash when syncing flags from a server while we have a search folder
that has a search rule which needs the complete body, because this unget()s
the message behind our back right after changing the flags.

BUG: 106030


 M  +12 -0     kmfolderimap.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=900449
Comment 53 Thomas McGuire 2009-01-03 16:14:12 UTC
SVN commit 904948 by tmcguire:

Backport r900449 by tmcguire from trunk to the 4.1 branch:

Fix a crash when syncing flags from a server while we have a search folder
that has a search rule which needs the complete body, because this unget()s
the message behind our back right after changing the flags.

CCBUG: 106030



 M  +12 -0     kmfolderimap.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=904948