Bug 171218 - KMail crashed while I was writing a letter. DIMAP.
Summary: KMail crashed while I was writing a letter. DIMAP.
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.10.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-17 16:26 UTC by Unknown
Modified: 2008-11-10 00:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2008-09-17 16:26:04 UTC
Version:           1.10.1 (using 4.1.2 (KDE 4.1.1 (KDE 4.1 >= 20080828)) "release 52.1", KDE:KDE4:Factory:Desktop / openSUSE_Factory)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.16-0.1-pae

While I was writing a letter, KMail crashed.

Here is the backtrace:

Alkalmazás: KMail (kmail), szignál: SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb442c6d0 (LWP 23708)]
[New Thread 0xafe19b90 (LWP 24807)]
[KCrash handler]
#6  0x2e656d62 in ?? ()
#7  0xb7b5c969 in KMFolderImap::flagsToStatus (msg=0x955fe50, flags=1, 
    newMsg=<value optimized out>, supportedFlags=<value optimized out>)
    at /usr/src/debug/kdepim-4.1.1/kmail/kmfolderimap.cpp:1489
#8  0xb7b81868 in KMFolderCachedImap::slotGetMessagesData (this=0x82b5000, 
    job=0x88d6f80, data=@0xbfbf4704)
    at /usr/src/debug/kdepim-4.1.1/kmail/kmfoldercachedimap.cpp:1725
#9  0xb7b8814e in KMFolderCachedImap::qt_metacall (this=0x82b5000, 
    _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfbf4488)
    at /usr/src/debug/kdepim-4.1.1/build/kmail/kmfoldercachedimap.moc:195
#10 0xb5dbee30 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#11 0xb5dbfbb2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#12 0xb661e9f9 in KIO::TransferJob::data () from /usr/lib/libkio.so.5
#13 0xb661f332 in KIO::TransferJob::slotData () from /usr/lib/libkio.so.5
#14 0xb6626a95 in KIO::TransferJob::qt_metacall () from /usr/lib/libkio.so.5
#15 0xb5dbee30 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#16 0xb5dbfbb2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#17 0xb66cfb33 in KIO::SlaveInterface::data () from /usr/lib/libkio.so.5
#18 0xb66d25f4 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#19 0xb66d02c7 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#20 0xb66c2f40 in KIO::Slave::gotInput () from /usr/lib/libkio.so.5
#21 0xb66c32b3 in KIO::Slave::qt_metacall () from /usr/lib/libkio.so.5
#22 0xb5dbee30 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#23 0xb5dbfbb2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#24 0xb65f4b97 in KIO::Connection::readyRead () from /usr/lib/libkio.so.5
#25 0xb65f65c3 in ?? () from /usr/lib/libkio.so.5
#26 0xb65f6c16 in KIO::Connection::qt_metacall () from /usr/lib/libkio.so.5
#27 0xb5db7fcb in QMetaCallEvent::placeMetaCall () from /usr/lib/libQtCore.so.4
#28 0xb5db9b31 in QObject::event () from /usr/lib/libQtCore.so.4
#29 0xb4fe20ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#30 0xb4fe9f4e in QApplication::notify () from /usr/lib/libQtGui.so.4
#31 0xb63f304d in KApplication::notify () from /usr/lib/libkdeui.so.5
#32 0xb5daa2c1 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#33 0xb5daae85 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb5dab07d in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#35 0xb507ab3f in ?? () from /usr/lib/libQtGui.so.4
#36 0xb5da897a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#37 0xb5da8b3a in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#38 0xb5dab145 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#39 0xb4fe1f67 in QApplication::exec () from /usr/lib/libQtGui.so.4
#40 0x0804a8a0 in main (argc=)
    at /usr/src/debug/kdepim-4.1.1/kmail/main.cpp:146
#0  0xffffe430 in __kernel_vsyscall ()
Comment 1 Unknown 2008-09-17 16:39:48 UTC
Update: I can reproduce this crash anytime I start KMail and move some letters to a folder.
So in this state the program is unusable.
Comment 2 Unknown 2008-09-23 19:32:56 UTC
I'm not sure, but is this bug maybe a duplicate of Bug 106030?
Comment 3 Unknown 2008-11-10 00:42:30 UTC

*** This bug has been marked as a duplicate of bug 106030 ***