Bug 131658 - Kmail caused signal 11 SIGSEGV
Summary: Kmail caused signal 11 SIGSEGV
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.3
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-01 15:46 UTC by jstalnak
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jstalnak 2006-08-01 15:46:18 UTC
Version:           1.9.3 (using KDE KDE 3.5.3)
Installed from:    SuSE RPMs
OS:                Linux

I'm using SuSE Linux 10.2 Alpha 2 (because SuSE Linux 10.1 package management SUCKS) on a Dell 9150 with an Intel PentiumD with 1.5 G Ram, etc.  It's been remarkably stable for an alpha release.  The only real issue I have is KMail crashes.

I leave KMail running 24x7 -- for the past several days on returning to work, the first time I click on a item in the KMail app Inbox, it crashes.  Here is the backtrace:

<quote>
System configuration startup check disabled.

(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 47035065865376 (LWP 2879)]
[New Thread 1107310912 (LWP 2883)]
[New Thread 1098918208 (LWP 2882)]
[New Thread 1090525504 (LWP 2881)]
[New Thread 1082132800 (LWP 2880)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0x0000000004acbbe9 in ?? ()
#6  0x00002ac72a91ab29 in KMFolderImap::flagsToStatus ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002ac72a926707 in KMFolderImap::slotGetMessagesData ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x00002ac72a927e6f in KMFolderImap::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#9  0x00002ac72b7db5ac in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#10 0x00002ac72ecc3284 in KIO::TransferJob::data ()
   from /opt/kde3/lib64/libkio.so.4
#11 0x00002ac72ecfc3c0 in KIO::TransferJob::qt_invoke ()
   from /opt/kde3/lib64/libkio.so.4
#12 0x00002ac72b7db5ac in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#13 0x00002ac72ecc3e82 in KIO::SlaveInterface::data ()
   from /opt/kde3/lib64/libkio.so.4
#14 0x00002ac72ed1873f in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib64/libkio.so.4
#15 0x00002ac72ed2142e in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib64/libkio.so.4
#16 0x00002ac72ecd106b in KIO::Slave::gotInput ()
   from /opt/kde3/lib64/libkio.so.4
#17 0x00002ac72ed10668 in KIO::Slave::qt_invoke ()
   from /opt/kde3/lib64/libkio.so.4
#18 0x00002ac72b7db5ac in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#19 0x00002ac72b7dc1ad in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#20 0x00002ac72b7f5dbb in QSocketNotifier::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#21 0x00002ac72b7847e5 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#22 0x00002ac72b785417 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#23 0x00002ac72af72c48 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#24 0x00002ac72b77a92b in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#25 0x00002ac72b73b450 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#26 0x00002ac72b7993e3 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#27 0x00002ac72b799292 in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#28 0x000000000040296d in QObject::checkConnectArgs ()
#29 0x00002ac72c1f2154 in __libc_start_main () from /lib64/libc.so.6
#30 0x00000000004026f9 in QObject::checkConnectArgs ()
#31 0x00007fff8060f1f8 in ?? ()
#32 0x0000000000000000 in ?? ()
</quote>

I can stark KMail right back up and it runs fine.
Comment 1 Andreas Kling 2006-08-08 07:02:20 UTC

*** This bug has been marked as a duplicate of 106030 ***