Bug 152602 - kmail crash with dimap sync
Summary: kmail crash with dimap sync
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: disconnected IMAP (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-20 18:13 UTC by Ingo Ebel
Modified: 2007-11-20 19:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Ebel 2007-11-20 18:13:44 UTC
Version:           1.9.6 (enterprise 20070904.708012) (using KDE 3.5.8 "release 21.2" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.22.12-0.1-default

kmail is always crashing after syncing my imap folders (disconnected imap)
there are more than 100 imap folders in my account.
i tried to remove all stuff an creating an new account but after the first sync of all folders its crashing again. don't know what to do else.

Überprüfung der Systemkonfiguration beim Start deaktiviert.

 [?1034h(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5fe56d0 (LWP 19130)]
[New Thread 0xb33d5b90 (LWP 19137)]
[New Thread 0xb3bd6b90 (LWP 19136)]
[New Thread 0xb43d7b90 (LWP 19135)]
[New Thread 0xb4bd8b90 (LWP 19134)]
[KCrash handler]
#6  0xb500bbdd in KMFolderCachedImap::slotProgress ()
   from /opt/kde3/lib/libkmailprivate.so
#7  0xb501a7f3 in KMFolderCachedImap::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#8  0xb6c2d8ad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0xb50f0046 in KMail::FolderJob::progress ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb50f6c9f in KMail::CachedImapJob::slotGetNextMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb50f3b5f in KMail::CachedImapJob::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb6c2d8ad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb76f72ae in KIO::Job::result () from /opt/kde3/lib/libkio.so.4
#14 0xb77358ad in KIO::Job::emitResult () from /opt/kde3/lib/libkio.so.4
#15 0xb77431ee in KIO::SimpleJob::slotFinished ()
   from /opt/kde3/lib/libkio.so.4
#16 0xb77438d8 in KIO::TransferJob::slotFinished ()
   from /opt/kde3/lib/libkio.so.4
#17 0xb773550d in KIO::TransferJob::qt_invoke () from /opt/kde3/lib/libkio.so.4
#18 0xb6c2d8ad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb6c2e44d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb76f327c in KIO::SlaveInterface::finished ()
   from /opt/kde3/lib/libkio.so.4
#21 0xb7765f29 in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#22 0xb7755a2a in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#23 0xb7707d0c in KIO::Slave::gotInput () from /opt/kde3/lib/libkio.so.4
#24 0xb77577b8 in KIO::Slave::qt_invoke () from /opt/kde3/lib/libkio.so.4
#25 0xb6c2d8ad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb6c2e350 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb6f624a0 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb6c4b3f0 in QSocketNotifier::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb6bcf0ac in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb6bcfe96 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb7278b52 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#32 0xb6bc3521 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb6b7e236 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb6be5c30 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb6be5ac6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb6bcec1f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x0805b703 in QWidget::setUpdatesEnabled ()
#38 0xbfe12d5c in ?? ()
#39 0x00000001 in ?? ()
#40 0x00000001 in ?? ()
#41 0x00000000 in ?? ()
Comment 1 Thomas McGuire 2007-11-20 19:38:28 UTC
Same backtrace as bug 113487, which itself is a duplicate of bug 106030 (the root of the problem seems to be the same).
Therefore marking as duplicate of bug 106030.

*** This bug has been marked as a duplicate of 106030 ***