Bug 113487 - crash on disconnected imap-ssl synchronising with Courier server
Summary: crash on disconnected imap-ssl synchronising with Courier server
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: disconnected IMAP (show other bugs)
Version: 1.8.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-28 10:02 UTC by Rutger Claes
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash backtrace in 1.9.1 (5.60 KB, text/plain)
2006-01-25 14:10 UTC, Rutger Claes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rutger Claes 2005-09-28 10:02:07 UTC
Version:           1.8.2 (using KDE 3.4.2, Debian Package 4:3.4.2-4 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.12c01

I am experiencing a lot of crashes using disconnected IMAP in Kmail on my self-hosted Courier imap server.

This is information from the mail.info file on the server:
Sep 28 09:57:17 monsoon imapd-ssl: LOGIN, user=rutger, ip=[::ffff:193.190.253.148], protocol=IMAP
[ Crash happens here ]
Sep 28 09:58:04 monsoon imapd-ssl: LOGOUT, user=rutger, ip=[::ffff:193.190.253.148], headers=0, body=0, time=47, starttls=1

This is my backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1247508064 (LWP 19346)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0xb7d88dfe in KMFolderCachedImap::slotProgress ()
   from /usr/lib/libkmailprivate.so
#4  0xb7d90fa1 in KMFolderCachedImap::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#5  0xb7158c5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#6  0xb7e36d06 in KMail::FolderJob::progress ()
   from /usr/lib/libkmailprivate.so
#7  0xb7e3b537 in KMail::CachedImapJob::slotGetNextMessage ()
   from /usr/lib/libkmailprivate.so
#8  0xb7e3af94 in KMail::CachedImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#9  0xb7158c5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb5c7b49a in KIO::Job::result () from /usr/lib/libkio.so.4
#11 0xb5ccb7f0 in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#12 0xb5ccb95b in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#13 0xb5ccc020 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#14 0xb5ccd5a2 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#15 0xb7158c5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb7159743 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb5c769c9 in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#18 0xb5ce44fa in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#19 0xb5c8ceb0 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#20 0xb5c91514 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#21 0xb5c916a9 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#22 0xb7158c5f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#23 0xb71595ad in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#24 0xb74ea20c in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#25 0xb7179659 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#26 0xb70ee778 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#27 0xb70ee996 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#28 0xb77dd9fc in KApplication::notify () from /usr/lib/libkdecore.so.4
#29 0xb707e665 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#30 0xb70dfb81 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#31 0xb70923d0 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#32 0xb7106ea2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#33 0xb7106dcb in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#34 0xb70ed305 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#35 0x0804a07f in ?? ()
#36 0xbfba1a58 in ?? ()
#37 0xbfba1c44 in ?? ()
#38 0xbfba1c58 in ?? ()
#39 0x0804a02e in ?? ()
#40 0xb6ee1c08 in ?? () from /usr/lib/libqt-mt.so.3
#41 0xb6fba492 in ?? () from /usr/lib/libqt-mt.so.3
#42 0x00000028 in ?? ()
#43 0x00000019 in ?? ()
#44 0xb79ba1ec in __malloc_initialize_hook () from /lib/tls/libc.so.6
#45 0x00000004 in ?? ()
#46 0xb7af0d44 in ?? () from /usr/lib/libkmailprivate.so
#47 0x03be048f in ?? ()
#48 0xb7b2519a in ?? () from /usr/lib/libkmailprivate.so
#49 0x38ba1a70 in ?? ()
#50 0x0804a368 in vtable for QGList ()
#51 0xb7f8fa60 in ?? ()
#52 0x0807ee28 in ?? ()
#53 0x00000000 in ?? ()
#54 0x0807e0b8 in ?? ()
#55 0x081041a0 in ?? ()
#56 0x08103c88 in ?? ()
#57 0x08105048 in ?? ()
#58 0x00000000 in ?? ()
#59 0x00000000 in ?? ()
#60 0x00000001 in ?? ()
#61 0x080607a8 in ?? ()
#62 0xbfba1a00 in ?? ()
#63 0x00000000 in ?? ()
#64 0x08109ef8 in ?? ()
#65 0x08093f40 in ?? ()
#66 0x08087728 in ?? ()
#67 0xb79ba200 in __malloc_initialize_hook () from /lib/tls/libc.so.6
#68 0x0804a3ec in vtable for QGList ()
#69 0x08088e40 in ?? ()
#70 0x0808a900 in ?? ()
#71 0x080890b0 in ?? ()
#72 0xb7620460 in vtable for QCString () from /usr/lib/libqt-mt.so.3
#73 0x08060030 in ?? ()
#74 0xbfba1c10 in ?? ()
#75 0x08088870 in ?? ()
#76 0x08061e50 in ?? ()
#77 0x0000012a in ?? ()
#78 0x000000ff in ?? ()
#79 0xb7aa6d65 in operator new () from /usr/lib/libstdc++.so.6
#80 0xb7899ec0 in __libc_start_main () from /lib/tls/libc.so.6
#81 0x08049e11 in ?? ()
Comment 1 Tommi Tervo 2005-09-28 14:26:14 UTC

*** This bug has been marked as a duplicate of 106030 ***
Comment 2 Adam Porter 2006-01-17 20:14:36 UTC
I don't think this is the same as bug 106030.

1.  The backtrace is different, while 106030's is always the same.
2.  It is with a different version.  I never had these crashes until 1.9.1, but this is filed on 1.8.2.
Comment 3 Rutger Claes 2006-01-25 14:10:42 UTC
Created attachment 14381 [details]
Crash backtrace in 1.9.1

This bug is marked a duplicate of bug 106030.  I don't know if that is correct,
but I'm affected by both.  I sometimes have: KMFolderCachedImap::slotProgress
() as last line on the backtrace, and sometimes KMFolderImap::flagsToStatus ().

The flagsToStatus() is indead also present in 106030, but I never see the
slotProgress() line causing any errors there.

Both problems could be caused by the same error, I don't know.	Just letting
know that I have crashes because of slotProgress() in 1.9.1 on KDE 3.5.0.