Bug 138522 - Crasch when using search folders on dimap
Summary: Crasch when using search folders on dimap
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-08 08:15 UTC by peppelorum
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peppelorum 2006-12-08 08:15:24 UTC
Version:           1.9.5 (using KDE 3.5.5, Debian Package 4:3.5.5a.dfsg.1-5 (4.0))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18.2

Kmail crashes when using more than one search folder (or even with just one folder). I've created two search folders, to start kmail works fine but after a short while after I chosen a search folder it crashes.
At first it worked just fine with just one search folder, and the krasch appeard after I created a second one. But now I have deleted the second search folder and the krasches still appears.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1241979200 (LWP 5915)]
[New Thread -1280488528 (LWP 5921)]
[New Thread -1272095824 (LWP 5920)]
[New Thread -1263703120 (LWP 5919)]
[New Thread -1255310416 (LWP 5918)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#9  0xb552d619 in KMFolderImap::flagsToStatus ()
   from /usr/lib/libkmailprivate.so
#10 0xb57db8cf in KMFolderCachedImap::slotGetMessagesData ()
   from /usr/lib/libkmailprivate.so
#11 0xb57dc8b2 in KMFolderCachedImap::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#12 0xb7021cb3 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb6b0673d in KIO::TransferJob::data () from /usr/lib/libkio.so.4
#14 0xb6b067c8 in KIO::TransferJob::slotData () from /usr/lib/libkio.so.4
#15 0xb6b43e19 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#16 0xb7021cb3 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb6b02e7e in KIO::SlaveInterface::data () from /usr/lib/libkio.so.4
#18 0xb6b63b42 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#19 0xb6b61ed8 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#20 0xb6b12fab in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#21 0xb6b51a60 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#22 0xb7021cb3 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#23 0xb70225ba in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#24 0xb73aba87 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#25 0xb704445e in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#26 0xb6fb9bd6 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#27 0xb6fbb9f3 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#28 0xb76e1e0e in KApplication::notify () from /usr/lib/libkdecore.so.4
#29 0xb6f4d3d1 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#30 0xb6fabf89 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#31 0xb6f61704 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#32 0xb6fd4129 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#33 0xb6fd3f4a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#34 0xb6fbb76f in QApplication::exec () from /usr/lib/libqt-mt.so.3
#35 0x0805ac3f in ?? ()
#36 0xbfdb5eec in ?? ()
#37 0x00000001 in ?? ()
#38 0x00000001 in ?? ()
#39 0x00000000 in ?? ()
Comment 1 Tommi Tervo 2006-12-08 09:09:40 UTC

*** This bug has been marked as a duplicate of 106030 ***