Bug 108030 - crashes on "make all mesgs in folder as read"
Summary: crashes on "make all mesgs in folder as read"
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kontact
Classification: Unclassified
Component: mail (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-24 02:19 UTC by Grzegorz Jaskiewicz
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Jaskiewicz 2005-06-24 02:19:56 UTC
Version:           unknown (using KDE 3.4.89 (>= 20050615), compiled sources)
Compiler:          gcc version 3.4.4 20050314 (prerelease) (Debian 3.4.3-12)
OS:                Linux (i686) release 2.6.11.7

right click on some folder, and make all mesgs as read. If number of mesgs in that  folder is big, it will take ages, and eventually kmail will decide to play funky on CPU. Linux will fight back and kill naughty bastard.

Using host libthread_db library "/lib/tls/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1243511104 (LWP 27969)]
[KCrash handler]
#3  0x00000000 in ?? ()
#4  0xb551c455 in KMFolderImap::flagsToStatus (msg=0x8f8d450, flags=32, 
    newMsg=true) at /home/gj/kde-sources/kdepim/kmail/kmfolderimap.cpp:1367
#5  0xb552a824 in KMFolderImap::slotGetMessagesData (this=0x8536520, 
    job=0x8f924c8, data=@0x8f8d450)
    at /home/gj/kde-sources/kdepim/kmail/kmfolderimap.cpp:1499
#6  0xb552f080 in KMFolderImap::qt_invoke (this=0x8536520, _id=139683104, 
    _o=0x8957990) at qucom_p.h:312
#7  0xb66f1e7b in QObject::activate_signal (this=0x8957990, clist=0x8b6b898, 
    o=0xbfffece0) at kernel/qobject.cpp:2355
#8  0xb730ecd5 in KIO::TransferJob::data (this=0x8957990, t0=0x8957990, 
    t1=@0xbffff120) at jobclasses.moc:972
#9  0xb730ed3d in KIO::TransferJob::slotData (this=0x8957990, 
    _data=@0xbffff120) at /home/gj/kde-sources/kdelibs/kio/kio/job.cpp:880
#10 0xb730ee13 in KIO::TransferJob::qt_invoke (this=0x8957990, 
    _id=-1073745632, _o=0xbfffee10) at qucom_p.h:312
#11 0xb66f1e7b in QObject::activate_signal (this=0x8600438, clist=0x8ad5ab0, 
    o=0xbfffee10) at kernel/qobject.cpp:2355
#12 0xb72f791f in KIO::SlaveInterface::data (this=0x8600438, t0=@0xbffff120)
    at slaveinterface.moc:194
#13 0xb72fba75 in KIO::SlaveInterface::dispatch (this=0x8600438, _cmd=100, 
    rawdata=@0xbffff120)
    at /home/gj/kde-sources/kdelibs/kio/kio/slaveinterface.cpp:234
#14 0xb72f9e11 in KIO::SlaveInterface::dispatch (this=0x8600438)
    at /home/gj/kde-sources/kdelibs/kio/kio/slaveinterface.cpp:173
#15 0xb72f3c97 in KIO::Slave::gotInput (this=0x8600438)
    at /home/gj/kde-sources/kdelibs/kio/kio/slave.cpp:300
#16 0xb72f4ba9 in KIO::Slave::qt_invoke (this=0x8600438, _id=4, _o=0xbffff2b0)
    at slave.moc:113
#17 0xb66f1e7b in QObject::activate_signal (this=0x85ffd40, clist=0x86006a0, 
    o=0xbffff2b0) at kernel/qobject.cpp:2355
#18 0xb66f21d4 in QObject::activate_signal (this=0x85ffd40, signal=2, 
    param=21) at kernel/qobject.cpp:2448
#19 0xb6a57fcd in QSocketNotifier::activated (this=0x85ffd40, t0=21)
    at .moc/debug-shared-mt/moc_qsocketnotifier.cpp:85
#20 0xb6712c98 in QSocketNotifier::event (this=0x85ffd40, e=0xbffff5b0)
    at kernel/qsocketnotifier.cpp:258
#21 0xb668d4fd in QApplication::internalNotify (this=0xbffff830, 
    receiver=0x85ffd40, e=0xbffff5b0) at kernel/qapplication.cpp:2635
#22 0xb668c9c1 in QApplication::notify (this=0xbffff830, receiver=0x85ffd40, 
    e=0xbffff5b0) at kernel/qapplication.cpp:2358
#23 0xb6d160a3 in KApplication::notify (this=0xbffff830, receiver=0x85ffd40, 
    event=0xbffff5b0)
    at /home/gj/kde-sources/kdelibs/kdecore/kapplication.cpp:549
#24 0xb661e945 in QApplication::sendEvent (receiver=0x85ffd40, 
    event=0xbffff5b0) at qapplication.h:491
#25 0xb667b3f7 in QEventLoop::activateSocketNotifiers (this=0x80a4e78)
    at kernel/qeventloop_unix.cpp:578
#26 0xb66325e4 in QEventLoop::processEvents (this=0x80a4e78, flags=4)
    at kernel/qeventloop_x11.cpp:383
#27 0xb66a2588 in QEventLoop::enterLoop (this=0x80a4e78)
    at kernel/qeventloop.cpp:198
#28 0xb66a24a6 in QEventLoop::exec (this=0x80a4e78)
    at kernel/qeventloop.cpp:145
#29 0xb668d67d in QApplication::exec (this=0xbffff830)
    at kernel/qapplication.cpp:2758
#30 0x08059591 in main (argc=1, argv=0xbffffab4)
    at /home/gj/kde-sources/kdepim/kontact/src/main.cpp:177
Comment 1 Stephan Binner 2006-01-17 14:16:07 UTC

*** This bug has been marked as a duplicate of 106030 ***