Bug 127863 - frequent crashes when uploading to dIMAP
Summary: frequent crashes when uploading to dIMAP
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: disconnected IMAP (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 129632 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-23 02:36 UTC by Matej Cepl
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
output of strace -f -o kmail-strace.txt kmail (259.32 KB, application/x-bzip2)
2006-05-23 02:40 UTC, Matej Cepl
Details
backtrace (3.20 KB, text/plain)
2006-05-26 19:02 UTC, Wilbert Berendsen
Details
backtrace (3.23 KB, text/plain)
2006-06-19 19:23 UTC, Matej Cepl
Details
backtrace (3.23 KB, text/plain)
2006-06-19 19:34 UTC, Matej Cepl
Details
backtrace (3.23 KB, text/plain)
2006-06-20 19:04 UTC, Matej Cepl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matej Cepl 2006-05-23 02:36:15 UTC
Version:           1.9.1 (using KDE 3.5.2, Debian Package 4:3.5.2-2+b1 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-rc3

My INBOX on IMAP got to the state that almost every other time when syncing kmail crashes. Tried fixing indexes, dIMAP cache, even deleted ~/.kde/share/apps/kmail/dimap/ folder, but after couple of successful synchronizations it crashes again. Unfortunately, no core (stripped binaries), but I have at least output of strace.
Comment 1 Matej Cepl 2006-05-23 02:40:17 UTC
Created attachment 16230 [details]
output of strace -f -o kmail-strace.txt kmail
Comment 2 Wilbert Berendsen 2006-05-26 19:02:02 UTC
Created attachment 16287 [details]
backtrace

Same problem here. Kontact very regularly crashes while syncing dimap account.
I got this backtrace.
Comment 3 Matej Cepl 2006-06-19 19:23:46 UTC
Created attachment 16702 [details]
backtrace

So I have installed -dbg packages and now I have this nice backtrace. I was not
able to synchronize dIMAP at all since this morning.

When the crash happens, I get this in ~/.xsession-errors:

*** KMail got signal 11 (Crashing)
KCrash: Application 'kmail' crashing...
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  20
  Minor opcode:  0
  Resource id:	0x360103a
kio (KIOConnection): ERROR: Could not write data
kio (KIOConnection): ERROR: Could not write data

Even tried to refresh dIMAP Cache, but nothing has changed -- kmail crashes
still.
Comment 4 Matej Cepl 2006-06-19 19:34:22 UTC
Created attachment 16703 [details]
backtrace

So I have installed -dbg packages and now I have this nice backtrace. I was not
able to synchronize dIMAP at all since this morning.

When the crash happens, I get this in ~/.xsession-errors:

*** KMail got signal 11 (Crashing)
KCrash: Application 'kmail' crashing...
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  20
  Minor opcode:  0
  Resource id:	0x360103a
kio (KIOConnection): ERROR: Could not write data
kio (KIOConnection): ERROR: Could not write data

Even tried to refresh dIMAP Cache, but nothing has changed -- kmail crashes
still.
Comment 5 Matej Cepl 2006-06-19 19:36:10 UTC
Comment on attachment 16702 [details]
backtrace

sorry, twice posted
Comment 6 Matej Cepl 2006-06-20 19:04:17 UTC
Created attachment 16721 [details]
backtrace

another one -- I am sorry to say that, but kmail is currently unusable to me.
Comment 7 Matej Cepl 2006-06-21 16:29:22 UTC
Actually, it seems to be somehow related to the named Searches -- when I removed all of them kmail hasn't crashed (tested just once, so longer testing is needed to be sure).
Comment 8 Matej Cepl 2006-06-22 12:41:01 UTC
This doesn't seem to trigger much developers' attention, but still -- there is a thread about this on http://comments.gmane.org/gmane.comp.kde.users.pim/7561 and I have to add two more things (which I didn't think were related, but the other reporter mentions them as well). That "cannot create folder" error message jumped on me too (but this jumps on me all the time, even in times when no crash occurs), and when recreating IMAP Cache (I thought that it could help, but it didn't) with File/Recreate Local IMAP Cache I got error that KMail cannot create subfolder "LSUB" (but the error didn't happen when I tried it now).

And the last comment is that the difference between crash and non-crash vis-a-vis search folders may lie in searching over dIMAP folders. It didn't happen before when I have search folders over folders in the Local Mail.
Comment 9 Ger Apeldoorn 2006-06-22 13:00:14 UTC
I'm experiencing the same problems.

Ger
Comment 10 Ismail Onur Filiz 2006-06-23 19:15:56 UTC
*** Bug 129632 has been marked as a duplicate of this bug. ***
Comment 11 Ismail Onur Filiz 2006-06-23 19:18:23 UTC
Pasting backtrace:

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1249080800 (LWP 11157)]
[New Thread -1278518352 (LWP 11162)]
[New Thread -1270125648 (LWP 11161)]
[New Thread -1261732944 (LWP 11160)]
[New Thread -1253340240 (LWP 11159)]
[KCrash handler]
#6  0x00000000 in ?? ()
#7  0xb7d48d31 in KMFolderImap::flagsToStatus (msg=0x8bbcdd8, flags=1, 
    newMsg=true)
    at /build/buildd/kdepim-3.5.2/build-tree/kdepim-3.5.2/kmail/kmfolderimap.cpp:1368
#8  0xb7d64ddf in KMFolderCachedImap::slotGetMessagesData (this=0x86222e8, 
    job=0x89317f8, data=@0x89317f8)
    at /build/buildd/kdepim-3.5.2/build-tree/kdepim-3.5.2/kmail/kmfoldercachedimap.cpp:1458
#9  0xb7d667d2 in KMFolderCachedImap::qt_invoke (this=0x86222e8, _id=9, 
    _o=0xbfcd23c0) at ./kmfoldercachedimap.moc:372
#10 0xb735754b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb5b104df in KIO::TransferJob::data (this=0x8971e30, t0=0x89317f8, 
    t1=@0x89317f8) at ./jobclasses.moc:993
#12 0xb5b10558 in KIO::TransferJob::slotData (this=0x8971e30, 
    _data=@0x89317f8) at /build/buildd/kdelibs-3.5.3/./kio/kio/job.cpp:906
#13 0xb5b64739 in KIO::TransferJob::qt_invoke (this=0x8971e30, _id=18, 
    _o=0xbfcd24b4) at ./jobclasses.moc:1072
#14 0xb735754b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xb5b0d6a2 in KIO::SlaveInterface::data (this=0x88c1de0, t0=@0x89317f8)
    at ./slaveinterface.moc:194
#16 0xb5b7a591 in KIO::SlaveInterface::dispatch (this=0x88c1de0, _cmd=100, 
    rawdata=@0xbfcd26b0)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/slaveinterface.cpp:234
#17 0xb5b21c87 in KIO::SlaveInterface::dispatch (this=0x88c1de0)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/slaveinterface.cpp:173
#18 0xb5b26b9b in KIO::Slave::gotInput (this=0x88c1de0)
    at /build/buildd/kdelibs-3.5.3/./kio/kio/slave.cpp:300
#19 0xb5b26d4b in KIO::Slave::qt_invoke (this=0x88c1de0, _id=4, _o=0xbfcd27d8)
    at ./slave.moc:113
#20 0xb735754b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0xb7357e52 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb76e9f7f in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#23 0xb737780a in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#24 0xb72ed87a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#25 0xb72eda76 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#26 0xb6fa124e in KApplication::notify (this=0xbfcd2db8, receiver=0x8b06218, 
    event=0xbfcd2b30)
    at /build/buildd/kdelibs-3.5.3/./kdecore/kapplication.cpp:550
#27 0xb727f001 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#28 0xb72df435 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#29 0xb7292d06 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#30 0xb7306255 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#31 0xb730617a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#32 0xb72ec38d in QApplication::exec () from /usr/lib/libqt-mt.so.3
#33 0x0804a098 in main (argc=143857656, argv=0x89317f8)
    at /build/buildd/kdepim-3.5.2/build-tree/kdepim-3.5.2/kmail/main.cpp:110
#34 0xb784beb0 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#35 0x08049e11 in _start () at ../sysdeps/i386/elf/start.S:119
Comment 12 Bram Schoenmakers 2006-11-15 14:38:42 UTC

*** This bug has been marked as a duplicate of 106030 ***