Bug 177308 - KMail crashed when I tried to access an IMAP folder
Summary: KMail crashed when I tried to access an IMAP folder
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.10.3
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-09 15:27 UTC by jde3
Modified: 2009-03-19 00:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jde3 2008-12-09 15:27:48 UTC
Version:           1.10.3 (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

Here is the report I got :

Application : KMail (kmail), signal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb422a6c0 (LWP 1397)]
[KCrash handler]
#6  0xb64ece7f in clearerr () from /lib/tls/i686/cmov/libc.so.6
#7  0xb77085cc in ?? () from /usr/lib/libkmailprivate.so.4
#8  0xb771d339 in ?? () from /usr/lib/libkmailprivate.so.4
#9  0xb7721cc1 in ?? () from /usr/lib/libkmailprivate.so.4
#10 0xb7f43a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#11 0xb7f447e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#12 0xb543b7a9 in KIO::TransferJob::data (this=0x8ada388, _t1=0x8ada388, 
    _t2=@0xbfd44444)
    at /build/buildd/kde4libs-4.1.3/obj-i486-linux-gnu/kio/jobclasses.moc:356
#13 0xb543c142 in KIO::TransferJob::slotData (this=0x8ada388, 
    _data=@0xbfd44444) at /build/buildd/kde4libs-4.1.3/kio/kio/job.cpp:927
#14 0xb544a115 in KIO::TransferJob::qt_metacall (this=0x8ada388, 
    _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfd442bc)
    at /build/buildd/kde4libs-4.1.3/obj-i486-linux-gnu/kio/jobclasses.moc:337
#15 0xb7f43a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#16 0xb7f447e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#17 0xb5509043 in KIO::SlaveInterface::data (this=0x8936800, _t1=@0xbfd44444)
    at /build/buildd/kde4libs-4.1.3/obj-i486-linux-gnu/kio/slaveinterface.moc:136
#18 0xb550ccbc in KIO::SlaveInterface::dispatch (this=0x8936800, _cmd=100, 
    rawdata=@0xbfd44444)
    at /build/buildd/kde4libs-4.1.3/kio/kio/slaveinterface.cpp:162
#19 0xb55096a7 in KIO::SlaveInterface::dispatch (this=0x8936800)
    at /build/buildd/kde4libs-4.1.3/kio/kio/slaveinterface.cpp:90
#20 0xb54f96cd in KIO::Slave::gotInput (this=0x8936800)
    at /build/buildd/kde4libs-4.1.3/kio/kio/slave.cpp:322
#21 0xb54fc113 in KIO::Slave::qt_metacall (this=0x8936800, 
    _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfd44558)
    at /build/buildd/kde4libs-4.1.3/obj-i486-linux-gnu/kio/slave.moc:75
#22 0xb7f43a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#23 0xb7f447e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#24 0xb54098f7 in KIO::Connection::readyRead (this=0x8944e98)
    at /build/buildd/kde4libs-4.1.3/obj-i486-linux-gnu/kio/connection.moc:84
#25 0xb540b9c9 in KIO::ConnectionPrivate::dequeue (this=0x8944e58)
    at /build/buildd/kde4libs-4.1.3/kio/kio/connection.cpp:82
#26 0xb540bb56 in KIO::Connection::qt_metacall (this=0x8944e98, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x8a082d0)
    at /build/buildd/kde4libs-4.1.3/obj-i486-linux-gnu/kio/connection.moc:72
#27 0xb7f3cbfb in QMetaCallEvent::placeMetaCall ()
   from /usr/lib/libQtCore.so.4
#28 0xb7f3e771 in QObject::event () from /usr/lib/libQtCore.so.4
#29 0xb681d8ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#30 0xb682572e in QApplication::notify () from /usr/lib/libQtGui.so.4
#31 0xb71b4b2d in KApplication::notify (this=0xbfd44da8, receiver=0x8944e98, 
    event=0x97b2528)
    at /build/buildd/kde4libs-4.1.3/kdeui/kernel/kapplication.cpp:311
#32 0xb7f2ee61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#33 0xb7f2fae5 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb7f2fcdd in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#35 0xb7f5982f in ?? () from /usr/lib/libQtCore.so.4
#36 0xb63e36f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb63e6da3 in ?? () from /usr/lib/libglib-2.0.so.0
#38 0xb63e6f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#39 0xb7f59478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#40 0xb68b7ea5 in ?? () from /usr/lib/libQtGui.so.4
#41 0xb7f2d52a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#42 0xb7f2d6ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#43 0xb7f2fda5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#44 0xb681d767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#45 0x0804a6c0 in _start ()
#0  0xb8045430 in __kernel_vsyscall ()
Comment 1 Jaime Torres 2008-12-09 15:38:07 UTC

*** This bug has been marked as a duplicate of bug 106030 ***