Bug 155272 - Crash when filter copies outgoing message to IMAP folder
Summary: Crash when filter copies outgoing message to IMAP folder
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-08 12:47 UTC by Tristan Miller
Modified: 2008-01-12 16:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2008-01-08 12:47:28 UTC
Version:            (using KDE KDE 3.5.8)
Installed from:    SuSE RPMs

Reproducibility: Always

Steps to reproduce:

1. Create a filter which copies outgoing messages to an IMAP folder.
2. Send a message.

Expected results:

3. Message is sent, gets placed in the sent mail folder, and a copy placed in the specified IMAP folder.

Observed results:

3. Message is sent, gets placed in the sent mail folder, and a copy placed in the specified IMAP folder.
4. KMail crashes with the following backtrace:

System configuration startup check disabled.

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1240786432 (LWP 7354)]
[New Thread -1280566384 (LWP 7360)]
[New Thread -1272173680 (LWP 7359)]
[New Thread -1263780976 (LWP 7358)]
[New Thread -1255388272 (LWP 7357)]
[KCrash handler]
#9  0x62677073 in ?? ()
#10 0xb57166b1 in KMFolderImap::flagsToStatus ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb57219bb in KMFolderImap::slotGetMessagesData ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb5725390 in KMFolderImap::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#13 0xb6ce3aad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb77cd05d in KIO::TransferJob::data () from /opt/kde3/lib/libkio.so.4
#15 0xb77cd0d8 in KIO::TransferJob::slotData () from /opt/kde3/lib/libkio.so.4
#16 0xb7809e99 in KIO::TransferJob::qt_invoke () from /opt/kde3/lib/libkio.so.4
#17 0xb6ce3aad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb77cac9e in KIO::SlaveInterface::data () from /opt/kde3/lib/libkio.so.4
#19 0xb7835be3 in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#20 0xb781b02a in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#21 0xb77dab2c in KIO::Slave::gotInput () from /opt/kde3/lib/libkio.so.4
#22 0xb781c830 in KIO::Slave::qt_invoke () from /opt/kde3/lib/libkio.so.4
#23 0xb6ce3aad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb6ce45f2 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb701f450 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb6d01ce0 in QSocketNotifier::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb6c84557 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb6c85321 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb73406f2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#30 0xb6c78f01 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb6c33424 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb6c9b380 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb6c9b216 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb6c8410f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x08058c12 in QWidget::setUpdatesEnabled ()
#36 0xbfb2dcbc in ?? ()
#37 0x00000001 in ?? ()
#38 0x00000001 in ?? ()
#39 0x00000000 in ?? ()


Not sure if this is related to Bug 108971 or not.
Comment 1 Thomas McGuire 2008-01-12 16:29:17 UTC
Same backtrace as in bug 106030.

*** This bug has been marked as a duplicate of 106030 ***