Bug 175825 - Kontact crashes when downloading emails (from IMAP, I think)
Summary: Kontact crashes when downloading emails (from IMAP, I think)
Status: RESOLVED DUPLICATE of bug 106030
Alias: None
Product: kmail
Classification: Unclassified
Component: IMAP (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-22 05:01 UTC by Serge-Étienne Parent
Modified: 2009-03-19 00:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serge-Étienne Parent 2008-11-22 05:01:20 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

Crashes when downloading emails with imap.

Application : Kontact (kontact), signal SIGILL
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb4ce56c0 (LWP 6003)]
[New Thread 0xb0cfbb90 (LWP 6038)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x08b63190 in ?? ()
#7  0xb1712379 in ?? () from /usr/lib/libkmailprivate.so.4
#8  0xb17443e0 in ?? () from /usr/lib/libkmailprivate.so.4
#9  0xb174792e in ?? () from /usr/lib/libkmailprivate.so.4
#10 0xb7eb6a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#11 0xb7eb77e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#12 0xb64ef7a9 in KIO::TransferJob::data () from /usr/lib/libkio.so.5
#13 0xb64f0142 in KIO::TransferJob::slotData () from /usr/lib/libkio.so.5
#14 0xb64fe115 in KIO::TransferJob::qt_metacall () from /usr/lib/libkio.so.5
#15 0xb7eb6a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#16 0xb7eb77e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#17 0xb65bd043 in KIO::SlaveInterface::data () from /usr/lib/libkio.so.5
#18 0xb65c0cbc in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#19 0xb65bd6a7 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#20 0xb65ad6cd in KIO::Slave::gotInput () from /usr/lib/libkio.so.5
#21 0xb65b0113 in KIO::Slave::qt_metacall () from /usr/lib/libkio.so.5
#22 0xb7eb6a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#23 0xb7eb77e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#24 0xb64bd8f7 in KIO::Connection::readyRead () from /usr/lib/libkio.so.5
#25 0xb64bf9c9 in ?? () from /usr/lib/libkio.so.5
#26 0xb64bfb56 in KIO::Connection::qt_metacall () from /usr/lib/libkio.so.5
#27 0xb7eafbfb in QMetaCallEvent::placeMetaCall ()
   from /usr/lib/libQtCore.so.4
#28 0xb7eb1771 in QObject::event () from /usr/lib/libQtCore.so.4
#29 0xb6ea88ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#30 0xb6eb076e in QApplication::notify () from /usr/lib/libQtGui.so.4
#31 0xb79a3b2d in KApplication::notify () from /usr/lib/libkdeui.so.5
#32 0xb7ea1e61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#33 0xb7ea2ae5 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb7ea2cdd in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#35 0xb7ecc82f in ?? () from /usr/lib/libQtCore.so.4
#36 0xb6a7d6f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb6a80da3 in ?? () from /usr/lib/libglib-2.0.so.0
#38 0xb6a80f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#39 0xb7ecc478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#40 0xb6f42ee5 in ?? () from /usr/lib/libQtGui.so.4
#41 0xb7ea052a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#42 0xb7ea06ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#43 0xb7ea2da5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#44 0xb6ea8767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#45 0x0804bf52 in _start ()
#0  0xb7fb8430 in __kernel_vsyscall ()
Comment 1 Médéric Boquien 2008-11-22 05:08:43 UTC
Hello,

Thank you for your report. Unfortunately some symbols are missing in the backtrace. Please follow to instructions available on this page http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports and resubmit a new backtrace.

Thanks.
Comment 2 Dario Andres 2008-12-06 23:55:15 UTC
Marking as duplicate of bug 106030 .(similar backtrace, same situation, the original bug is from KDE3, but, another bugreports were from KDE4 versions). If you think this is not a duplicate, just report it to me. :)

*** This bug has been marked as a duplicate of bug 106030 ***