Bug 89278

Summary: Crash closing project from menu
Product: kdevelop Reporter: Steven T. Hatton <hattons>
Component: generalAssignee: kdevelop-bugs-null
Status: RESOLVED NOT A BUG    
Severity: crash CC: Andreas.Schallenberg, AngusCMarch, atzus, basti, bluedzins, edulix, FredericDruide, greatbunzinni, info, jhlaks, joel, kde, metehan, n.bergantino, rpolli, sleepingeliminator, steven_risner, ucbpabe, vdboor, vkrevs
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Steven T. Hatton 2004-09-11 08:25:53 UTC
Version:           3.1.0 (using KDE 3.3.0, SuSE)
Compiler:          gcc version 3.3.3 (SuSE Linux)
OS:                Linux (i686) release 2.6.5-7.108-default

This is the last part of the xterm dump as KDevelop crashed when I closed a project using the menu Project->Close Project.  The last thing I was messing with what the Automake Manager.  Note that the back trace mentioned some font stuff as the last function call. I believe the bug I filed for a crash closing a tab also has that as the last function.

kdevelop (core): parentWidget: [KDockWidget pointer (0x8774150) to widget fileviewpartwidget, geometry=241x982+0+0]
kdevelop (file view): FileTreeWidget::~FileTreeWidget()
kdevelop (file view): StdFileTreeWidgetImpl::~StdFileTreeWidgetImpl()
kdevelop (file view): FileTreeViewWidgetImpl::~FileTreeViewWidgetImpl()
kdevelop (core): Language support for KDevCppSupport unloading...
kdevelop (cpp support): !!!!!!!!!!!!!!!!!! BG PARSER DESTROYED !!!!!!!!!!!!
kdevelop (cpp support): BackgroundParser::removeAllFiles()
kdevelop (core): [virtual void NewMainWindow::removeView(QWidget*)]  - view: [ProblemReporter pointer (0x88c0e58) to widget problemreporter, geometry=1508x206+0+12]
kdevelop (core): parentWidget: [KDockWidget pointer (0x88c2ad0) to widget problemreporter, geometry=1508x218+0+0]
kdevelop (cpp support): [virtual CppSupportPart::~CppSupportPart()] 
kdevelop (core): [virtual void NewMainWindow::removeView(QWidget*)]  - view: [AutoProjectWidget pointer (0x8a46898) to widget auto project widget, geometry=355x970+0+12]
kdevelop (core): parentWidget: [KDockWidget pointer (0x8738d38) to widget auto project widget, geometry=355x982+0+0]
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  40
  Minor opcode:  0
  Resource id:  0x0
KCrash: Application 'kdevelop' crashing...
drkonqi: WARNING: file: is not a correct argument for setSelection!
drkonqi: WARNING: Pixmap not found for mimetype text/x-hpp


Here's the backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 27133)]
[New Thread 32769 (LWP 27135)]
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 27133)]
[New Thread 32769 (LWP 27135)]
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 27133)]
[New Thread 32769 (LWP 27135)]
[KCrash handler]
#6  0x412a6a7b in QFont::QFont () from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x414d4607 in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x4125df1d in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x46703e7e in KateViewInternal::updateCursor ()
   from /opt/kde3/lib/kde3/libkatepart.so
#10 0x4670bf24 in KateView::setCursorPositionInternal ()
   from /opt/kde3/lib/kde3/libkatepart.so
#11 0x467137d3 in KateDocument::closeURL ()
   from /opt/kde3/lib/kde3/libkatepart.so
#12 0x080886e3 in PartController::closePart (this=0x8230a18, part=0x893b660)
    at partcontroller.cpp:744
#13 0x080898b1 in PartController::closeFilesDialog (this=0x8230a18, 
    ignoreList=@0xbfff9770) at partcontroller.cpp:1031
#14 0x08089a0b in PartController::closeAllFiles (this=0x8230a18)
    at partcontroller.cpp:1059
#15 0x08089a46 in PartController::slotCloseAllWindows (this=0x8230a18)
    at partcontroller.cpp:1064
#16 0x0809250c in ProjectManager::closeProject (this=0x8202168, exiting=false)
    at projectmanager.cpp:369
#17 0x080943cd in ProjectManager::qt_invoke (this=0x8202168, _id=4, 
    _o=0xbfff98a0) at projectmanager.moc:122
#18 0x412f023e in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x412f09e6 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x40bcc189 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#21 0x40bcc1ad in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#22 0x40bd4e41 in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#23 0x412f023e in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x416375e2 in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x4130d3f3 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x413fc6cf in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x41325cd5 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x4128e9ef in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x41290bc8 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x40f20a4e in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#31 0x4122e080 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x4122ccdd in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x4123d615 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x412a64a1 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x412a62e6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x412902df in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x080b0f79 in main (argc=1, argv=0xbfffa6f4) at main.cpp:138
Comment 1 Jens Dagerbo 2004-09-11 16:39:36 UTC
Yeah, this and bug #89052 look like two different ways of hitting the same bug. 

Steven, what Qt version are you running?!

I can see no mention of QXIMInputContext in either latest qt-copy or the Qt-3.3.3 documentation. 

With the help of google I found this: http://freedesktop.org/pipermail/uim/2004-June/000370.html, which mentions this as new code as late as three months ago.

Best I can figure is that you are running on a SuSE-modified Qt, in which case you should report this crash to them.


Comment 2 Steven T. Hatton 2004-09-12 03:32:34 UTC
On Saturday 11 September 2004 10:39, Jens Dagerbo wrote:

> Steven, what Qt version are you running?!
>
> I can see no mention of QXIMInputContext in either latest qt-copy or the
> Qt-3.3.3 documentation.

<nearest suse ftp mirror>/pub/suse/i386/supplementary/KDE/update_for_9.1

> With the help of google I found this:
> http://freedesktop.org/pipermail/uim/2004-June/000370.html, which mentions
> this as new code as late as three months ago.
>
> Best I can figure is that you are running on a SuSE-modified Qt, in which
> case you should report this crash to them.

I'll let them know.  Thanks.
Comment 3 Jens Dagerbo 2004-09-12 06:13:03 UTC
Yeah, there it is. SuSE's qt3-3.3.3-11.src.rpm comes with a patch that adds the code in question.

In other words, this bug report is of no use to us. Closing as INVALID.
Comment 4 Jens Dagerbo 2004-12-03 16:12:12 UTC
*** Bug 94294 has been marked as a duplicate of this bug. ***
Comment 5 Jens Dagerbo 2004-12-16 23:07:13 UTC
*** Bug 95245 has been marked as a duplicate of this bug. ***
Comment 6 Jens Dagerbo 2005-01-05 09:38:23 UTC
*** Bug 96293 has been marked as a duplicate of this bug. ***
Comment 7 Matt Rogers 2005-01-13 16:25:03 UTC
*** Bug 96293 has been marked as a duplicate of this bug. ***
Comment 8 Matt Rogers 2005-01-20 16:12:00 UTC
*** Bug 97531 has been marked as a duplicate of this bug. ***
Comment 9 Thiago Macieira 2005-05-12 04:17:52 UTC
*** Bug 103460 has been marked as a duplicate of this bug. ***
Comment 10 Thiago Macieira 2005-05-12 04:19:23 UTC
*** Bug 105472 has been marked as a duplicate of this bug. ***
Comment 11 Jens Dagerbo 2005-05-23 12:20:04 UTC
*** Bug 105960 has been marked as a duplicate of this bug. ***
Comment 12 Jens Dagerbo 2005-08-21 22:49:26 UTC
*** Bug 110986 has been marked as a duplicate of this bug. ***
Comment 13 Jens Dagerbo 2005-10-10 03:13:08 UTC
*** Bug 114029 has been marked as a duplicate of this bug. ***
Comment 14 Jens Dagerbo 2005-11-09 09:39:11 UTC
*** Bug 115963 has been marked as a duplicate of this bug. ***
Comment 15 Jens Dagerbo 2005-11-11 15:14:14 UTC
*** Bug 116122 has been marked as a duplicate of this bug. ***
Comment 16 kim Lux 2005-11-11 18:02:21 UTC
I had the same problem with several versions of kdevelop.  I am running FC4, which uses qt-3.3.4-17.4.fc4.kde
Comment 17 Alvin 2005-11-27 17:56:16 UTC
With some help from opensuse.org.suse-linux.kde I think I have found a work around. Now, this is for SUSE 9.3 but it should work on other versions of SUSE as well.

In SUSE 9.3 it appears that the XIM input method is not defined. Therefore, by setting the INPUT_METHOD to "none" KDevelop stops crashing.

In SUSE, this is set by:

1. Yast->System->/etc/sysconfig Editor
2. Then click Search and enter: input method
3. Select INPUT_METHOD
4. Then set the field to "none" (without the quotes)

OR

1. Edit /etc/sysconfig/language
2. Change INPUT_METHOD= to INPUT_METHOD=""
3. Save changes then run /sbin/SuSEconfig as root.

To ensure that the changes were seen, I restarted X.

I was told another tip was to use /usr/lib/qt3/bin/qtconfig and disable XIM in the Interface tab (at the bottom). I haven't tried this yet, but I thought it would be worth mentioning in case it works for someone else.
Comment 18 Alvin 2005-12-04 19:22:21 UTC
I think I was a little hasty at posting my previous "fix". Turns out setting INPUT_METHOD didn't really fix the problem.

I tried using qtconfig to disable XIM support and KDevelop rarely crashes now. I have tested this everyday for about a week.
Comment 19 Vadym Krevs 2005-12-04 19:42:19 UTC
My "fix" was to disable LIBQXIM plugins completely by renaming them.

mkdir /usr/lib/qt3/plugins/inputmethods/bad
cd /usr/lib/qt3/plugins/inputmethods/bad
mv  /usr/lib/qt3/plugins/inputmethods/bad/libqxim.lib64-non-mt.so .
mv /usr/lib/qt3/plugins/inputmethods/bad/libqxim.lib64.so .
mv /usr/lib/qt3/plugins/inputmethods/bad/libqxim.so .

Having done that, I have not experienced any crashes closing projects, switching between tabs. 
Comment 20 Tommi Tervo 2005-12-07 14:40:04 UTC
*** Bug 117856 has been marked as a duplicate of this bug. ***
Comment 21 Jens Dagerbo 2006-04-26 20:13:53 UTC
*** Bug 126303 has been marked as a duplicate of this bug. ***
Comment 22 Jens Dagerbo 2006-05-11 18:11:44 UTC
*** Bug 127128 has been marked as a duplicate of this bug. ***
Comment 23 Jens Dagerbo 2006-05-27 04:43:34 UTC
*** Bug 128072 has been marked as a duplicate of this bug. ***
Comment 24 Jens Dagerbo 2006-06-05 01:40:44 UTC
*** Bug 128620 has been marked as a duplicate of this bug. ***
Comment 25 Jens Dagerbo 2006-06-24 06:39:58 UTC
*** Bug 129715 has been marked as a duplicate of this bug. ***
Comment 26 Eduardo Robles Elvira 2006-06-24 18:48:13 UTC
I have experienced one crash when closing a file after having deleted the /usr/lib/qt3/plugins/inputmethods/ directory!. This is the back trace - not a very useful one but that's all I can do for now:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1217542464 (LWP 12161)]
[New Thread -1227732048 (LWP 3086)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0x43f14136 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#2  0x43f13f3c in sleep () from /lib/tls/i686/cmov/libc.so.6
#3  0x4113d70f in ?? () from /usr/lib/libkparts.so.2
#4  0x00000001 in ?? ()
#5  0x00000000 in ?? ()
Comment 27 Rolf Eike Beer 2006-08-11 12:54:59 UTC
This is my backtrace: KDevelop 3.3.4 running on SuSE 10.0 (x86), qt 3.3.6. Happens very often when I open a single project. When I open the project on startup everything is fine.

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47282119770192 (LWP 21524)]
[New Thread 1082132800 (LWP 21757)]
[KCrash handler]
#5  0x00002b00b5a589a8 in QWidget::topLevelWidget ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#6  0x00002b00bc7ca0d6 in QXIMInputContext::setMicroFocus (this=0xffea30, 
    x=27, y=112, h=14, f=0x0) at qximinputcontext_x11.cpp:761
#7  0x00002b00b59a7a64 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#8  0x00002aaaaac26609 in KateViewInternal::updateMicroFocusHint ()
   from /opt/kde3/lib64/kde3/libkatepart.so
#9  0x00002aaaaac2a90c in KateViewInternal::updateCursor ()
   from /opt/kde3/lib64/kde3/libkatepart.so
#10 0x00002aaaaac2ce5a in KateView::setCursorPositionInternal ()
   from /opt/kde3/lib64/kde3/libkatepart.so
#11 0x00002aaaaac50874 in KateView::setCursorPositionReal ()
   from /opt/kde3/lib64/kde3/libkatepart.so
#12 0x00002b00b45a8d96 in PartController::editDocumentInternal ()
   from /opt/kde3/lib64/libkdevshell.so.0
#13 0x00002b00b45b61ed in ProjectSession::loadDocument ()
   from /opt/kde3/lib64/libkdevshell.so.0
#14 0x00002b00b45b6238 in ProjectSession::loadDocument ()
   from /opt/kde3/lib64/libkdevshell.so.0
#15 0x00002b00b45b62ed in ProjectSession::qt_invoke ()
   from /opt/kde3/lib64/libkdevshell.so.0
#16 0x00002b00b5a2aa8c in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#17 0x00002b00b5d0ec52 in QSignal::signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#18 0x00002b00b5a435a5 in QSignal::activate ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#19 0x00002b00b5a49bc8 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#20 0x00002b00b59d3a95 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#21 0x00002b00b59d46c7 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#22 0x00002b00b53db218 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#23 0x00002b00b59ca005 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#24 0x00002b00b598a4ed in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#25 0x00002b00b59e87a1 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#26 0x00002b00b59e864a in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#27 0x00000000004072f7 in main (argc=<value optimized out>, 
    argv=<value optimized out>) at main.cpp:145
Comment 28 Amilcar do Carmo Lucas 2006-08-11 14:04:15 UTC
The last Backtrace has nothing to do with the original bug.
It is a duplicate of a KATE bug fixed in KDE 3.5.4
Comment 29 Rolf Eike Beer 2006-08-11 14:14:56 UTC
Ok, thx. Which one? And why it is still in KDevelop 3.3.4?
Comment 30 Amilcar do Carmo Lucas 2006-08-11 14:36:07 UTC
KDevelop only uses KATE, KDevelop does not provide KATE.
KATE is part of KDE. So unless you update your KDE to 3.5.4 the bug will not go away.
Comment 31 Rolf Eike Beer 2006-08-14 09:14:08 UTC
I upgraded everything at the same time.
Comment 32 Jens Dagerbo 2006-09-05 22:13:32 UTC
*** Bug 133598 has been marked as a duplicate of this bug. ***
Comment 33 Jens Dagerbo 2006-09-19 21:07:12 UTC
*** Bug 134347 has been marked as a duplicate of this bug. ***