Bug 110986 - crashing when changing/closing projects
Summary: crashing when changing/closing projects
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-18 05:53 UTC by Angus
Modified: 2005-08-24 08:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angus 2005-08-18 05:53:39 UTC
Version:           3.2.0 (using KDE KDE 3.4.0)
Installed from:    SuSE RPMs
Compiler:          gcc version 3.3.5 20050117 (prerelease) (SUSE Linux) 
OS:                Linux

When closing or changing a project I'm often faced with segmentation faults. One way in which I can always get it to crash is by opening another project (through Project|Open Recent Project) and then quickly change windows before the task is completed. I've also crashed a lot when changing projects with the konsole open. 
   I should also point out that I've experienced this problem on just about every KDevelop version I've had since 3.0.0, and on 2 distributions: Fedora and SuSE.

Here's the backtrace from one such crash. Let me know if you want others:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1105011232 (LWP 9827)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#7  0x4148045b in QFont::QFont () from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x423f7abf in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#9  0x423c41f3 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#10 0x41436662 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x42ef54c1 in TEWidget::setCursorPos ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#12 0x42efcaf3 in TEmulation::showBulk ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#13 0x42efcc08 in TEmulation::onImageSizeChange ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#14 0x42f0f892 in TESession::onContentSizeChange ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#15 0x42f0f97b in TESession::qt_invoke ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#16 0x414cae7e in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x42ef41ca in TEWidget::changedContentSizeSignal ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#18 0x42ef5a89 in TEWidget::updateImageSize ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#19 0x42ef5bfd in TEWidget::resizeEvent ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#20 0x41501392 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x42ef6422 in TEWidget::event () from /opt/kde3/lib/kde3/libkonsolepart.so
#22 0x41467d5f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x41469a83 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x410f36b1 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#25 0x41433323 in QWidget::internalSetGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x41505658 in QWidget::setGeometry () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x41463db1 in QWidgetItem::setGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x414b2ab7 in QBoxLayout::setGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x41463171 in QLayout::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x414ca37e in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x414ca460 in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x41500ebf in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x41467d5f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x41469a83 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x410f36b1 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#36 0x41433323 in QWidget::internalSetGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x41505658 in QWidget::setGeometry () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0x41463db1 in QWidgetItem::setGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0x414b2ab7 in QBoxLayout::setGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x41463171 in QLayout::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0x414ca37e in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0x414ca460 in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0x41500ebf in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0x40dcc4d8 in KDockWidget::event () from /opt/kde3/lib/libkdeui.so.4
#45 0x41467d5f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0x41469a83 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0x410f36b1 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#48 0x41433323 in QWidget::internalSetGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0x41505658 in QWidget::setGeometry () from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0x08052901 in QWidget::setGeometry ()
#51 0x41616289 in QWidgetStack::setChildGeometries ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0x41616034 in QWidgetStack::resizeEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#53 0x41501392 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#54 0x41467d5f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#55 0x41469a83 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#56 0x410f36b1 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#57 0x41433323 in QWidget::internalSetGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#58 0x41505658 in QWidget::setGeometry () from /usr/lib/qt3/lib/libqt-mt.so.3
#59 0x41463db1 in QWidgetItem::setGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#60 0x414b2ab7 in QBoxLayout::setGeometry ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#61 0x41462d57 in QLayout::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#62 0x41463075 in QLayout::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#63 0x414ca37e in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#64 0x414ca460 in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#65 0x41500ebf in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#66 0x41467d5f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#67 0x41469a83 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#68 0x410f36b1 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#69 0x41468ed0 in QApplication::sendPostedEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#70 0x41468f54 in QApplication::sendPostedEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#71 0x41414bc0 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#72 0x4147fe51 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#73 0x4147fc96 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#74 0x4146994f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#75 0x0804e91d in ?? ()
#76 0xbfffef30 in ?? ()
#77 0x080efa50 in ?? ()
#78 0xbfffee80 in ?? ()
#79 0x00000001 in ?? ()
#80 0x00000000 in ?? ()
#81 0x00000001 in ?? ()
#82 0x080533d0 in vtable for QDragMoveEvent ()
#83 0x08053c4d in typeinfo name for ShellExtension ()
#84 0x08052b65 in typeinfo name for QGList ()
#85 0x08052b39 in typeinfo name for QGList ()
#86 0x0006d8b5 in ?? ()
#87 0x40008002 in do_lookup_x () from /lib/ld-linux.so.2
#88 0x41cc9e80 in __libc_start_main () from /lib/tls/libc.so.6
#89 0x0804de11 in ?? ()
Comment 1 Jens Dagerbo 2005-08-21 22:49:24 UTC
SuSE bug. Update your Qt lib.

Dupe.

*** This bug has been marked as a duplicate of 89278 ***
Comment 2 Angus 2005-08-24 08:13:00 UTC
Jens Dagerbo wrote:

[bugs.kde.org quoted mail]
    It's also a Fedora bug. What do I update it to? The original bug's 
thread talks about a problem with 9.1, and I have 9.3, and none of the 
rpms on my system with "qt" in their name also have "suse".