Bug 103460 - kdevelop crashes while closing application
Summary: kdevelop crashes while closing application
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-07 23:21 UTC by Diederik van der Boor
Modified: 2005-05-12 04:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diederik van der Boor 2005-04-07 23:21:10 UTC
Version:           unknown (using KDE 3.4.0 Level "a" , SUSE 9.2 UNSUPPORTED)
Compiler:          gcc version 3.3.4 (pre 3.3.5 20040809)
OS:                Linux (i686) release 2.6.8-24.14-default

I've closed my kdevelop, and it crashed while it was closing.

This is the provided backtrace:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1104930720 (LWP 13856)]
[KCrash handler]
#7  0x4147a14b in QFont::QFont () from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x4241dadf in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#9  0x423ea203 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#10 0x41430512 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x44bc743b in KateViewInternal::updateMicroFocusHint ()
   from /opt/kde3/lib/kde3/libkatepart.so
#12 0x44bcf60a in KateViewInternal::updateCursor ()
   from /opt/kde3/lib/kde3/libkatepart.so
#13 0x44bd4204 in KateView::setCursorPositionInternal ()
   from /opt/kde3/lib/kde3/libkatepart.so
#14 0x44bdfb93 in KateDocument::closeURL ()
   from /opt/kde3/lib/kde3/libkatepart.so
#15 0x40071a1f in PartController::closePart ()
   from /opt/kde3/lib/libkdevshell.so.0
#16 0x4007122d in PartController::closeFilesDialog ()
   from /opt/kde3/lib/libkdevshell.so.0
#17 0x40071445 in PartController::closeAllFiles ()
   from /opt/kde3/lib/libkdevshell.so.0
#18 0x40070c96 in PartController::readyToClose ()
   from /opt/kde3/lib/libkdevshell.so.0
#19 0x4005b9a1 in Core::queryClose () from /opt/kde3/lib/libkdevshell.so.0
#20 0x400684ea in NewMainWindow::queryClose ()
   from /opt/kde3/lib/libkdevshell.so.0
#21 0x40e9ffe7 in KMainWindow::closeEvent () from /opt/kde3/lib/libkdeui.so.4
#22 0x414fa79b in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x415c14d2 in QMainWindow::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x40236fc1 in KMdiMainFrm::event () from /opt/kde3/lib/libkmdi.so.1
#25 0x41461baf in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x41463773 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x410ed631 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#28 0x414fcbf5 in QWidget::close () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x413ed21a in QETWidget::translateCloseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x413f3278 in QApplication::x11ClientMessage ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x413fdb34 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x4140eb08 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x41479b41 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x41479986 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x4146363f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x0804e93d in main ()

I hope this backtrace is sufficient to solve the problem.
Comment 1 Jens Dagerbo 2005-04-13 10:30:32 UTC
>I hope this backtrace is sufficient to solve the problem.

Not to solve, but to identify it. 

You are using SuSE's patched Qt lib. This bug is in their patch, we can't fix it.

(There are a few dupes of this in the bug database, but I can't seem to find them right now...)
Comment 2 Thiago Macieira 2005-05-12 04:17:49 UTC

*** This bug has been marked as a duplicate of 89278 ***