Bug 96293 - When all opened file windows are closed, often there is a crash.
Summary: When all opened file windows are closed, often there is a crash.
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 3.1.2
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-04 15:12 UTC by Steven Risner
Modified: 2005-01-13 16:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Risner 2005-01-04 15:12:39 UTC
Version:           3.1.2 (using KDE KDE 3.3.2)
Installed from:    SuSE RPMs
Compiler:          gcc 3.3 
OS:                Linux

Had about 5-7 code files opened and closed them all, fairly quick.  About 1/.5 sec

on the last file close Kdevelop crashed.

Happens intermitantly, so my be attributed to the speed in which closing is done or something else.

occurs about 30% of the time.
Comment 1 Thiago Macieira 2005-01-04 15:32:56 UTC
Can you paste the backtrace?
Comment 2 Steven Risner 2005-01-04 18:16:27 UTC
How do I do that?
Comment 3 Thiago Macieira 2005-01-04 19:04:15 UTC
When it crashes, the KDE Crash Handler will appear. Click the Backtrace tab. If it produces a backtrace and if it doesn't say it is useless, paste it here. (Do not attach, please)
Comment 4 Robert DeSonia 2005-01-05 03:30:05 UTC
I get the same behaviour on my AMD64 Opteron with Fedora Core 3 x86_64 (KDE 3.3.2).  After kdevelop 3.1.2 did it, I downloaded the CVS snapshot dated 050103 and compiled with --enable-debug.  The problem still exists; here is the trace information.

Using host libthread_db library "/lib64/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 182903807552 (LWP 10358)]
[New Thread 1084229984 (LWP 10359)]
[Thread debugging using libthread_db enabled]
[New Thread 182903807552 (LWP 10358)]
[New Thread 1084229984 (LWP 10359)]
[Thread debugging using libthread_db enabled]
[New Thread 182903807552 (LWP 10358)]
[New Thread 1084229984 (LWP 10359)]
[KCrash handler]
#3  0x0000003004d06773 in QFont::QFont ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#4  0x0000002a99efe4d5 in QWidget::font ()
   from /usr/lib64/qt-3.3/plugins/inputmethods/libqxim.so
#5  0x0000002a99efdcd7 in QXIMInputContext::setMicroFocus ()
   from /usr/lib64/qt-3.3/plugins/inputmethods/libqxim.so
#6  0x0000002a99bc07fd in QMultiInputContext::setMicroFocus ()
   from /usr/lib64/qt-3.3/plugins/inputmethods/libqimsw-multi.so
#7  0x0000003004cc634e in QWidget::setMicroFocusHint ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#8  0x0000002a9cd30c29 in TEWidget::setCursorPos ()
   from /usr/lib64/kde3/libkonsolepart.so
#9  0x0000002a9cd3f46e in TEmulation::showBulk ()
   from /usr/lib64/kde3/libkonsolepart.so
#10 0x0000002a9cd3f97b in TEmulation::qt_invoke ()
   from /usr/lib64/kde3/libkonsolepart.so
#11 0x0000002a9cd38a0a in TEmuVt102::qt_invoke ()
   from /usr/lib64/kde3/libkonsolepart.so
#12 0x0000003004d4abd8 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#13 0x0000003004d4b342 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#14 0x0000003004d67ac5 in QTimer::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#15 0x0000003004cf20cd in QApplication::internalNotify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#16 0x0000003004cf2275 in QApplication::notify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#17 0x00000030056f121e in KApplication::notify ()
   from /usr/lib64/libkdecore.so.4
#18 0x0000003004ce70e3 in QEventLoop::activateTimers ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#19 0x0000003004ca8e8d in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#20 0x0000003004d06185 in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#21 0x0000003004d060e2 in QEventLoop::exec ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#22 0x00000000004079a4 in main (argc=-1073745008, argv=0x7fbffff3a0)
    at main.cpp:139
Comment 5 Matt Rogers 2005-01-05 03:53:07 UTC
the backtrace posted in comment #4 doesn't seem related due to a fedora specific qt plugin for XIM input methods. However, if both SuSE and Fedora use the same plugin, then it might very well be the cause of the problem especially if both systems are 64-bit.
Comment 6 Jens Dagerbo 2005-01-05 09:34:49 UTC
SuSE does use some additional code for XIM input (don't know if it is the same code as Fedora uses or not) and it does lead to crashes. I don't have the BR numbers ready, but there have been several reports from SuSE users already.

(On a side note: This is the problem with crashreports without a backtrace, we would have no idea the patched Qt is the likely cause, if not for the bt pasted in comment #4.)
Comment 7 Jens Dagerbo 2005-01-05 09:38:22 UTC
Found it. It seems very likely this is another crash report based on SuSE's patched Qt library.

Closing as dupe.

*** This bug has been marked as a duplicate of 89278 ***
Comment 8 Steven Risner 2005-01-05 12:40:08 UTC
To comment a back trace from my system has not been posted,  and I do not believe I am using the QT plugin (if that matters.)  Additionaly the crash occurs when closing the last file open in the project, not the project itself.  If and when it happens again I'll post the bactrace.  Unless you know absolutly certain its been resolved or a duplicate you should probably leave it open until I least post a backtrace to verify the bugs cause.
Comment 9 Jens Dagerbo 2005-01-05 16:41:39 UTC
In the SuSE case, I don't think it is a plugin (I have no idea about Fedora). At least when I last looked at it, SuSE had the XIM code as a patch to the Qt codebase.

If you can produce a backtrace, please post it.

If it is fundamentally different to the backtrace in bug #89278 and the other dupes, please reopen the bug. As the bug creator, you should have permission to do that.
Comment 10 Robert DeSonia 2005-01-06 04:09:35 UTC
Sorry for the confusion of throwing in a backtrace, but I had one to offer up and the description matched my experience exactly.  I just didn't want to make a duplicate bug report after finding yours and it seems like you weren't 100% sure how to get a backtrace.

Just as a follow-up: I went and updated my QT with the version in the Fedora development repository (via yum) and I can't reproduce the crash now.  Thanks, Jens!  

-rdd
Comment 11 Steven Risner 2005-01-13 16:14:14 UTC
The following is the backtrace for this issue.  I hope it is related to the same incident.

[New Thread 16384 (LWP 5420)]
[New Thread 32769 (LWP 5423)]

[KCrash handler]
#4  0x41271a8b in QFont::QFont(QFont const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0x423f8308 in QXIMInputContext::setMicroFocus(int, int, int, int, QFont*)
    () from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#6  0x423c6783 in QMultiInputContext::setMicroFocus(int, int, int, int, QFont*)
    () from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#7  0x41222832 in QWidget::setMicroFocusHint(int, int, int, int, bool, QFont*)
    () from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x467c2faa in KateViewInternal::updateMicroFocusHint() ()
   from /opt/kde3/lib/kde3/libkatepart.so
#9  0x467c7b6e in KateViewInternal::updateCursor(KateTextCursor const&, bool, bool, bool) () from /opt/kde3/lib/kde3/libkatepart.so
#10 0x467a7eb5 in KateView::setCursorPositionInternal(unsigned, unsigned, unsigned, bool) () from /opt/kde3/lib/kde3/libkatepart.so
#11 0x46774af8 in KateDocument::closeURL() ()
   from /opt/kde3/lib/kde3/libkatepart.so
#12 0x0809052f in PartController::closePart(KParts::Part*) ()
#13 0x0809154d in PartController::closeFilesDialog(KURL::List const&) ()
#14 0x08091673 in PartController::closeAllFiles() ()
#15 0x080919d5 in PartController::readyToClose() ()
#16 0x0808b68d in Core::queryClose() ()
#17 0x080b0e9e in NewMainWindow::queryClose() ()
#18 0x40bfd583 in KMainWindow::closeEvent(QCloseEvent*) ()
   from /opt/kde3/lib/libkdeui.so.4
#19 0x412f3cb6 in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x413b4c62 in QMainWindow::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x40158bb1 in KMdiMainFrm::event(QEvent*) ()
   from /opt/kde3/lib/libkmdi.so.1
#22 0x4125e07f in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x4125d330 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x40e20d62 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde3/lib/libkdecore.so.4
#25 0x412f343d in QWidget::close(bool) () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x411f214c in QETWidget::translateCloseEvent(_XEvent const*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x411ebf6d in QApplication::x11ClientMessage(QWidget*, _XEvent*, bool) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x411ec66b in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x41203b8d in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x41270763 in QEventLoop::enterLoop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x41270656 in QEventLoop::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x4125e29f in QApplication::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x080b5354 in main ()
#34 0x41a678ae in __libc_start_main () from /lib/libc.so.6
Comment 12 Matt Rogers 2005-01-13 16:25:01 UTC
This is still a duplicate of 89278. You may try contacting SuSE at feedback.suse.de IIRC so you can report the problem to them. The QtMultiInputContext and QXIMInputContext classes don't exist in Qt itself. they're added patches

*** This bug has been marked as a duplicate of 89278 ***