Bug 115963 - Crash in "find in files" when closing open files
Summary: Crash in "find in files" when closing open files
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 3.2.1
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-08 22:45 UTC by Fred
Modified: 2005-11-09 09:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 2005-11-08 22:45:52 UTC
Version:           3.2.1 (using KDE KDE 3.4.2)
Installed from:    Fedora RPMs
OS:                Linux

I can reproduce this 100% of the time.

1- Open a KDevelop project
2- Ctrl-Alt-F (Find in files), and search for a string that appears in many files
3- Undock the "Find in files" dock widget
4- Click on one of the finds in the "Find in files" dock widget
5- Close all the open files in KDevelop with the little red X by the tabs
6- Click on one of the finds in the "Find in files" dock widget
Result : Crash


Backtrace :

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209034272 (LWP 22507)]
[New Thread -1213830224 (LWP 22508)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x00132a56 in XTranslateCoordinates () from /usr/X11R6/lib/libX11.so.6
#5  0x07547d36 in QWidget::mapFromGlobal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#6  0x00ac6833 in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt-3.3/plugins/inputmethods/libqxim.so
#7  0x00466420 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt-3.3/plugins/inputmethods/libqimsw-multi.so
#8  0x07548aa9 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#9  0x02e19424 in KateViewInternal::updateMicroFocusHint ()
   from /usr/lib/kde3/libkatepart.so
#10 0x02e20822 in KateViewInternal::updateCursor ()
   from /usr/lib/kde3/libkatepart.so
#11 0x02df7c6f in KateView::setCursorPositionInternal ()
   from /usr/lib/kde3/libkatepart.so
#12 0x02e00007 in KateView::setCursorPositionReal ()
   from /usr/lib/kde3/libkatepart.so
#13 0x0239c20f in EditorProxy::setLineNumber () from /usr/lib/libkdevshell.so.0
#14 0x023b437e in PartController::editDocumentInternal ()
   from /usr/lib/libkdevshell.so.0
#15 0x023b5a3e in PartController::editDocument ()
   from /usr/lib/libkdevshell.so.0
#16 0x00ef4fb0 in GrepViewWidget::slotExecuted ()
   from /usr/lib/kde3/libkdevgrepview.so
#17 0x00ef6417 in GrepViewWidget::qt_invoke ()
   from /usr/lib/kde3/libkdevgrepview.so
#18 0x075e5df4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x0797017f in QListBox::clicked () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x076c87a1 in QListBox::mouseReleaseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x07624167 in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x075810cd in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x0758202f in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x005c0851 in KApplication::notify () from /usr/lib/libkdecore.so.4
#25 0x07518746 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x07516f01 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x0752b008 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x07599772 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x07599696 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x07580a99 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x0804e5dd in ?? ()
#32 0x00c04de6 in __libc_start_main () from /lib/libc.so.6
#33 0x0804d941 in ?? ()


When running kdevelop from the konsole, I get the following output while performing the above steps :

QLayout "unnamed" added to IndexView "unnamed", which already has a layout
ERROR: syntax error
QObject::connect: No such slot ClassViewPart::removeNamespace(const QString&)
QObject::connect:  (sender name:   'ClassViewWidget')
QObject::connect:  (receiver name: 'ClassViewPart')
ERROR: syntax error
ERROR: syntax error
ASSERT: "part && parent" in partwidget.cpp (40)
ERROR: syntax error
ERROR: syntax error
QObject::disconnect: No such signal QObject::cursorPositionChanged()
QObject::disconnect: No such signal QObject::cursorPositionChanged()
KCrash: Application 'kdevelop' crashing...
Comment 1 Jens Dagerbo 2005-11-09 09:39:09 UTC
Dupe

*** This bug has been marked as a duplicate of 89278 ***