Bug 128072 - crash when closing files that have been opened during project build process
Summary: crash when closing files that have been opened during project build process
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-26 12:07 UTC by Kai
Modified: 2006-05-27 04:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai 2006-05-26 12:07:30 UTC
Version:           3.3.2 (complied from source) (using KDE KDE 3.4.2)
Installed from:    Mandrake RPMs
Compiler:          gcc 4.0.1 4.0.1-5mdk for Mandriva Linux release 2006.0
OS:                Linux

Opened an existing project.
Build from existing Makefile.
Clicked on a warning in the messages tab during linking process -> File opened.
Closed the newly opened file while linking is still running. -> Crash with Segmentation fault.

Backtrace:
Using host libthread_db library "/lib/tls/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1240541504 (LWP 27160)]
[New Thread -1252205648 (LWP 27201)]
[KCrash handler]
#4  0xb692dab7 in QWidget::topLevelWidget ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0xb5ca1657 in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/lib/inputmethods/libqxim.so
#6  0xb5cd34f6 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/lib/inputmethods/libqimsw-multi.so
#7  0xb6862874 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x0869afb0 in ?? ()
#9  0x0000009b in ?? ()
#10 0x00000303 in ?? ()
#11 0x00000000 in ?? ()
Comment 1 Jens Dagerbo 2006-05-27 04:43:33 UTC
Dupe.

*** This bug has been marked as a duplicate of 89278 ***