Bug 126303 - Crash when closing multiple tabs quickly
Summary: Crash when closing multiple tabs quickly
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 3.3.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-26 18:54 UTC by Joel Webb
Modified: 2006-04-26 20:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Webb 2006-04-26 18:54:45 UTC
Version:           3.3.2 (using KDE 3.5.2 Level "a" , SUSE 10.0 UNSUPPORTED)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15.8-default

Having 5 or 6 pages open. I closed them all out, one at a time, but relatively quickly. When I got to the last tab, the application crashed.

It appears that this bug just started happening with this release. I never had issues like this before with KDevelop.

Here is the Debug output:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1105317888 (LWP 26293)]
[New Thread 1118677936 (LWP 26443)]
[Thread debugging using libthread_db enabled]
[New Thread 1105317888 (LWP 26293)]
[New Thread 1118677936 (LWP 26443)]
[Thread debugging using libthread_db enabled]
[New Thread 1105317888 (LWP 26293)]
[New Thread 1118677936 (LWP 26443)]
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x40bcedad in QFont::QFont () from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x42573268 in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#8  0x4245f769 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#9  0x40b83583 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x42e37218 in TEWidget::setCursorPos ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#11 0x42e514d8 in TEmulation::showBulk ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#12 0x42e55b23 in TEmulation::qt_invoke ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#13 0x42e55b74 in TEmuVt102::qt_invoke ()
   from /opt/kde3/lib/kde3/libkonsolepart.so
#14 0x40c17929 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40c17de0 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x40f66c19 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40c3c11f in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x40bb6f41 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x40bb78c9 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x408bc0de in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#21 0x40baba94 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x40b6467e in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x40bcdfd8 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x40bcded6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x40bb688f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x0804de16 in ?? ()
#27 0xbf96a690 in ?? ()
#28 0x080c2100 in ?? ()
#29 0xbf96a80c in ?? ()
#30 0x00000001 in ?? ()
#31 0x0805219d in vtable for QGList ()
#32 0x00000001 in ?? ()
#33 0x08052290 in vtable for QGList ()
#34 0x08052241 in vtable for QGList ()
#35 0x08051a79 in vtable for QGList ()
#36 0x08051a65 in vtable for QGList ()
#37 0x00000000 in ?? ()
#38 0xbf96a6d0 in ?? ()
#39 0x40007ec4 in do_lookup_x () from /lib/ld-linux.so.2
#40 0x4118cea0 in __libc_start_main () from /lib/tls/libc.so.6
#41 0x0804d2a1 in ?? ()
Comment 1 Jens Dagerbo 2006-04-26 20:13:51 UTC
Dupe. See bug #89278.

*** This bug has been marked as a duplicate of 89278 ***