Bug 127128 - crash when changing projects in the background
Summary: crash when changing projects in the background
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-11 11:27 UTC by Maciej Pilichowski
Modified: 2006-05-11 18:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Pilichowski 2006-05-11 11:27:49 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    SuSE RPMs

Slow down your CPU as much as you can. I assume there are two project A and B with so many files that tabs are go beyond the screen (IDEAl -- is the last letter is "l" btw.?).

Run Konsole (maximized). Run Kdevelop (maximized). Open A. Open B. Switch to A (open recent project --> A). Switch to B. Does it work? Yes. Now -- switch to A and _immediately_ task-switch to Konsole. Wait a second or two. Kdevelop will crash.


(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1105273664 (LWP 12617)]
[New Thread 1117911984 (LWP 12683)]
[Thread debugging using libthread_db enabled]
[New Thread 1105273664 (LWP 12617)]
[New Thread 1117911984 (LWP 12683)]
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1105273664 (LWP 12617)]
[New Thread 1117911984 (LWP 12683)]
[KCrash handler]
#6  0x4033caf8 in KIO::ParseTreeID::~ParseTreeID ()
   from /opt/kde3/lib/libkio.so.4
#7  0x4181cf45 in XTranslateCoordinates () from /usr/X11R6/lib/libX11.so.6
#8  0x40b7f78c in QWidget::mapFromGlobal () from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x423ac1bc in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#10 0x4237f769 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#11 0x40b80583 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x42b4bd42 in KateViewInternal::updateMicroFocusHint ()
   from /opt/kde3/lib/kde3/libkatepart.so
#13 0x42b66002 in KateViewInternal::updateCursor ()
   from /opt/kde3/lib/kde3/libkatepart.so
#14 0x42b6b1e3 in KateView::setCursorPositionInternal ()
   from /opt/kde3/lib/kde3/libkatepart.so
#15 0x42b9312d in KateView::setCursorPositionReal ()
   from /opt/kde3/lib/kde3/libkatepart.so
#16 0x400691ce in EditorProxy::setLineNumber ()
   from /opt/kde3/lib/libkdevshell.so.0
#17 0x4007f6f7 in PartController::editDocumentInternal ()
   from /opt/kde3/lib/libkdevshell.so.0
#18 0x4008fd81 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#19 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#20 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#21 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#22 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#23 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#24 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#25 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#26 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#27 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#28 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#29 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#30 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#31 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#32 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#33 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#34 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#35 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#36 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#37 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#38 0x4008fdd9 in ProjectSession::loadDocument ()
   from /opt/kde3/lib/libkdevshell.so.0
#39 0x4008fe92 in ProjectSession::qt_invoke ()
   from /opt/kde3/lib/libkdevshell.so.0
#40 0x40c14929 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0x40f61892 in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0x40c3184b in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0x40c39393 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0x40bb3f41 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0x40bb48c9 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0x408b80de in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#47 0x40ba8a94 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0x40b6167e in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0x40bcafd8 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0x40bcaed6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0x40bb388f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0x0804de16 in ?? ()
#53 0xbfe4b600 in ?? ()
#54 0x0813b1a8 in ?? ()
#55 0xbfe4b77c in ?? ()
#56 0x00000001 in ?? ()
#57 0x0805219d in vtable for QGList ()
#58 0x00000001 in ?? ()
#59 0x08052290 in vtable for QGList ()
#60 0x08052241 in vtable for QGList ()
#61 0x08051a79 in vtable for QGList ()
#62 0x08051a65 in vtable for QGList ()
#63 0x00000000 in ?? ()
#64 0xbfe4b640 in ?? ()
#65 0x40007ec4 in do_lookup_x () from /lib/ld-linux.so.2
#66 0x41189ea0 in __libc_start_main () from /lib/tls/libc.so.6
#67 0x0804d2a1 in ?? ()
Comment 1 Jens Dagerbo 2006-05-11 18:11:42 UTC
This crash never grows old, I guess.

Dupe and invalid.

*** This bug has been marked as a duplicate of 89278 ***