Bug 95245 - SIGSEGV in kdevelop when switching tabs
Summary: SIGSEGV in kdevelop when switching tabs
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 3.1.2
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-16 10:29 UTC by Vadym Krevs
Modified: 2005-01-20 11:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vadym Krevs 2004-12-16 10:29:20 UTC
Version:           3.1.2 (using KDE KDE 3.3.2)
Installed from:    SuSE RPMs
Compiler:          gcc 3.3.5 
OS:                Linux

Hi. I use Kdevelop on Suse Linux for all work on our company's 5000+ file software app (~128Mb source code). For that I've created a "Generic C++ application (custom makefiles)" project. Usually KDevelop starts, opens the last used project, and reopens all source files (in different tabs) that were opened before exit. However, occasionally, when I click on a different tab to switch to another file, or try using CTags lookup, or minimize/maximise the entire Kdevelop application window, Kdevelop crashes with a SIGSEGV, and the following stack trace is produced:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1102832256 (LWP 32388)]
[New Thread 1116617648 (LWP 32397)]
[Thread debugging using libthread_db enabled]
[New Thread 1102832256 (LWP 32388)]
[New Thread 1116617648 (LWP 32397)]
[Thread debugging using libthread_db enabled]
[New Thread 1102832256 (LWP 32388)]
[New Thread 1116617648 (LWP 32397)]
[KCrash handler]
#7  0x412a3b8b in QFont::QFont () from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x4221ad2a in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqxim.so
#9  0x421e73a3 in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so
#10 0x4125ae32 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x438ed853 in KateViewInternal::updateMicroFocusHint ()
   from /opt/kde3/lib/kde3/libkatepart.so
#12 0x00000000 in ?? ()
#13 0x0000000e in ?? ()
#14 0x00000000 in ?? ()
#15 0x0000000e in ?? ()
#16 0x00000001 in ?? ()
#17 0x00000000 in ?? ()
#18 0x4386078b in KateViewInternal::lineToY ()
   from /opt/kde3/lib/kde3/libkatepart.so


Loaded plugins: Bookmarks, CTags Frontend, CTags Frontend (2), Classview, Debugger Frontend, File Groups, File Tree
Comment 1 Amilcar do Carmo Lucas 2004-12-16 11:08:30 UTC
Seams to be a kate issue. mattr, teatime ?
Comment 2 Vadym Krevs 2004-12-16 12:57:12 UTC
I forgot to mention that I use the FTP version of Suse Linux 9.1.
Comment 3 Matt Rogers 2004-12-16 15:45:32 UTC
without a better backtrace, I would say that it is a kate issue. Probably the easiest way for us to tell is if it's reproduciable using kate or not. However, these two lines:

#8  0x4221ad2a in QXIMInputContext::setMicroFocus () 
    from /usr/lib/qt3/plugins/inputmethods/libqxim.so 
#9  0x421e73a3 in QMultiInputContext::setMicroFocus () 
    from /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so 

make me think it's a bad interaction with a qt plugin. We can't really pin it on anything yet.
Comment 4 Jens Dagerbo 2004-12-16 17:56:31 UTC
This is invalid and a dupe. SuSE patches Qt and it's the added code that crashes. I'll find the dupe tonight and close it unless someone beats me to it.

Comment 5 Jens Dagerbo 2004-12-16 23:07:12 UTC
Dupe.

*** This bug has been marked as a duplicate of 89278 ***
Comment 6 Vadym Krevs 2005-01-20 11:20:31 UTC
Now the same happens on Suse 9.2 Professional. However, Kdevelop is the only KDE application that crashes.
Comment 7 Amilcar do Carmo Lucas 2005-01-20 11:29:32 UTC
Well, have you read the comments ?
SuSE RPM's are broken, uninstall KDevelop and compile KDevelop HEAD locally on your machine. The crashes, and 140 bugs should disappear.