Bug 94294 - KDevelop crashed for no reason
Summary: KDevelop crashed for no reason
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: RedHat RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-02 20:29 UTC by Metehan Karabiber
Modified: 2004-12-03 16:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Metehan Karabiber 2004-12-02 20:29:33 UTC
Version:           KDevelop (using KDE KDE 3.3.1)
Installed from:    RedHat RPMs
OS:                Linux

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -151144768 (LWP 4103)]
[KCrash handler]
#4  0x04793b49 in QWidget::mapFromGlobal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0x00ed9ace in QXIMInputContext::setMicroFocus ()
   from /usr/lib/qt-3.3/plugins/inputmethods/libqxim.so
#6  0x00ea7c5d in QMultiInputContext::setMicroFocus ()
   from /usr/lib/qt-3.3/plugins/inputmethods/libqimsw-multi.so
#7  0x04797790 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#8  0x0104e911 in TEWidget::setCursorPos ()
   from /usr/lib/kde3/libkonsolepart.so
#9  0x0105f693 in TEmulation::showBulk () from /usr/lib/kde3/libkonsolepart.so
#10 0x0105fb7a in TEmulation::clearSelection ()
   from /usr/lib/kde3/libkonsolepart.so
#11 0x0105fd39 in TEmulation::qt_invoke ()
   from /usr/lib/kde3/libkonsolepart.so
#12 0x0105780c in TEmuVt102::qt_invoke () from /usr/lib/kde3/libkonsolepart.so
#13 0x048263a0 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x04826a7a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x0105238e in TEWidget::clearSelectionSignal ()
   from /usr/lib/kde3/libkonsolepart.so
#16 0x010523b1 in TEWidget::onClearSelection ()
   from /usr/lib/kde3/libkonsolepart.so
#17 0x01054949 in TEWidget::qt_invoke () from /usr/lib/kde3/libkonsolepart.so
#18 0x048263a0 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x04826a7a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x04b513b3 in QClipboard::selectionChanged ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x04765982 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x04777686 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x047dce75 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x047dcdce in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x047c6a4b in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x080a1131 in QValueListPrivate<QString>::at ()
#27 0x00b13e33 in __libc_start_main () from /lib/tls/libc.so.6
#28 0x080721b1 in ?? ()
Comment 1 Metehan Karabiber 2004-12-02 20:30:32 UTC
The OS is Fedora Core 3
Comment 2 Jens Dagerbo 2004-12-03 16:12:11 UTC
Looks like they are using the same crashy patches to Qt as SuSE then.

Invalid and dupe. :)

*** This bug has been marked as a duplicate of 89278 ***