Bug 128620 - Kdevelop Crashes on Tab Close
Summary: Kdevelop Crashes on Tab Close
Status: RESOLVED DUPLICATE of bug 89278
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 3.3.3
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-04 15:32 UTC by Pieter Botha
Modified: 2006-06-05 01:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pieter Botha 2006-06-04 15:32:49 UTC
Version:           3.3.3 (using KDE KDE 3.5.3)
Installed from:    SuSE RPMs
OS:                Linux

When I close a tab, kdevelop seems to crash (now and then). The tabs contain each time, makefile's. I use QT4.
This is in a project which has subversion enabled.

Backtrace:
System configuration startup check disabled.

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47619899678800 (LWP 624)]
[New Thread 1082132800 (LWP 713)]
[KCrash handler]
#5  QFont (this=0x7fff51269220, font=@0x1dea540) at ../include/qshared.h:49
#6  0x00002b4f61dffd90 in QXIMInputContext::setMicroFocus (this=0x11b4ac0, 
    x=<value optimized out>, y=<value optimized out>, h=15, f=0x0)
    at ../../../../include/qwidget.h:809
#7  0x00002b4f5adb7a64 in QWidget::setMicroFocusHint (this=0x1ec3950, x=2, 
    y=73, width=0, height=15, text=<value optimized out>, f=0x0)
    at kernel/qwidget_x11.cpp:981
#8  0x00002aaaabf02cfa in TEWidget::setCursorPos ()
   from /opt/kde3/lib64/kde3/libkonsolepart.so
#9  0x00002aaaabf18820 in TEmulation::showBulk ()
   from /opt/kde3/lib64/kde3/libkonsolepart.so
#10 0x00002aaaabf18f1d in TEmulation::qt_invoke ()
   from /opt/kde3/lib64/kde3/libkonsolepart.so
#11 0x00002aaaabf18f6b in TEmuVt102::qt_invoke ()
   from /opt/kde3/lib64/kde3/libkonsolepart.so
#12 0x00002b4f5ae3aa8c in QObject::activate_signal (this=0x1ef0a50, 
    clist=<value optimized out>, o=0x7fff51269430) at kernel/qobject.cpp:2356
#13 0x00002b4f5ae3b7a3 in QObject::activate_signal (this=0x7fff51269220, 
    signal=<value optimized out>) at kernel/qobject.cpp:2325
#14 0x00002b4f5ae59e95 in QTimer::event (this=0x1ef0a50, e=0x1dea540)
    at kernel/qtimer.cpp:219
#15 0x00002b4f5ade3a95 in QApplication::internalNotify (
    this=<value optimized out>, receiver=0x1ef0a50, e=0x7fff512696d0)
    at kernel/qapplication.cpp:2636
#16 0x00002b4f5ade46c7 in QApplication::notify (this=0x7fff51269940, 
    receiver=0x1ef0a50, e=0x7fff512696d0) at kernel/qapplication.cpp:2359
#17 0x00002b4f5a7d2b08 in KApplication::notify (this=0x7fff51269940, 
    receiver=0x1ef0a50, event=0x7fff512696d0) at ./kdecore/kapplication.cpp:552
#18 0x00002b4f5adda005 in QEventLoop::activateTimers (
    this=<value optimized out>) at kernel/qapplication.h:520
#19 0x00002b4f5ad9a4ed in QEventLoop::processEvents (this=0x5af2b0, flags=0)
    at kernel/qeventloop_x11.cpp:389
#20 0x00002b4f5adf87a1 in QEventLoop::enterLoop (this=0x7fff51269220)
    at kernel/qeventloop.cpp:198
#21 0x00002b4f5adf864a in QEventLoop::exec (this=0x7fff51269220)
    at kernel/qeventloop.cpp:145
#22 0x00000000004072f7 in main ()
Comment 1 Jens Dagerbo 2006-06-05 01:40:42 UTC
Dupe. 

*** This bug has been marked as a duplicate of 89278 ***