Bug 283241 - plasma crashes due to networkmanager
Summary: plasma crashes due to networkmanager
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
: 284007 284284 285555 286032 286511 287089 287357 287825 288117 290031 291005 291084 292884 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-03 12:33 UTC by kavol
Modified: 2012-01-30 17:36 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.8.98 (0.9.0_rc3)


Attachments
New crash information added by DrKonqi (6.59 KB, text/plain)
2011-10-05 11:45 UTC, kavol
Details
New crash information added by DrKonqi (5.74 KB, text/plain)
2011-10-12 11:35 UTC, kavol
Details
Test if pointer is valid before using it (634 bytes, patch)
2011-10-18 18:21 UTC, Lamarque V. Souza
Details
New crash information added by DrKonqi (7.77 KB, text/plain)
2011-10-23 15:00 UTC, Bruno Friedmann
Details
New crash information added by DrKonqi (8.54 KB, text/plain)
2011-11-06 17:16 UTC, Thilo-Alexander Ginkel
Details
Valgrind log (12.48 KB, application/x-bzip)
2011-11-06 22:36 UTC, Thilo-Alexander Ginkel
Details
Defaults to InterfaceConnection instead of WirelessInterfaceConnection (716 bytes, patch)
2011-11-07 00:37 UTC, Lamarque V. Souza
Details
New crash information added by DrKonqi (7.47 KB, text/plain)
2011-12-07 13:53 UTC, Valentin Rusu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kavol 2011-10-03 12:33:11 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.4
Operating System: Linux 2.6.40.4-5.fc15.x86_64 x86_64
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:

I've just plugged in my FreeRunner which creates an usb network device. The phone was stuck, so the connection failed, there's even some trace in kernel output, and plasma crashed a short while after. Disconnecting and connecting the phone again did not generate any more kernel crash output, but plasma has crashed two times again.

From dmesg:

[ 4517.739424] usb 2-1.2: new full speed USB device number 3 using ehci_hcd
[ 4517.827944] usb 2-1.2: New USB device found, idVendor=0525, idProduct=a4a2
[ 4517.827950] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 4517.827955] usb 2-1.2: Product: RNDIS/Ethernet Gadget
[ 4517.827959] usb 2-1.2: Manufacturer: Linux 2.6.37.6 with s3c2410_udc
[ 4518.038414] cdc_subset: probe of 2-1.2:1.0 failed with error -22
[ 4518.039176] cdc_subset 2-1.2:1.1: usb0: register 'cdc_subset' at usb-0000:00:1d.0-1.2, Linux Device, 76:55:34:ad:a5:29
[ 4518.039261] usbcore: registered new interface driver cdc_subset
[ 4518.095115] cdc_ether: probe of 2-1.2:1.0 failed with error -16
[ 4518.095132] usbcore: registered new interface driver cdc_ether
[ 4523.724551] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[ 4528.344497] usb0: no IPv6 routers present
[ 4528.533997] ------------[ cut here ]------------
[ 4528.534012] WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0xf0/0x150()
[ 4528.534015] Hardware name: 4384BR2
[ 4528.534019] NETDEV WATCHDOG: usb0 (cdc_subset): transmit queue 0 timed out
[ 4528.534022] Modules linked in: ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 cdc_ether cdc_subset usbnet mii tcp_lp tun ppdev parport_pc lp parport sunrpc cpufreq_ondemand acpi_cpufreq mperf rfcomm bnep snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec btusb snd_hwdep uvcvideo videodev snd_seq media arc4 snd_seq_device thinkpad_acpi bluetooth v4l2_compat_ioctl32 i2c_i801 iTCO_wdt iTCO_vendor_support snd_pcm iwlagn joydev e1000e intel_ips snd_timer snd snd_page_alloc soundcore mac80211 microcode cfg80211 rfkill virtio_net kvm_intel kvm ipv6 xts gf128mul dm_crypt firewire_ohci sdhci_pci sdhci firewire_core mmc_core crc_itu_t mxm_wmi wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
[ 4528.534113] Pid: 1472, comm: X Not tainted 2.6.40.4-5.fc15.x86_64 #1
[ 4528.534116] Call Trace:
[ 4528.534118]  <IRQ>  [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
[ 4528.534135]  [<ffffffff81054d49>] warn_slowpath_fmt+0x46/0x48
[ 4528.534141]  [<ffffffff813f15f1>] ? netif_tx_lock+0x4a/0x7c
[ 4528.534148]  [<ffffffff813f1767>] dev_watchdog+0xf0/0x150
[ 4528.534155]  [<ffffffff81061d96>] run_timer_softirq+0x19b/0x280
[ 4528.534163]  [<ffffffff8100e969>] ? paravirt_read_tsc+0x9/0xd
[ 4528.534169]  [<ffffffff813f1677>] ? netif_tx_unlock+0x54/0x54
[ 4528.534176]  [<ffffffff8105a954>] __do_softirq+0xc9/0x1b5
[ 4528.534181]  [<ffffffff8100e969>] ? paravirt_read_tsc+0x9/0xd
[ 4528.534188]  [<ffffffff8148fa5c>] call_softirq+0x1c/0x30
[ 4528.534193]  [<ffffffff8100abb9>] do_softirq+0x46/0x81
[ 4528.534197]  [<ffffffff8105ac36>] irq_exit+0x57/0xb1
[ 4528.534203]  [<ffffffff81490371>] smp_apic_timer_interrupt+0x7c/0x8a
[ 4528.534210]  [<ffffffff8148f213>] apic_timer_interrupt+0x13/0x20
[ 4528.534213]  <EOI>  [<ffffffff814880b4>] ? _raw_spin_unlock_irqrestore+0x17/0x19
[ 4528.534227]  [<ffffffff81453781>] ? unix_poll+0x16/0x9a
[ 4528.534234]  [<ffffffff813c6a7a>] sock_poll+0x1a/0x1c
[ 4528.534241]  [<ffffffff81135dcf>] do_select+0x2fb/0x4f5
[ 4528.534247]  [<ffffffff81135845>] ? poll_freewait+0xaa/0xaa
[ 4528.534252]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534258]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534262]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534267]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534272]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534277]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534282]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534287]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534292]  [<ffffffff81135911>] ? __pollwait+0xcc/0xcc
[ 4528.534298]  [<ffffffff8113612c>] core_sys_select+0x163/0x202
[ 4528.534305]  [<ffffffff81073230>] ? __remove_hrtimer+0x5c/0x83
[ 4528.534311]  [<ffffffff814880b4>] ? _raw_spin_unlock_irqrestore+0x17/0x19
[ 4528.534316]  [<ffffffff8107342c>] ? hrtimer_try_to_cancel+0x81/0x8f
[ 4528.534321]  [<ffffffff81059b71>] ? timespec_add_safe+0x37/0x66
[ 4528.534327]  [<ffffffff8100e9eb>] ? read_tsc+0x9/0x19
[ 4528.534332]  [<ffffffff8113625c>] sys_select+0x91/0xb9
[ 4528.534338]  [<ffffffff8148e842>] system_call_fastpath+0x16/0x1b
[ 4528.534342] ---[ end trace 4f03ad293bd8fc8d ]---
[ 4529.853496] cdc_subset 2-1.2:1.1: usb0: kevent 1 may have been dropped
[ 4530.096176] usb 2-1.2: USB disconnect, device number 3
[ 4530.096364] cdc_subset 2-1.2:1.1: usb0: can't clear rx halt, status -11
[ 4530.096408] cdc_subset 2-1.2:1.1: usb0: unregister 'cdc_subset' usb-0000:00:1d.0-1.2, Linux Device
[ 4532.571158] usb 2-1.2: new full speed USB device number 4 using ehci_hcd

The crash can be reproduced some of the time.

-- Backtrace:
Application: Shell plochy Plasma (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f34523c7a42 in init (wobj=0x2089618, this=0x17f7ec0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x1833190, remote=0x2089600) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:116
#8  0x00007f34523c6985 in WirelessNetworkItem::WirelessNetworkItem (this=0x181ce90, remote=0x2089600, parent=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/wirelessnetworkitem.cpp:54
#9  0x00007f34523b960b in ActivatableListWidget::createItem (this=0x17c45a0, activatable=0x2089600, addIfAlreadyCached=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:178
#10 0x00007f34523b988d in ActivatableListWidget::activatableAdded (this=0x17c45a0, added=0x2089600) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:275
#11 0x00007f34523ad99c in ActivatableListWidget::qt_metacall (this=0x17c45a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff3042d10) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:101
#12 0x0000003653d6cfea in QMetaObject::activate (sender=0x1657170, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff3042d10) at kernel/qobject.cpp:3278
#13 0x00007f34521808af in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x2089600) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:104
#14 0x00007f3452185c17 in RemoteActivatableList::handleActivatableAdded (this=0x1657170, addedPath=..., type=<optimized out>) at /usr/src/debug/networkmanagement-0.9/libs/client/remoteactivatablelist.cpp:258
#15 0x00007f34521809f6 in RemoteActivatableList::qt_metacall (this=0x1657170, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff3042f50) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:90
#16 0x0000003653d6cfea in QMetaObject::activate (sender=0x16ab580, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff3042f50) at kernel/qobject.cpp:3278
#17 0x00007f3452189483 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=4) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:104
#18 0x00007f345218981c in NetworkManagementInterface::qt_metacall (this=0x16ab580, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7ffff30431e0) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:84
#19 0x000000365462073b in QDBusConnectionPrivate::deliverCall (this=0xe1c940, object=0x16ab580, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#20 0x0000003654629c2f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x0000003653d70baa in QObject::event (this=0x16ab580, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x0000003655fb9324 in notify_helper (e=0x1dd3600, receiver=0x16ab580, this=0xe35da0) at kernel/qapplication.cpp:4481
#23 QApplicationPrivate::notify_helper (this=0xe35da0, receiver=0x16ab580, e=0x1dd3600) at kernel/qapplication.cpp:4453
#24 0x0000003655fbe1b1 in QApplication::notify (this=0xe1de90, receiver=0x16ab580, e=0x1dd3600) at kernel/qapplication.cpp:4360
#25 0x0000003657841d56 in KApplication::notify (this=0xe1de90, receiver=0x16ab580, event=0x1dd3600) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#26 0x0000003653d5a20c in QCoreApplication::notifyInternal (this=0xe1de90, receiver=0x16ab580, event=0x1dd3600) at kernel/qcoreapplication.cpp:787
#27 0x0000003653d5d7d4 in sendEvent (event=0x1dd3600, receiver=0x16ab580) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xdc0cd0) at kernel/qcoreapplication.cpp:1428
#29 0x0000003653d84973 in sendPostedEvents () at kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=0xe3c7b0) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00000030178427ed in g_main_dispatch (context=0xe3ba60) at gmain.c:2441
#32 g_main_context_dispatch (context=0xe3ba60) at gmain.c:3014
#33 0x0000003017842fc8 in g_main_context_iterate (context=0xe3ba60, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
#34 0x000000301784325c in g_main_context_iteration (context=0xe3ba60, may_block=1) at gmain.c:3155
#35 0x0000003653d84dcf in QEventDispatcherGlib::processEvents (this=0xdc27e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#36 0x000000365605c12e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#37 0x0000003653d59722 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#38 0x0000003653d5991f in QEventLoop::exec (this=0x7ffff3043ba0, flags=...) at kernel/qeventloop.cpp:201
#39 0x0000003653d5da67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#40 0x000000365fa3f203 in kdemain (argc=1, argv=0x7ffff3043f88) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/main.cpp:120
#41 0x000000301482139d in __libc_start_main () from /lib64/libc.so.6
#42 0x00000000004008c1 in _start ()

Reported using DrKonqi
Comment 1 kavol 2011-10-05 11:45:04 UTC
Created attachment 64241 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.4

- What I was doing when the application crashed:

Unlike last time, the phone wasn't stuck - I just rebooted it while it was connected, which was enough to trigger the plasma crash.

A few lines from dmesg around the time of crash:

[18283.339695] usb 1-1.5.3: USB disconnect, device number 13
[18283.339777] cdc_ether 1-1.5.3:1.0: eth1: unregister 'cdc_ether' usb-0000:00:1a.0-1.5.3, CDC Ethernet Device
[18300.370293] usb 1-1.5.3: new full speed USB device number 14 using ehci_hcd
[18300.458683] usb 1-1.5.3: New USB device found, idVendor=0525, idProduct=a4a2
[18300.458689] usb 1-1.5.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[18300.458694] usb 1-1.5.3: Product: RNDIS/Ethernet Gadget
[18300.458697] usb 1-1.5.3: Manufacturer: Linux 2.6.37.6 with s3c2410_udc
[18300.460126] cdc_subset: probe of 1-1.5.3:1.0 failed with error -22
[18300.460976] cdc_ether 1-1.5.3:1.0: eth1: register 'cdc_ether' at usb-0000:00:1a.0-1.5.3, CDC Ethernet Device, 00:1f:11:01:10:db
[18311.050170] eth1: no IPv6 routers present

-- Backtrace (Reduced):
#6  0x00007f74cb86ca42 in init (wobj=0x1866b08, this=0x1bfa1f0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x17c1f00, remote=0x1866af0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:116
#8  0x00007f74cb86b985 in WirelessNetworkItem::WirelessNetworkItem (this=0x17e3170, remote=0x1866af0, parent=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/wirelessnetworkitem.cpp:54
#9  0x00007f74cb85e60b in ActivatableListWidget::createItem (this=0xcd5140, activatable=0x1866af0, addIfAlreadyCached=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:178
#10 0x00007f74cb85e88d in ActivatableListWidget::activatableAdded (this=0xcd5140, added=0x1866af0) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:275
Comment 2 Lamarque V. Souza 2011-10-12 04:10:13 UTC
I cannot reproduce this problem. Which Plasma NM version do you use? Which NM version do you use?

This crash happens in the wireless code but you have not mentioned which wifi card you have nor if it was active when the crash happened.
Comment 3 kavol 2011-10-12 10:13:17 UTC
(In reply to comment #2)
> I cannot reproduce this problem.

unfortunately, it seems very irregular

> Which Plasma NM version do you use?

kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc15.x86_64
kde-plasma-networkmanagement-libs-0.9-0.59.20110919git.nm09.fc15.x86_64

> Which NM version do you use?

now it is:

NetworkManager-0.9.1.90-3.git20110927.fc15.x86_64
NetworkManager-glib-0.9.1.90-3.git20110927.fc15.x86_64

but it seems the upgrade is newer than the date of the crashes, I believe I had this before:

NetworkManager-glib-0.9.0-1.fc15.x86_64
NetworkManager-0.9.0-1.fc15.x86_64

> This crash happens in the wireless code but you have not mentioned which wifi
> card you have

it detects like this:

[   61.824339] iwlagn 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74

> nor if it was active when the crash happened.

if only I knew ...

I got the machine docked, i.e. with ethernet cable plugged in, but I really do not know whether NM tried to activate wifi in parallel or not
Comment 4 kavol 2011-10-12 11:35:22 UTC
Created attachment 64458 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.4

- What I was doing when the application crashed:

It just crashed again with the newer NetworkManager version (see above). Simply rebooting FreeRunner was enough to trigger the crash.

-- Backtrace (Reduced):
#6  0x00007f384d2b1a42 in init (wobj=0x26d3888, this=0x36b7be0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x33d4270, remote=0x26d3870) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:116
#8  0x00007f384d2b0985 in WirelessNetworkItem::WirelessNetworkItem (this=0x33e9710, remote=0x26d3870, parent=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/wirelessnetworkitem.cpp:54
#9  0x00007f384d2a360b in ActivatableListWidget::createItem (this=0x2db3850, activatable=0x26d3870, addIfAlreadyCached=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:178
#10 0x00007f384d2a388d in ActivatableListWidget::activatableAdded (this=0x2db3850, added=0x26d3870) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:275
Comment 5 Lamarque V. Souza 2011-10-12 14:39:55 UTC
(In reply to comment #4)
> Created an attachment (id=64458) [details]
> New crash information added by DrKonqi
> 
> plasma-desktop (0.4) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.4
> 
> - What I was doing when the application crashed:
> 
> It just crashed again with the newer NetworkManager version (see above). Simply
> rebooting FreeRunner was enough to trigger the crash.

Is FreeRunner a mobile phone?

Please upgrade to a newer snapshot. Last month I made several changes in how activatables are initialized.
Comment 6 Lamarque V. Souza 2011-10-14 19:57:40 UTC
*** Bug 284007 has been marked as a duplicate of this bug. ***
Comment 7 Lamarque V. Souza 2011-10-14 19:58:29 UTC
Can you try upgrading your NM version? It seems it helps to solve this problem: https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=743891
Comment 8 kavol 2011-10-14 20:37:18 UTC
(In reply to comment #5)
> Is FreeRunner a mobile phone?

well, they say so ...

> Please upgrade to a newer snapshot. Last month I made several changes in how
> activatables are initialized.

there doesn't seem to be packaged anything newer than kde-plasma-networkmanagement-0.9-0.59.20110919git and I do not feel like messing with my install

do you have any concrete suspicion or is that just a random try?

(In reply to comment #7)
> Can you try upgrading your NM version? It seems it helps to solve this problem:
> https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=743891

comment #4 to RHBZ#743891 says

"now on live image NetworkManager-0.9.1.90-3.git20110927.fc16 and no crash"

I can hardly imagine how "upgrading" from NM 0.9.1.90-3.git20110927 (see comments #3 and #4 here) to NM 0.9.1.90-3.git20110927 could help ;-)

as for upgrading to KDE 4.7.2, the same as above - F16 is not ready yet, or at least not in good enough shape for me to upgrade my system, I'm getting unresolvable package conflicts

so I'll try to remember to report back once F16 with KDE 4.7.2 comes out
Comment 9 Lamarque V. Souza 2011-10-14 22:36:48 UTC
(In reply to comment #8)
> (In reply to comment #5)
> > Is FreeRunner a mobile phone?
> there doesn't seem to be packaged anything newer than
> kde-plasma-networkmanagement-0.9-0.59.20110919git and I do not feel like
> messing with my install
> 
> do you have any concrete suspicion or is that just a random try?

Sure it is a random try. There have been several changes in the part of the source code that deals with activatables like wirelessstatus.cpp. I also cannot reproduce this problem and all three people I know that have this problem uses Fedora packages.
 
The only thing that would cause a crash like the one in your crashlog is a corrupted pointer. But I really do not know how a corrupted pointer could appear only in Plasma NM compiled by Fedora. I also do not understand what your phone has to do with this part of the source code, which deals with wifi access points not mobile broadband.

> I can hardly imagine how "upgrading" from NM 0.9.1.90-3.git20110927 (see
> comments #3 and #4 here) to NM 0.9.1.90-3.git20110927 could help ;-)

Ok, so forget it.
 
> as for upgrading to KDE 4.7.2, the same as above - F16 is not ready yet, or at
> least not in good enough shape for me to upgrade my system, I'm getting
> unresolvable package conflicts

Problems in KDE SC rarely affects Plasma NM, upgrading to 4.7.2 is very unlikely to solve your problem.
Comment 10 Nicolas L. 2011-10-17 18:50:05 UTC
*** Bug 284284 has been marked as a duplicate of this bug. ***
Comment 11 Lamarque V. Souza 2011-10-17 19:37:05 UTC
Please send me the output of the command:

g++ -v
Comment 12 Diego 2011-10-18 07:20:08 UTC
For me the output is:

$ g++ -v
Using built-in specs.
COLLECT_GCC=/usr/bin/g++
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.6.1/lto-wrapper
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.6.1 20110908 (Red Hat 4.6.1-9) (GCC)

By the way I have the same problem (see duplicate) with a device which brings up a USB Gadget Ethernet (as FreeRunner does it seems). My wifi card is:
2:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Same NM version:
NetworkManager-0.9.1.90-3.git20110927.fc15.x86_64
Comment 13 Lamarque V. Souza 2011-10-18 18:21:39 UTC
Created attachment 64678 [details]
Test if pointer is valid before using it

Well, g++ 4.6.1 is a bit experimental IMO. Maybe it is doing something wrong. Anyway, can someone try the attached patch and see if it helps to prevent the crash?
Comment 14 Diego 2011-10-20 08:13:36 UTC
(In reply to comment #13)
> Created an attachment (id=64678) [details]
> Test if pointer is valid before using it
> 
> Well, g++ 4.6.1 is a bit experimental IMO. Maybe it is doing something wrong.
> Anyway, can someone try the attached patch and see if it helps to prevent the
> crash?

Thank you for the patch, I'll be abroad so I cannot test it now, please be patient!
Comment 15 Bruno Friedmann 2011-10-23 15:00:10 UTC
Created attachment 64809 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:
I connect my N9 by usb, and push the choice connect & synchronize. Immediately Plasma Desktop Crash

If I connect it as storage device it's ok, plasma doesn't crash ...

-- Backtrace (Reduced):
#6  0x00007f3f07ffc902 in init (wobj=0x2fd6108, this=0x2d20620) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x2fd0360, remote=0x2fd60f0) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:116
#8  0x00007f3f07ffbf75 in WirelessNetworkItem::WirelessNetworkItem (this=0x2d84520, remote=0x2fd60f0, parent=<optimized out>) at /usr/src/debug/networkmanagement/applet/wirelessnetworkitem.cpp:54
#9  0x00007f3f07fededb in ActivatableListWidget::createItem (this=0x174e010, activatable=0x2fd60f0, addIfAlreadyCached=<optimized out>) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:183
#10 0x00007f3f07fee15d in ActivatableListWidget::activatableAdded (this=0x174e010, added=0x2fd60f0) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:280
Comment 16 Lamarque V. Souza 2011-10-23 18:05:29 UTC
Guys, please, when reporting a bug in Plasma NM please add the Plasma NM and NetworkManager version you are using and which distribution.
Comment 17 Lamarque V. Souza 2011-10-23 18:12:01 UTC
By the crashlog I see you all are using a version of Plasma NM at least one month old. During this time the part of the source code when the crash happens was refactored. Can you please upgrade to the latest git version (nm09 branch) and see if the problem still happens?
Comment 18 Bruno Friedmann 2011-10-23 20:44:16 UTC
Okay I saw that Will is on CC, 
@Lamarque, sorry to use released software, most of end users act like that.
If you are not happy with the result of drKonqui patches welcomed.
Comment 19 Lamarque V. Souza 2011-10-23 21:04:33 UTC
drKonqui is not able to add individual kded's modules and plasmoids versions, it would be great if it could. I rely on users to tell me the Plasma NM version they are using. Of course, drKonqui has no knowledge about non-KDE software, such as NM, so the same applies.

I guess this problem has something to do with the Bluedevil 1.2's bug that crashes kded very often (http://bugs.kde.org/284717). I fixed two bugs yesterday to prevent Plasma NM from crashing when kded crashes. Unfortunately, I read the bug entries after I had released Plasma NM 0.8.90, so I need you to test the latest nm09 branch to see if those two fixes also fix this bug.
Comment 20 Lamarque V. Souza 2011-11-03 01:11:34 UTC
*** Bug 285555 has been marked as a duplicate of this bug. ***
Comment 21 Lamarque V. Souza 2011-11-03 19:37:44 UTC
Git commit 49fb02e3894ef7e96bf2856f262d3b14dfda79fd by Lamarque V. Souza.
Committed on 03/11/2011 at 20:33.
Pushed by lvsouza into branch 'master'.

Test if DBus interface object is valid before using it.

CCBUG: 283241

M  +8    -1    applet/wirelessstatus.cpp
M  +5    -0    libs/client/remotewirelessinterfaceconnection.cpp
M  +1    -0    libs/client/remotewirelessinterfaceconnection.h
M  +6    -0    libs/client/remotewirelessnetwork.cpp
M  +1    -0    libs/client/remotewirelessnetwork.h
M  +1    -0    libs/client/remotewirelessobject.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/49fb02e3894ef7e96bf2856f262d3b14dfda79fd
Comment 22 Lamarque V. Souza 2011-11-03 19:42:55 UTC
Git commit 1240c6f6f83d6a0502f659c7c49fe6d03ecb917f by Lamarque V. Souza.
Committed on 03/11/2011 at 20:33.
Pushed by lvsouza into branch 'nm09'.

Test if DBus interface object is valid before using it.

CCBUG: 283241

M  +8    -1    applet/wirelessstatus.cpp
M  +5    -0    libs/client/remotewirelessinterfaceconnection.cpp
M  +1    -0    libs/client/remotewirelessinterfaceconnection.h
M  +6    -0    libs/client/remotewirelessnetwork.cpp
M  +1    -0    libs/client/remotewirelessnetwork.h
M  +1    -0    libs/client/remotewirelessobject.h

http://commits.kde.org/networkmanagement/1240c6f6f83d6a0502f659c7c49fe6d03ecb917f
Comment 23 Lamarque V. Souza 2011-11-03 20:56:57 UTC
Can someone test if the last commit fix the bug? I have never been able to reliably reproduce it.
Comment 24 Thilo-Alexander Ginkel 2011-11-06 17:16:54 UTC
Created attachment 65306 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:

Woke up my machine from s2ram. This happened with version 0.9.0rc2. Should the fix mentioned above already be included there?

-- Backtrace (Reduced):
#6  0x00007f8ed2b7af55 in init (wobj=0x2ef5638, this=0x37317c0) at ../../applet/wirelessstatus.cpp:67
#7  WirelessStatus::WirelessStatus (this=0x2ef8100, remote=0x2ef5620) at ../../applet/wirelessstatus.cpp:123
#8  0x00007f8ed2b799c4 in WirelessNetworkItem::WirelessNetworkItem (this=0x1bdd300, remote=0x2ef5620, parent=<optimized out>) at ../../applet/wirelessnetworkitem.cpp:53
#9  0x00007f8ed2b6c3f5 in ActivatableListWidget::createItem (this=0x1910480, activatable=0x2ef5620, index=0) at ../../applet/activatablelistwidget.cpp:181
#10 0x00007f8ed2b6c63e in ActivatableListWidget::activatableAdded (this=0x1910480, added=0x2ef5620, index=0) at ../../applet/activatablelistwidget.cpp:269
Comment 25 Lamarque V. Souza 2011-11-06 17:42:37 UTC
Yes, it is included. Actually the crash happens in the test I added to check if the DBus interface is valid.
Comment 26 Lamarque V. Souza 2011-11-06 18:08:55 UTC
One question. Do you all have pm-utils installed? I use pm-utils here and it signals NM to sleep on suspend to disk / ram. When NM is sleeping Plasma NM clears all activatables (the items in the plasmoid's connection list). I guess if NM is not put to sleep that may cause dangling pointers that could cause this crash.

In my notebook after I trigger the suspend to ram shortcut the system tray icon changes to a red square with a white cross in the middle, which means Plasma NM has disabled networking because NM is not available anymore. If that does not happen in you notebook then that can be the problem.
Comment 27 Lamarque V. Souza 2011-11-06 18:46:40 UTC
I guess I may found the problem. In bluedevil/src/actionplugins/networkpanu/helper/networkpanuhelper.cpp Bluedevil search only for the PANU service (00001115-0000-1000-8000-00805F9B34FB), but there is also the NAP service which uses UUID 00001116-0000-1000-8000-00805F9B34FB.

In Plasma NM I only test for the NAP service, which is the one that worked with my friend's iPhone 3GS serveral months ago.
Comment 28 Lamarque V. Souza 2011-11-06 18:49:53 UTC
You can try registering your tether connection using the networkmanagement_configshell command line tool:

http://lamarque-lvs.blogspot.com/2011/04/plasma-nm-bluetooth-tethering.html

if it works then the problem described in comment #27 is the source of the problem.
Comment 29 Thilo-Alexander Ginkel 2011-11-06 22:05:15 UTC
On Sun, Nov 6, 2011 at 19:08, Lamarque V. Souza <lamarque@kde.org> wrote:
> --- Comment #26 from Lamarque V. Souza <lamarque kde org>  2011-11-06 18:08:55 ---
> One question. Do you all have pm-utils installed?

Yes.

> I use pm-utils here and it
> signals NM to sleep on suspend to disk / ram. When NM is sleeping Plasma NM
> clears all activatables (the items in the plasmoid's connection list). I guess
> if NM is not put to sleep that may cause dangling pointers that could cause
> this crash.
>
> In my notebook after I trigger the suspend to ram shortcut the system tray icon
> changes to a red square with a white cross in the middle, which means Plasma NM
> has disabled networking because NM is not available anymore. If that does not
> happen in you notebook then that can be the problem.

Frankly, the suspend happens too fast, so I cannot tell whether the
icon changes. The crash happens always, so if you would like me to do
some debugging, let me know.

My NM connections are system connections if that makes a difference.

BTW, I do not use Bluetooth tethering, but I do have a WWAN (UMTS)
modem in my laptop.
Comment 30 Lamarque V. Souza 2011-11-06 22:21:25 UTC
Sorry about the bluetooth tethering messages, they should have gone to another bug I am trying to solve.

System connection should not make any difference, but you can try changing them to user connections just to make sure.

Also try running plasma-desktop through valgrind:

killall plasma-desktop
valgrind -v --leak-check=full --log-file=plasma-desktop.log --malloc-fill=0xaa --free-fill=0xbb plasma-desktop

You must be patient when using valgrind, it will make plasma-desktop start up extremelly slow (almost a minute). Compress the plasma-desktop.log file and attach it to the this bug entry.
Comment 31 Thilo-Alexander Ginkel 2011-11-06 22:36:45 UTC
Created attachment 65318 [details]
Valgrind log

When I change my WiFi connection to a user connection, the NM Widget even sporadically crashes during login (but also during resume). Please find attached the requested valgrind log. I guess that having a connection being established is sufficient to trigger the issue.
Comment 32 Lamarque V. Souza 2011-11-06 23:51:12 UTC
Strange, according to the log Plasma NM is allocating memory for a VPN connection but doing a cast on a wireless connection, that should not happen.

There are othe memory errors in the log that do not seem to be related to Plasma NM. I will try to investigate further.
Comment 33 Thilo-Alexander Ginkel 2011-11-07 00:12:08 UTC
On Mon, Nov 7, 2011 at 00:51, Lamarque V. Souza <lamarque@kde.org> wrote:
> --- Comment #32 from Lamarque V. Souza <lamarque kde org>  2011-11-06 23:51:12 ---
> Strange, according to the log Plasma NM is allocating memory for a VPN
> connection but doing a cast on a wireless connection, that should not happen.

That's plausible. I do have an OpenVPN VPN connection defined, which
is set to "Connect Automatically", but typically is not connected.
Comment 34 Lamarque V. Souza 2011-11-07 00:37:27 UTC
Created attachment 65322 [details]
Defaults to InterfaceConnection instead of WirelessInterfaceConnection

(In reply to comment #33)
> On Mon, Nov 7, 2011 at 00:51, Lamarque V. Souza <lamarque@kde.org> wrote:
> > --- Comment #32 from Lamarque V. Souza <lamarque kde org>  2011-11-06 23:51:12 ---
> > Strange, according to the log Plasma NM is allocating memory for a VPN
> > connection but doing a cast on a wireless connection, that should not happen.
> 
> That's plausible. I do have an OpenVPN VPN connection defined, which
> is set to "Connect Automatically", but typically is not connected.

The problem is that the cast only works for wireless connections and that is causing the crash. I do not understand why it is trying to cast a wireless connection since the connection that was just added is a VPN one. It is like it has changed the connection type in the middle of process of adding a connection.

I have a guess for what is happening, can you test the attached patch for me?
Comment 35 Lamarque V. Souza 2011-11-07 15:53:49 UTC
Git commit 0e87ab1a567aca695d655df8e423b5f9de35b2e3 by Lamarque V. Souza.
Committed on 06/11/2011 at 22:54.
Pushed by lvsouza into branch 'nm09'.

Revert "Test if DBus interface object is valid before using it."
1240c6f6f83d6a0502f659c7c49fe6d03ecb917f does not prevent the crash it
is was supposed to fix.

This reverts commit 1240c6f6f83d6a0502f659c7c49fe6d03ecb917f.

CCBUG: 283241

M  +1    -8    applet/wirelessstatus.cpp
M  +0    -5    libs/client/remotewirelessinterfaceconnection.cpp
M  +0    -1    libs/client/remotewirelessinterfaceconnection.h
M  +0    -6    libs/client/remotewirelessnetwork.cpp
M  +0    -1    libs/client/remotewirelessnetwork.h
M  +0    -1    libs/client/remotewirelessobject.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/0e87ab1a567aca695d655df8e423b5f9de35b2e3
Comment 36 Lamarque V. Souza 2011-11-07 15:54:33 UTC
Git commit d1d481d82d350083cedd3b040e5121a23247cc49 by Lamarque V. Souza.
Committed on 06/11/2011 at 19:15.
Pushed by lvsouza into branch 'master'.

Revert "Test if DBus interface object is valid before using it."
49fb02e3894ef7e96bf2856f262d3b14dfda79fd does not prevent the crash it
is was supposed to fix.

This reverts commit 49fb02e3894ef7e96bf2856f262d3b14dfda79fd.

CCBUG: 283241

M  +1    -8    applet/wirelessstatus.cpp
M  +0    -5    libs/client/remotewirelessinterfaceconnection.cpp
M  +0    -1    libs/client/remotewirelessinterfaceconnection.h
M  +0    -6    libs/client/remotewirelessnetwork.cpp
M  +0    -1    libs/client/remotewirelessnetwork.h
M  +0    -1    libs/client/remotewirelessobject.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/d1d481d82d350083cedd3b040e5121a23247cc49
Comment 37 Lamarque V. Souza 2011-11-07 21:22:07 UTC
*** Bug 286032 has been marked as a duplicate of this bug. ***
Comment 38 Thilo-Alexander Ginkel 2011-11-07 22:58:48 UTC
On Mon, Nov 7, 2011 at 01:37, Lamarque V. Souza <lamarque@kde.org> wrote:
> --- Comment #34 from Lamarque V. Souza <lamarque kde org>  2011-11-07 00:37:27 ---
> Created an attachment (id=65322)
>  --> (http://bugs.kde.org/attachment.cgi?id=65322)
> Defaults to InterfaceConnection instead of WirelessInterfaceConnection
> [...]
> I have a guess for what is happening, can you test the attached patch for me?

Sure. The patch works just great, no more crashes on resume.

Thanks,
Thilo
Comment 39 Lamarque V. Souza 2011-11-07 23:35:17 UTC
Git commit ca33e27e81395b4ce2f78b728ea3e3946bbb3f07 by Lamarque V. Souza.
Committed on 08/11/2011 at 00:23.
Pushed by lvsouza into branch 'master'.

Make two calls synchronous and also make
RemoteActivatable::activatableType() return a sane default in case of
errors.

activatableType() was returning
Knm::Activatable::WirelessInterfaceConnection in case of error or when
the assynchronous DBus call returned before the real value was
available, which led to a crash in applet/wirelessstatus.cpp when the
real activatable type was not WirelessInterfaceConnection ot
WirelessNetwork.

BUG: 283241
FIXED-IN: 0.9.0

M  +10   -3    libs/client/remoteactivatable.cpp

http://commits.kde.org/networkmanagement/ca33e27e81395b4ce2f78b728ea3e3946bbb3f07
Comment 40 Lamarque V. Souza 2011-11-07 23:37:26 UTC
Git commit 5d6050bf3e70930bfb80321f710613142c2db95a by Lamarque V. Souza.
Committed on 08/11/2011 at 00:23.
Pushed by lvsouza into branch 'nm09'.

Make two calls synchronous and also make
RemoteActivatable::activatableType() return a sane default in case of
errors.

activatableType() was returning
Knm::Activatable::WirelessInterfaceConnection in case of error or when
the assynchronous DBus call returned before the real value was
available, which led to a crash in applet/wirelessstatus.cpp when the
real activatable type was not WirelessInterfaceConnection ot
WirelessNetwork.

BUG: 283241
FIXED-IN: 0.9.0
(cherry picked from commit ca33e27e81395b4ce2f78b728ea3e3946bbb3f07)

M  +10   -3    libs/client/remoteactivatable.cpp

http://commits.kde.org/networkmanagement/5d6050bf3e70930bfb80321f710613142c2db95a
Comment 41 Christoph Feck 2011-11-14 03:51:15 UTC
*** Bug 286511 has been marked as a duplicate of this bug. ***
Comment 42 Lamarque V. Souza 2011-11-21 02:41:34 UTC
*** Bug 287089 has been marked as a duplicate of this bug. ***
Comment 43 Lamarque V. Souza 2011-11-23 10:17:07 UTC
*** Bug 287357 has been marked as a duplicate of this bug. ***
Comment 44 kavol 2011-11-23 13:02:01 UTC
(In reply to comment #40)
> Git commit 5d6050bf3e70930bfb80321f710613142c2db95a by Lamarque V. Souza.
> Committed on 08/11/2011 at 00:23.
> Pushed by lvsouza into branch 'nm09'.

if this is included in

kde-plasma-networkmanagement-libs-0.9-0.65.rc2.nm09.fc16.x86_64
kde-plasma-networkmanagement-0.9-0.65.rc2.nm09.fc16.x86_64

then it seems to fix the issue for me, thanks!
Comment 45 Lamarque V. Souza 2011-11-23 13:43:27 UTC
(In reply to comment #44)
> (In reply to comment #40)
> > Git commit 5d6050bf3e70930bfb80321f710613142c2db95a by Lamarque V. Souza.
> > Committed on 08/11/2011 at 00:23.
> > Pushed by lvsouza into branch 'nm09'.
> 
> if this is included in
> 
> kde-plasma-networkmanagement-libs-0.9-0.65.rc2.nm09.fc16.x86_64
> kde-plasma-networkmanagement-0.9-0.65.rc2.nm09.fc16.x86_64

According to http://rpmfind.net//linux/RPM/fedora/updates/16/x86_64/kde-plasma-networkmanagement-0.9-0.65.rc2.nm09.fc16.x86_64.html that package was created four days before the commit, so it is not included.

The problem acts like a race condition where one of the racers wins almost all the time, so it is not always reproducible.
Comment 46 Lamarque V. Souza 2011-11-29 20:55:59 UTC
*** Bug 287825 has been marked as a duplicate of this bug. ***
Comment 47 Lamarque V. Souza 2011-12-04 22:22:43 UTC
*** Bug 288117 has been marked as a duplicate of this bug. ***
Comment 48 Rex Dieter 2011-12-05 17:16:22 UTC
fedora 16 users, mind testing out:
kde-plasma-networkmanagement-0.9-0.67.20111203git.nm09.fc16
http://koji.fedoraproject.org/koji/buildinfo?buildID=277228

(I'll queue it for updates-testing shortly)
Comment 49 kavol 2011-12-06 13:28:19 UTC
(In reply to comment #45)
> According to
> http://rpmfind.net//linux/RPM/fedora/updates/16/x86_64/kde-plasma-networkmanagement-0.9-0.65.rc2.nm09.fc16.x86_64.html
> that package was created four days before the commit, so it is not included.
> 
> The problem acts like a race condition where one of the racers wins almost all
> the time, so it is not always reproducible.

yep, I just got another crash ... seems I was just lucky not seeing it twice in a row :-/

going to try the new package ...
Comment 50 kavol 2011-12-06 16:54:03 UTC
(In reply to comment #48)
> fedora 16 users, mind testing out:
> kde-plasma-networkmanagement-0.9-0.67.20111203git.nm09.fc16
> http://koji.fedoraproject.org/koji/buildinfo?buildID=277228

thanks; I rebooted the phone five times and no crashes so far ...

> (I'll queue it for updates-testing shortly)

I still do not see it in bodhi ...?
Comment 51 Valentin Rusu 2011-12-07 13:53:29 UTC
Created attachment 66477 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.2 (4.7.2) "release 5" using Qt 4.7.4

- What I was doing when the application crashed:

I was restarting the wifi router while the connection was active. During router restart, I inserted the LAN cable.

-- Backtrace (Reduced):
#6  0xaaa71e3b in init (wobj=0x8c66a34, this=0x8bb15b0) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x90ff518, remote=0x8c66a28) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:116
#8  0xaaa7050b in WirelessNetworkItem::WirelessNetworkItem (this=0x9294bf0, remote=0x8c66a28, parent=0x8b46140) at /usr/src/debug/networkmanagement/applet/wirelessnetworkitem.cpp:53
#9  0xaaa61518 in ActivatableListWidget::createItem (this=0x8b3f658, activatable=0x8c66a28, index=0) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:181
#10 0xaaa617bc in ActivatableListWidget::activatableAdded (this=0x8b3f658, added=0x8c66a28, index=0) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:269
Comment 52 Anne-Marie Mahfouf 2011-12-28 17:53:16 UTC
*** Bug 290031 has been marked as a duplicate of this bug. ***
Comment 53 Thijs 2012-01-09 08:22:08 UTC
*** Bug 291005 has been marked as a duplicate of this bug. ***
Comment 54 Thijs 2012-01-09 22:02:46 UTC
*** Bug 291084 has been marked as a duplicate of this bug. ***
Comment 55 Jekyll Wu 2012-01-30 17:36:49 UTC
*** Bug 292884 has been marked as a duplicate of this bug. ***