Bug 285555 - Plasma crash on network cable plugged in
Summary: Plasma crash on network cable plugged in
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-02 13:22 UTC by Ilya Taranov
Modified: 2011-11-03 01:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Taranov 2011-11-02 13:22:45 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.4
Operating System: Linux 2.6.40.6-0.fc15.x86_64 x86_64
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:

Plugged network cable into my notebook ethernet card.
Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007fd9eb64ea42 in init (wobj=0x1497f68, this=0x15aa7f0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x15ac4d0, remote=0x1497f50) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:116
#8  0x00007fd9eb64d985 in WirelessNetworkItem::WirelessNetworkItem (this=0x15a9d80, remote=0x1497f50, parent=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/wirelessnetworkitem.cpp:54
#9  0x00007fd9eb64060b in ActivatableListWidget::createItem (this=0xde5220, activatable=0x1497f50, addIfAlreadyCached=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:178
#10 0x00007fd9eb64088d in ActivatableListWidget::activatableAdded (this=0xde5220, added=0x1497f50) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:275
#11 0x00007fd9eb63499c in ActivatableListWidget::qt_metacall (this=0xde5220, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff56546a40) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:101
#12 0x00007fda0dfc4fea in QMetaObject::activate (sender=0xe58d00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff56546a40) at kernel/qobject.cpp:3278
#13 0x00007fd9eb4078af in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x1497f50) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:104
#14 0x00007fd9eb40cc17 in RemoteActivatableList::handleActivatableAdded (this=0xe58d00, addedPath=..., type=<optimized out>) at /usr/src/debug/networkmanagement-0.9/libs/client/remoteactivatablelist.cpp:258
#15 0x00007fd9eb4079f6 in RemoteActivatableList::qt_metacall (this=0xe58d00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff56546c80) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:90
#16 0x00007fda0dfc4fea in QMetaObject::activate (sender=0xda87b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff56546c80) at kernel/qobject.cpp:3278
#17 0x00007fd9eb410483 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=4) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:104
#18 0x00007fd9eb41081c in NetworkManagementInterface::qt_metacall (this=0xda87b0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff56546f10) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:84
#19 0x00007fda0e30173b in QDBusConnectionPrivate::deliverCall (this=0x7161d0, object=0xda87b0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#20 0x00007fda0e30ac2f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007fda0dfc8baa in QObject::event (this=0xda87b0, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x00007fda0d179324 in notify_helper (e=0x1581ae0, receiver=0xda87b0, this=0x725ad0) at kernel/qapplication.cpp:4481
#23 QApplicationPrivate::notify_helper (this=0x725ad0, receiver=0xda87b0, e=0x1581ae0) at kernel/qapplication.cpp:4453
#24 0x00007fda0d17e1b1 in QApplication::notify (this=0x7103f0, receiver=0xda87b0, e=0x1581ae0) at kernel/qapplication.cpp:4360
#25 0x00007fda0eec41c6 in KApplication::notify (this=0x7103f0, receiver=0xda87b0, event=0x1581ae0) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#26 0x00007fda0dfb220c in QCoreApplication::notifyInternal (this=0x7103f0, receiver=0xda87b0, event=0x1581ae0) at kernel/qcoreapplication.cpp:787
#27 0x00007fda0dfb57d4 in sendEvent (event=0x1581ae0, receiver=0xda87b0) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6becb0) at kernel/qcoreapplication.cpp:1428
#29 0x00007fda0dfdc973 in sendPostedEvents () at kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=0x72e380) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007fda053927ed in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#32 0x00007fda05392fc8 in ?? () from /lib64/libglib-2.0.so.0
#33 0x00007fda0539325c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#34 0x00007fda0dfdcdcf in QEventDispatcherGlib::processEvents (this=0x6c07c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007fda0d21c12e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#36 0x00007fda0dfb1722 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007fda0dfb191f in QEventLoop::exec (this=0x7fff565478d0, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007fda0dfb5a67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#39 0x00007fda13d7b203 in kdemain (argc=1, argv=0x7fff56547cb8) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/main.cpp:120
#40 0x00007fda0c4a739d in __libc_start_main (main=0x400890 <main(int, char**)>, argc=1, ubp_av=0x7fff56547cb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff56547ca8) at libc-start.c:226
#41 0x00000000004008c1 in _start ()

This bug may be a duplicate of or related to bug 283241.

Possible duplicates by query: bug 284284, bug 284007.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-11-03 01:11:34 UTC

*** This bug has been marked as a duplicate of bug 283241 ***