Bug 287825 - crash after kde reboot
Summary: crash after kde reboot
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-29 10:54 UTC by Harrivel
Modified: 2011-11-29 20:55 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.8.98 (0.9.0_rc3)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harrivel 2011-11-29 10:54:05 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-7.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed: the system have just rebooted. I have to reboot to get internet connexion by an Orange Livebox, I am searching the good parameters to make automatic connexion at first boot the morning.

-- Backtrace:
Application: Outil de gestion de fenêtres Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007fcdd2e3d7c2 in init (wobj=0x3301e78, this=0x33b90f0) at /usr/src/debug/networkmanagement-0.8.90/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x33b9590, remote=0x3301e60) at /usr/src/debug/networkmanagement-0.8.90/applet/wirelessstatus.cpp:116
#8  0x00007fcdd2e3c334 in WirelessNetworkItem::WirelessNetworkItem (this=0x33b1c50, remote=0x3301e60, parent=<optimized out>) at /usr/src/debug/networkmanagement-0.8.90/applet/wirelessnetworkitem.cpp:54
#9  0x00007fcdd2e2ee15 in ActivatableListWidget::createItem (this=0x3186660, activatable=0x3301e60, index=0) at /usr/src/debug/networkmanagement-0.8.90/applet/activatablelistwidget.cpp:181
#10 0x00007fcdd2e2f05e in ActivatableListWidget::activatableAdded (this=0x3186660, added=0x3301e60, index=0) at /usr/src/debug/networkmanagement-0.8.90/applet/activatablelistwidget.cpp:269
#11 0x00007fcdd2e222ea in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/networkmanagement-0.8.90/x86_64-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:79
#12 ActivatableListWidget::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/networkmanagement-0.8.90/x86_64-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:72
#13 0x00000035f058b7d1 in QMetaObject::activate (sender=0x2e80190, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc03af4c0) at kernel/qobject.cpp:3546
#14 0x00007fcdd2bd989d in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x3301e60, _t2=0) at /usr/src/debug/networkmanagement-0.8.90/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:118
#15 0x00007fcdd2bdefc3 in RemoteActivatableList::handleActivatableAdded (this=0x2e80190, addedPath=<optimized out>, type=<optimized out>, index=0) at /usr/src/debug/networkmanagement-0.8.90/libs/client/remoteactivatablelist.cpp:180
#16 0x00000035f058b7d1 in QMetaObject::activate (sender=0x2cf4af0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc03af6f0) at kernel/qobject.cpp:3546
#17 0x00007fcdd2be0dc1 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=3, _t3=0) at /usr/src/debug/networkmanagement-0.8.90/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:119
#18 0x00007fcdd2be1075 in qt_static_metacall (_a=0x7fffc03af9a0, _id=<optimized out>, _o=0x2cf4af0, _c=<optimized out>) at /usr/src/debug/networkmanagement-0.8.90/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:62
#19 NetworkManagementInterface::qt_static_metacall (_o=0x2cf4af0, _c=<optimized out>, _id=<optimized out>, _a=0x7fffc03af9a0) at /usr/src/debug/networkmanagement-0.8.90/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:56
#20 0x00007fcdd2be119b in NetworkManagementInterface::qt_metacall (this=0x2cf4af0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc03af9a0) at /usr/src/debug/networkmanagement-0.8.90/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:109
#21 0x00000035f1e22ccb in QDBusConnectionPrivate::deliverCall (this=0x23c6ec0, object=0x2cf4af0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:947
#22 0x00000035f05909e6 in QObject::event (this=0x2cf4af0, e=<optimized out>) at kernel/qobject.cpp:1194
#23 0x00000035f35c96f4 in notify_helper (e=0x2481e10, receiver=0x2cf4af0, this=0x23d4540) at kernel/qapplication.cpp:4518
#24 QApplicationPrivate::notify_helper (this=0x23d4540, receiver=0x2cf4af0, e=0x2481e10) at kernel/qapplication.cpp:4490
#25 0x00000035f35ce573 in QApplication::notify (this=0x23c62f0, receiver=0x2cf4af0, e=0x2481e10) at kernel/qapplication.cpp:4379
#26 0x00000035f5050396 in KApplication::notify (this=0x23c62f0, receiver=0x2cf4af0, event=0x2481e10) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#27 0x00000035f0577b4c in QCoreApplication::notifyInternal (this=0x23c62f0, receiver=0x2cf4af0, event=0x2481e10) at kernel/qcoreapplication.cpp:876
#28 0x00000035f057b5da in sendEvent (event=0x2481e10, receiver=0x2cf4af0) at kernel/qcoreapplication.h:231
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2365740) at kernel/qcoreapplication.cpp:1500
#30 0x00000035f05a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#31 postEventSourceDispatch (s=0x23d8760) at kernel/qeventdispatcher_glib.cpp:279
#32 0x00000035e5444a7d in g_main_dispatch (context=0x23d6d30) at gmain.c:2425
#33 g_main_context_dispatch (context=0x23d6d30) at gmain.c:2995
#34 0x00000035e5445278 in g_main_context_iterate (context=0x23d6d30, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#35 0x00000035e544544c in g_main_context_iteration (context=0x23d6d30, may_block=1) at gmain.c:3136
#36 0x00000035f05a682f in QEventDispatcherGlib::processEvents (this=0x2366c00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#37 0x00000035f366c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#38 0x00000035f0576c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#39 0x00000035f0576ed7 in QEventLoop::exec (this=0x7fffc03b0360, flags=...) at kernel/qeventloop.cpp:204
#40 0x00000035f057b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#41 0x00000035fec41263 in kdemain (argc=1, argv=0x7fffc03b0748) at /usr/src/debug/kdebase-workspace-4.7.2/kdebase-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#42 0x00000035e582169d in __libc_start_main (main=0x400870 <main(int, char**)>, argc=1, ubp_av=0x7fffc03b0748, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc03b0738) at libc-start.c:226
#43 0x00000000004008a1 in _start ()

Possible duplicates by query: bug 287357, bug 286511, bug 284284, bug 284007.

Reported using DrKonqi
Comment 1 Bogdan Udrescu 2011-11-29 15:32:22 UTC
duplicate of bug 283241
Comment 2 Lamarque V. Souza 2011-11-29 20:55:59 UTC

*** This bug has been marked as a duplicate of bug 283241 ***