Bug 286032 - Plasma crashed on LAN cable unplug
Summary: Plasma crashed on LAN cable unplug
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-07 19:37 UTC by Alex Minton
Modified: 2011-11-07 21:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Minton 2011-11-07 19:37:03 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1-desktop x86_64
Distribution: "openSUSE 12.1 RC 1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was configuring my new router. While it rebooted itself I detached the LAN cable from my laptop to router. NM was not configuring wired interface in this specific moment, cause router was in a reboot.

-- Backtrace:
Application: Оболочка Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f20517a8760 (LWP 2207))]

Thread 2 (Thread 0x7f202b418700 (LWP 2213)):
#0  0x00007f204ee14423 in poll () from /lib64/libc.so.6
#1  0x00007f204bc0aa98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f204bc0af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f2050426576 in QEventDispatcherGlib::processEvents (this=0x154a020, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f20503faa22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f20503fac1f in QEventLoop::exec (this=0x7f202b417df0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f20503125df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f20503ddaef in QInotifyFileSystemWatcherEngine::run (this=0x14dc650) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2050315025 in QThreadPrivate::start (arg=0x14dc650) at thread/qthread_unix.cpp:331
#9  0x00007f2050084f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f204ee1d53d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f20517a8760 (LWP 2207)):
[KCrash Handler]
#6  0x00007f203563ebe2 in init (wobj=0x29d42c8, this=0x2bed970) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x2c3d0c0, remote=0x29d42b0) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:116
#8  0x00007f203563d754 in WirelessNetworkItem::WirelessNetworkItem (this=0x1ece090, remote=0x29d42b0, parent=<optimized out>) at /usr/src/debug/networkmanagement/applet/wirelessnetworkitem.cpp:53
#9  0x00007f2035630235 in ActivatableListWidget::createItem (this=0x173ccb0, activatable=0x29d42b0, index=1) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:181
#10 0x00007f203563047e in ActivatableListWidget::activatableAdded (this=0x173ccb0, added=0x29d42b0, index=1) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:269
#11 0x00007f2035623d73 in ActivatableListWidget::qt_metacall (this=0x173ccb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d2706c0) at /usr/src/debug/networkmanagement/build/applet/moc_activatablelistwidget.cpp:104
#12 0x00007f205040e59a in QMetaObject::activate (sender=0x1077590, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4d2706c0) at kernel/qobject.cpp:3287
#13 0x00007f20353d330d in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x29d42b0, _t2=1) at /usr/src/debug/networkmanagement/build/libs/client/moc_remoteactivatablelist.cpp:104
#14 0x00007f20353d8d33 in RemoteActivatableList::handleActivatableAdded (this=0x1077590, addedPath=<optimized out>, type=<optimized out>, index=1) at /usr/src/debug/networkmanagement/libs/client/remoteactivatablelist.cpp:180
#15 0x00007f20353d345c in RemoteActivatableList::qt_metacall (this=0x1077590, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d2708b0) at /usr/src/debug/networkmanagement/build/libs/client/moc_remoteactivatablelist.cpp:90
#16 0x00007f205040e59a in QMetaObject::activate (sender=0xdb7960, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4d2708b0) at kernel/qobject.cpp:3287
#17 0x00007f20353dab21 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=3, _t3=1) at /usr/src/debug/networkmanagement/build/libs/client/networkmanagementinterface.moc:105
#18 0x00007f20353daecb in NetworkManagementInterface::qt_metacall (this=0xdb7960, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff4d270b40) at /usr/src/debug/networkmanagement/build/libs/client/networkmanagementinterface.moc:85
#19 0x00007f204d1b79fb in QDBusConnectionPrivate::deliverCall (this=0x6ba030, object=0xdb7960, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#20 0x00007f204d1c0d5f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007f205041214a in QObject::event (this=0xdb7960, e=<optimized out>) at kernel/qobject.cpp:1226
#22 0x00007f204f5adbe4 in notify_helper (e=0x2bb5d90, receiver=0xdb7960, this=0x6def70) at kernel/qapplication.cpp:4481
#23 QApplicationPrivate::notify_helper (this=0x6def70, receiver=0xdb7960, e=0x2bb5d90) at kernel/qapplication.cpp:4453
#24 0x00007f204f5b2a71 in QApplication::notify (this=0x6c8b20, receiver=0xdb7960, e=0x2bb5d90) at kernel/qapplication.cpp:4360
#25 0x00007f205118de36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#26 0x00007f20503fb81c in QCoreApplication::notifyInternal (this=0x6c8b20, receiver=0xdb7960, event=0x2bb5d90) at kernel/qcoreapplication.cpp:787
#27 0x00007f20503febf8 in sendEvent (event=0x2bb5d90, receiver=0xdb7960) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x615f10) at kernel/qcoreapplication.cpp:1428
#29 0x00007f20504260b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f204bc0a58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f204bc0ad88 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f204bc0af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f205042650f in QEventDispatcherGlib::processEvents (this=0x6d7e50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007f204f650f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f20503faa22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f20503fac1f in QEventLoop::exec (this=0x7fff4d271500, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007f20503fede7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#39 0x00007f203eedb773 in kdemain (argc=1, argv=0x631ad0) at /usr/src/debug/kde-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#40 0x0000000000408897 in _start ()

This bug may be a duplicate of or related to bug 283241.

Possible duplicates by query: bug 284284, bug 284007.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-11-07 21:22:07 UTC

*** This bug has been marked as a duplicate of bug 283241 ***