Bug 291005 - Plasma crash on resume from sleep
Summary: Plasma crash on resume from sleep
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-08 23:04 UTC by Marc
Modified: 2012-01-09 08:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc 2012-01-08 23:04:01 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.97 (4.8 RC2 (4.7.97)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Resume from suspend

KDE 4.8 rc2 kubuntu packages 
lenovo T410 NVIDIA binary driver

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f339a8bd7c0 (LWP 25497))]

Thread 4 (Thread 0x7f337565b700 (LWP 25501)):
#0  0x00007f338e4f8424 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f338e4f8e6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f338e4f9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f33973d2f3e in QEventDispatcherGlib::processEvents (this=0x1d505f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f33973a6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f33973a6ef7 in QEventLoop::exec (this=0x7f337565acd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f33972be27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f3397389cbf in QInotifyFileSystemWatcherEngine::run (this=0x1d504f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f33972c0d05 in QThreadPrivate::start (arg=0x1d504f0) at thread/qthread_unix.cpp:331
#9  0x00007f338b81256c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f338f005efc in start_thread (arg=0x7f337565b700) at pthread_create.c:304
#11 0x00007f339a1c089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f336efbf700 (LWP 25502)):
#0  0x00007f339a1b4773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f338e4f8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f338e4f9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f33973d2f3e in QEventDispatcherGlib::processEvents (this=0x1e5eed0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f33973a6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f33973a6ef7 in QEventLoop::exec (this=0x7f336efbecd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f33972be27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f3397389cbf in QInotifyFileSystemWatcherEngine::run (this=0x1e5e1e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f33972c0d05 in QThreadPrivate::start (arg=0x1e5e1e0) at thread/qthread_unix.cpp:331
#9  0x00007f338b81256c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f338f005efc in start_thread (arg=0x7f336efbf700) at pthread_create.c:304
#11 0x00007f339a1c089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f336c24e700 (LWP 25505)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f33943d7fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f33943d8019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f338b81256c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f338f005efc in start_thread (arg=0x7f336c24e700) at pthread_create.c:304
#5  0x00007f339a1c089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f339a8bd7c0 (LWP 25497)):
[KCrash Handler]
#6  0x00007f336e5ae8a2 in init (wobj=0x31cde28, this=0x1fa0fa0) at ../../applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x2b33860, remote=0x31cde10) at ../../applet/wirelessstatus.cpp:116
#8  0x00007f336e5ad414 in WirelessNetworkItem::WirelessNetworkItem (this=0x23c84d0, remote=0x31cde10, parent=<optimized out>) at ../../applet/wirelessnetworkitem.cpp:54
#9  0x00007f336e59fec5 in ActivatableListWidget::createItem (this=0x215b460, activatable=0x31cde10, index=0) at ../../applet/activatablelistwidget.cpp:181
#10 0x00007f336e5a010e in ActivatableListWidget::activatableAdded (this=0x215b460, added=0x31cde10, index=0) at ../../applet/activatablelistwidget.cpp:269
#11 0x00007f336e593253 in ActivatableListWidget::qt_metacall (this=0x215b460, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffda20e840) at moc_activatablelistwidget.cpp:104
#12 0x00007f33973baeba in QMetaObject::activate (sender=0x1e02a30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffda20e840) at kernel/qobject.cpp:3278
#13 0x00007f3374206a2d in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x31cde10, _t2=0) at moc_remoteactivatablelist.cpp:104
#14 0x00007f337420c4e3 in RemoteActivatableList::handleActivatableAdded (this=0x1e02a30, addedPath=<optimized out>, type=<optimized out>, index=0) at ../../../libs/client/remoteactivatablelist.cpp:180
#15 0x00007f3374206b7c in RemoteActivatableList::qt_metacall (this=0x1e02a30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffda20ea30) at moc_remoteactivatablelist.cpp:90
#16 0x00007f33973baeba in QMetaObject::activate (sender=0x220f020, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffda20ea30) at kernel/qobject.cpp:3278
#17 0x00007f337420e2d1 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=1, _t3=0) at networkmanagementinterface.moc:105
#18 0x00007f337420e67b in NetworkManagementInterface::qt_metacall (this=0x220f020, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffda20eca0) at networkmanagementinterface.moc:85
#19 0x00007f33976ff0e9 in QDBusConnectionPrivate::deliverCall (this=0x1509080, object=0x220f020, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#20 0x00007f339770838f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007f33973bea5e in QObject::event (this=0x220f020, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x00007f3396758424 in notify_helper (e=0x33376b0, receiver=0x220f020, this=0x151af70) at kernel/qapplication.cpp:4486
#23 QApplicationPrivate::notify_helper (this=0x151af70, receiver=0x220f020, e=0x33376b0) at kernel/qapplication.cpp:4458
#24 0x00007f339675d291 in QApplication::notify (this=0x1508410, receiver=0x220f020, e=0x33376b0) at kernel/qapplication.cpp:4365
#25 0x00007f3398056ae6 in KApplication::notify (this=0x1508410, receiver=0x220f020, event=0x33376b0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f33973a7afc in QCoreApplication::notifyInternal (this=0x1508410, receiver=0x220f020, event=0x33376b0) at kernel/qcoreapplication.cpp:787
#27 0x00007f33973ab51f in sendEvent (event=0x33376b0, receiver=0x220f020) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1455430) at kernel/qcoreapplication.cpp:1428
#29 0x00007f33973d2a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f338e4f8a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f338e4f9258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f338e4f9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f33973d2ed6 in QEventDispatcherGlib::processEvents (this=0x1456f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007f339680007e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f33973a6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f33973a6ef7 in QEventLoop::exec (this=0x7fffda20f4c0, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007f33973ab789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#39 0x00007f339a4bf7e3 in kdemain (argc=1, argv=0x7fffda20f8a8) at ../../../../plasma/desktop/shell/main.cpp:120
#40 0x00007f339a10030d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fffda20f8a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffda20f898) at libc-start.c:226
#41 0x0000000000400671 in _start ()

Possible duplicates by query: bug 287357, bug 286511, bug 284284, bug 284007.

Reported using DrKonqi
Comment 1 Thijs 2012-01-09 08:22:08 UTC

*** This bug has been marked as a duplicate of bug 283241 ***