Bug 284007 - Plasma workspace crashes when an USB ethernet gadget comes up
Summary: Plasma workspace crashes when an USB ethernet gadget comes up
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-14 16:10 UTC by Diego
Modified: 2011-10-14 19:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego 2011-10-14 16:10:16 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.4
Operating System: Linux 2.6.40.6-0.fc15.x86_64 x86_64
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:

I've got a board which setups as an USB Ethernet gadget. When the gadget comes up Plasma crashes with the attached backtrace.

The crash can be reproduced every time.

-- Backtrace:
Application: Shell del desktop di Plasma (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007f2a46701a42 in init (wobj=0x3afdc48, this=0x39d24d0) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x3d3d110, remote=0x3afdc30) at /usr/src/debug/networkmanagement-0.9/applet/wirelessstatus.cpp:116
#8  0x00007f2a46700985 in WirelessNetworkItem::WirelessNetworkItem (this=0x3f3e200, remote=0x3afdc30, parent=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/wirelessnetworkitem.cpp:54
#9  0x00007f2a466f360b in ActivatableListWidget::createItem (this=0x23002e0, activatable=0x3afdc30, addIfAlreadyCached=<optimized out>) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:178
#10 0x00007f2a466f388d in ActivatableListWidget::activatableAdded (this=0x23002e0, added=0x3afdc30) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:275
#11 0x00007f2a466e799c in ActivatableListWidget::qt_metacall (this=0x23002e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff26b7e970) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:101
#12 0x00007f2a6b06bfea in QMetaObject::activate (sender=0x21f6ed0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff26b7e970) at kernel/qobject.cpp:3278
#13 0x00007f2a464ba8af in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x3afdc30) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:104
#14 0x00007f2a464bfc17 in RemoteActivatableList::handleActivatableAdded (this=0x21f6ed0, addedPath=..., type=<optimized out>) at /usr/src/debug/networkmanagement-0.9/libs/client/remoteactivatablelist.cpp:258
#15 0x00007f2a464ba9f6 in RemoteActivatableList::qt_metacall (this=0x21f6ed0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff26b7ebb0) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:90
#16 0x00007f2a6b06bfea in QMetaObject::activate (sender=0x21f7bc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff26b7ebb0) at kernel/qobject.cpp:3278
#17 0x00007f2a464c3483 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=4) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:104
#18 0x00007f2a464c381c in NetworkManagementInterface::qt_metacall (this=0x21f7bc0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff26b7ee40) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:84
#19 0x00007f2a6b3a873b in QDBusConnectionPrivate::deliverCall (this=0x19f1410, object=0x21f7bc0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#20 0x00007f2a6b3b1c2f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007f2a6b06fbaa in QObject::event (this=0x21f7bc0, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x00007f2a6a220324 in notify_helper (e=0x3fea610, receiver=0x21f7bc0, this=0x19fffc0) at kernel/qapplication.cpp:4481
#23 QApplicationPrivate::notify_helper (this=0x19fffc0, receiver=0x21f7bc0, e=0x3fea610) at kernel/qapplication.cpp:4453
#24 0x00007f2a6a2251b1 in QApplication::notify (this=0x19f0c90, receiver=0x21f7bc0, e=0x3fea610) at kernel/qapplication.cpp:4360
#25 0x00007f2a6bf67d56 in KApplication::notify (this=0x19f0c90, receiver=0x21f7bc0, event=0x3fea610) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#26 0x00007f2a6b05920c in QCoreApplication::notifyInternal (this=0x19f0c90, receiver=0x21f7bc0, event=0x3fea610) at kernel/qcoreapplication.cpp:787
#27 0x00007f2a6b05c7d4 in sendEvent (event=0x3fea610, receiver=0x21f7bc0) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1980cd0) at kernel/qcoreapplication.cpp:1428
#29 0x00007f2a6b083973 in sendPostedEvents () at kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=0x19fd600) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f2a623c37ed in g_main_dispatch (context=0x19fc8e0) at gmain.c:2441
#32 g_main_context_dispatch (context=0x19fc8e0) at gmain.c:3014
#33 0x00007f2a623c3fc8 in g_main_context_iterate (context=0x19fc8e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
#34 0x00007f2a623c425c in g_main_context_iteration (context=0x19fc8e0, may_block=1) at gmain.c:3155
#35 0x00007f2a6b083dcf in QEventDispatcherGlib::processEvents (this=0x19827e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#36 0x00007f2a6a2c312e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#37 0x00007f2a6b058722 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#38 0x00007f2a6b05891f in QEventLoop::exec (this=0x7fff26b7f800, flags=...) at kernel/qeventloop.cpp:201
#39 0x00007f2a6b05ca67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#40 0x00007f2a70e1e203 in kdemain (argc=1, argv=0x7fff26b7fbe8) at /usr/src/debug/kdebase-workspace-4.6.5/plasma/desktop/shell/main.cpp:120
#41 0x00007f2a6954e39d in __libc_start_main (main=0x400890 <main(int, char**)>, argc=1, ubp_av=0x7fff26b7fbe8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff26b7fbd8) at libc-start.c:226
#42 0x00000000004008c1 in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-10-14 19:57:40 UTC

*** This bug has been marked as a duplicate of bug 283241 ***