Bug 287089 - KDE crashed, when I connected the Ethernet cable
Summary: KDE crashed, when I connected the Ethernet cable
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-20 18:59 UTC by wzab
Modified: 2011-11-21 02:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wzab 2011-11-20 18:59:16 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.3
Operating System: Linux 3.1.1 x86_64
Distribution: Debian GNU/Linux testing (wheezy)

-- Information about the crash:
- What I was doing when the application crashed:

I have connected the Ethernet cable, when KDE session was already opened, and another network connection (via WiFi already existed).
This was the first time, when such situation occured (even though I often connected/disconnected Ethernet cable while using WiFi).

-- Backtrace:
Application: Powłoka pulpitu Plazmy (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0054af8780 (LWP 3023))]

Thread 3 (Thread 0x7f003a4ae700 (LWP 3024)):
#0  0x00007f00543f3723 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0048599414 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f0048599cfa in g_main_loop_run () from /lib/libglib-2.0.so.0
#3  0x00007f003f40f534 in ?? () from /usr/lib/libgio-2.0.so.0
#4  0x00007f00485be9b6 in ?? () from /lib/libglib-2.0.so.0
#5  0x00007f00492a7b40 in start_thread (arg=<optimized out>) at pthread_create.c:304
#6  0x00007f00543fe36d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f00245e4700 (LWP 3031)):
#0  0x00007f00543f3723 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0048599414 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f0048599949 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f00515aab26 in QEventDispatcherGlib::processEvents (this=0x7f0034001b70, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f005157f1c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f005157f3bf in QEventLoop::exec (this=0x7f00245e3dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f00514971ef in QThread::exec (this=<optimized out>) at thread/qthread.cpp:492
#7  0x00007f00515621ef in QInotifyFileSystemWatcherEngine::run (this=0x20f3970) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0051499c05 in QThreadPrivate::start (arg=0x20f3970) at thread/qthread_unix.cpp:320
#9  0x00007f00492a7b40 in start_thread (arg=<optimized out>) at pthread_create.c:304
#10 0x00007f00543fe36d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0054af8780 (LWP 3023)):
[KCrash Handler]
#6  0x00007f0026b53f1d in WirelessStatusPrivate::init(RemoteWirelessObject*) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#7  0x00007f0026b535f2 in WirelessStatus::WirelessStatus(RemoteWirelessNetwork*) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#8  0x00007f0026b52057 in WirelessNetworkItem::WirelessNetworkItem(RemoteWirelessNetwork*, QGraphicsItem*) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#9  0x00007f0026b42959 in ActivatableListWidget::createItem(RemoteActivatable*, int) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#10 0x00007f0026b43028 in ActivatableListWidget::activatableAdded(RemoteActivatable*, int) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#11 0x00007f0026b32c05 in ActivatableListWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#12 0x00007f0051592b1a in QMetaObject::activate (sender=0x1eb5c00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0e1f9db0) at kernel/qobject.cpp:3278
#13 0x00007f002690419a in RemoteActivatableList::activatableAdded(RemoteActivatable*, int) () from /usr/lib/libknmclient.so.4
#14 0x00007f00269094dd in RemoteActivatableList::handleActivatableAdded(QString const&, unsigned int, int) () from /usr/lib/libknmclient.so.4
#15 0x00007f00269040ea in RemoteActivatableList::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmclient.so.4
#16 0x00007f0051592b1a in QMetaObject::activate (sender=0x1eaa6a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0e1f9fb0) at kernel/qobject.cpp:3278
#17 0x00007f002690c3f1 in NetworkManagementInterface::ActivatableAdded(QString const&, unsigned int, int) () from /usr/lib/libknmclient.so.4
#18 0x00007f002690c27a in NetworkManagementInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmclient.so.4
#19 0x00007f00518d7971 in QDBusConnectionPrivate::deliverCall (this=0x1821df0, object=0x1eaa6a0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:941
#20 0x00007f00518e0eaf in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007f00515966ca in QObject::event (this=0x1eaa6a0, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x00007f00509389f4 in notify_helper (e=0x2839700, receiver=0x1eaa6a0, this=0x182f810) at kernel/qapplication.cpp:4467
#23 QApplicationPrivate::notify_helper (this=0x182f810, receiver=0x1eaa6a0, e=0x2839700) at kernel/qapplication.cpp:4439
#24 0x00007f005093d881 in QApplication::notify (this=0x1821190, receiver=0x1eaa6a0, e=0x2839700) at kernel/qapplication.cpp:4346
#25 0x00007f0052268b96 in KApplication::notify (this=0x1821190, receiver=0x1eaa6a0, event=0x2839700) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f005157ffbc in QCoreApplication::notifyInternal (this=0x1821190, receiver=0x1eaa6a0, event=0x2839700) at kernel/qcoreapplication.cpp:731
#27 0x00007f0051583378 in sendEvent (event=0x2839700, receiver=0x1eaa6a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x17b6860) at kernel/qcoreapplication.cpp:1372
#29 0x00007f00515aa663 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f0048598edd in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#32 0x00007f00485996b8 in ?? () from /lib/libglib-2.0.so.0
#33 0x00007f0048599949 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#34 0x00007f00515aaabf in QEventDispatcherGlib::processEvents (this=0x17b7f50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007f00509dc9ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f005157f1c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f005157f3bf in QEventLoop::exec (this=0x7fff0e1fab70, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007f0051583567 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#39 0x00007f00546ee5a3 in kdemain (argc=1, argv=0x7fff0e1faf58) at ../../../../plasma/desktop/shell/main.cpp:120
#40 0x00007f0054347ead in __libc_start_main (main=<optimized out>, argc=<optimized out>, ubp_av=<optimized out>, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0e1faf48) at libc-start.c:228
#41 0x00000000004006c1 in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-11-21 02:41:34 UTC

*** This bug has been marked as a duplicate of bug 283241 ***