Bug 287357 - I connected the Ethernet cable and KDE crashed
Summary: I connected the Ethernet cable and KDE crashed
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-23 10:08 UTC by wzab
Modified: 2011-11-23 10:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wzab 2011-11-23 10:08:54 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.3
Operating System: Linux 3.1.1 x86_64
Distribution: Debian GNU/Linux testing (wheezy)

-- Information about the crash:
- What I was doing when the application crashed:

I connected the Ethernet cable and KDE crashed.
The problem occured second time

-- Backtrace:
Application: Powłoka pulpitu Plazmy (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0ade279780 (LWP 2717))]

Thread 3 (Thread 0x7f0ac3c2e700 (LWP 2718)):
#0  0x00007f0addb74723 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0ad1d1a414 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f0ad1d1acfa in g_main_loop_run () from /lib/libglib-2.0.so.0
#3  0x00007f0ac8b90534 in ?? () from /usr/lib/libgio-2.0.so.0
#4  0x00007f0ad1d3f9b6 in ?? () from /lib/libglib-2.0.so.0
#5  0x00007f0ad2a28b40 in start_thread (arg=<optimized out>) at pthread_create.c:304
#6  0x00007f0addb7f36d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0ab1d9a700 (LWP 2725)):
#0  0x00007f0addb74723 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0ad1d1a414 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f0ad1d1a949 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f0adad2bb26 in QEventDispatcherGlib::processEvents (this=0x2817800, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f0adad001c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0adad003bf in QEventLoop::exec (this=0x7f0ab1d99dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f0adac181ef in QThread::exec (this=<optimized out>) at thread/qthread.cpp:492
#7  0x00007f0adace31ef in QInotifyFileSystemWatcherEngine::run (this=0x2817180) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0adac1ac05 in QThreadPrivate::start (arg=0x2817180) at thread/qthread_unix.cpp:320
#9  0x00007f0ad2a28b40 in start_thread (arg=<optimized out>) at pthread_create.c:304
#10 0x00007f0addb7f36d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0ade279780 (LWP 2717)):
[KCrash Handler]
#6  0x00007f0ab4309f1d in WirelessStatusPrivate::init(RemoteWirelessObject*) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#7  0x00007f0ab43095f2 in WirelessStatus::WirelessStatus(RemoteWirelessNetwork*) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#8  0x00007f0ab4308057 in WirelessNetworkItem::WirelessNetworkItem(RemoteWirelessNetwork*, QGraphicsItem*) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#9  0x00007f0ab42f8959 in ActivatableListWidget::createItem(RemoteActivatable*, int) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#10 0x00007f0ab42f9028 in ActivatableListWidget::activatableAdded(RemoteActivatable*, int) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#11 0x00007f0ab42e8c05 in ActivatableListWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#12 0x00007f0adad13b1a in QMetaObject::activate (sender=0x260db80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff13213610) at kernel/qobject.cpp:3278
#13 0x00007f0ab40ba19a in RemoteActivatableList::activatableAdded(RemoteActivatable*, int) () from /usr/lib/libknmclient.so.4
#14 0x00007f0ab40bf4dd in RemoteActivatableList::handleActivatableAdded(QString const&, unsigned int, int) () from /usr/lib/libknmclient.so.4
#15 0x00007f0ab40ba0ea in RemoteActivatableList::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmclient.so.4
#16 0x00007f0adad13b1a in QMetaObject::activate (sender=0x25ea100, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff13213810) at kernel/qobject.cpp:3278
#17 0x00007f0ab40c23f1 in NetworkManagementInterface::ActivatableAdded(QString const&, unsigned int, int) () from /usr/lib/libknmclient.so.4
#18 0x00007f0ab40c227a in NetworkManagementInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmclient.so.4
#19 0x00007f0adb058971 in QDBusConnectionPrivate::deliverCall (this=0x1e6fe90, object=0x25ea100, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:941
#20 0x00007f0adb061eaf in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007f0adad176ca in QObject::event (this=0x25ea100, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x00007f0ada0b99f4 in notify_helper (e=0x2ee8d70, receiver=0x25ea100, this=0x1e7d8b0) at kernel/qapplication.cpp:4467
#23 QApplicationPrivate::notify_helper (this=0x1e7d8b0, receiver=0x25ea100, e=0x2ee8d70) at kernel/qapplication.cpp:4439
#24 0x00007f0ada0be881 in QApplication::notify (this=0x1e6f230, receiver=0x25ea100, e=0x2ee8d70) at kernel/qapplication.cpp:4346
#25 0x00007f0adb9e9b96 in KApplication::notify (this=0x1e6f230, receiver=0x25ea100, event=0x2ee8d70) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f0adad00fbc in QCoreApplication::notifyInternal (this=0x1e6f230, receiver=0x25ea100, event=0x2ee8d70) at kernel/qcoreapplication.cpp:731
#27 0x00007f0adad04378 in sendEvent (event=0x2ee8d70, receiver=0x25ea100) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1e04860) at kernel/qcoreapplication.cpp:1372
#29 0x00007f0adad2b663 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f0ad1d19edd in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#32 0x00007f0ad1d1a6b8 in ?? () from /lib/libglib-2.0.so.0
#33 0x00007f0ad1d1a949 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#34 0x00007f0adad2babf in QEventDispatcherGlib::processEvents (this=0x1e05f50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007f0ada15d9ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f0adad001c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f0adad003bf in QEventLoop::exec (this=0x7fff132143d0, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007f0adad04567 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#39 0x00007f0adde6f5a3 in kdemain (argc=1, argv=0x7fff132147b8) at ../../../../plasma/desktop/shell/main.cpp:120
#40 0x00007f0addac8ead in __libc_start_main (main=<optimized out>, argc=<optimized out>, ubp_av=<optimized out>, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff132147a8) at libc-start.c:228
#41 0x00000000004006c1 in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-11-23 10:17:07 UTC

*** This bug has been marked as a duplicate of bug 283241 ***