Bug 288117 - Plasma crash on 3G-modem unplugged
Summary: Plasma crash on 3G-modem unplugged
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-03 10:49 UTC by Alex Minton
Modified: 2011-12-04 22:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Minton 2011-12-03 10:49:13 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I was testing my new shiny openSUSE 12.1 installation and had the huawey e173 USB-modem working fine, but after I terminated connection and unplugged the modem, Plasma crashed.

-- Backtrace:
Application: Оболочка Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd40be82760 (LWP 2606))]

Thread 2 (Thread 0x7fd3e8945700 (LWP 2618)):
#0  0x00007fff859ff8de in ?? ()
#1  0x00007fd406597e91 in clock_gettime () from /lib64/librt.so.1
#2  0x00007fd40aa3e114 in do_gettime (frac=0x7fd3e8944b78, sec=0x7fd3e8944b70) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fd40aaffd1d in QTimerInfoList::updateCurrentTime (this=0x7fd3dc001ed0) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007fd40ab00053 in QTimerInfoList::timerWait (this=0x7fd3dc001ed0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007fd40aafeabc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fd3e8944c5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fd40aafeb65 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fd4062e2b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fd4062e392d in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fd4062e3f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fd40aaff576 in QEventDispatcherGlib::processEvents (this=0x7fd3dc0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007fd40aad3a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fd40aad3c1f in QEventLoop::exec (this=0x7fd3e8944df0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007fd40a9eb5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007fd40aab6aef in QInotifyFileSystemWatcherEngine::run (this=0x12655c0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fd40a9ee025 in QThreadPrivate::start (arg=0x12655c0) at thread/qthread_unix.cpp:331
#17 0x00007fd40a75df05 in start_thread () from /lib64/libpthread.so.0
#18 0x00007fd4094f653d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fd40be82760 (LWP 2606)):
[KCrash Handler]
#6  0x00007fd3f1d6dbe2 in init (wobj=0xcf6d28, this=0x1bee460) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x1c958a0, remote=0xcf6d10) at /usr/src/debug/networkmanagement/applet/wirelessstatus.cpp:116
#8  0x00007fd3f1d6c754 in WirelessNetworkItem::WirelessNetworkItem (this=0x1e6e060, remote=0xcf6d10, parent=<optimized out>) at /usr/src/debug/networkmanagement/applet/wirelessnetworkitem.cpp:53
#9  0x00007fd3f1d5f235 in ActivatableListWidget::createItem (this=0x1210da0, activatable=0xcf6d10, index=1) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:181
#10 0x00007fd3f1d5ffed in ActivatableListWidget::filter (this=0x1210da0) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:295
#11 0x00007fd3f1d60288 in ActivatableListWidget::setHasWireless (this=0x1210da0, hasWireless=true) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:279
#12 0x00007fd3f1d5a461 in NMPopup::updateHasWireless (this=0x101ad10, checked=<optimized out>) at /usr/src/debug/networkmanagement/applet/nmpopup.cpp:569
#13 0x00007fd3f1d5c3e1 in NMPopup::interfaceRemoved (this=0x101ad10, uni=<optimized out>) at /usr/src/debug/networkmanagement/applet/nmpopup.cpp:348
#14 0x00007fd3f1d5259b in NMPopup::qt_metacall (this=0x101ad10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff859cec10) at /usr/src/debug/networkmanagement/build/applet/moc_nmpopup.cpp:114
#15 0x00007fd40aae759a in QMetaObject::activate (sender=0xdb2c80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff859cec10) at kernel/qobject.cpp:3287
#16 0x00007fd3f1235185 in Solid::Control::NetworkManagerNm09::Notifier::networkInterfaceRemoved (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/networkmanagement/build/solidcontrolfuture/libs/solid/control/networkmanager.moc:123
#17 0x00007fd3f12356e1 in Solid::Control::NetworkManagerNm09Private::_k_networkInterfaceRemoved (this=0xdb2c80, uni=...) at /usr/src/debug/networkmanagement/solidcontrolfuture/libs/solid/control/networkmanager.cpp:229
#18 0x00007fd3f1235859 in Solid::Control::NetworkManagerNm09Private::qt_metacall (this=0xdb2c80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff859ced50) at /usr/src/debug/networkmanagement/build/solidcontrolfuture/libs/solid/control/networkmanager_p.moc:82
#19 0x00007fd40aae759a in QMetaObject::activate (sender=0xdf25d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff859ced50) at kernel/qobject.cpp:3287
#20 0x00007fd3f04299b5 in Solid::Control::Ifaces::NetworkManagerNm09::networkInterfaceRemoved (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/networkmanagement/build/solidcontrolfuture/libs/solid/control/ifaces/networkmanager.moc:133
#21 0x00007fd3f0644cb9 in NMNetworkManagerNm09::deviceRemoved (this=0xdf25d0, objpath=...) at /usr/src/debug/networkmanagement/solidcontrolfuture/solid/networkmanager-0.9/manager.cpp:231
#22 0x00007fd3f0646fd1 in NMNetworkManagerNm09::qt_metacall (this=0xdf25d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff859ceef0) at /usr/src/debug/networkmanagement/build/solidcontrolfuture/solid/networkmanager-0.9/manager.moc:99
#23 0x00007fd40aae759a in QMetaObject::activate (sender=0xdf2f60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff859ceef0) at kernel/qobject.cpp:3287
#24 0x00007fd3f0652275 in OrgFreedesktopNetworkManagerInterface::DeviceRemoved (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/networkmanagement/build/solidcontrolfuture/solid/networkmanager-0.9/nm-managerinterface.moc:215
#25 0x00007fd3f06534bc in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0xdf2f60, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0x7fff859cf530) at /usr/src/debug/networkmanagement/build/solidcontrolfuture/solid/networkmanager-0.9/nm-managerinterface.moc:130
#26 0x00007fd4078909fb in QDBusConnectionPrivate::deliverCall (this=0x82c460, object=0xdf2f60, msg=..., metaTypes=..., slotIdx=7) at qdbusintegrator.cpp:942
#27 0x00007fd407899d5f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#28 0x00007fd40aaeb14a in QObject::event (this=0xdf2f60, e=<optimized out>) at kernel/qobject.cpp:1226
#29 0x00007fd409c86be4 in notify_helper (e=0x200dd90, receiver=0xdf2f60, this=0x6e87b0) at kernel/qapplication.cpp:4481
#30 QApplicationPrivate::notify_helper (this=0x6e87b0, receiver=0xdf2f60, e=0x200dd90) at kernel/qapplication.cpp:4453
#31 0x00007fd409c8ba71 in QApplication::notify (this=0x6dda70, receiver=0xdf2f60, e=0x200dd90) at kernel/qapplication.cpp:4360
#32 0x00007fd40b866e36 in KApplication::notify (this=0x6dda70, receiver=0xdf2f60, event=0x200dd90) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#33 0x00007fd40aad481c in QCoreApplication::notifyInternal (this=0x6dda70, receiver=0xdf2f60, event=0x200dd90) at kernel/qcoreapplication.cpp:787
#34 0x00007fd40aad7bf8 in sendEvent (event=0x200dd90, receiver=0xdf2f60) at kernel/qcoreapplication.h:215
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x615800) at kernel/qcoreapplication.cpp:1428
#36 0x00007fd40aaff0b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#37 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#38 0x00007fd4062e358d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#39 0x00007fd4062e3d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#40 0x00007fd4062e3f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#41 0x00007fd40aaff50f in QEventDispatcherGlib::processEvents (this=0x6cbad0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#42 0x00007fd409d29f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007fd40aad3a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007fd40aad3c1f in QEventLoop::exec (this=0x7fff859cfef0, flags=...) at kernel/qeventloop.cpp:201
#45 0x00007fd40aad7de7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x00007fd3f962e773 in kdemain (argc=1, argv=0x615430) at /usr/src/debug/kde-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#47 0x0000000000408897 in _start ()

Possible duplicates by query: bug 287357, bug 286511, bug 284284, bug 284007.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-12-03 13:59:44 UTC

*** This bug has been marked as a duplicate of bug 283204 ***
Comment 2 Lamarque V. Souza 2011-12-04 22:22:43 UTC

*** This bug has been marked as a duplicate of bug 283241 ***