Bug 284284 - Plasma desktop crashed when lan card activated
Summary: Plasma desktop crashed when lan card activated
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-17 16:49 UTC by monts
Modified: 2011-10-17 18:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description monts 2011-10-17 16:49:37 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 2.6.40.6-0.fc15.x86_64 x86_64
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:

Plasma desktop crashes when the lan card em0 is activated or disabled and re activated in a active plasma desktop session. The lan card em0 is connected to a adsl2 router via a Ethernet cable. If the router is powered off or power cycled in a active Plasma desktop session, most of the time the desktop workspace crashes before the lan interface em0 is bought back.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f1a3f2b7522 in init (wobj=0x19a7978, this=0x1bbb500) at /usr/src/debug/networkmanagement-0.8.80/applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x1bcad20, remote=0x19a7960) at /usr/src/debug/networkmanagement-0.8.80/applet/wirelessstatus.cpp:116
#8  0x00007f1a3f2b6b9c in WirelessNetworkItem::WirelessNetworkItem (this=0x1bd0450, remote=0x19a7960, parent=<optimized out>) at /usr/src/debug/networkmanagement-0.8.80/applet/wirelessnetworkitem.cpp:55
#9  0x00007f1a3f2a8bf5 in ActivatableListWidget::createItem (this=0x14dc200, activatable=0x19a7960, index=0) at /usr/src/debug/networkmanagement-0.8.80/applet/activatablelistwidget.cpp:181
#10 0x00007f1a3f2a8e5e in ActivatableListWidget::activatableAdded (this=0x14dc200, added=0x19a7960, index=0) at /usr/src/debug/networkmanagement-0.8.80/applet/activatablelistwidget.cpp:271
#11 0x00007f1a3f29bde3 in ActivatableListWidget::qt_metacall (this=0x14dc200, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8f89b040) at /usr/src/debug/networkmanagement-0.8.80/x86_64-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:104
#12 0x000000382836cfea in QMetaObject::activate (sender=0x13640e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8f89b040) at kernel/qobject.cpp:3278
#13 0x0000003927a092ed in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x19a7960, _t2=0) at /usr/src/debug/networkmanagement-0.8.80/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:104
#14 0x0000003927a0ec93 in RemoteActivatableList::handleActivatableAdded (this=0x13640e0, addedPath=<optimized out>, type=<optimized out>, index=0) at /usr/src/debug/networkmanagement-0.8.80/libs/client/remoteactivatablelist.cpp:180
#15 0x0000003927a0943c in RemoteActivatableList::qt_metacall (this=0x13640e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8f89b230) at /usr/src/debug/networkmanagement-0.8.80/x86_64-redhat-linux-gnu/libs/client/moc_remoteactivatablelist.cpp:90
#16 0x000000382836cfea in QMetaObject::activate (sender=0x1429560, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8f89b230) at kernel/qobject.cpp:3278
#17 0x0000003927a10b21 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=3, _t3=0) at /usr/src/debug/networkmanagement-0.8.80/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:105
#18 0x0000003927a10ecb in NetworkManagementInterface::qt_metacall (this=0x1429560, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff8f89b4c0) at /usr/src/debug/networkmanagement-0.8.80/x86_64-redhat-linux-gnu/libs/client/networkmanagementinterface.moc:85
#19 0x0000003828c2073b in QDBusConnectionPrivate::deliverCall (this=0x6621d0, object=0x1429560, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#20 0x0000003828c29c2f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x0000003828370baa in QObject::event (this=0x1429560, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x000000300b1b9324 in notify_helper (e=0x1bca6a0, receiver=0x1429560, this=0x67ee30) at kernel/qapplication.cpp:4481
#23 QApplicationPrivate::notify_helper (this=0x67ee30, receiver=0x1429560, e=0x1bca6a0) at kernel/qapplication.cpp:4453
#24 0x000000300b1be1b1 in QApplication::notify (this=0x666150, receiver=0x1429560, e=0x1bca6a0) at kernel/qapplication.cpp:4360
#25 0x0000003c3f44c546 in KApplication::notify (this=0x666150, receiver=0x1429560, event=0x1bca6a0) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#26 0x000000382835a20c in QCoreApplication::notifyInternal (this=0x666150, receiver=0x1429560, event=0x1bca6a0) at kernel/qcoreapplication.cpp:787
#27 0x000000382835d7d4 in sendEvent (event=0x1bca6a0, receiver=0x1429560) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x614590) at kernel/qcoreapplication.cpp:1428
#29 0x0000003828384973 in sendPostedEvents () at kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=0x67dca0) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00000030038427ed in g_main_dispatch (context=0x67cce0) at gmain.c:2441
#32 g_main_context_dispatch (context=0x67cce0) at gmain.c:3014
#33 0x0000003003842fc8 in g_main_context_iterate (context=0x67cce0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
#34 0x000000300384325c in g_main_context_iteration (context=0x67cce0, may_block=1) at gmain.c:3155
#35 0x0000003828384dcf in QEventDispatcherGlib::processEvents (this=0x615c80, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#36 0x000000300b25c12e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#37 0x0000003828359722 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#38 0x000000382835991f in QEventLoop::exec (this=0x7fff8f89be80, flags=...) at kernel/qeventloop.cpp:201
#39 0x000000382835da67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#40 0x0000003c46a41193 in kdemain (argc=1, argv=0x7fff8f89c268) at /usr/src/debug/kdebase-workspace-4.7.2/kdebase-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#41 0x000000300042139d in __libc_start_main () from /lib64/libc.so.6
#42 0x00000000004008a1 in _start ()

Possible duplicates by query: bug 284007.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-10-17 18:50:05 UTC

*** This bug has been marked as a duplicate of bug 283241 ***