Bug 290031 - Kde crash after login
Summary: Kde crash after login
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-28 17:46 UTC by Graziano
Modified: 2011-12-28 17:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graziano 2011-12-28 17:46:24 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-37-generic i686
Distribution: Ubuntu 10.04.3 LTS

-- Information about the crash:
After logging in i have seen the crash reporting assistant opening

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b9aa0 (LWP 1460))]

Thread 2 (Thread 0xa9db9b70 (LWP 1462)):
#0  0x00bd4e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x0659c6fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x065a1825 in QTimerInfoList::updateCurrentTime (this=0x95cd4e4) at kernel/qeventdispatcher_unix.cpp:340
#3  0x065a186a in QTimerInfoList::timerWait (this=0x95cd4e4, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x0659f818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa9db90cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0x0659f8a5 in timerSourcePrepare (source=0x0, timeout=0xbd8ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x06a3daca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x06a3dee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x06a3e4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x0659f60f in QEventDispatcherGlib::processEvents (this=0x95dbe78, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x06572059 in QEventLoop::processEvents (this=0xa9db9290, flags=) at kernel/qeventloop.cpp:149
#11 0x065724aa in QEventLoop::exec (this=0xa9db9290, flags=...) at kernel/qeventloop.cpp:201
#12 0x0646e5a8 in QThread::exec (this=0x95dc968) at thread/qthread.cpp:487
#13 0x06551c1b in QInotifyFileSystemWatcherEngine::run (this=0x95dc968) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x0647132e in QThreadPrivate::start (arg=0x95dc968) at thread/qthread_unix.cpp:248
#15 0x00a4296e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x00b23a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77b9aa0 (LWP 1460)):
[KCrash Handler]
#6  0x045902b7 in WirelessStatusPrivate::init (this=0x99a3f48, remote=0x9c56868) at ../../applet/wirelessstatus.cpp:62
#7  WirelessStatus (this=0x99a3f48, remote=0x9c56868) at ../../applet/wirelessstatus.cpp:112
#8  0x0458ef38 in WirelessNetworkItem (this=0x9c5c4e0, remote=0x9c56868, parent=0x96d7508) at ../../applet/wirelessnetworkitem.cpp:54
#9  0x0458786b in ActivatableListWidget::createItem (this=0x96c4b10, activatable=0x9c56868) at ../../applet/activatablelistwidget.cpp:164
#10 0x0457e2cf in ActivatableListWidget::qt_metacall (this=0x96c4b10, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbf901d88) at moc_activatablelistwidget.cpp:91
#11 0x06578c9a in QMetaObject::metacall (object=0x96c4b10, cl=12243904, idx=27, argv=0xbf901d88) at kernel/qmetaobject.cpp:237
#12 0x065873d5 in QMetaObject::activate (sender=0x9274a10, m=0x2090850, local_signal_index=0, argv=0xbf901d88) at kernel/qobject.cpp:3293
#13 0x02081083 in RemoteActivatableList::activatableAdded (this=0x9274a10, _t1=0x9c56868) at moc_remoteactivatablelist.cpp:104
#14 0x020881ae in RemoteActivatableList::handleActivatableAdded (this=0x9274a10, addedPath=..., type=0) at ../../../libs/client/remoteactivatablelist.cpp:134
#15 0x02088e0b in RemoteActivatableList::init (this=0x9274a10) at ../../../libs/client/remoteactivatablelist.cpp:73
#16 0x020890f9 in RemoteActivatableList::serviceOwnerChanged (this=0x9274a10, changedService=..., oldOwner=..., newOwner=...) at ../../../libs/client/remoteactivatablelist.cpp:164
#17 0x02081c3b in RemoteActivatableList::qt_metacall (this=0x9274a10, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbf902130) at moc_remoteactivatablelist.cpp:92
#18 0x06578c9a in QMetaObject::metacall (object=0x9274a10, cl=12243904, idx=10, argv=0xbf902130) at kernel/qmetaobject.cpp:237
#19 0x065873d5 in QMetaObject::activate (sender=0x8f17910, m=0x520c88, local_signal_index=2, argv=0xbf902130) at kernel/qobject.cpp:3293
#20 0x00508d9f in QDBusConnectionInterface::serviceOwnerChanged (this=0x8f17910, _t1=..., _t2=..., _t3=...) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:210
#21 0x005090c3 in QDBusConnectionInterface::qt_metacall (this=0x8f17910, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf902300) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:137
#22 0x06578c9a in QMetaObject::metacall (object=0x8f17910, cl=12243904, idx=7, argv=0xbf902300) at kernel/qmetaobject.cpp:237
#23 0x065873d5 in QMetaObject::activate (sender=0x8f17910, m=0x520c88, local_signal_index=6, argv=0xbf902300) at kernel/qobject.cpp:3293
#24 0x00508c4f in QDBusConnectionInterface::NameOwnerChanged (this=0x8f17910, _t1=..., _t2=..., _t3=...) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:238
#25 0x00509153 in QDBusConnectionInterface::qt_metacall (this=0x8f17910, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbf90250c) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:141
#26 0x004c9b34 in QDBusConnectionPrivate::deliverCall (this=0x8f12930, object=0x8f17910, msg=..., metaTypes=..., slotIdx=11) at qdbusintegrator.cpp:904
#27 0x004d4ea7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9c45820, object=0x8f17910) at qdbusintegrator_p.h:101
#28 0x065843fe in QObject::event (this=0x8f17910, e=0x9c45820) at kernel/qobject.cpp:1248
#29 0x0121b4dc in QApplicationPrivate::notify_helper (this=0x8f18308, receiver=0x8f17910, e=0x9c45820) at kernel/qapplication.cpp:4300
#30 0x0122205e in QApplication::notify (this=0x8f122a8, receiver=0x8f17910, e=0x9c45820) at kernel/qapplication.cpp:3704
#31 0x00eab40a in KApplication::notify (this=0x8f122a8, receiver=0x8f17910, event=0x9c45820) at ../../kdeui/kernel/kapplication.cpp:302
#32 0x06573a3b in QCoreApplication::notifyInternal (this=0x8f122a8, receiver=0x8f17910, event=0x9c45820) at kernel/qcoreapplication.cpp:704
#33 0x06576473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8ec5fc8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8ec5fc8) at kernel/qcoreapplication.cpp:1345
#35 0x065765dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#36 0x0659fadf in QCoreApplication::sendPostedEvents (s=0x8f1a310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#37 postEventSourceDispatch (s=0x8f1a310) at kernel/qeventdispatcher_glib.cpp:276
#38 0x06a3a5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#39 0x06a3e2d8 in ?? () from /lib/libglib-2.0.so.0
#40 0x06a3e4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#41 0x0659f5d5 in QEventDispatcherGlib::processEvents (this=0x8f181b0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#42 0x012db135 in QGuiEventDispatcherGlib::processEvents (this=0x8f181b0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x06572059 in QEventLoop::processEvents (this=0xbf902d34, flags=) at kernel/qeventloop.cpp:149
#44 0x065724aa in QEventLoop::exec (this=0xbf902d34, flags=...) at kernel/qeventloop.cpp:201
#45 0x0657669f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#46 0x0121b577 in QApplication::exec () at kernel/qapplication.cpp:3579
#47 0x01b9605e in kdemain (argc=1, argv=0x8f06930) at ../../../../plasma/desktop/shell/main.cpp:112
#48 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x8ee89f0 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#49 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#50 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#51 0x0804fe4f in main (argc=4, argv=0xbf9037e4, envp=0xbf9037f8) at ../../kinit/kinit.cpp:1845

Possible duplicates by query: bug 287357.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2011-12-28 17:53:16 UTC

*** This bug has been marked as a duplicate of bug 283241 ***