Bug 292884 - KDE Crash when ethernet cable connected
Summary: KDE Crash when ethernet cable connected
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Chakra Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-30 17:26 UTC by Eduardo
Modified: 2012-01-30 17:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo 2012-01-30 17:26:53 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.1-CHAKRA i686
Distribution: "Chakra Linux"

-- Information about the crash:
- What I was doing when the application crashed:
Wired connection suddenly enabled after a while working with wireless, then KDE crash apps still working
- Unusual behavior I noticed:

- Custom settings of the application:

The crash can be reproduced every time.

-- Backtrace:
Application: Shell de escritorio Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb569d930 (LWP 1693))]

Thread 2 (Thread 0xaaa7fb70 (LWP 1701)):
#0  0xb5ac7d00 in clock_gettime () from /lib/librt.so.1
#1  0xb6c66b35 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6d392d6 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6d3962a in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6d37e73 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb6d37f0d in ?? () from /usr/lib/libQtCore.so.4
#6  0xb5a2ea3e in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb5a2f8f3 in ?? () from /usr/lib/libglib-2.0.so.0
#8  0xb5a2ffc4 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb6d38957 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6d0973d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6d09981 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0xb6c0d2cb in QThread::exec() () from /usr/lib/libQtCore.so.4
#13 0xb6cea39d in ?? () from /usr/lib/libQtCore.so.4
#14 0xb6c10123 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb6b99cf7 in start_thread () from /lib/libpthread.so.0
#16 0xb5f9586e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb569d930 (LWP 1693)):
[KCrash Handler]
#7  0xaa270261 in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#8  0xaa26e7eb in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#9  0xaa25f6a2 in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#10 0xaa25f94c in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#11 0xaa2513f6 in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#12 0xb6d10acd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#13 0xb6d1f8aa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#14 0xa9f17e1d in RemoteActivatableList::activatableAdded(RemoteActivatable*, int) () from /usr/lib/libknmclient.so.4
#15 0xa9f1e895 in RemoteActivatableList::handleActivatableAdded(QString const&, unsigned int, int) () from /usr/lib/libknmclient.so.4
#16 0xa9f17fe5 in RemoteActivatableList::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmclient.so.4
#17 0xb6d10acd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#18 0xb6d1f8aa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#19 0xa9f20a85 in ?? () from /usr/lib/libknmclient.so.4
#20 0xa9f20de5 in ?? () from /usr/lib/libknmclient.so.4
#21 0xb5ba80d5 in ?? () from /usr/lib/libQtDBus.so.4
#22 0xb5bb2286 in ?? () from /usr/lib/libQtDBus.so.4
#23 0xb6d22992 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#24 0xb625e764 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#25 0xb6263b13 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb74600b1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#27 0xb6d0a6fe in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#28 0xb6d0dee3 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#29 0xb6d0e03c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#30 0xb6d384c4 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb5a2f532 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb5a2fd10 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb5a2ffc4 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb6d388fa in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0xb6311a7a in ?? () from /usr/lib/libQtGui.so.4
#36 0xb6d0973d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0xb6d09981 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#38 0xb6d0e0ed in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#39 0xb625c5d4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#40 0xb16b259b in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#41 0x0804f90a in _start ()

This bug may be a duplicate of or related to bug 283241.

Possible duplicates by query: bug 291084, bug 291005, bug 290031, bug 287357, bug 286511.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-30 17:36:49 UTC

*** This bug has been marked as a duplicate of bug 283241 ***