Bug 291084 - Plasma crash when wifi or ethernet connection go down unexpectedly
Summary: Plasma crash when wifi or ethernet connection go down unexpectedly
Status: RESOLVED DUPLICATE of bug 283241
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-09 21:22 UTC by danlo8600
Modified: 2012-03-16 17:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.83 KB, text/plain)
2012-03-16 17:34 UTC, Brian Homeyer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description danlo8600 2012-01-09 21:22:32 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.97 (4.8 RC2 (4.7.97)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
If i turn off my accesspoint during wifi or ethernet connection plasma crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Shell del desktop di Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9e6195d7a0 (LWP 1863))]

Thread 8 (Thread 0x7f9e3d796700 (LWP 1880)):
#0  0x00007f9e55581694 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f9e55582d81 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e55583429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e5e45cf3e in QEventDispatcherGlib::processEvents (this=0x222b280, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9e5e430cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e5e430ef7 in QEventLoop::exec (this=0x7f9e3d795db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9e5e34827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9e5e413cbf in QInotifyFileSystemWatcherEngine::run (this=0x222c470) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9e5e34ad05 in QThreadPrivate::start (arg=0x222c470) at thread/qthread_unix.cpp:331
#9  0x00007f9e5608fefc in start_thread (arg=0x7f9e3d796700) at pthread_create.c:304
#10 0x00007f9e6124a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f9e3af61700 (LWP 1885)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f9e3af60ad0 in ?? ()
#2  0x00007fffc7dff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0x7f9e33d1c700 (LWP 1908)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9e5b461fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f9e5b462019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f9e5608fefc in start_thread (arg=0x7f9e33d1c700) at pthread_create.c:304
#4  0x00007f9e6124a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f9e2bee9700 (LWP 4520)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9e5e34b1ab in wait (time=18446744073709551615, this=0x22a44d0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2282d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9e5a145864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e7660, th=0x4a66f00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9e5a147e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x224cf70, th=0x4a66f00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9e5a146ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f9e2bee8e00, parent=0x22e7660, th=0x4a66f00) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9e5a146d5b in ThreadWeaver::Thread::run (this=0x4a66f00) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9e5e34ad05 in QThreadPrivate::start (arg=0x4a66f00) at thread/qthread_unix.cpp:331
#8  0x00007f9e5608fefc in start_thread (arg=0x7f9e2bee9700) at pthread_create.c:304
#9  0x00007f9e6124a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f9e2b6e8700 (LWP 4521)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9e5e34b1ab in wait (time=18446744073709551615, this=0x22a44d0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2282d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9e5a145864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e7660, th=0x7f9e3403c410) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9e5a147e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x224cf70, th=0x7f9e3403c410) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9e5a147e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x224cf70, th=0x7f9e3403c410) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f9e5a147e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x224cf70, th=0x7f9e3403c410) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f9e5a147e24 in ThreadWeaver::WorkingHardState::applyForWork (this=0x224cf70, th=0x7f9e3403c410) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f9e5a146ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f9e2b6e7e00, parent=0x22e7660, th=0x7f9e3403c410) at ../../../threadweaver/Weaver/Thread.cpp:87
#9  0x00007f9e5a146d5b in ThreadWeaver::Thread::run (this=0x7f9e3403c410) at ../../../threadweaver/Weaver/Thread.cpp:142
#10 0x00007f9e5e34ad05 in QThreadPrivate::start (arg=0x7f9e3403c410) at thread/qthread_unix.cpp:331
#11 0x00007f9e5608fefc in start_thread (arg=0x7f9e2b6e8700) at pthread_create.c:304
#12 0x00007f9e6124a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9e2450c700 (LWP 4522)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9e5e34b1ab in wait (time=18446744073709551615, this=0x22a44d0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2282d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9e5a145864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e7660, th=0x543f2c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9e5a147e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x224cf70, th=0x543f2c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9e5a146ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f9e2450be00, parent=0x22e7660, th=0x543f2c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9e5a146d5b in ThreadWeaver::Thread::run (this=0x543f2c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9e5e34ad05 in QThreadPrivate::start (arg=0x543f2c0) at thread/qthread_unix.cpp:331
#8  0x00007f9e5608fefc in start_thread (arg=0x7f9e2450c700) at pthread_create.c:304
#9  0x00007f9e6124a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9e27cb6700 (LWP 4523)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9e5e34b1ab in wait (time=18446744073709551615, this=0x22a44d0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2282d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9e5a145864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x22e7660, th=0x6093820) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9e5a147e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x224cf70, th=0x6093820) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9e5a146ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f9e27cb5e00, parent=0x22e7660, th=0x6093820) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9e5a146d5b in ThreadWeaver::Thread::run (this=0x6093820) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9e5e34ad05 in QThreadPrivate::start (arg=0x6093820) at thread/qthread_unix.cpp:331
#8  0x00007f9e5608fefc in start_thread (arg=0x7f9e27cb6700) at pthread_create.c:304
#9  0x00007f9e6124a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9e6195d7a0 (LWP 1863)):
[KCrash Handler]
#6  0x00007f9e3a5508a2 in init (wobj=0x4f5f9e8, this=0x5207c50) at ../../applet/wirelessstatus.cpp:65
#7  WirelessStatus::WirelessStatus (this=0x20776d0, remote=0x4f5f9d0) at ../../applet/wirelessstatus.cpp:116
#8  0x00007f9e3a54f414 in WirelessNetworkItem::WirelessNetworkItem (this=0x4d12e60, remote=0x4f5f9d0, parent=<optimized out>) at ../../applet/wirelessnetworkitem.cpp:54
#9  0x00007f9e3a541ec5 in ActivatableListWidget::createItem (this=0x26d9e40, activatable=0x4f5f9d0, index=1) at ../../applet/activatablelistwidget.cpp:181
#10 0x00007f9e3a54210e in ActivatableListWidget::activatableAdded (this=0x26d9e40, added=0x4f5f9d0, index=1) at ../../applet/activatablelistwidget.cpp:269
#11 0x00007f9e3a535253 in ActivatableListWidget::qt_metacall (this=0x26d9e40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc7d75cc0) at moc_activatablelistwidget.cpp:104
#12 0x00007f9e5e444eba in QMetaObject::activate (sender=0x21f4850, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc7d75cc0) at kernel/qobject.cpp:3278
#13 0x00007f9e3a307a2d in RemoteActivatableList::activatableAdded (this=<optimized out>, _t1=0x4f5f9d0, _t2=1) at moc_remoteactivatablelist.cpp:104
#14 0x00007f9e3a30d4e3 in RemoteActivatableList::handleActivatableAdded (this=0x21f4850, addedPath=<optimized out>, type=<optimized out>, index=1) at ../../../libs/client/remoteactivatablelist.cpp:180
#15 0x00007f9e3a307b7c in RemoteActivatableList::qt_metacall (this=0x21f4850, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc7d75eb0) at moc_remoteactivatablelist.cpp:90
#16 0x00007f9e5e444eba in QMetaObject::activate (sender=0x21f3570, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc7d75eb0) at kernel/qobject.cpp:3278
#17 0x00007f9e3a30f2d1 in NetworkManagementInterface::ActivatableAdded (this=<optimized out>, _t1=<optimized out>, _t2=3, _t3=1) at networkmanagementinterface.moc:105
#18 0x00007f9e3a30f67b in NetworkManagementInterface::qt_metacall (this=0x21f3570, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffc7d76120) at networkmanagementinterface.moc:85
#19 0x00007f9e5e7890e9 in QDBusConnectionPrivate::deliverCall (this=0xcf1870, object=0x21f3570, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#20 0x00007f9e5e79238f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007f9e5e448a5e in QObject::event (this=0x21f3570, e=<optimized out>) at kernel/qobject.cpp:1217
#22 0x00007f9e5d7e2424 in notify_helper (e=0x28252e0, receiver=0x21f3570, this=0xd0f970) at kernel/qapplication.cpp:4486
#23 QApplicationPrivate::notify_helper (this=0xd0f970, receiver=0x21f3570, e=0x28252e0) at kernel/qapplication.cpp:4458
#24 0x00007f9e5d7e7291 in QApplication::notify (this=0xcee0c0, receiver=0x21f3570, e=0x28252e0) at kernel/qapplication.cpp:4365
#25 0x00007f9e5f0e0ae6 in KApplication::notify (this=0xcee0c0, receiver=0x21f3570, event=0x28252e0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f9e5e431afc in QCoreApplication::notifyInternal (this=0xcee0c0, receiver=0x21f3570, event=0x28252e0) at kernel/qcoreapplication.cpp:787
#27 0x00007f9e5e43551f in sendEvent (event=0x28252e0, receiver=0x21f3570) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc93430) at kernel/qcoreapplication.cpp:1428
#29 0x00007f9e5e45ca73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f9e55582a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f9e55583258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f9e55583429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f9e5e45ced6 in QEventDispatcherGlib::processEvents (this=0xc94f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007f9e5d88a07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f9e5e430cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f9e5e430ef7 in QEventLoop::exec (this=0x7fffc7d76940, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007f9e5e435789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#39 0x00007f9e615497e3 in kdemain (argc=1, argv=0x7fffc7d76d28) at ../../../../plasma/desktop/shell/main.cpp:120
#40 0x00007f9e6118a30d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fffc7d76d28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc7d76d18) at libc-start.c:226
#41 0x0000000000400671 in _start ()

Possible duplicates by query: bug 291005, bug 287357, bug 286511, bug 284284, bug 284007.

Reported using DrKonqi
Comment 1 Thijs 2012-01-09 22:02:46 UTC

*** This bug has been marked as a duplicate of bug 283241 ***
Comment 2 Brian Homeyer 2012-03-16 17:34:07 UTC
Created attachment 69676 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.8.1 (4.8.1) using Qt 4.8.0

- What I was doing when the application crashed:
I was doing nothing, but the network interface went down, and plasma crashed.  Duplicatable by disabling networking also.

-- Backtrace (Reduced):
#7  0xa8c22b6b in init (wobj=0xa56dee4, this=0xa539d38) at ../../applet/wirelessstatus.cpp:65
#8  WirelessStatus::WirelessStatus (this=0xa8cbcf0, remote=0xa56ded8) at ../../applet/wirelessstatus.cpp:116
#9  0xa8c2122b in WirelessNetworkItem::WirelessNetworkItem (this=0xb6268e8, remote=0xa56ded8, parent=0xa90fe50) at ../../applet/wirelessnetworkitem.cpp:54
#10 0xa8c121d2 in ActivatableListWidget::createItem (this=0xa90b4e8, activatable=0xa56ded8, index=0) at ../../applet/activatablelistwidget.cpp:181
#11 0xa8c1247c in ActivatableListWidget::activatableAdded (this=0xa90b4e8, added=0xa56ded8, index=0) at ../../applet/activatablelistwidget.cpp:269