Bug 93439 - a finder bar like Firefox's in kdelibs
Summary: a finder bar like Firefox's in kdelibs
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: 3.3.1
Platform: unspecified Linux
: NOR wishlist with 1596 votes (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
: 105565 111543 112053 122314 141046 147453 156377 161335 161994 170251 176878 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-17 11:50 UTC by Giovanni Venturi
Modified: 2009-02-10 12:00 UTC (History)
21 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Venturi 2004-11-17 11:50:02 UTC
Version:           3.3.1 (using KDE 3.3.1 (CVS >= 20041110), compiled sources)
Compiler:          gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)
OS:                Linux (i686) release 2.6.8-1.521

I'd like to have a bar in konqueror to look for words in HTML pages as in FireFox 1.0.
The idea is this. As in KMail a button can show/hide the details about POP downloading we need a button in Konqueor to show/hide the finder words bar (that can appear on the bottom of Konqueror). Into this bar I type a word and while I do this Konqueror starts the search for the first instance of that word in the HTML page. The search starts again when I change the word or while I'm typing it adding some character. Some other button on this bar to look for the next instance of this word or the previous one. Some check button to enable/disable the uppercase/nouppercase.
Comment 1 Maksim Orlovich 2004-11-17 15:28:19 UTC
It does have one. The google bar lets you search in the page, or you can use / for incremental search
Comment 2 Giovanni Venturi 2004-11-17 15:36:17 UTC
That bar for me look for a word with google and not in the current html page I've got in Konqueror.
Comment 3 Maksim Orlovich 2004-11-17 15:44:13 UTC
right-click on the google icon and chose "find in the current page" instead.
Comment 4 Giovanni Venturi 2004-11-17 17:18:24 UTC
On Wednesday 17 November 2004 15:44, Maksim Orlovich wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>
> http://bugs.kde.org/show_bug.cgi?id=93439
> maksim kde org changed:
>
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
>- Status|REOPENED                    |RESOLVED
>          Resolution|                            |WORKSFORME
>
>
>
> ------- Additional Comments From maksim kde org  2004-11-17 15:44 -------
> right-click on the google icon and chose "find in the current page"
> instead.
No, it's not what I suggested in this whishlist. It's a not correct way of 
reply me and close so this request. It's not usable and then doing like you 
told me I found just the first occurrence. Then this way of using that bar is 
not intuitive at all. Where can I found how to use Google bar? No tooltip 
that explain all these functions. No way of look for more instance of the 
same word into the page. No function I suggested. I don't think you can close 
this whishlist so. Close it as: "wontfix": I don't like Firefox and that 
function you proposed it's a waste of time. I know that I can use "CTRL+F" to 
look for text into the page, but I think a search bar that look for a word 
while you are typing doesn't exists. Have you haver used FireFox 1.0? If not, 
try it, try it.

Comment 5 Maksim Orlovich 2004-11-17 17:20:24 UTC
Fair enough, I'll reopen it, but don't consider it likely to be implemented. We already have 3 separate ways of searching
Comment 6 Sven Langkamp 2004-11-23 01:03:07 UTC
This is related to 33795.

Such a toolbar could combine all three ways of search:
-it's a lighter version of ctrl+f
-it stays in place like the google bar and is not above the page
-you can type like in the incremental search just without the /
Comment 7 Tom 2005-01-17 16:12:39 UTC
This toolbar would be a nice feature for the next KDE 3.4 (the beta version 3.3.91 provides a lot of eye-candy - as far as I've seen)
A "search while typing" feature with a nice little bar (for find next and so on) could also be uses when Konqueror is in File Manager Mode, e.g. for quick searching a file or - when using ? and * - for selecting files.
As also akregator uses Konqueror, the status line "Starting: Search while you type" is not really useful - I never know whether I'm allowed to type or not, because there is no textbox.
I thing "search while typing" is a key-feature which should be implemented in Konqueror, just like the way it is in FireFox (and with an option to disable it).

Oh, by the way, great work you did on the KDE 3.3.91 so far, I'm really impressed. Thanks for this most confortable progie !

Comment 8 Bruno 2005-02-15 10:26:43 UTC
It would be a great usability toolbar : when you search you don't need to type on a search to get a "search not found", you have directly the field which gets red... 
I vote for it
Comment 9 Tom 2005-02-20 17:19:30 UTC
So far there are (where) four main reasons why I use Firefox instead of Konqueror:

First: Complete selections of Webpages can be used in OpenOffice vie Copy and Past (Konqueror can do this too now)
Second: Firefox has a Plugin interface for Adblockers (Konqueror too,but no Adblocker afaik)
Third: FF has the absolutely fabulous killer feature 'search when typing', which works indeed great with its toolbar. But I like it to see that Konqueror/Akregator/Kde help center etc. also have the /-type feature.
Forth: Kicking with the mouse wheel activates that nice and little scrollcontrol icon, which is also fabulous (don't know whether it is planned to implement something similar or not)

Comment 10 Jimmy Kloss 2005-03-24 18:46:21 UTC
The search while type feature is really a great one. I would love to see this in konqueror. 
Anyway I would prefer to such a bar on top, under the Location bar. For use in filemanager mode it it should filter the files containing the typed in string instead of marking them in some color, just like it is done JuK and amaroK.

So go for usability and consistence as you always do ;-)
KDE has really reached a great level of quality, so do not stop improving it.
Comment 11 Thiago Macieira 2005-03-24 23:14:00 UTC
> The search while type feature is really a great one. I would love to see
> this in konqueror. 

It's already there. It has been for some time. Just press / to search text or ' to search for links.

There's no toolbar. To search for the next occurrence, hit F3.
Comment 12 Jimmy Kloss 2005-03-24 23:43:39 UTC
> It's already there. It has been for some time. Just press / to search text or ' to search for links. 
> There's no toolbar. To search for the next occurrence, hit F3.

Just tested it and it works great so far, but on a german keyboard I have to press shift+7 to get a / that's not really comfortable to use. For the filter feature in filemanager mode is a bar needed anyway.

Take a look here:
http://www.kde-look.org/content/show.php?content=21729

Like this it would be so much more intuitive. At least from point of view.
Comment 13 Tom 2005-03-25 12:58:14 UTC
Don't know where to place it, but here is a general idea:

A system wide search-while-typing search bar that opens itself in all (read only) textboxes, html (help and info systems) and fileviews (or whereever one needs this functionality). It could be dockable (stays in with the other bars like google-bar), just placeable (like firefox has it) or just hovering somewhere in the window, where search-while-typing is performed. 

This is of course only a suggestion for the already implemented function. I just wanted to post it here, before M$ claims that they have invented something similar and have a patent on it ;)
Comment 14 Jimmy Kloss 2005-03-25 14:48:13 UTC
Sounds quite good! Can I expect to see this in the next release?
Comment 15 Tommi Tervo 2005-09-05 10:36:29 UTC
*** Bug 105565 has been marked as a duplicate of this bug. ***
Comment 16 Tommi Tervo 2005-09-05 10:36:41 UTC
*** Bug 112053 has been marked as a duplicate of this bug. ***
Comment 17 Roland Wolters 2005-09-05 11:44:10 UTC
I want to add my point of view:

We need a firefox like bar because of four reasons:

1) usability: it is much more easy to use and intuitive (no normal user besides the power users and developers would ever use the google search field or the / !)
2) see the page: you can still see the page where you are searching, not like the actual solution 
3) marking: you can mark all found words: that is a must for people who uses konqueror for real investigation 
4) similarity: we have this search bar now (KDE 3.5 svn) in several other applications like konversation and kviewshell - all other apps have at least some kind of bar with a text input field, only konqueror has stil the old technic. 
 
I know that you can use / for incremental search, but I am not for a new, fourth way of searching but for replacing an old one through a better one (strg+f).
Comment 18 Damir Perisa 2005-10-15 03:59:32 UTC
reading this bug, i want to add/suggest a first step for usability in this direction ... hope you don't mind having yet another comment in this bug report ;-)

the ctrl-f (find in local copy of data) feature is working for me fine ... however if you select some text in an text file or web page and press the left mouse button you have this 3 options:

- copy text
- select all
- search 'the selected text' with Google

this list is missing the "search locally" option in my eyes. the workaround is to press ctrl-f and copy-paste the selected part (middle mouse button) and search this way... this one additional action by user can be avoided by adding the option to the left-mouse-menu-on-selected-text
Comment 19 Damir Perisa 2005-10-15 04:06:52 UTC
just my 2 cents on the "search bar" or whatever you want to call it:

i think it's a good idea, if you can find space to place it... or best would be to leave it to be customisable placed ;-)

one important thing i think we need to keep is the advanced features from the ctrl-f searching: all features from there should be still supported from the search bar. the implementation can be this way so that we can keep it simple to the less experienced user (and the firefox fans ;-) but offer a small ">>" button, that would open a small box to select the options you want to select. (especially enabling regexps) ... an alternative would be to use some indicator that the expression you are searching is a regular expression... however, the "/^foo/" indicators are not very helpful, because the web is full of strings with "/" in them... maybe "rx: ^foo" instead?

anyway: summary: only wanted to express the need not to kill features by making it simpler to use. 
Comment 20 Mohd Asif Ali Rizwaan 2005-10-17 02:30:07 UTC
I wish you support this "Search Bar" like firefox or konversation's ctrl+f, for these reasons:

1. Text/view is not blocked with the search (toolbar) whereas the popup dialog blocks the view (text gets hidden beside the popup dialog, then can't read something important there)

2. Multiple instances can be highlighted, whereas popup dialog only show 1 instance of the text it finds (then click next to find one more)

3. Can be used in file manager/web browser for multiple occurrence of a text/substring, much like "ctrl + '+'" as in filemanager, but no option to find/highlight multiple instance of a text/substring in web browser.

please consider searchbar (search toolbar) for ease-of-use and better visibility of information. thanks.
Comment 21 Thiago Macieira 2005-10-17 03:31:58 UTC
Item 1 from comment #20 is already implemented, without the bar.
Comment 22 Roland Wolters 2005-10-22 18:06:05 UTC
Item 1 from comment #20 is implemented by the '/' search possibility.
Technically you are right, but this is not usable for the average computer user. I'm sorry to say this, but it has nothing to do with usability and it is not known to the users until they meet someone who tells them that this exists or until they start to read this bug.

So you cannot really point out that it is implemented in a "realistic" way.
Comment 23 Chani 2005-11-03 01:53:32 UTC
this /-search thing sounds interesting. I'll have to try it when I go home.
but (as comment #22 points out) it has one fatal flaw: I had no clue it existed until I stumbled upon this wish :) and I bet 99% of konq users don't know about it either.
I want the firefox-like search bar too.
Comment 24 Jörg Hermsdorf 2006-02-21 03:47:48 UTC
see also http://bugs.kde.org/show_bug.cgi?id=122314, which requests this feature for all KDE applications

see http://www.kde-look.org/content/show.php?content=35503 for a mockup (screenshots)
Comment 25 Sebastián Benítez 2006-02-22 00:48:07 UTC
I must also agree that this feature should be implemented using a common search bar widget. Integrating this through all KDE applications will make the desktop better.
Comment 26 Thiago Macieira 2006-02-25 21:17:41 UTC
Agreed.
Comment 27 Thiago Macieira 2006-02-25 21:18:13 UTC
*** Bug 122314 has been marked as a duplicate of this bug. ***
Comment 28 Baldrun Orv 2006-02-26 21:46:53 UTC
I really like the way the mockup implements the firefoxlike-search function.  This would definitely be a win for all kde applications.
Comment 29 Technologov 2006-02-27 15:17:47 UTC
Yes, new-search is _needed_ in all KDE application !

Note to the mockup - it should have "highlight all occurences" checkbox.
Comment 30 Jörg Hermsdorf 2006-03-05 21:20:44 UTC
Added "highlight all occurences" checkbox to the mockup ;)
Comment 31 Philipp Sternberg 2006-03-15 17:08:51 UTC
would be nice to have kind of component which can display additional information about the current search. For example, i'm sometimes interested how many occurencies there are for a search in a document. Component could be an icon a the very right in the bar, which would display information when the mouse hovers over it in  form of a tooltip. Alternativly the tooltip could appear for some seconds directly after the search is finshed, etc.
Comment 32 Kusi 2006-03-17 14:30:33 UTC
I think the firefox search bar is close to perfect. If combined with an additional option button which pops up standard kde search dialog (regexp etc), I couldn't think of anything better.

Right now, the kde search dialog...
1) ...is not consistent in stepping through the search result. When searching on a website, you have to press enter to step to the next result, while searching in a text form or kwrite, you have to press F3 to iterate through the results.

2) ...always gets into your way while searching on a website. Although the search result is always visible while stepping through, the context of the searched word is covered by the search dialog. This hinders you from quickly recognizing if the actual search result is the desired one. 

3) ...is only valid for one window/tab. You can't use the same search dialog for two different tabs. When you start a search on tab 1 and switch to tab 2 and then want to use the search dialog again, nothing happens. In fact, you can open 10 search dialog boxes for all kind of windows and you have no clue, which one belongs to which tab. This is really annoying when searching for the same expression on several websites.

In contrast, the Firefox search bar
a) focuses the right widget all the time
b) doesn't get into your way
c) lets you find the result with the least possible amount of clicks
d) lets you search the same expression on different tabs without reentering the text
e) nice coloring (red for not available, yellow box for all search results) 

(comment moved from #122314)
Comment 33 Jaques Arantes 2006-03-17 16:19:51 UTC
This wish seems to be quite old AND still has relevance.
I see resonably spaced comments from 2004-11-17 to 2006-03-17 and, by myself, I'd really love to see such feature implemented, but I could not understand if it is going to or not.

I will vote for it, anyway.


Bug 122314 was marked as duplicated of this one, even being more generic.
I like the idea, too. One step forward the "competition".

Comment 34 Marcel Partap 2006-06-14 16:52:26 UTC
I'd also favor a search bar in kdelips, one which can search in any current kpart [like kpart.search("berlin AND tokyo") or so (sadly i have so no clue about the kde code)]. But findasyoutype should be optional, from bad experience.
And then we also might need a happy filter bar to set the view filters, that'd be great. (ashame i have no coding skills. I'd love to work a bit on kde..)
Comment 35 Dotan Cohen 2006-06-24 22:55:53 UTC
I would also like to see the Firefox search bar implemented in all KDE apps- especially Kate. The search feature is the main reason that I use firefox over konqi.
Comment 36 Gregor Kališnik 2006-07-04 01:22:11 UTC
It would be great if these kind of a find bar would be implemented into KDE apps. It's the feature that I miss the most.
Comment 37 m.wege 2006-08-19 23:38:26 UTC
I also would like to see a firefox-like search function implemented. It is much more usably. I have recently switched using konqueror most of the time. This is one of the most missed functions.
Comment 38 Pascal d'Hermilly 2006-08-20 22:34:32 UTC
Yes, please. I love this functionality.
Comment 39 Pascal d'Hermilly 2006-08-23 02:11:43 UTC
I see there is this sort of search integrated in Konversation (at least in 3.5.4). 

Maybe the konqueror-devs could speak with them about how to implement it.
Comment 40 Karl Marklund 2006-08-25 11:04:24 UTC
I've been thinking of this for quite some time and was vere happy to find others share my desire to finaly get rid of the old up-in-your-face seach. 

Strange that it wasn't until Firefox came around that this (to me) "natural" way of implementing find on page emerged. I tend to use firefox more and more only because of the anoying find in Konqueror. 

And Yes, I would love to have this in all K-apps.

And No, I didn't know about the /-find until I read about it here.

Btw, the current /-find might be usefull but cannot realy compare to the firefox-find.
Comment 41 Arvid Picciani 2006-09-09 15:29:44 UTC
with regex please :)
Comment 42 Tommi Tervo 2006-09-14 12:45:29 UTC
*** Bug 111543 has been marked as a duplicate of this bug. ***
Comment 43 Roland Wolters 2006-10-01 21:56:41 UTC
For you information:
it looks like kate is going to implement such a search as well:
http://impul.se/~kling/blog/?p=10

So at the moment konversation and kate support such a search bar, others, like kmail and konqueror, are still missing.
Comment 44 Jonathan M Davis 2006-11-26 06:13:18 UTC
Personally, I don't think that the firefox method of searching is necessarily desirable as the default. However, I think that the desire for such a feature is high enough, that it would be a good idea to add a setting where you choose to either ctrl-f act as it does now or open a firefox-style search bar.

For me, the / key is plenty for incremental search. As a vim user, it appeals greatly to me. However, as others have pointed out, it's not exactly intuitive. 
Unless you use vim and try it just to see if it works or you read it somewhere online like this bug report, you're unlikely to know about it. It seems to me that it would be a good idea to put a note about the / key next to the aforementioned ctrl-f configuration selection dialog (wherever in the configuration stuff it is). It might be difficult to put a nice concise note about it in the configuration dialog, but it would be nice.

Basically, I think that the current implementation of the search function in Konqueror should be supplemented, not replaced.
Comment 45 Sebastián Benítez 2006-11-26 11:47:33 UTC
What about putting something like "type / to start searching" in the statusbar, once the page is loaded, along with the current "page loaded"?
Comment 46 Roland Wolters 2006-11-26 17:19:35 UTC
I can't believe that the "/" method would pass any non-geek test; I can hardly imagine any user except for the real geeks which is able to handle this kind of search where you have no separated field where you see what you are doing.

But, and that's probably more important: this is not a task for users to discuss here, the usability people have to say what the best and most usable way is to search for something.

Also, one great addition we would get with the Firefox-way is to mark all places in one page where the searched term appears.
Comment 47 aztun 2007-02-03 23:20:54 UTC
please please I need this feature in konqueror to surf the web. its the only reason why sometimes I still use firefox
Comment 48 jos poortvliet 2007-02-04 20:27:26 UTC
how do you 'need' it, as there IS find-as-you-type (use /) and you can use the searchbar as well... i do think it's a neath thing, and it should be in kdelibs as some apps are already using it (kwrite, konversation) but i don't get the 'i need it to surf the web' part...
Comment 49 Dotan Cohen 2007-02-04 23:03:07 UTC
I also 'need' a search bar like Firefox's. Yes, I can live without it, but for research there is nothing like tabbed browsing and that search bar. It's also the feature keeping me on Firefox. I do know about /, but I dislike hidden features.
Comment 50 Roland Wolters 2007-02-05 00:03:58 UTC
Speaking about "need it" - the "highlight" option of firefox is a feature I sometimes need while doing web research.
No need for surfing the web, but indeed a need for doing research. This way of searching (a firefox like bar with highlight and next/previous buttons) would also be useful in all other "text processing" apps in KDE (kword, kmail, kate (highlight!), etc.).
Comment 51 jos poortvliet 2007-02-05 15:18:58 UTC
> ------- Additional Comments From rolandwolters web de  2007-02-05 00:03
> ------- Speaking about "need it" - the "highlight" option of firefox is a
> feature I sometimes need while doing web research. No need for surfing the
> web, but indeed a need for doing research. This way of searching (a firefox
> like bar with highlight and next/previous buttons) would also be useful in
> all other "text processing" apps in KDE (kword, kmail, kate (highlight!),
> etc.).


Well, it's indeed a hidden feature, but Khtml can do this - use the / key and 
type ahead. And of course F3 for next match. I agree it would be great to 
have a ff-like find bar in KDElibs, but I haven't seen anyone lately who 
was/is willing to work on it. Might still come, tough, as the konversation 
dev's (who have one) aren't working on a KDE4 version yet (afaik).
Comment 52 Roland Wolters 2007-02-05 22:50:11 UTC
@jos: Just to be clear: You misunderstood me. I stressed out the highlighting feature of konqueror. It will highlight the term everywhere on the page, just like google search does it when you view a cached version of a page.
And I cannot reproduce that with the way you mentioned.
Comment 53 jos poortvliet 2007-02-05 23:02:35 UTC
> ------- Additional Comments From rolandwolters web de  2007-02-05 22:50
> ------- jos: Just to be clear: You misunderstood me. I stressed out the
> highlighting feature of konqueror. It will highlight the term everywhere on
> the page, just like google search does it when you view a cached version of
> a page. And I cannot reproduce that with the way you mentioned.


aaah, i see. that's indeed probably an usefull feature (well, personally i 
don't like it, but others might...)
Comment 54 Stefan Monov 2007-02-06 01:01:04 UTC
*** Bug 141046 has been marked as a duplicate of this bug. ***
Comment 55 David Lee 2007-02-06 02:07:16 UTC
Another critical need for there to be a search field toolbar with the '/' find-as-you-type feature is that you cannot search for Asian languages without a text field (IMEs are only activated in an actual text field). If I want to search for Asian languages, I always have to use the Ctrl-F search dialog, which is definitely not as convenient as the '/' find-as-you-type.

In the worst case, konqueror should at least have the Search dialog box, or the google-search-turned-into-page-search field "find as you type".

This is a clarification of Bug 141046.
Comment 56 Roland Wolters 2007-03-08 13:44:11 UTC
FYI: Looks like konsole will get a similar search bar as well.
http://kdemonkey.blogspot.com/2007/03/konsole-progress-searching-history.html
Comment 57 Michal Krenek (Mikos) 2007-03-08 15:10:26 UTC
This feature is now implemented separately in Konversation, Kate and Konsole. This is really bad situation - inefficient code duplication. There should really be some general implementation of this search bar in kdelibs, which can be used by all applications (especially it's a pitty that Konqueror and KMail doesn't support it).

Please implement it, it is frequently demanded feature, it is already implemented in some KDE apps and I know people which use Firefox instead of Konqueror only because this bottom search bar is missing.
Comment 58 Egbert van der Wal 2007-05-23 16:30:32 UTC
Just found this, after the lack of this feature has annoyed me for months. I too am one of those that keeps falling back to Firefox because of the lack of this feature, even though I think Konqueror overall works better.
Comment 59 FiNeX 2007-06-24 01:01:04 UTC
Maybe it would be enough to improve the search "/" adding one textbox?
Is the search with "/" documented in the konqueror manual? (I've not installed the KDE guide on my PC)

hi!
Comment 60 Roland Wolters 2007-06-24 10:15:46 UTC
Finex - if you add a search box for the "/", where would that be different from a search box for "Ctrl+F"?
Also, this wish is exactly to *not* have a floating search box!
Comment 61 Alexander Solano 2007-06-25 21:40:16 UTC
With all honesty I can't understand why some don't feel like this is a feature worth having. As said by others using "/" or "'" to search is not a real option. Until today (after reading this post) I was not aware of that option, and I'm still trying to figure out how to use it... Point being: It is NOT an intuitive tool!

What makes Firefox so superior to other browsers is the little things, and this is one of the "big little things". Comparing the current "kde search" options with Firefox's ones is like comparing swans with pigs. Konqueror is a great browser, but it's search tools are still at the "Microsoft's IE" level.

Now, should we aspire for something even better? Of course! But in the mean time if I have to explain what the Konqueror's search tool works like I'd rather say "like Firefox's" then "like IE's".
Comment 62 Tommi Tervo 2007-07-02 14:18:23 UTC
*** Bug 147453 has been marked as a duplicate of this bug. ***
Comment 63 squan 2007-12-23 22:04:28 UTC
Also F3 (next match) should work if I load a new URL.
And even if I switch to another tab.
Comment 64 amine 2008-01-08 22:29:59 UTC
I agree with "squan" Next match should work when loading a new URL or in other tabs.
Comment 65 Dotan Cohen 2008-01-09 00:14:49 UTC
> I agree with "squan" Next match should work when loading
> a new URL or in other tabs. 

Like it does in Firefox!
Comment 66 Pino Toscano 2008-01-22 13:05:17 UTC
*** Bug 156377 has been marked as a duplicate of this bug. ***
Comment 67 Pino Toscano 2008-04-27 18:31:15 UTC
*** Bug 161335 has been marked as a duplicate of this bug. ***
Comment 68 Juan Canham 2008-05-16 21:37:34 UTC
this would be useful in kpdf-kpart too where / doesnt always work
it would also allow for an easy way to highlight all

please dont let NIHS stop this being implemented 
Comment 69 Tommi Tervo 2008-09-02 15:04:11 UTC
*** Bug 170251 has been marked as a duplicate of this bug. ***
Comment 70 Tommi Tervo 2008-12-04 12:27:05 UTC
*** Bug 176878 has been marked as a duplicate of this bug. ***
Comment 71 David Faure 2008-12-04 17:12:45 UTC
Ctrl+F now opens a find bar at the bottom of KHTML, Germain implemented it.
This will be in KDE-4.2.
Comment 72 Dotan Cohen 2008-12-04 18:11:56 UTC
For other KDE apps, such as KOrganizer, should we file bugs on the individual apps? Should we reference this bug in those bugs?
Comment 73 David Faure 2008-12-04 18:32:36 UTC
KOrganizer is independent from KHTML, please file a separate bug report if there isn't one already.
Comment 74 Johannes Simon 2009-02-10 12:00:14 UTC
*** Bug 161994 has been marked as a duplicate of this bug. ***