Bug 122314 - firefox like instant search for all KDE programs
Summary: firefox like instant search for all KDE programs
Status: RESOLVED DUPLICATE of bug 93439
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.0
Platform: unspecified Linux
: NOR wishlist with 155 votes (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-19 23:54 UTC by Jörg Hermsdorf
Modified: 2006-05-23 22:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Hermsdorf 2006-02-19 23:54:02 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs

Many KDE programs (Konqueror, Kwrite, Kate, ...) implement the search tool (CTRL-F or Edit>Search ...) for searching the contentpart of the application for phrases. It would be nice to have this functionality implemented like firefox does. When it's used the first time, a new searchbar is displayed in the application window above the statusbar. The cursor is automatically placed at the search field. While typing in the letters, search is already instantly started and jumps to matching results.
Comment 1 DaBlade 2006-02-21 02:29:21 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Jörg Hermsdorf 2006-02-21 03:45:52 UTC
See http://www.kde-look.org/content/show.php?content=35503 for a mockup (Screenshots) and more comments.

http://bugs.kde.org/show_bug.cgi?id=93439 seems to be a similar pending whishlist item requesting this feature only for konqueror. I think it should be realised as a kpart which can be used by all KDE applications.
Comment 3 gsasha 2006-02-21 05:26:36 UTC
I think this feature could also be very useful for Konsole.
Comment 4 Iuri Fiedoruk 2006-02-21 17:50:26 UTC
Yes, this kind of search is much better than the old pop-up windows that usually blocks your vision of the text. Once KDE4 will be rethink from scratch, I belive changing the way of search in kdelibs for something similar to firefox search is a VERY good idea.
Comment 5 Thiago Macieira 2006-02-22 20:07:45 UTC
Maybe on KDE4. But yes, it's a good idea.
Comment 6 Kusi 2006-02-22 22:13:16 UTC
I think the firefox search bar is close to perfect. If combined with an additional option button which pops up standard kde search dialog (regexp etc), I couldn't think of anything better. 

Right now, the kde search dialog...
1) ...is not consistent in stepping through the search result. When searching on a website, you have to press enter to step to the next result, while searching in a text form or kwrite, you have to press F3 to iterate through the results. 

2) ...always gets into your way while searching on a website. Although the search result is always visible while stepping through, the main window is covered by quite a big area which hinders you from quickly recognizing if the actual search result is the desired one.

3) ...is only valid for one window/tab. You can't use the same search dialog for two different tabs. When you start a search on tab 1 and switch to tab 2 and then want to use the search dialog again, nothing happens. In fact, you can open 10 search dialog boxes for all kind of windows and you have no clue, which one belongs to which tab. This is really annoying when searching for the same expression on several websites.

In contrast, the Firefox search bar
a) focuses the right widget all the time
b) doesn't get into your way
c) lets you find the result with the least possible amount of clicks
d) lets you search the same expression on different tabs without reentering the text
e) nice coloring (red for not available, yellow box for all search results)


Comment 7 Thiago Macieira 2006-02-25 21:18:05 UTC
Please transfer your votes.

*** This bug has been marked as a duplicate of 93439 ***
Comment 8 Iuri Fiedoruk 2006-02-25 21:31:55 UTC
Sorry, but I don't think those bugs are the same.
The another one if for konqueror only, this is more like kdelibs.

Or this should be kept open, or the other bug should have the title changed.
Comment 9 Stefan Monov 2006-02-26 20:06:05 UTC
I agree with comment #8
Comment 10 Roland Wolters 2006-02-26 21:32:50 UTC
The other bug is already renamed and has the right explanations, so this bug can stay closed.
Comment 11 Christo 2006-05-23 22:59:16 UTC
perfect - good IDea


.. i would also request to keep Error-Windows together with the MainApp-Window ( like MacOS does ) .. HA missed the Thread :-)