Bug 385814 - Some icons removed from the favorites list are back when plasma session is restarted
Summary: Some icons removed from the favorites list are back when plasma session is re...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.15.2
Platform: Archlinux Packages Linux
: VHI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 385749 385850 388143 388304 389515 395833 399413 400001 406565 411297 417582 419198 422040 422881 434996 435647 436591 453095 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-16 15:04 UTC by Patrick Silva
Modified: 2022-05-09 09:47 UTC (History)
51 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.5


Attachments
Screenshot (31.45 KB, image/png)
2017-12-24 10:20 UTC, Stefano
Details
kactivitymanagerdrc from ~/.config (119 bytes, text/plain)
2019-03-18 07:41 UTC, Syam
Details
kactivitymanagerd-statsrc from ~/.config (663 bytes, text/plain)
2019-03-18 07:42 UTC, Syam
Details
another ~/.config/kactivitymanagerdrc (119 bytes, text/plain)
2019-03-18 10:02 UTC, Kristopher Ives
Details
another ~/.config/kactivitymanagerd-statsrc (715 bytes, text/plain)
2019-03-18 10:03 UTC, Kristopher Ives
Details
Database changes (17.96 KB, image/png)
2020-06-12 07:03 UTC, Alexander Lohnau
Details
kactivitymanagerdrc (2.27 KB, text/plain)
2021-05-04 01:33 UTC, farid
Details
kactivitymanagerdrc (193 bytes, text/plain)
2021-05-04 01:34 UTC, farid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2017-10-16 15:04:24 UTC
It affects both kicker and kickoff apps menus.
It does not happen with gtk apps icons, I can remove Firefox and Chromium icons from the favorites list without any problem, for example.

Arch, plasma 5.11.
Comment 1 Patrick Silva 2017-10-17 00:47:37 UTC
*** Bug 385749 has been marked as a duplicate of this bug. ***
Comment 2 Eike Hein 2017-10-17 02:50:55 UTC
Ivan?
Comment 3 Patrick Silva 2017-10-17 12:50:13 UTC
*** Bug 385850 has been marked as a duplicate of this bug. ***
Comment 4 Xeno Idaltu 2017-10-17 19:44:54 UTC
Yes, I confirm this to be happening with Kate on Arch+Plasma 5.11
Comment 5 pyzek 2017-10-31 20:21:54 UTC
I have the same issue, Kate and Dolphin keep coming back.
I'm running Arch with Plasma 5.11.2
Comment 6 Alexander Mentyu 2017-12-06 08:23:07 UTC
Kate is reappearing in favorites. Dolphin, KInfocenter, Discover, Konsole, KSysGuard and System Settings aren't

Distribution: KDE neon Developer Edition - Stable Branches
Plasma: 5.11.4
Frameworks: 5.41.0
Qt: 5.9.3
Kernel 4.10.0-40-generic
Type: 64-bit
Comment 7 roman.dinga 2017-12-11 16:00:51 UTC
Indeed, I'm experiencing the same symptoms. Only Kate is coming back with every login.
Comment 8 Patrick Silva 2017-12-16 15:01:20 UTC
I just tested several kde apps...
okular
gwenview
discover
ktorrent
k3b
kdenlive
dolphin
kate

Only kate was affected.
Comment 9 Chris Holland 2017-12-24 04:16:53 UTC
https://www.reddit.com/r/kde/comments/7lqt3u/discover_keeps_returning_in_my_favorites/

/u/RASQ37 has this issue with Kate
/u/Astroniglio (Arch Linux) has this issue with Discover
Comment 10 Stefano 2017-12-24 10:12:24 UTC
I confirm this issue, but with the Discover entry instead.

Plasma 5.11.4 on Archlinux
Frameworks 5.41.0
Qt 5.10.0
Comment 11 Stefano 2017-12-24 10:20:00 UTC
Created attachment 109499 [details]
Screenshot
Comment 12 Stefano 2017-12-24 10:21:23 UTC
Comment on attachment 109499 [details]
Screenshot

Every entry is duplicated and set to appear in the favourites of every activity, but not Discover, which have no checkmarks.
Comment 13 Stefano 2017-12-24 10:24:35 UTC
(In reply to Stefano from comment #12)
> Comment on attachment 109499 [details]
> Screenshot
> 
> Every entry is duplicated and set to appear in the favourites of every
> activity, but not Discover, which have no checkmarks.

Also, if a set it ignores every settings. If I set it to appear only on my "test" activity (from screenshot), it appears also in the other. When I set it to not appear in every activity, it disappears, but returns when I restart plasma.

PS. Sorry for the duplicated comments...
Comment 14 Eike Hein 2018-01-01 10:57:17 UTC
*** Bug 388304 has been marked as a duplicate of this bug. ***
Comment 15 Kai Uwe Broulik 2018-01-01 10:58:38 UTC
I think this is a separate bug affecting Kate (likely caused by my jump list actions feature meddling with desktop files)
Comment 16 Kai Uwe Broulik 2018-01-01 10:59:31 UTC
Ok, nevermind, if it also affects Discover..
Comment 17 Eike Hein 2018-01-01 11:00:42 UTC
I'm not sure, but it clearly seems there's general wonkyness with state persistence. I've gotten both reports of favorite additions and removals not being remembered now, I think.

Sorry for the delay folks, we will try to prioritize this problem after the holidays. December was a bit crazy.
Comment 18 Christoph Feck 2018-01-10 22:43:36 UTC
*** Bug 388143 has been marked as a duplicate of this bug. ***
Comment 19 EGD 2018-03-28 19:16:16 UTC
i confirm this bug in plasma 5.12.3
but in my case favorites empty after logout
Comment 20 Patrick Silva 2018-05-04 21:47:47 UTC
I can not confirm this bug on my current system.

Arch Linux 
plasma 5.12.5
frameworks 5.45
kate 18.04
Comment 21 Syam 2018-05-11 13:22:20 UTC
I can confirm this bug on:
Fedora 28, x86-64
plasma 5.12.5
Kate 17.12.2
Frameworks 5.44.0
Comment 22 Erik Martre 2018-06-04 07:56:15 UTC
This bug was gone but came back recently : icons of favorite apps are wiped off at reboot, even default ones.

OpenSuse Tumbleweed
KDE Plasma 5.12.5
Frameworks 5.46.0
kernel 4.6.12-1-default

Had to remove ~/.local/share/kactivitymanagerd/resources/ and ~/.config/kactivitymanagerd-statsrc as a workaround.
Comment 23 Colin J Thomson 2018-06-04 19:03:52 UTC
Thanks for the tip, removing those fixes it for me also.
Running Plasma 5.12.90, Frameworks 5.46 on F28
Comment 24 Noppakorn Jiravaranun 2018-06-17 15:21:55 UTC
I confirm this to be happening. For me it is with Discover,Kate and Dolphin
Arch Linux
Plasma 5.13.0
Comment 25 zjeffer 2018-07-02 09:25:26 UTC
Comfirmed with Kate in Arch+Plasma 5.13.2-1. Really annoying bug.
Comment 26 Patrick Silva 2018-07-09 17:39:39 UTC
*** Bug 395833 has been marked as a duplicate of this bug. ***
Comment 27 Øystein Steffensen-Alværvik 2018-07-09 21:14:36 UTC
Occurs with Falkon also.
Comment 28 Øystein Steffensen-Alværvik 2018-08-18 10:01:20 UTC
(In reply to Erik Martre from comment #22)
> Had to remove ~/.local/share/kactivitymanagerd/resources/ and
> ~/.config/kactivitymanagerd-statsrc as a workaround.

This works until the user switches to another menu (like from Kickoff to Kicker), then the old icons come back again.
Comment 29 Øystein Steffensen-Alværvik 2018-08-23 10:16:26 UTC
*** Bug 389515 has been marked as a duplicate of this bug. ***
Comment 30 dharman 2018-08-30 12:11:26 UTC
I can confirm this bug on:

KDE neon, x86-64
plasma 5.13.4
Kate 18.08.0
Frameworks 5.49.0
Comment 31 Patrick Silva 2018-10-05 23:30:54 UTC
*** Bug 399413 has been marked as a duplicate of this bug. ***
Comment 32 Patrick Silva 2018-10-18 22:21:58 UTC
*** Bug 400001 has been marked as a duplicate of this bug. ***
Comment 33 Francois Prunier 2018-11-08 13:36:53 UTC
Just to confirm, this has nothing to do with Kate, it happens to me with Kontact. Can't get the bloody shortcut off the favourite.

Plasma 5.13.5
Frameworks 5.50.0
Qt 5.11.1

(Kubuntu 18.10).
Comment 34 Halmut Holz 2018-12-09 11:11:42 UTC
I have this problem too with the Filezilla icon in Kubuntu 18.04.
KDE Plasma version 5.12.6
Frameworks 5.44.0
QT 5.9.5
Comment 35 Matej Mrenica 2019-03-10 08:37:43 UTC
This still happens with Kate and Plasma 5.15.2
Comment 36 Kristopher Ives 2019-03-17 08:31:44 UTC
Does anyone know how I can work around this until the bug is fixed? Like, which config file to edit so that Kate isn't shown in the list (I know this bug isn't specific to Kate)
Comment 37 roman.dinga 2019-03-17 08:56:17 UTC
This bug is present since Plasma 5.8. and is one of the reasons why I stopped using Plasma completely: you can file as many bugs as you want, they are not solved for years, nobody does anything with them. They just keep adding new features, but bugs are not resolved at all, I don't know why they even keep a bug reporting tool. For years of using Plasma, I created numerous bug reports, none of them were ever solved. So I'm back with Gnome, where when I report a bug, it is taken care within days, a week or two maximum (that is my experience)
Comment 38 Patrick Silva 2019-03-17 09:59:23 UTC
(In reply to roman.dinga from comment #37)
> This bug is present since Plasma 5.8. and is one of the reasons why I
> stopped using Plasma completely: you can file as many bugs as you want, they
> are not solved for years, nobody does anything with them. They just keep
> adding new features, but bugs are not resolved at all, I don't know why they
> even keep a bug reporting tool. For years of using Plasma, I created
> numerous bug reports, none of them were ever solved. So I'm back with Gnome,
> where when I report a bug, it is taken care within days, a week or two
> maximum (that is my experience)

My case is opposite.
I already reported several bugs to gnome and nobody cares.
Nnautilus is almost unusable with touchscreen because old bugs.
Comment 39 Chris Holland 2019-03-17 12:38:28 UTC
Per activity favourites was added a month before this bug report was made (just before Plasma 5.11.0).

* https://github.com/KDE/plasma-desktop/blame/master/applets/kicker/plugin/kastatsfavoritesmodel.cpp
* https://github.com/KDE/plasma-desktop/commit/4ba9b01e2d6acc361f4ac0c7e4c21066eb575146

It added the ability for sharing the favorites on all monitors / activities.

Since this only affects a few users (?) it sounds like there's a race condition somewhere which is fairly difficult to test for and track down. Especially when it might only happen when plasmashell is starting up when you first login which means you have to relog every time you attempt to test.

Anyone still experiencing this, please upload your:

~/.config/kactivitymanagerdrc
~/.config/kactivitymanagerd-statsrc

If you can reproduce the bug repeatedly, please also upload what those files look like after you edit the favorites before you reboot (before the bug is triggered) and what they look like after.
Comment 40 Syam 2019-03-18 07:41:56 UTC
Created attachment 118872 [details]
kactivitymanagerdrc from ~/.config
Comment 41 Syam 2019-03-18 07:42:37 UTC
Created attachment 118873 [details]
kactivitymanagerd-statsrc from ~/.config
Comment 42 Syam 2019-03-18 07:45:07 UTC
(In reply to Chris Holland from comment #39)

I am affected by this bug and can reproduce it at will. At every login, I find Kate in favourites list. I delete it, logout and log back in. I find that Kate is back in the favourites list.

I have attached the two files that you mentioned. These files do not change at all when Kate is removed from favourites, nor after a re-login.
Comment 43 Kristopher Ives 2019-03-18 10:02:51 UTC
Created attachment 118876 [details]
another ~/.config/kactivitymanagerdrc
Comment 44 Kristopher Ives 2019-03-18 10:03:06 UTC
Created attachment 118877 [details]
another ~/.config/kactivitymanagerd-statsrc
Comment 45 Chris Holland 2019-03-18 22:42:50 UTC
This breakdown is for developers, regular users can skip this comment.

* https://github.com/KDE/plasma-desktop/blame/master/applets/kicker/plugin/kastatsfavoritesmodel.cpp#L622
* https://github.com/KDE/kactivities-stats/blame/master/src/resultwatcher.cpp#L368
* https://github.com/KDE/kactivities-stats/blame/master/src/resultwatcher.cpp#L69
* https://github.com/KDE/kactivities-stats/blob/248d6355aaabc389b4a4916afd63b7ef18b4c3b2/src/common/dbus/common.h#L50

To see the info of the DBus interface used run:
qdbus org.kde.ActivityManager /ActivityManager/Resources/Linking

To monitor the add/remove favorites code, double click the signal in `qdbusviewer`, or run:
dbus-monitor "type='signal',interface='org.kde.ActivityManager.ResourcesLinking',member='ResourceLinkedToActivity'" "type='signal',interface='org.kde.ActivityManager.ResourcesLinking',member='ResourceUnlinkedFromActivity'"

Some sort of magic then stores the favourite list in an SQLite database. The `kactivitymanagerd-statsrc` file is just for sorting the order of the favorites.
~/.local/share/kactivitymanagerd/resources/database

Browse the ResourceLink table to see all the favourites using `sqlitebrowser`, or run:
sqlite3 ~/.local/share/kactivitymanagerd/resources/database "SELECT * FROM 'ResourceLink';"

    $ sqlite3 ~/.local/share/kactivitymanagerd/resources/database "SELECT * FROM 'ResourceLink';"
    :global|org.kde.plasma.favorites.applications|qupzilla.desktop
    :global|org.kde.plasma.favorites.applications|org.kde.discover.desktop
    :global|org.kde.plasma.favorites.applications|preferred://browser
    :global|org.kde.plasma.favorites.applications|kontact.desktop
    :global|org.kde.plasma.favorites.applications|applications:systemsettings.desktop
    :global|org.kde.plasma.favorites.applications|applications:org.kde.dolphin.desktop
    80cddcc9-cf02-4e23-af0b-dc569f24a2b4|org.kde.plasma.favorites.applications|applications:LEGO The Hobbit.desktop
    :global|org.kde.plasma.favorites.documents|/usr/share/plasma/wallpapers/org.kde.image/contents/ui/config.qml
Comment 46 Elmo R 2019-03-28 10:49:23 UTC
The following worked for me:

 ~  cat discover-bs.txt
xprop on window
saw WM_CLASS(STRING) = "plasma-discover", "discover"
ps aux |grep plasma-discover
saw exr003    2934  0.4  0.6 2037288 208716 ?      Sl   06:34   0:01 /usr/bin/plasma-discover appstream://org.kde.discover.desktop
locate org.kde.discover.desktop
saw /usr/share/applications/org.kde.discover.desktop
rpm -qf /usr/share/applications/org.kde.discover.desktop
saw discover-5.12.6-lp150.2.3.1.x86_64
sudo zypper rm discover
sudo zypper al discover
Comment 47 trmdi 2019-03-29 03:21:42 UTC
I can no longer reproduce this on: Plasma 5.15.3 - KF 5.56.0 - Qt 5.12.2 - openSUSE Tumbleweed 20190325.

If someone still has this, try:
> $ sqlite3 ~/.local/share/kactivitymanagerd/resources/database "DELETE FROM 'ResourceLink';"

(I don't know if it fixes anything though)
Comment 48 Kristopher Ives 2019-03-30 01:47:52 UTC
Running the sqlite3 delete command does "work" but it also removes ALL existing resource links for event he stuff I do want to keep.
Comment 49 vnullptr 2019-07-01 03:54:58 UTC
I'm encountering this problem on my Arch's Plasma system after each shutdown/restart.
Comment 50 vnullptr 2019-07-01 03:56:07 UTC
(In reply to Patrick Silva from comment #0)
> It affects both kicker and kickoff apps menus.
> It does not happen with gtk apps icons, I can remove Firefox and Chromium
> icons from the favorites list without any problem, for example.
> 
> Arch, plasma 5.11.

But, when I remove Discover it comes back!
Comment 51 Christoph Feck 2019-09-17 01:26:20 UTC
*** Bug 411297 has been marked as a duplicate of this bug. ***
Comment 52 Halmut Holz 2019-11-09 19:58:29 UTC
After upgrading to Kubuntu 19.10 the problem still exists. In my case it is filezilla that always comes back when I remove it from the Favourites.
Comment 53 Halmut Holz 2019-11-09 19:59:46 UTC
PS:
Operating System: Kubuntu 19.10
KDE Plasma Version: 5.16.5
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.4
Kernel Version: 5.3.0-19-generic
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-7500T CPU @ 2.70GHz
Memory: 7,6 GiB
Comment 54 Christian Parpart 2020-01-30 08:33:45 UTC
Sadly it hits me too. It's a bug from 2017, wow. :)

SOFTWARE/OS VERSIONS:
Linux/KDE Plasma: Ubuntu 19.10 (very fresh(!) install)
KDE Plasma Version: 5.16.5
KDE Frameworks Version:  5.62.0
Qt Version: 5.12.4

I want to remove kate from the favorites list, and it keeps reappearing after new login. No matter how often I remove it from this list. This just makes me uninstall kate (in the hope that it'll never come up again). Hmm...
Comment 55 David 2020-02-08 22:12:28 UTC
I have this problem with Kate, and deleting the relevant rows in the ResourceLink table of ~/.local/share/kactivitymanagerd/resources/database seems to have solved the problem for now. Kate didn't re-appear in the favorites list after a logout/login.
Comment 56 Nate Graham 2020-02-15 22:13:01 UTC
*** Bug 417582 has been marked as a duplicate of this bug. ***
Comment 57 Stefan Champailler 2020-02-27 09:05:40 UTC

I had the problem with Dolphin, and deleting the relevant row in the ResourceLink table of ~/.local/share/kactivitymanagerd/resources/database have solved it (I used DB BRowser for SQL Lite to do that).

Dolphin didn't re-appear in the favorites list after a logout/login.

Si I kind of confirm the previous comment that explained that solution.
Comment 58 Stefan Champailler 2020-02-27 13:09:51 UTC
(In reply to Stefan Champailler from comment #57)
> 
> I had the problem with Dolphin, and deleting the relevant row in the
> ResourceLink table of ~/.local/share/kactivitymanagerd/resources/database
> have solved it (I used DB BRowser for SQL Lite to do that).
> 
> Dolphin didn't re-appear in the favorites list after a logout/login.
> 
> Si I kind of confirm the previous comment that explained that solution.

PS :

KDE Frameworks 5.54.0
Qt 5.11.3 (built against 5.11.3)
The xcb windowing system
On debian stable
Comment 59 Frank Kruger 2020-03-22 19:42:23 UTC
I was hit by this bug after ugrading to KDE Frameworks 5.68.0, with Discover appearing in the list of favourites in the application menu, even after removing it and logout/login.

Deleting the corresponding lines in the "ResourceLink" table in ~/.local/share/kactivitymanagerd/resources/database) solved the issue.
Comment 60 medin 2020-03-24 21:27:40 UTC
Me too after upgrading to kde 5.68.0 on Manjaro, the removed LibreOffice Writer icon from favorites is added again after every reboot.

Operating System: Manjaro Linux 
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.68.0
Qt Version: 5.14.1
Kernel Version: 5.5.11-1-MANJARO
OS Type: 64-bit
Processors: 2 × Pentium® Dual-Core CPU T4400 @ 2.20GHz
Memory: 5.7 GiB of RAM
Comment 61 Nate Graham 2020-04-15 04:47:03 UTC
*** Bug 419198 has been marked as a duplicate of this bug. ***
Comment 62 Patrick Silva 2020-05-25 22:00:41 UTC
*** Bug 422040 has been marked as a duplicate of this bug. ***
Comment 63 Christian Schumacher 2020-05-29 21:48:28 UTC
Can confirm this happens with Kate on my Gentoo Linux 
KDE-Plasma-Version: 5.18.5
KDE-Frameworks-Version: 5.67.0
Qt-Version: 5.14.2
Kernel-Version: 5.4.38-gentoo (64-bit)
Comment 64 Alexander Lohnau 2020-06-12 07:03:00 UTC
Created attachment 129249 [details]
Database changes

I debugged this and noticed that when I change the activity from all activities to another a new entry gets created, instead of the old one updated.

And if I then select to show this on no activities the new entry gets removed, but the original :global entry is still there.
Comment 65 Alexander Lohnau 2020-06-12 07:11:13 UTC
If the first entry of the screenshot gets the "applications:" prefix it works as expected.

From my perspective it looks like only the default entries have this problem, because they don't start with "applications:"
Comment 66 Patrick Silva 2020-06-12 21:53:10 UTC
*** Bug 422881 has been marked as a duplicate of this bug. ***
Comment 68 Alexander Lohnau 2020-06-13 07:46:03 UTC
Git commit 54896998ef1249f721a2fe616b61b51b4eda33fd by Alexander Lohnau.
Committed on 13/06/2020 at 07:46.
Pushed by alex into branch 'Plasma/5.18'.

Fix removing of icons and activity settings for new and existing setups

M  +12   -3    src/service/plugins/sqlite/ResourceLinking.cpp

https://invent.kde.org/plasma/kactivitymanagerd/commit/54896998ef1249f721a2fe616b61b51b4eda33fd
Comment 69 Alexander Lohnau 2020-06-13 08:26:11 UTC
Now it is fixed, this was a nasty one to debug.

Thanks @all for reporting and hopefully this improves your Plasma experience :-).
Comment 70 trmdi 2020-06-13 08:59:42 UTC
Very nice @Alex. Thank you. 🙏
Comment 71 Halmut Holz 2020-06-13 18:19:05 UTC
(In reply to Alex from comment #69)
> Now it is fixed, this was a nasty one to debug.
> 
> Thanks @all for reporting and hopefully this improves your Plasma experience
> :-).

Great work, thanks! :)
Comment 72 Nate Graham 2020-07-10 15:01:28 UTC
*** Bug 406565 has been marked as a duplicate of this bug. ***
Comment 73 databasedevil 2020-07-25 23:05:41 UTC
Thank you Alex!  This has been bugging me for a while now, glad to know I wasn't crazy. It happened on Fedora 30, 31, and 32.

For anyone else who finds this, here's what I did to fix it, in case you don't have up to date plasma packages:

$ sqlite3 ~/.local/share/kactivitymanagerd/resources/database
sqlite> DELETE from ResourceLink where targettedResource='kate.desktop';
sqlite> DELETE from ResourceLink where targettedResource='org.kde.kate.desktop';
Comment 74 Tiedemate 2020-10-26 13:06:32 UTC
Hi,

maybe it is not fixed completely? I am running Plasma 5.19.5 on Kubuntu. If I add Opera, Firefox and Chromium to the favorites in the Application Menu, after a reboot one of those icons will disappear and one other will be duplicated in the favorites. It is not possible to have exactly one entry in the favorites for Opera, Firefox and Chromium. If I want to have all three, I have to accept the double icons and add a fourth entry, to have all three browsers.
Deleting 
~/.config/kactivitymanagerdrc 
and
~/.config/kactivitymanagerd-statsrc
fixes the issue, now I can have exactly one entry for each of the three browsers and this status also survives reboots.
Comment 75 Patrick Silva 2020-10-26 13:18:05 UTC
Sometimes the icon of Discover app store is duplicated in my kickoff launcher,
but I do not know the exact steps to reproduce yet.
I'm not sure if duplicated icons and the bug described in this report are the same issue.

Operating System: Arch Linux
KDE Plasma Version: 5.20.1
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 76 Alexander Lohnau 2020-10-26 17:16:32 UTC
(In reply to Tiedemate from comment #74)
> If I want to have all three, I have to accept the double icons and add a fourth entry, to have all three browsers.

Hmm, seems like it is related to default browser entry. Which is basically a pinned application which represents whatever browser you currently have. My guess is that it saves both the preferred browser + the one you have manually added, which leads to one entry being duplicated.
So it seems like a separate issue.

Can you try to remember/reproduce if this duplicate entry is the same as you default browser?
Comment 77 Tiedemate 2021-01-31 12:25:58 UTC
Can't reproduce at the moment, since it's fixed with the workaround on all my systems. I'll give it a try once again when Kubuntu 21.04 has been released.
Comment 78 Nate Graham 2021-03-31 02:54:31 UTC
*** Bug 434996 has been marked as a duplicate of this bug. ***
Comment 79 farid 2021-05-04 01:29:02 UTC
This started happening recently with me.

KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Comment 80 farid 2021-05-04 01:33:35 UTC
Created attachment 138124 [details]
kactivitymanagerdrc
Comment 81 farid 2021-05-04 01:34:16 UTC
Created attachment 138125 [details]
kactivitymanagerdrc
Comment 82 farid 2021-05-04 01:42:05 UTC
(In reply to Tiedemate from comment #74)
> Hi,
> 
> maybe it is not fixed completely? I am running Plasma 5.19.5 on Kubuntu. If
> I add Opera, Firefox and Chromium to the favorites in the Application Menu,
> after a reboot one of those icons will disappear and one other will be
> duplicated in the favorites. It is not possible to have exactly one entry in
> the favorites for Opera, Firefox and Chromium. If I want to have all three,
> I have to accept the double icons and add a fourth entry, to have all three
> browsers.
> Deleting 
> ~/.config/kactivitymanagerdrc 
> and
> ~/.config/kactivitymanagerd-statsrc
> fixes the issue, now I can have exactly one entry for each of the three
> browsers and this status also survives reboots.


Deleting those files didn't fix it after reboot.
Comment 83 farid 2021-05-04 01:44:47 UTC
This is happening in application launcher btw, not kicker.
Comment 84 afedotov861 2021-10-22 16:11:33 UTC
This happens in kickoff and kicker for me, so i don't think it is specific to any launcher. Usually after encountering another plasma bug of some sort (like kwin crashing) and then logging out and logging back in. Kate reappears for me, and system settings is moved up to the second position, after firefox. Sometimes there is even a duplicate firefox added to the end of the list, it's inconsistent for me.
Comment 85 Nate Graham 2021-10-30 16:07:52 UTC
I can also still reproduce the issue. System Settings, Dolphin, and Konsole always return for me.
Comment 86 Nate Graham 2022-01-21 05:39:26 UTC
*** Bug 435647 has been marked as a duplicate of this bug. ***
Comment 87 Nate Graham 2022-01-21 05:39:31 UTC
*** Bug 436591 has been marked as a duplicate of this bug. ***
Comment 88 Bug Janitor Service 2022-02-13 07:14:41 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1452
Comment 89 Nate Graham 2022-02-16 01:02:38 UTC
*** Bug 450130 has been marked as a duplicate of this bug. ***
Comment 90 Nate Graham 2022-04-28 21:52:23 UTC
Git commit ff446e235e15e6879b0cb3e96870b180d7293653 by Nate Graham, on behalf of Méven Car.
Committed on 28/04/2022 at 21:52.
Pushed by ngraham into branch 'master'.

Convert old-style Favorites resources in KActivities DB

In the past, application Favorites were stored with their .desktop file path
such as "/usr/share/applications/org.kde.dolphin.desktop". But now those
entries are stored like so: "applications:org.kde.dolphin.desktop".

This commit converts old DB entries to the new style, which solves the issue
of users with old databases being unable to change their Favorite items.
FIXED-IN: 5.24.5

M  +16   -2    applets/kicker/plugin/kastatsfavoritesmodel.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/ff446e235e15e6879b0cb3e96870b180d7293653
Comment 91 Nate Graham 2022-04-28 21:52:49 UTC
Git commit 06602886d624fc8aa9f1f39c6f002793c4b96e10 by Nate Graham, on behalf of Méven Car.
Committed on 28/04/2022 at 21:52.
Pushed by ngraham into branch 'Plasma/5.24'.

Convert old-style Favorites resources in KActivities DB

In the past, application Favorites were stored with their .desktop file path
such as "/usr/share/applications/org.kde.dolphin.desktop". But now those
entries are stored like so: "applications:org.kde.dolphin.desktop".

This commit converts old DB entries to the new style, which solves the issue
of users with old databases being unable to change their Favorite items.
FIXED-IN: 5.24.5


(cherry picked from commit ff446e235e15e6879b0cb3e96870b180d7293653)

M  +16   -2    applets/kicker/plugin/kastatsfavoritesmodel.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/06602886d624fc8aa9f1f39c6f002793c4b96e10
Comment 92 Nate Graham 2022-05-03 17:27:32 UTC
*** Bug 453095 has been marked as a duplicate of this bug. ***