Bug 422040 - Unpinned apps in Kicker reappear on [activity change] or [new login]
Summary: Unpinned apps in Kicker reappear on [activity change] or [new login]
Status: RESOLVED DUPLICATE of bug 385814
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Menu (Kicker) (show other bugs)
Version: 5.18.5
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2020-05-25 09:50 UTC by Microeinstein
Modified: 2020-05-25 22:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen recording of the issue (locale: it_IT) (358.14 KB, video/mp4)
2020-05-25 09:50 UTC, Microeinstein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Microeinstein 2020-05-25 09:50:58 UTC
Created attachment 128763 [details]
Screen recording of the issue (locale: it_IT)

SUMMARY
I have some pinned apps (LibreOffice Writer, Cantata) that keep reappearing everytime I change activity or perform a new login (which I guess includes loading an activity).

STEPS TO REPRODUCE
1. Open Kicker
2. Right-click on a pinned app
3. -> Favourites
4. Re-pin on all activities/current activity
5. Unpin the same app
6. Change activity

OBSERVED RESULT
The app reappears as pinned, even with no checkmark on any activity.

EXPECTED RESULT
The app does not reappear.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma:       Arch Linux (5.6.14-xanmod1-1-xanmod)
                          (bug exists on vanilla kernel too)
KDE Plasma Version:     5.18.5
KDE Frameworks Version: 5.70.0
Qt Version:             5.14.2

ADDITIONAL INFORMATION
I recently migrated my installation from Manjaro to Arch Linux successfully (by reinstalling  the system from scratch, carefully porting configurations, keeping my home intact). The bug was also present on Manjaro.
Comment 1 Patrick Silva 2020-05-25 22:00:41 UTC

*** This bug has been marked as a duplicate of bug 385814 ***
Comment 2 Microeinstein 2020-05-25 22:51:43 UTC
Ah, sorry - I swear I searched for existing reports before posting... probably with wrong keywords though ._.