Bug 247984 - KTorrents crash on gvfs folder [memcpy, QCA::MemoryRegion, QCA::Hash::update, bt::SHA1HashGen::update]
Summary: KTorrents crash on gvfs folder [memcpy, QCA::MemoryRegion, QCA::Hash::update,...
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 247114 249520 251303 251826 253817 253849 253878 253893 254383 254562 255080 255263 255577 256345 256348 256822 257314 258034 258248 258341 258765 260253 260347 260359 261009 261102 261347 262037 262378 262446 263012 263393 263830 263942 266962 267104 267437 267933 268333 271638 272601 279462 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-15 20:52 UTC by Alexey Kuznetsov
Modified: 2011-08-05 16:56 UTC (History)
44 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.75 KB, text/plain)
2010-08-16 07:27 UTC, Alexey Kuznetsov
Details
New crash information added by DrKonqi (7.75 KB, text/plain)
2010-08-16 18:41 UTC, Alexey Kuznetsov
Details
New crash information added by DrKonqi (8.10 KB, text/plain)
2010-10-26 00:42 UTC, Tony Pott
Details
New crash information added by DrKonqi (9.07 KB, text/plain)
2010-11-13 08:41 UTC, ionut.stanescu
Details
New crash information added by DrKonqi (8.98 KB, text/plain)
2011-05-26 13:29 UTC, Tony Muir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Kuznetsov 2010-08-15 20:52:01 UTC
Application: ktorrent (4.0.2)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32.16-150.fc12.ppc ppc
Distribution: "Fedora release 12 (Constantine)"

-- Information about the crash:
do run ktrorrent on gfvfs folder and you got this crash.

stable!

The crash can be reproduced every time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
Warning: the current language does not match this frame.
[Current thread is 1 (Thread 0x4830aca0 (LWP 24658))]

Thread 4 (Thread 0x505ff3b0 (LWP 24669)):
#0  0x0fc9c508 in __pthread_cond_timedwait (cond=0x505feb60, mutex=0x505feb94, abstime=0x505febd0) at pthread_cond_timedwait.c:160
#1  0x48097cc4 in thread_sleep (ti=0x505febd0) at thread/qthread_unix.cpp:398
#2  0x48097ed0 in QThread::msleep (msecs=220479) at thread/qthread_unix.cpp:424
#3  0x0216cc10 in net::DownloadThread::update (this=0x107c68c0) at /usr/src/debug/libktorrent-1.0.2/src/net/downloadthread.cpp:91
#4  0x0216d684 in net::NetworkThread::run (this=0x107c68c0) at /usr/src/debug/libktorrent-1.0.2/src/net/networkthread.cpp:48
#5  0x48098614 in QThreadPrivate::start (arg=0x107c68c0) at thread/qthread_unix.cpp:248
#6  0x0fc96038 in start_thread (arg=0x505ff3b0) at pthread_create.c:299
#7  0x0feec5f0 in clone () from /lib/libc.so.6

Thread 3 (Thread 0x50fff3b0 (LWP 24670)):
#0  0x0fc9c508 in __pthread_cond_timedwait (cond=0x50ffeb60, mutex=0x50ffeb94, abstime=0x50ffebd0) at pthread_cond_timedwait.c:160
#1  0x48097cc4 in thread_sleep (ti=0x50ffebd0) at thread/qthread_unix.cpp:398
#2  0x48097ed0 in QThread::msleep (msecs=181913) at thread/qthread_unix.cpp:424
#3  0x0216bfc0 in net::UploadThread::update (this=0x107c6cd8) at /usr/src/debug/libktorrent-1.0.2/src/net/uploadthread.cpp:89
#4  0x0216d684 in net::NetworkThread::run (this=0x107c6cd8) at /usr/src/debug/libktorrent-1.0.2/src/net/networkthread.cpp:48
#5  0x48098614 in QThreadPrivate::start (arg=0x107c6cd8) at thread/qthread_unix.cpp:248
#6  0x0fc96038 in start_thread (arg=0x50fff3b0) at pthread_create.c:299
#7  0x0feec5f0 in clone () from /lib/libc.so.6

Thread 2 (Thread 0x519ff3b0 (LWP 24671)):
#0  0x0fc9bf0c in __pthread_cond_wait (cond=0x11280f30, mutex=0x11280f18) at pthread_cond_wait.c:153
#1  0x4809997c in wait (this=<value optimized out>, mutex=0x1127f478, time=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1127f478, time=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x02171120 in net::ReverseResolverThread::run (this=0x1127f470) at /usr/src/debug/libktorrent-1.0.2/src/net/reverseresolver.cpp:123
#4  0x48098614 in QThreadPrivate::start (arg=0x1127f470) at thread/qthread_unix.cpp:248
#5  0x0fc96038 in start_thread (arg=0x519ff3b0) at pthread_create.c:299
#6  0x0feec5f0 in clone () from /lib/libc.so.6

Thread 1 (Thread 0x4830aca0 (LWP 24658)):
[KCrash Handler]
#5  _wordcopy_fwd_aligned (dstp=<value optimized out>, srcp=<value optimized out>, len=3256) at wordcopy.c:106
#6  0x0fe81270 in memcpy (dstpp=0x11629fb8, srcpp=<value optimized out>, len=16384) at memcpy.c:55
#7  0x02a45538 in Private (this=0xbfcec548, from=...) at /usr/include/bits/string3.h:52
#8  QCA::MemoryRegion::MemoryRegion (this=0xbfcec548, from=...) at qca_tools.cpp:445
#9  0x02a63784 in QCA::Hash::update (this=0x11688048, a=<value optimized out>) at qca_basic.cpp:215
#10 0x02152384 in bt::SHA1HashGen::update (this=0x118d1524, data=0x4856b2d4 "V\231\061\261\231\360\031\tB\215k\325\372", len=16384) at /usr/src/debug/libktorrent-1.0.2/src/util/sha1hashgen.cpp:240
#11 0x021953f0 in bt::ChunkDownload::updateHash (this=0x118d14b0) at /usr/src/debug/libktorrent-1.0.2/src/download/chunkdownload.cpp:555
#12 0x02196a88 in bt::ChunkDownload::piece (this=0x118d14b0, p=..., ok=<value optimized out>) at /usr/src/debug/libktorrent-1.0.2/src/download/chunkdownload.cpp:127
#13 0x0219e688 in bt::Downloader::pieceReceived (this=0x10b6ff58, p=...) at /usr/src/debug/libktorrent-1.0.2/src/download/downloader.cpp:134
#14 0x0217fcf8 in bt::PeerManager::pieceReceived (this=<value optimized out>, p=<value optimized out>) at /usr/src/debug/libktorrent-1.0.2/src/peer/peermanager.cpp:671
#15 0x0217e2b4 in bt::Peer::packetReady (this=0x116d8880, packet=0x4b3b21e8 "\a", len=<value optimized out>) at /usr/src/debug/libktorrent-1.0.2/src/peer/peer.cpp:283
#16 0x0218a6d0 in bt::PacketReader::update (this=0x1168b540) at /usr/src/debug/libktorrent-1.0.2/src/peer/packetreader.cpp:141
#17 0x0217cd20 in bt::Peer::update (this=0x116d8880) at /usr/src/debug/libktorrent-1.0.2/src/peer/peer.cpp:538
#18 0x02183350 in bt::PeerManager::update (this=0x10b7e590) at /usr/src/debug/libktorrent-1.0.2/src/peer/peermanager.cpp:142
#19 0x021bae6c in bt::TorrentControl::update (this=0x10b4a040) at /usr/src/debug/libktorrent-1.0.2/src/torrent/torrentcontrol.cpp:163
#20 0x1001d3b4 in kt::Core::update (this=0x107e5c68) at /usr/src/debug/ktorrent-4.0.2/ktorrent/core.cpp:1023
#21 0x100268b0 in kt::Core::qt_metacall (this=0x107e5c68, _c=InvokeMetaMethod, _id=12, _a=0xbfcec91c) at /usr/src/debug/ktorrent-4.0.2/ppc-redhat-linux-gnu/ktorrent/core.moc:168
#22 0x481bd180 in QMetaObject::metacall (object=<value optimized out>, cl=<value optimized out>, idx=<value optimized out>, argv=<value optimized out>) at kernel/qmetaobject.cpp:237
#23 0x481d02dc in QMetaObject::activate (sender=0x107e5c7c, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#24 0x48227a40 in QTimer::timeout (this=<value optimized out>) at .moc/release-shared/moc_qtimer.cpp:134
#25 0x481d79d4 in QTimer::timerEvent (this=0x107e5c7c, e=<value optimized out>) at kernel/qtimer.cpp:271
#26 0x481cb4e0 in QObject::event (this=0x107e5c7c, e=0xbfcecdc0) at kernel/qobject.cpp:1212
#27 0x0082bae8 in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=0x107e5c7c, e=0xbfcecdc0) at kernel/qapplication.cpp:4306
#28 0x00833668 in QApplication::notify (this=<value optimized out>, receiver=0x107e5c7c, e=0xbfcecdc0) at kernel/qapplication.cpp:4189
#29 0x1002d5ec in kt::App::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at /usr/src/debug/ktorrent-4.0.2/ktorrent/app.cpp:97
#30 0x481b7560 in QCoreApplication::notifyInternal (this=0xbfced080, receiver=<value optimized out>, event=0xbfcecdc0) at kernel/qcoreapplication.cpp:726
#31 0x481ecdb8 in sendEvent (this=0x107ebfc4) at kernel/qcoreapplication.h:215
#32 QTimerInfoList::activateTimers (this=0x107ebfc4) at kernel/qeventdispatcher_unix.cpp:603
#33 0x481e96d4 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#34 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#35 0x0fb06f60 in g_main_dispatch (context=0x107eaf10) at gmain.c:1960
#36 IA__g_main_context_dispatch (context=0x107eaf10) at gmain.c:2513
#37 0x0fb0bc18 in g_main_context_iterate (context=0x107eaf10, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#38 0x0fb0bdc8 in IA__g_main_context_iteration (context=0x107eaf10, may_block=1) at gmain.c:2654
#39 0x481e9198 in QEventDispatcherGlib::processEvents (this=0x107c5648, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#40 0x008ec4f0 in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x481b535c in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x481b5798 in QEventLoop::exec (this=0xbfced014, flags=...) at kernel/qeventloop.cpp:201
#43 0x481ba394 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#44 0x0082bbc0 in QApplication::exec () at kernel/qapplication.cpp:3585
#45 0x1001bb84 in main (argc=1, argv=0xbfced644) at /usr/src/debug/ktorrent-4.0.2/ktorrent/main.cpp:176

Reported using DrKonqi
Comment 1 Alexey Kuznetsov 2010-08-16 07:27:41 UTC
Created attachment 50598 [details]
New crash information added by DrKonqi

just crash on downloading.
Comment 2 Alexey Kuznetsov 2010-08-16 18:41:01 UTC
Created attachment 50619 [details]
New crash information added by DrKonqi

gvfs crash. happens again. hope more detailed stack trace
Comment 3 Joris Guisson 2010-08-16 20:53:13 UTC
And this doesn't happen on other filesystems ?
Comment 4 Alexey Kuznetsov 2010-08-17 07:30:52 UTC
i use it only on my ppc server, via remote desktop (vnc).

i suppose not :)
Comment 5 Joris Guisson 2010-08-17 18:55:14 UTC
And the underlying filesystem is ?
Comment 6 Alexey Kuznetsov 2010-08-17 19:16:56 UTC
ext4 for booth ktorrent and samba.
Comment 7 Joris Guisson 2010-08-18 19:56:31 UTC
If you are downloading to a samba share of an ext4 partition mounted via gvfs, why would you run KT then via a remote desktop ?

Also how frequent are these crashes, if I setup a similar situation, how long would I need to wait before it happens ?
Comment 8 Alexey Kuznetsov 2010-08-18 20:27:14 UTC
because i dont like to have any limitations of my actions on my personal notebook. rebooting, changing os, walking with it outside home network.

so, i do run vncserver on my ppc machine, and use vnc client to control all my downloading.

see not problems here.
Comment 9 Alexey Kuznetsov 2010-08-18 21:53:19 UTC
and about crashes...

it happens about each hour-six.
Comment 10 Joris Guisson 2010-08-22 20:16:53 UTC
*** Bug 247114 has been marked as a duplicate of this bug. ***
Comment 11 Joris Guisson 2010-09-16 19:54:32 UTC
*** Bug 251303 has been marked as a duplicate of this bug. ***
Comment 12 Joris Guisson 2010-09-20 19:29:32 UTC
*** Bug 251826 has been marked as a duplicate of this bug. ***
Comment 13 Joris Guisson 2010-10-11 18:45:58 UTC
*** Bug 253849 has been marked as a duplicate of this bug. ***
Comment 14 Joris Guisson 2010-10-11 18:46:26 UTC
*** Bug 253817 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2010-10-12 01:08:26 UTC
*** Bug 253893 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2010-10-12 01:28:48 UTC
Hm, does Torrent support file sizes > 4 GB? chunkdownload.cpp:567 has

    chunk->getPiece(i*MAX_PIECE_LEN,len,true);

which will overflow 32 bits ...
Comment 17 Joris Guisson 2010-10-12 11:45:00 UTC
Seeing that no torrent has a chunk size larger then 4 GB, that piece of code cannot overflow.
Comment 18 Joris Guisson 2010-10-13 18:42:34 UTC
*** Bug 253878 has been marked as a duplicate of this bug. ***
Comment 19 Joris Guisson 2010-10-16 19:21:39 UTC
*** Bug 254383 has been marked as a duplicate of this bug. ***
Comment 20 Joris Guisson 2010-10-18 18:54:55 UTC
*** Bug 254562 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2010-10-25 23:04:41 UTC
*** Bug 255263 has been marked as a duplicate of this bug. ***
Comment 22 Tony Pott 2010-10-26 00:42:53 UTC
Created attachment 52871 [details]
New crash information added by DrKonqi

Happens also on 4.4.4.

Seems to happen most often when good download speed ( > 250 kB/s ) achieved.
Comment 23 Tony Pott 2010-10-28 04:03:54 UTC
Just tried a little experiment: downloaded into a very, very slow drive (trucrypt encryped micro sd card: you can type the data faster). Crashes within 20 secs, i.e. as soon as any downloading starts. Is there some kind of buffering issue raising its ugly twisted little head here?
Comment 24 Joris Guisson 2010-10-29 18:09:59 UTC
*** Bug 255577 has been marked as a duplicate of this bug. ***
Comment 25 Joris Guisson 2010-10-31 12:31:27 UTC
SVN commit 1191545 by guisson:

Revamp PieceData management, fixes a crash 

BUG: 247984


 M  +1 -18     CMakeLists.txt  
 A             diskio/CMakeLists.txt  
 M  +23 -44    diskio/cache.cpp  
 M  +19 -17    diskio/cache.h  
 M  +4 -27     diskio/cachefile.cpp  
 M  +11 -18    diskio/chunk.cpp  
 M  +3 -3      diskio/chunk.h  
 M  +13 -15    diskio/multifilecache.cpp  
 M  +4 -4      diskio/multifilecache.h  
 M  +56 -38    diskio/piecedata.cpp  
 M  +66 -40    diskio/piecedata.h  
 M  +14 -14    diskio/singlefilecache.cpp  
 M  +4 -4      diskio/singlefilecache.h  
 A             diskio/tests (directory)  
 A             diskio/tests/CMakeLists.txt  
 A             diskio/tests/chunkmanagertest.cpp   [License: GPL (v2+)]
 M  +12 -24    download/chunkdownload.cpp  
 M  +2 -3      download/chunkdownload.h  
 M  +2 -20     download/downloader.cpp  
 M  +3 -0      download/streamingchunkselector.h  
 M  +9 -5      download/tests/streamingchunkselectortest.cpp  
 M  +2 -2      download/webseed.cpp  
 M  +1 -1      download/webseed.h  
 M  +12 -5     torrent/torrentfilestream.cpp  
 M  +5 -0      util/functions.cpp  
 M  +2 -0      util/signalcatcher.cpp  
 M  +4 -0      util/signalcatcher.h  
 M  +1 -8      version.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1191545
Comment 26 Joris Guisson 2010-10-31 12:32:37 UTC
*** Bug 255080 has been marked as a duplicate of this bug. ***
Comment 27 Joris Guisson 2010-11-08 18:06:18 UTC
*** Bug 256345 has been marked as a duplicate of this bug. ***
Comment 28 Joris Guisson 2010-11-08 18:06:40 UTC
*** Bug 256348 has been marked as a duplicate of this bug. ***
Comment 29 ionut.stanescu 2010-11-13 08:41:15 UTC
Created attachment 53385 [details]
New crash information added by DrKonqi

ktorrent (4.0.3) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

Ktorrent crash randomly.

-- Backtrace (Reduced):
#8  0x00ae17a6 in bt::Chunk::readPiece (this=0x91156c8, off=1720320, len=16384, data=0xafc00025 "\301-W\204\237Y\"\200\060\031\333;cC\022>\377\242f\232\335\364A\253\"\030\253\364\222)\021\300\304_\354\020q\035\275\265\235\275\062B\366\253\273;\"\350\330\f\273\235n,\221\210C\353\333\311f\342\264\212\274\f\324\251\314\221\365\374GL\214\032\207\211\323\277\215&]o\202\366\261\266-\032c]{8%=\r\314\r\b\362\004W\r\371s\246\225w7l\003\037\003\004\022\321\325dt\377\331\345\023b\336E\\F\375\177\003\312\a\212\225(\230\243\026\332\261\345l\266#\216\264\302\213\322\373\376y\\\362+\005\267\225\255S\334Ly=\277'\276\324\344\\\311\263\263\332\241\030\216\373\355\313\314Hk\223\070;\330\322v\005\004kX\262\333\315"...) at //usr/include/bits/string3.h:52
#9  0x00a90bea in bt::Packet::Packet (this=0xb3df1ca0, index=16665, begin=1720320, len=16384, ch=0x91156c8) at ../../src/download/packet.cpp:85
#10 0x00a8aa5f in bt::PacketWriter::sendChunk (this=0xad4f08f8, index=16665, begin=1720320, len=16384, ch=0x91156c8) at ../../src/peer/packetwriter.cpp:195
#11 0x00a892fc in bt::PeerUploader::update (this=0xad2f0440, cman=..., opt_unchoked=101) at ../../src/peer/peeruploader.cpp:83
#12 0x00ab20d8 in bt::Uploader::update (this=0x9166508, opt_unchoked=101) at ../../src/torrent/uploader.cpp:48
Comment 30 Joris Guisson 2010-11-13 18:31:39 UTC
*** Bug 256822 has been marked as a duplicate of this bug. ***
Comment 31 Dario Andres 2010-11-19 22:17:45 UTC
*** Bug 257314 has been marked as a duplicate of this bug. ***
Comment 32 Joris Guisson 2010-11-28 10:03:23 UTC
*** Bug 258034 has been marked as a duplicate of this bug. ***
Comment 33 Joris Guisson 2010-11-29 18:07:12 UTC
*** Bug 258248 has been marked as a duplicate of this bug. ***
Comment 34 Joris Guisson 2010-11-30 18:12:27 UTC
*** Bug 258341 has been marked as a duplicate of this bug. ***
Comment 35 Joris Guisson 2010-12-04 10:55:25 UTC
*** Bug 258765 has been marked as a duplicate of this bug. ***
Comment 36 Joris Guisson 2010-12-16 18:00:41 UTC
*** Bug 260253 has been marked as a duplicate of this bug. ***
Comment 37 Dario Andres 2010-12-17 17:25:00 UTC
*** Bug 260359 has been marked as a duplicate of this bug. ***
Comment 38 Joris Guisson 2010-12-17 18:46:38 UTC
*** Bug 260347 has been marked as a duplicate of this bug. ***
Comment 39 Dario Andres 2010-12-23 00:13:30 UTC
*** Bug 261009 has been marked as a duplicate of this bug. ***
Comment 40 Joris Guisson 2010-12-24 13:00:07 UTC
*** Bug 261102 has been marked as a duplicate of this bug. ***
Comment 41 Joris Guisson 2010-12-27 12:46:44 UTC
*** Bug 261347 has been marked as a duplicate of this bug. ***
Comment 42 Joris Guisson 2011-01-04 18:45:05 UTC
*** Bug 262037 has been marked as a duplicate of this bug. ***
Comment 43 Joris Guisson 2011-01-07 20:53:38 UTC
*** Bug 262446 has been marked as a duplicate of this bug. ***
Comment 44 Joris Guisson 2011-01-07 20:58:25 UTC
*** Bug 262378 has been marked as a duplicate of this bug. ***
Comment 45 Dario Kampkaspar 2011-01-09 07:13:12 UTC
May I ask in which version of ktorrent this one is fixed? In 4.0.5 this has happened to me (https://bugs.kde.org/show_bug.cgi?id=262378), and just this night again.
Comment 46 Joris Guisson 2011-01-09 12:35:40 UTC
It was fixed in 4.1beta1
Comment 47 Joris Guisson 2011-01-13 17:49:13 UTC
*** Bug 263012 has been marked as a duplicate of this bug. ***
Comment 48 Joris Guisson 2011-01-18 17:57:59 UTC
*** Bug 263393 has been marked as a duplicate of this bug. ***
Comment 49 Joris Guisson 2011-01-22 12:43:48 UTC
*** Bug 263830 has been marked as a duplicate of this bug. ***
Comment 50 Joris Guisson 2011-01-22 12:44:55 UTC
*** Bug 263942 has been marked as a duplicate of this bug. ***
Comment 51 Joris Guisson 2011-02-05 11:19:58 UTC
*** Bug 263942 has been marked as a duplicate of this bug. ***
Comment 52 Lukas Appelhans 2011-02-06 12:25:36 UTC
*** Bug 249520 has been marked as a duplicate of this bug. ***
Comment 53 Joris Guisson 2011-02-23 18:01:43 UTC
*** Bug 266962 has been marked as a duplicate of this bug. ***
Comment 54 Joris Guisson 2011-02-25 18:50:29 UTC
*** Bug 267104 has been marked as a duplicate of this bug. ***
Comment 55 Joris Guisson 2011-03-03 20:51:28 UTC
*** Bug 267437 has been marked as a duplicate of this bug. ***
Comment 56 Joris Guisson 2011-03-08 19:37:06 UTC
*** Bug 267933 has been marked as a duplicate of this bug. ***
Comment 57 Joris Guisson 2011-03-13 11:13:09 UTC
*** Bug 268333 has been marked as a duplicate of this bug. ***
Comment 58 Joris Guisson 2011-04-25 09:15:56 UTC
*** Bug 271638 has been marked as a duplicate of this bug. ***
Comment 59 Joris Guisson 2011-05-07 11:07:41 UTC
*** Bug 272601 has been marked as a duplicate of this bug. ***
Comment 60 Tony Muir 2011-05-26 13:29:50 UTC
Created attachment 60351 [details]
New crash information added by DrKonqi

ktorrent (4.0.5) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
I had only ktorrent running, when ever i start up ktorrent to download it lasts about 3 minutes, then crashes.

-- Backtrace (Reduced):
#8  0x086ef016 in QCA::MemoryRegion::MemoryRegion(QByteArray const&) () from /usr/lib/libqca.so.2
#9  0x08706167 in QCA::Hash::update(QByteArray const&) () from /usr/lib/libqca.so.2
#10 0x0014a4d9 in bt::SHA1HashGen::update (this=0x9261680, data=0xb4c1cbf9 "", len=16384) at ../../src/util/sha1hashgen.cpp:240
#11 0x00186ec8 in bt::ChunkDownload::updateHash (this=0x9261610) at ../../src/download/chunkdownload.cpp:555
#12 0x00188c21 in bt::ChunkDownload::piece (this=0x9261610, p=..., ok=@0xbfab833f) at ../../src/download/chunkdownload.cpp:127
Comment 61 Christoph Feck 2011-08-05 16:56:32 UTC
*** Bug 279462 has been marked as a duplicate of this bug. ***