Bug 256348 - Segmentation fault, and crash happens immediatelly at aplication start.
Summary: Segmentation fault, and crash happens immediatelly at aplication start.
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-08 10:19 UTC by Levente Szilagyi
Modified: 2010-11-08 18:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Levente Szilagyi 2010-11-08 10:19:39 UTC
Application that crashed: ktorrent
Version of the application: 3.2.4
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-22-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Ktorrent can not run because always stopped by the crash report and exit.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7fcb49135750 (LWP 5783))]

Thread 3 (Thread 0x7fcb2b255910 (LWP 5791)):
#0  0x00007fcb4584b8e3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fcb48c6b1f9 in net::DownloadThread::waitForSocketReady (this=0xf8a640, timeout=<value optimized out>) at ../../libbtcore/net/downloadthread.cpp:188
#2  0x00007fcb48c6b2bc in net::DownloadThread::update (this=0x18d44f0) at ../../libbtcore/net/downloadthread.cpp:53
#3  0x00007fcb48c6bc89 in net::NetworkThread::run (this=0xf8a640) at ../../libbtcore/net/networkthread.cpp:48
#4  0x00007fcb46ea5445 in QThreadPrivate::start (arg=0xf8a640) at thread/qthread_unix.cpp:188
#5  0x00007fcb424d7a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007fcb45857d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fcb2aa54910 (LWP 5792)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007fcb46ea64fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0xf8afc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xf8afc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fcb48c6ab88 in net::UploadThread::update (this=0xf8af50) at ../../libbtcore/net/uploadthread.cpp:73
#4  0x00007fcb48c6bc89 in net::NetworkThread::run (this=0xf8af50) at ../../libbtcore/net/networkthread.cpp:48
#5  0x00007fcb46ea5445 in QThreadPrivate::start (arg=0xf8af50) at thread/qthread_unix.cpp:188
#6  0x00007fcb424d7a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#7  0x00007fcb45857d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcb49135750 (LWP 5783)):
[KCrash Handler]
#5  memcpy () at ../sysdeps/x86_64/memcpy.S:267
#6  0x00007fcb45277276 in QCA::MemoryRegion::MemoryRegion(QByteArray const&) () from /usr/lib/libqca.so.2
#7  0x00007fcb4528e9d4 in QCA::Hash::update(char const*, int) () from /usr/lib/libqca.so.2
#8  0x00007fcb48c882d2 in bt::ChunkDownload::updateHash (this=0x28a6d70) at ../../libbtcore/download/chunkdownload.cpp:562
#9  0x00007fcb48c89055 in bt::ChunkDownload::piece (this=0x28a6d70, p=..., ok=<value optimized out>) at ../../libbtcore/download/chunkdownload.cpp:133
#10 0x00007fcb48c8f8be in bt::Downloader::pieceReceived (this=0x1b60c80, p=...) at ../../libbtcore/download/downloader.cpp:133
#11 0x00007fcb48c78091 in bt::Peer::packetReady (this=0x7fcb300040d0, packet=0x2bdef40 "\a", len=<value optimized out>) at ../../libbtcore/peer/peer.cpp:269
#12 0x00007fcb48c80f95 in bt::PacketReader::update (this=0x7fcb30003f70) at ../../libbtcore/peer/packetreader.cpp:131
#13 0x00007fcb48c77dd5 in bt::Peer::update (this=0x7fcb300040d0) at ../../libbtcore/peer/peer.cpp:474
#14 0x00007fcb48c7b7c0 in bt::PeerManager::update (this=0x1b0ded0) at ../../libbtcore/peer/peermanager.cpp:117
#15 0x00007fcb48cac4cc in bt::TorrentControl::update (this=0x1b0e6c0) at ../../libbtcore/torrent/torrentcontrol.cpp:178
#16 0x000000000042c1c2 in kt::Core::update (this=0x11a2d20) at ../../ktorrent/core.cpp:877
#17 0x0000000000431d2c in kt::Core::qt_metacall (this=0x11a2d20, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7fff25179170) at ./core.moc:148
#18 0x00007fcb46fa0ddc in QMetaObject::activate (sender=0x11a2d48, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x712) at kernel/qobject.cpp:3113
#19 0x00007fcb46f9ad83 in QObject::event (this=0x11a2d48, e=0x7fcb49151000) at kernel/qobject.cpp:1075
#20 0x00007fcb46433efc in QApplicationPrivate::notify_helper (this=0xfc01f0, receiver=0x11a2d48, e=0x7fff25179770) at kernel/qapplication.cpp:4056
#21 0x00007fcb4643b1ce in QApplication::notify (this=0x7fff25179aa0, receiver=0x11a2d48, e=0x7fff25179770) at kernel/qapplication.cpp:4021
#22 0x00007fcb47e5dab6 in KApplication::notify (this=0x7fff25179aa0, receiver=0x11a2d48, event=0x7fff25179770) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007fcb46f8bc2c in QCoreApplication::notifyInternal (this=0x7fff25179aa0, receiver=0x11a2d48, event=0x7fff25179770) at kernel/qcoreapplication.cpp:610
#24 0x00007fcb46fb6862 in QCoreApplication::sendEvent (this=0xfb85c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#25 QTimerInfoList::activateTimers (this=0xfb85c0) at kernel/qeventdispatcher_unix.cpp:572
#26 0x00007fcb46fb425d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#27 0x00007fcb41802bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#28 0x00007fcb41806598 in ?? () from /lib/libglib-2.0.so.0
#29 0x00007fcb418066c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#30 0x00007fcb46fb41a6 in QEventDispatcherGlib::processEvents (this=0xfc0420, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#31 0x00007fcb464c84be in QGuiEventDispatcherGlib::processEvents (this=0x2d0b317, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007fcb46f8a532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#33 0x00007fcb46f8a904 in QEventLoop::exec (this=0x7fff25179a10, flags=) at kernel/qeventloop.cpp:201
#34 0x00007fcb46f8cab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x0000000000424ef2 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../ktorrent/main.cpp:171
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Joris Guisson 2010-11-08 18:06:40 UTC

*** This bug has been marked as a duplicate of bug 247984 ***