Bug 258034 - kT crash at Quit
Summary: kT crash at Quit
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-27 02:22 UTC by brooke.bearden
Modified: 2010-11-28 10:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brooke.bearden 2010-11-27 02:22:36 UTC
Application: ktorrent (4.0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Closed kT from File -> Quit, kT crashed instead. At time of crash had 3 torrents running: 1 active, 1 seeding, 1 "not started"
- Custom settings of the application:open port thru router virtual servers; using uTP; DHT enabled

-- Backtrace:
Application: KTorrent (ktorrent), signal: Bus error
[Current thread is 1 (Thread 0xb77ba710 (LWP 1724))]

Thread 6 (Thread 0xb7562b70 (LWP 1725)):
#0  0x009ca416 in __kernel_vsyscall ()
#1  0x01a18df6 in poll () from /lib/libc.so.6
#2  0x053fca1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x053ef43c in ?? () from /lib/libglib-2.0.so.0
#4  0x053efba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x024526b4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0x0541648f in ?? () from /lib/libglib-2.0.so.0
#7  0x009ebcc9 in start_thread () from /lib/libpthread.so.0
#8  0x01a276be in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb460eb70 (LWP 1727)):
#0  0x0385e225 in QElapsedTimer::isMonotonic () at tools/qelapsedtimer_unix.cpp:88
#1  0x0385e4a2 in do_gettime () at tools/qelapsedtimer_unix.cpp:103
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x039356e5 in QTimerInfoList::updateCurrentTime (this=0xb6c04d34) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0393572a in QTimerInfoList::timerWait (this=0xb6c04d34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x039337a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb460e0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x053eee6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x053ef279 in ?? () from /lib/libglib-2.0.so.0
#8  0x053ef848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x0393359f in QEventDispatcherGlib::processEvents (this=0x9052488, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#10 0x03903609 in QEventLoop::processEvents (this=0xb460e290, flags=) at kernel/qeventloop.cpp:149
#11 0x03903a8a in QEventLoop::exec (this=0xb460e290, flags=...) at kernel/qeventloop.cpp:201
#12 0x037ffb7e in QThread::exec (this=0x9052540) at thread/qthread.cpp:490
#13 0x007da39e in utp::UTPServerThread::run (this=0x9052540) at ../../src/utp/utpserverthread.cpp:44
#14 0x03802df9 in QThreadPrivate::start (arg=0x9052540) at thread/qthread_unix.cpp:266
#15 0x009ebcc9 in start_thread () from /lib/libpthread.so.0
#16 0x01a276be in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb3e0db70 (LWP 1728)):
#0  0x009ca416 in __kernel_vsyscall ()
#1  0x01a20391 in select () from /lib/libc.so.6
#2  0x0079c8db in dht::RPCServerThread::run (this=0x8eb93f8) at ../../src/dht/rpcserver.cpp:107
#3  0x03802df9 in QThreadPrivate::start (arg=0x8eb93f8) at thread/qthread_unix.cpp:266
#4  0x009ebcc9 in start_thread () from /lib/libpthread.so.0
#5  0x01a276be in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa93ffb70 (LWP 1782)):
#0  net::Poll::add (this=0x8e93980, fd=60, mode=net::Poll::INPUT) at ../../src/net/poll.cpp:47
#1  0x0072afe8 in net::Socket::prepare (this=0xa9561370, p=0x8e93980, mode=net::Poll::INPUT) at ../../src/net/socket.cpp:460
#2  0x0072f4a0 in net::DownloadThread::waitForSocketReady (this=0x8e93978) at ../../src/net/downloadthread.cpp:123
#3  0x0072f5af in net::DownloadThread::update (this=0x8e93978) at ../../src/net/downloadthread.cpp:48
#4  0x00730178 in net::NetworkThread::run (this=0x8e93978) at ../../src/net/networkthread.cpp:48
#5  0x03802df9 in QThreadPrivate::start (arg=0x8e93978) at thread/qthread_unix.cpp:266
#6  0x009ebcc9 in start_thread () from /lib/libpthread.so.0
#7  0x01a276be in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa8bfeb70 (LWP 1783)):
#0  0x009ca416 in __kernel_vsyscall ()
#1  0x009f04dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x03801ef2 in QMutexPrivate::wait (this=0x8e93910, timeout=-1) at thread/qmutex_unix.cpp:84
#3  0x037fd5ca in QMutex::lock (this=0x8116894) at thread/qmutex.cpp:167
#4  0x0072d890 in net::SocketMonitor::lock (this=0x8116890) at ../../src/net/socketmonitor.cpp:82
#5  0x0072eb15 in net::UploadThread::update (this=0x8e93d80) at ../../src/net/uploadthread.cpp:49
#6  0x00730178 in net::NetworkThread::run (this=0x8e93d80) at ../../src/net/networkthread.cpp:48
#7  0x03802df9 in QThreadPrivate::start (arg=0x8e93d80) at thread/qthread_unix.cpp:266
#8  0x009ebcc9 in start_thread () from /lib/libpthread.so.0
#9  0x01a276be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77ba710 (LWP 1724)):
[KCrash Handler]
#7  0x019ccfd1 in ?? () from /lib/libc.so.6
#8  0x007a37a6 in bt::Chunk::readPiece (this=0x90fdf30, off=2932736, len=16384, data=0xb263f285 "A,:\025\016\271\060\267m\222\227\031U") at //usr/include/bits/string3.h:52
#9  0x00752bea in bt::Packet::Packet (this=0xa94fcf18, index=6480, begin=2932736, len=16384, ch=0x90fdf30) at ../../src/download/packet.cpp:85
#10 0x0074ca5f in bt::PacketWriter::sendChunk (this=0xb2631288, index=6480, begin=2932736, len=16384, ch=0x90fdf30) at ../../src/peer/packetwriter.cpp:195
#11 0x0074b2fc in bt::PeerUploader::update (this=0xa9543c28, cman=..., opt_unchoked=11494) at ../../src/peer/peeruploader.cpp:83
#12 0x007740d8 in bt::Uploader::update (this=0x911a920, opt_unchoked=11494) at ../../src/torrent/uploader.cpp:48
#13 0x0077cd71 in bt::TorrentControl::update (this=0x90ba080) at ../../src/torrent/torrentcontrol.cpp:173
#14 0x080690f3 in kt::Core::update (this=0xb6c04810) at ../../ktorrent/core.cpp:1030
#15 0x080716cd in kt::Core::qt_metacall (this=0xb6c04810, _c=QMetaObject::InvokeMetaMethod, _id=2932736, _a=0xbf8515ac) at ./core.moc:167
#16 0x0390a8ca in QMetaObject::metacall (object=0xb6c04810, cl=415, idx=22, argv=0xbf8515ac) at kernel/qmetaobject.cpp:237
#17 0x0391d6ad in QMetaObject::activate (sender=0xb6c04824, m=0x3a375a4, local_signal_index=0, argv=0x2cc000) at kernel/qobject.cpp:3280
#18 0x0396f1e7 in QTimer::timeout (this=0xb6c04824) at .moc/release-shared/moc_qtimer.cpp:134
#19 0x039231ce in QTimer::timerEvent (this=0xb6c04824, e=0xbf851ab0) at kernel/qtimer.cpp:271
#20 0x03917504 in QObject::event (this=0xb6c04824, e=0xbf85125c) at kernel/qobject.cpp:1183
#21 0x061cbfdc in QApplicationPrivate::notify_helper (this=0x8eb7348, receiver=0xb6c04824, e=0xbf851ab0) at kernel/qapplication.cpp:4396
#22 0x061d204e in QApplication::notify (this=0xbf851e00, receiver=0xb6c04824, e=0xbf851ab0) at kernel/qapplication.cpp:3798
#23 0x080783dc in kt::App::notify (this=0x19f, receiver=0xbf85125c, event=0x2cc000) at ../../ktorrent/app.cpp:97
#24 0x03904b3b in QCoreApplication::notifyInternal (this=0xbf851e00, receiver=0xb6c04824, event=0xbf851ab0) at kernel/qcoreapplication.cpp:732
#25 0x03936ad6 in sendEvent (this=0x8ebd1bc) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x8ebd1bc) at kernel/qeventdispatcher_unix.cpp:602
#27 0x039338a7 in timerSourceDispatch (source=0x8ebd600) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=0x8ebd600) at kernel/qeventdispatcher_glib.cpp:231
#29 0x053eb855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x053ef668 in ?? () from /lib/libglib-2.0.so.0
#31 0x053ef848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x03933565 in QEventDispatcherGlib::processEvents (this=0x8e926d8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#33 0x0628dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8e926d8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x03903609 in QEventLoop::processEvents (this=0xbf851d74, flags=) at kernel/qeventloop.cpp:149
#35 0x03903a8a in QEventLoop::exec (this=0xbf851d74, flags=...) at kernel/qeventloop.cpp:201
#36 0x0390800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#37 0x061cae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#38 0x08066e91 in main (argc=5, argv=0xbf852204) at ../../ktorrent/main.cpp:176

Possible duplicates by query: bug 255577, bug 247984.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-11-28 10:03:23 UTC

*** This bug has been marked as a duplicate of bug 247984 ***