Bug 258341 - kTorrent crashes repeatedly
Summary: kTorrent crashes repeatedly
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-30 05:18 UTC by two_of_clubs
Modified: 2010-11-30 18:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description two_of_clubs 2010-11-30 05:18:59 UTC
Application: ktorrent (3.3.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-26-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I am running the ktorrent web interface on Ubuntu and the program is constantly crashing even though it is the only thing running. I have no idea why.

The crash can be reproduced every time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7710710 (LWP 1281))]

Thread 4 (Thread 0xb0a2fb70 (LWP 1523)):
#0  net::DownloadThread::waitForSocketReady (this=0x9775560) at ../../libbtcore/net/downloadthread.cpp:157
#1  0x00773a4f in net::DownloadThread::update (this=0x9775560) at ../../libbtcore/net/downloadthread.cpp:53
#2  0x007746b8 in net::NetworkThread::run (this=0x9775560) at ../../libbtcore/net/networkthread.cpp:48
#3  0x032aa32e in QThreadPrivate::start (arg=0x9775560) at thread/qthread_unix.cpp:248
#4  0x00ea896e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x023bba4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xb022eb70 (LWP 1524)):
#0  0x008d7422 in __kernel_vsyscall ()
#1  0x00ead015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x032ab287 in QWaitConditionPrivate::wait (this=0x97758f8, mutex=0x97758fc, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x97758f8, mutex=0x97758fc, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x007733a9 in net::UploadThread::update (this=0x97758c0) at ../../libbtcore/net/uploadthread.cpp:73
#5  0x007746b8 in net::NetworkThread::run (this=0x97758c0) at ../../libbtcore/net/networkthread.cpp:48
#6  0x032aa32e in QThreadPrivate::start (arg=0x97758c0) at thread/qthread_unix.cpp:248
#7  0x00ea896e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x023bba4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xafa2db70 (LWP 1525)):
#0  0x008d7422 in __kernel_vsyscall ()
#1  0x023abe2b in read () from /lib/tls/i686/cmov/libc.so.6
#2  0x0235542b in _IO_file_underflow () from /lib/tls/i686/cmov/libc.so.6
#3  0x02356ccb in _IO_default_uflow () from /lib/tls/i686/cmov/libc.so.6
#4  0x023580f8 in __uflow () from /lib/tls/i686/cmov/libc.so.6
#5  0x0234b28c in _IO_getline_info () from /lib/tls/i686/cmov/libc.so.6
#6  0x0234b1d1 in _IO_getline () from /lib/tls/i686/cmov/libc.so.6
#7  0x0234a21a in fgets () from /lib/tls/i686/cmov/libc.so.6
#8  0x092c0cd4 in ?? () from /lib/libnss_mdns4.so.2
#9  0x092c1177 in _nss_mdns4_gethostbyaddr_r () from /lib/libnss_mdns4.so.2
#10 0x023d236b in gethostbyaddr_r () from /lib/tls/i686/cmov/libc.so.6
#11 0x023d75db in getnameinfo () from /lib/tls/i686/cmov/libc.so.6
#12 0x0077792b in net::ReverseResolver::resolve (this=0xa2d4f28, addr=...) at ../../libbtcore/net/reverseresolver.cpp:64
#13 0x007779c3 in net::ReverseResolver::run (this=0xa2d4f28) at ../../libbtcore/net/reverseresolver.cpp:73
#14 0x00777ac7 in net::ReverseResolverThread::run (this=0x9e7c488) at ../../libbtcore/net/reverseresolver.cpp:118
#15 0x032aa32e in QThreadPrivate::start (arg=0x9e7c488) at thread/qthread_unix.cpp:248
#16 0x00ea896e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#17 0x023bba4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7710710 (LWP 1281)):
[KCrash Handler]
#6  0x023fe277 in ?? () from /lib/tls/i686/cmov/libc.so.6
#7  0x00fbeff4 in ?? () from /usr/lib/libqca.so.2
#8  0x00f35167 in QCA::Hash::update(QByteArray const&) () from /usr/lib/libqca.so.2
#9  0x0075d18f in bt::SHA1HashGen::update (this=0x9f6a1d8, data=0xb5646000 "\372\252\335\365\322", len=16384) at ../../libbtcore/util/sha1hashgen.cpp:240
#10 0x00795b7e in bt::ChunkDownload::updateHash (this=0x9f6a168) at ../../libbtcore/download/chunkdownload.cpp:579
#11 0x0079740d in bt::ChunkDownload::piece (this=0x9f6a168, p=..., ok=@0xbfc2213f) at ../../libbtcore/download/chunkdownload.cpp:145
#12 0x0079daf9 in bt::Downloader::pieceReceived (this=0x9a69e80, p=...) at ../../libbtcore/download/downloader.cpp:126
#13 0x0078541f in bt::PeerManager::pieceReceived (this=0x9a4a228, p=...) at ../../libbtcore/peer/peermanager.cpp:677
#14 0x00783abf in bt::Peer::packetReady (this=0x9fa0c68, packet=0xb5892440 "\a", len=16393) at ../../libbtcore/peer/peer.cpp:268
#15 0x0078dba9 in bt::PacketReader::update (this=0xa20a5a8) at ../../libbtcore/peer/packetreader.cpp:141
#16 0x00783409 in bt::Peer::update (this=0x9fa0c68) at ../../libbtcore/peer/peer.cpp:462
#17 0x00787886 in bt::PeerManager::update (this=0x9a4a228) at ../../libbtcore/peer/peermanager.cpp:119
#18 0x007b997d in bt::TorrentControl::update (this=0x9a42aa8) at ../../libbtcore/torrent/torrentcontrol.cpp:150
#19 0x08071a63 in kt::Core::update (this=0x98db300) at ../../ktorrent/core.cpp:849
#20 0x08077308 in kt::Core::qt_metacall (this=0x98db300, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfc224bc) at ./core.moc:155
#21 0x033b1c9a in QMetaObject::metacall (object=0x98db300, cl=12272, idx=21, argv=0xbfc224bc) at kernel/qmetaobject.cpp:237
#22 0x033c03d5 in QMetaObject::activate (sender=0x98db314, m=0x34c05a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#23 0x03411aa7 in QTimer::timeout (this=0x98db314) at .moc/release-shared/moc_qtimer.cpp:134
#24 0x033c860e in QTimer::timerEvent (this=0x98db314, e=0xbfc229f0) at kernel/qtimer.cpp:271
#25 0x033bd254 in QObject::event (this=0x98db314, e=0xa0c0900) at kernel/qobject.cpp:1212
#26 0x03f804dc in QApplicationPrivate::notify_helper (this=0x9797750, receiver=0x98db314, e=0xbfc229f0) at kernel/qapplication.cpp:4300
#27 0x03f8705e in QApplication::notify (this=0xbfc22d44, receiver=0x98db314, e=0xbfc229f0) at kernel/qapplication.cpp:3704
#28 0x002eff2a in KApplication::notify (this=0xbfc22d44, receiver=0x98db314, event=0xbfc229f0) at ../../kdeui/kernel/kapplication.cpp:302
#29 0x033aca3b in QCoreApplication::notifyInternal (this=0xbfc22d44, receiver=0x98db314, event=0xbfc229f0) at kernel/qcoreapplication.cpp:704
#30 0x033dbd66 in QCoreApplication::sendEvent (this=0x979c084) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QTimerInfoList::activateTimers (this=0x979c084) at kernel/qeventdispatcher_unix.cpp:603
#32 0x033d8917 in timerSourceDispatch (source=0x979c0b8) at kernel/qeventdispatcher_glib.cpp:184
#33 idleTimerSourceDispatch (source=0x979c0b8) at kernel/qeventdispatcher_glib.cpp:231
#34 0x07b7b5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x07b7f2d8 in ?? () from /lib/libglib-2.0.so.0
#36 0x07b7f4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x033d85d5 in QEventDispatcherGlib::processEvents (this=0x9774380, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#38 0x04040135 in QGuiEventDispatcherGlib::processEvents (this=0x9774380, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x033ab059 in QEventLoop::processEvents (this=0xbfc22cb4, flags=) at kernel/qeventloop.cpp:149
#40 0x033ab4aa in QEventLoop::exec (this=0xbfc22cb4, flags=...) at kernel/qeventloop.cpp:201
#41 0x033af69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#42 0x03f80577 in QApplication::exec () at kernel/qapplication.cpp:3579
#43 0x08067a51 in main (argc=3, argv=0xbfc23114) at ../../ktorrent/main.cpp:172

Possible duplicates by query: bug 257617, bug 257314, bug 256822, bug 256345, bug 255263.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-11-30 18:12:27 UTC

*** This bug has been marked as a duplicate of bug 247984 ***