Bug 260347 - Ktorrent crash when changing torren position in queue manager
Summary: Ktorrent crash when changing torren position in queue manager
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-17 09:43 UTC by Yevgeniy
Modified: 2010-12-17 18:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yevgeniy 2010-12-17 09:43:34 UTC
Application: ktorrent (4.0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Changing position (move up) of a torrent in queue manager.
Data files are located on external USB disk with NTFS.
USB disk was automounted in /media.
I am not sure but may be the USB disk was auto unmounted because of no disk activity (torrent was in stalled state and I moved another torrent up in the queue).

The crash can be reproduced some of the time.

-- Backtrace:
Application: KTorrent (ktorrent), signal: Bus error
[Current thread is 1 (Thread 0xb7890710 (LWP 3794))]

Thread 6 (Thread 0xb2bbab70 (LWP 3809)):
#0  0x02e56693 in g_main_context_acquire () from /lib/libglib-2.0.so.0
#1  0x02e581ee in ?? () from /lib/libglib-2.0.so.0
#2  0x02e58848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x0152359f in QEventDispatcherGlib::processEvents (this=0x9412120, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0x014f3609 in QEventLoop::processEvents (this=0xb2bba290, flags=) at kernel/qeventloop.cpp:149
#5  0x014f3a8a in QEventLoop::exec (this=0xb2bba290, flags=...) at kernel/qeventloop.cpp:201
#6  0x013efb7e in QThread::exec (this=0x944b730) at thread/qthread.cpp:490
#7  0x014d235b in QInotifyFileSystemWatcherEngine::run (this=0x944b730) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x013f2df9 in QThreadPrivate::start (arg=0x944b730) at thread/qthread_unix.cpp:266
#9  0x003f2cc9 in start_thread () from /lib/libpthread.so.0
#10 0x07e2669e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb22feb70 (LWP 3861)):
#0  0x00442416 in __kernel_vsyscall ()
#1  0x07e1f371 in select () from /lib/libc.so.6
#2  0x00c598db in dht::RPCServerThread::run (this=0x91352b0) at ../../src/dht/rpcserver.cpp:107
#3  0x013f2df9 in QThreadPrivate::start (arg=0x91352b0) at thread/qthread_unix.cpp:266
#4  0x003f2cc9 in start_thread () from /lib/libpthread.so.0
#5  0x07e2669e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb12fcb70 (LWP 4391)):
#0  0x00442416 in __kernel_vsyscall ()
#1  0x003f7884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x013f233e in thread_sleep (ti=0x1) at thread/qthread_unix.cpp:416
#3  0x013f2493 in QThread::msleep (msecs=250) at thread/qthread_unix.cpp:442
#4  0x00bec802 in net::DownloadThread::update (this=0x8e7f978) at ../../src/net/downloadthread.cpp:91
#5  0x00bed178 in net::NetworkThread::run (this=0x8e7f978) at ../../src/net/networkthread.cpp:48
#6  0x013f2df9 in QThreadPrivate::start (arg=0x8e7f978) at thread/qthread_unix.cpp:266
#7  0x003f2cc9 in start_thread () from /lib/libpthread.so.0
#8  0x07e2669e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb0afbb70 (LWP 4392)):
#0  0x00442416 in __kernel_vsyscall ()
#1  0x003f7884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x013f233e in thread_sleep (ti=0x1) at thread/qthread_unix.cpp:416
#3  0x013f2493 in QThread::msleep (msecs=250) at thread/qthread_unix.cpp:442
#4  0x00bebd52 in net::UploadThread::update (this=0x8e7fd80) at ../../src/net/uploadthread.cpp:89
#5  0x00bed178 in net::NetworkThread::run (this=0x8e7fd80) at ../../src/net/networkthread.cpp:48
#6  0x013f2df9 in QThreadPrivate::start (arg=0x8e7fd80) at thread/qthread_unix.cpp:266
#7  0x003f2cc9 in start_thread () from /lib/libpthread.so.0
#8  0x07e2669e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb02fab70 (LWP 4393)):
#0  0x00442416 in __kernel_vsyscall ()
#1  0x003f74dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x013f39c7 in wait (this=0x98550fc, mutex=0x98550f8, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x98550fc, mutex=0x98550f8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0x00bf08f2 in net::ReverseResolverThread::run (this=0x98550f0) at ../../src/net/reverseresolver.cpp:123
#5  0x013f2df9 in QThreadPrivate::start (arg=0x98550f0) at thread/qthread_unix.cpp:266
#6  0x003f2cc9 in start_thread () from /lib/libpthread.so.0
#7  0x07e2669e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7890710 (LWP 3794)):
[KCrash Handler]
#7  0x07dcbfd1 in ?? () from /lib/libc.so.6
#8  0x00c607a6 in bt::Chunk::readPiece (this=0x9a26648, off=3129344, len=16384, data=0xa508fc5 "") at //usr/include/bits/string3.h:52
#9  0x00c0fbea in bt::Packet::Packet (this=0x97a9c78, index=1121, begin=3129344, len=16384, ch=0x9a26648) at ../../src/download/packet.cpp:85
#10 0x00c09a5f in bt::PacketWriter::sendChunk (this=0xa5e7288, index=1121, begin=3129344, len=16384, ch=0x9a26648) at ../../src/peer/packetwriter.cpp:195
#11 0x00c082fc in bt::PeerUploader::update (this=0x97b9fa8, cman=..., opt_unchoked=14885) at ../../src/peer/peeruploader.cpp:83
#12 0x00c310d8 in bt::Uploader::update (this=0x9d27dc8, opt_unchoked=14885) at ../../src/torrent/uploader.cpp:48
#13 0x00c39d71 in bt::TorrentControl::update (this=0x9e9c1f8) at ../../src/torrent/torrentcontrol.cpp:173
#14 0x080690f3 in kt::Core::update (this=0x8f8b080) at ../../ktorrent/core.cpp:1030
#15 0x080716cd in kt::Core::qt_metacall (this=0x8f8b080, _c=QMetaObject::InvokeMetaMethod, _id=3129344, _a=0xbfd6b6ec) at ./core.moc:167
#16 0x014fa8ca in QMetaObject::metacall (object=0x8f8b080, cl=4096, idx=22, argv=0xbfd6b6ec) at kernel/qmetaobject.cpp:237
#17 0x0150d6ad in QMetaObject::activate (sender=0x8f8b094, m=0x16275a4, local_signal_index=0, argv=0x2fc000) at kernel/qobject.cpp:3280
#18 0x0155f1e7 in QTimer::timeout (this=0x8f8b094) at .moc/release-shared/moc_qtimer.cpp:134
#19 0x015131ce in QTimer::timerEvent (this=0x8f8b094, e=0xbfd6bbf0) at kernel/qtimer.cpp:271
#20 0x01507504 in QObject::event (this=0x8f8b094, e=0xbfd6b39c) at kernel/qobject.cpp:1183
#21 0x01754fdc in QApplicationPrivate::notify_helper (this=0x8ea27a8, receiver=0x8f8b094, e=0xbfd6bbf0) at kernel/qapplication.cpp:4396
#22 0x0175b04e in QApplication::notify (this=0xbfd6bf40, receiver=0x8f8b094, e=0xbfd6bbf0) at kernel/qapplication.cpp:3798
#23 0x080783dc in kt::App::notify (this=0x1000, receiver=0xbfd6b39c, event=0x2fc000) at ../../ktorrent/app.cpp:97
#24 0x014f4b3b in QCoreApplication::notifyInternal (this=0xbfd6bf40, receiver=0x8f8b094, event=0xbfd6bbf0) at kernel/qcoreapplication.cpp:732
#25 0x01526ad6 in sendEvent (this=0x8ea3b74) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x8ea3b74) at kernel/qeventdispatcher_unix.cpp:602
#27 0x015238a7 in timerSourceDispatch (source=0x8ea3ba8) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=0x8ea3ba8) at kernel/qeventdispatcher_glib.cpp:231
#29 0x02e54855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x02e58668 in ?? () from /lib/libglib-2.0.so.0
#31 0x02e58848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x01523565 in QEventDispatcherGlib::processEvents (this=0x8e7e6d8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#33 0x01816be5 in QGuiEventDispatcherGlib::processEvents (this=0x8e7e6d8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x014f3609 in QEventLoop::processEvents (this=0xbfd6beb4, flags=) at kernel/qeventloop.cpp:149
#35 0x014f3a8a in QEventLoop::exec (this=0xbfd6beb4, flags=...) at kernel/qeventloop.cpp:201
#36 0x014f800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#37 0x01753e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#38 0x08066e91 in main (argc=5, argv=0xbfd6c344) at ../../ktorrent/main.cpp:176

Possible duplicates by query: bug 258038, bug 258034, bug 255577, bug 247984.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-12-17 18:46:38 UTC

*** This bug has been marked as a duplicate of bug 247984 ***