Bug 258248 - seems to crash when I have Ktorrent and Firefox open at the same time.
Summary: seems to crash when I have Ktorrent and Firefox open at the same time.
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-29 06:14 UTC by phueduiq
Modified: 2010-11-29 18:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description phueduiq 2010-11-29 06:14:54 UTC
Application that crashed: ktorrent
Version of the application: 3.2.4
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-22-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
While downloading with Ktorrent, the program crashes after about 30 seconds, if i have Firefox open at the same time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f8ec0c54750 (LWP 19491))]

Thread 8 (Thread 0x7f8e980fb910 (LWP 19503)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f8e99e42c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8eb9ff6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f8ebd376d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f8e967d8910 (LWP 19504)):
#0  0x00007f8ebd36a8e3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8eb932537c in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f8eb93256c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f8ebead31fe in QEventDispatcherGlib::processEvents (this=0x15e4930, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#4  0x00007f8ebeaa9532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f8ebeaa9904 in QEventLoop::exec (this=0x7f8e967d8000, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f8ebe9c16cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f8e9a09d56e in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#8  0x00007f8ebe9c4445 in QThreadPrivate::start (arg=0x15faf30) at thread/qthread_unix.cpp:188
#9  0x00007f8eb9ff6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f8ebd376d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 6 (Thread 0x7f8e91bc5910 (LWP 19517)):
#0  0x00007f8ebd36a8e3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=333) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8e95dd3cbe in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#2  0x00007f8eb9ff6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f8ebd376d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 5 (Thread 0x7f8e959c0910 (LWP 19518)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f8e99e53983 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f8eb9ff6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007f8ebd376d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f8e949be910 (LWP 19523)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f8ebe9c5462 in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0xb70cd0, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xb70cd0, time=30000) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f8ebe9bb4f2 in QThreadPoolThread::run (this=<value optimized out>) at concurrent/qthreadpool.cpp:140
#4  0x00007f8ebe9c4445 in QThreadPrivate::start (arg=0x7f8ea01a5d60) at thread/qthread_unix.cpp:188
#5  0x00007f8eb9ff6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f8ebd376d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 3 (Thread 0x7f8eaee05910 (LWP 19550)):
#0  0x00007f8ebd36a8e3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8ec078a1f9 in net::DownloadThread::waitForSocketReady (this=0x97a530, timeout=<value optimized out>) at ../../libbtcore/net/downloadthread.cpp:188
#2  0x00007f8ec078a2bc in net::DownloadThread::update (this=0x1ccbf60) at ../../libbtcore/net/downloadthread.cpp:53
#3  0x00007f8ec078ac89 in net::NetworkThread::run (this=0x97a530) at ../../libbtcore/net/networkthread.cpp:48
#4  0x00007f8ebe9c4445 in QThreadPrivate::start (arg=0x97a530) at thread/qthread_unix.cpp:188
#5  0x00007f8eb9ff6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f8ebd376d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f8ea7fff910 (LWP 19551)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f8ebe9c54fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x97aeb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x97aeb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f8ec0789b88 in net::UploadThread::update (this=0x97ae40) at ../../libbtcore/net/uploadthread.cpp:73
#4  0x00007f8ec078ac89 in net::NetworkThread::run (this=0x97ae40) at ../../libbtcore/net/networkthread.cpp:48
#5  0x00007f8ebe9c4445 in QThreadPrivate::start (arg=0x97ae40) at thread/qthread_unix.cpp:188
#6  0x00007f8eb9ff6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#7  0x00007f8ebd376d4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 1 (Thread 0x7f8ec0c54750 (LWP 19491)):
[KCrash Handler]
#5  memcpy () at ../sysdeps/x86_64/memcpy.S:267
#6  0x00007f8ebcd96276 in QCA::MemoryRegion::MemoryRegion(QByteArray const&) () from /usr/lib/libqca.so.2
#7  0x00007f8ebcdad9d4 in QCA::Hash::update(char const*, int) () from /usr/lib/libqca.so.2
#8  0x00007f8ec07a72d2 in bt::ChunkDownload::updateHash (this=0xfe4550) at ../../libbtcore/download/chunkdownload.cpp:562
#9  0x00007f8ec07a8055 in bt::ChunkDownload::piece (this=0xfe4550, p=..., ok=<value optimized out>) at ../../libbtcore/download/chunkdownload.cpp:133
#10 0x00007f8ec07ae8be in bt::Downloader::pieceReceived (this=0xebd980, p=...) at ../../libbtcore/download/downloader.cpp:133
#11 0x00007f8ec0797091 in bt::Peer::packetReady (this=0x1cbe420, packet=0x187ee30 "\a", len=<value optimized out>) at ../../libbtcore/peer/peer.cpp:269
#12 0x00007f8ec079ff95 in bt::PacketReader::update (this=0x1b967a0) at ../../libbtcore/peer/packetreader.cpp:131
#13 0x00007f8ec0796dd5 in bt::Peer::update (this=0x1cbe420) at ../../libbtcore/peer/peer.cpp:474
#14 0x00007f8ec079a7c0 in bt::PeerManager::update (this=0xeb3ee0) at ../../libbtcore/peer/peermanager.cpp:117
#15 0x00007f8ec07cb4cc in bt::TorrentControl::update (this=0xeb2f70) at ../../libbtcore/torrent/torrentcontrol.cpp:178
#16 0x000000000042c1c2 in kt::Core::update (this=0xb7feb0) at ../../ktorrent/core.cpp:877
#17 0x0000000000431d2c in kt::Core::qt_metacall (this=0xb7feb0, _c=QMetaObject::InvokeMetaMethod, _id=214, _a=0x7fffae3ec000) at ./core.moc:148
#18 0x00007f8ebeabfddc in QMetaObject::activate (sender=0xb7fed8, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x6dd) at kernel/qobject.cpp:3113
#19 0x00007f8ebeab9d83 in QObject::event (this=0xb7fed8, e=0x7f8eadb87000) at kernel/qobject.cpp:1075
#20 0x00007f8ebdf52efc in QApplicationPrivate::notify_helper (this=0x9af060, receiver=0xb7fed8, e=0x7fffae3ec600) at kernel/qapplication.cpp:4056
#21 0x00007f8ebdf5a1ce in QApplication::notify (this=0x7fffae3ec930, receiver=0xb7fed8, e=0x7fffae3ec600) at kernel/qapplication.cpp:4021
#22 0x00007f8ebf97cab6 in KApplication::notify (this=0x7fffae3ec930, receiver=0xb7fed8, event=0x7fffae3ec600) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007f8ebeaaac2c in QCoreApplication::notifyInternal (this=0x7fffae3ec930, receiver=0xb7fed8, event=0x7fffae3ec600) at kernel/qcoreapplication.cpp:610
#24 0x00007f8ebead5862 in QCoreApplication::sendEvent (this=0x9a8b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#25 QTimerInfoList::activateTimers (this=0x9a8b60) at kernel/qeventdispatcher_unix.cpp:572
#26 0x00007f8ebead325d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#27 0x00007f8eb9321bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#28 0x00007f8eb9325598 in ?? () from /lib/libglib-2.0.so.0
#29 0x00007f8eb93256c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#30 0x00007f8ebead31a6 in QEventDispatcherGlib::processEvents (this=0x977530, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#31 0x00007f8ebdfe74be in QGuiEventDispatcherGlib::processEvents (this=0x1761179, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007f8ebeaa9532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#33 0x00007f8ebeaa9904 in QEventLoop::exec (this=0x7fffae3ec8a0, flags=) at kernel/qeventloop.cpp:201
#34 0x00007f8ebeaabab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x0000000000424ef2 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../ktorrent/main.cpp:171
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Joris Guisson 2010-11-29 18:07:12 UTC

*** This bug has been marked as a duplicate of bug 247984 ***