Bug 256822 - ktorrent still crashing spontaneously
Summary: ktorrent still crashing spontaneously
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-13 17:16 UTC by yinghu37
Modified: 2010-11-13 18:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yinghu37 2010-11-13 17:16:57 UTC
Application: ktorrent (4.0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Running ktorrent with 4 torrents, two actively downloading; nothing else particularly running on computer; ktorrent crashed while user away from machine.

-- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f05de76b760 (LWP 10285))]

Thread 6 (Thread 0x7f05cfba7710 (LWP 10286)):
#0  0x00007f05dba1e665 in __pthread_mutex_lock (mutex=0x2505a58) at pthread_mutex_lock.c:61
#1  0x00007f05d513f8bf in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x00007f05d513fe78 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f05d51407b5 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x00007f05d02de0f4 in ?? () from /usr/lib/libgio-2.0.so.0
#5  0x00007f05d51657e4 in ?? () from /lib/libglib-2.0.so.0
#6  0x00007f05dba1c971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007f05da2f191d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f05c1e80710 (LWP 10291)):
#0  0x00007f05da2ea2b3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f05de2e5212 in dht::RPCServerThread::run (this=0x271e880) at ../../src/dht/rpcserver.cpp:107
#2  0x00007f05dbca727e in QThreadPrivate::start (arg=0x271e880) at thread/qthread_unix.cpp:266
#3  0x00007f05dba1c971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f05da2f191d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f05c14f3710 (LWP 10310)):
#0  0x00007f05de282865 in net::DownloadThread::update (this=0x2483320) at ../../src/net/downloadthread.cpp:65
#1  0x00007f05de2832c9 in net::NetworkThread::run (this=0x2483320) at ../../src/net/networkthread.cpp:48
#2  0x00007f05dbca727e in QThreadPrivate::start (arg=0x2483320) at thread/qthread_unix.cpp:266
#3  0x00007f05dba1c971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f05da2f191d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f05bbfff710 (LWP 10311)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f05dbca6845 in thread_sleep (ti=0x7f05bbffeda0) at thread/qthread_unix.cpp:416
#2  0x00007f05dbca69b0 in QThread::msleep (msecs=<value optimized out>) at thread/qthread_unix.cpp:442
#3  0x00007f05de28207d in net::UploadThread::update (this=0x2483990) at ../../src/net/uploadthread.cpp:89
#4  0x00007f05de2832c9 in net::NetworkThread::run (this=0x2483990) at ../../src/net/networkthread.cpp:48
#5  0x00007f05dbca727e in QThreadPrivate::start (arg=0x2483990) at thread/qthread_unix.cpp:266
#6  0x00007f05dba1c971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007f05da2f191d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f05c0cf2710 (LWP 10312)):
#0  0x00007f05da2e51d3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=4961) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f05d59f9383 in send_dg (statp=0x7f05c0cf2dc8, buf=<value optimized out>, buflen=<value optimized out>, buf2=0x0, buflen2=<value optimized out>, ansp=<value optimized out>, anssizp=0x7f05c0cf0950, terrno=0x7f05c0cf08f8, ns=0, v_circuit=0x7f05c0cf08f4, gotsomewhere=0x7f05c0cf08fc, anscp=0x7f05c0cf1400, ansp2=0x0, anssizp2=0x0, resplen2=0x0) at res_send.c:1066
#2  0x00007f05d59fb004 in __libc_res_nsend (statp=0x7f05c0cf2dc8, buf=<value optimized out>, buflen=<value optimized out>, buf2=0x0, buflen2=<value optimized out>, ans=0x7f05c0cf0b70 "\355\252\201\200", anssiz=1024, ansp=0x7f05c0cf1400, ansp2=0x0, nansp2=0x0, resplen2=0x0) at res_send.c:556
#3  0x00007f05d59f7665 in __libc_res_nquery (statp=0x7f05c0cf2dc8, name=<value optimized out>, class=<value optimized out>, type=<value optimized out>, answer=0x7f05c0cf0b70 "\355\252\201\200", anslen=<value optimized out>, answerp=0x7f05c0cf1400, answerp2=0x0, nanswerp2=0x0, resplen2=0x0) at res_query.c:225
#4  0x00007f05c00ebfd1 in _nss_dns_gethostbyaddr2_r (addr=<value optimized out>, len=<value optimized out>, af=2, result=<value optimized out>, buffer=<value optimized out>, buflen=<value optimized out>, errnop=0x7f05c0cf2698, h_errnop=0x7f05c0cf1b8c, ttlp=0x0) at nss_dns/dns-host.c:471
#5  0x00007f05c00ec145 in _nss_dns_gethostbyaddr_r (addr=0x7f05c0cf0810, len=1, af=4961, result=0xffffffffffffffff, buffer=0x0, buflen=139662686357528, errnop=0x7f05c0cf2698, h_errnop=0x7f05c0cf1b8c) at nss_dns/dns-host.c:530
#6  0x00007f05da30c568 in __gethostbyaddr_r (addr=0x2e631c4, len=4, type=<value optimized out>, resbuf=0x7f05c0cf1b50, buffer=<value optimized out>, buflen=<value optimized out>, result=0x7f05c0cf1b80, h_errnop=0x7f05c0cf1b8c) at ../nss/getXXbyYY_r.c:253
#7  0x00007f05da312b5b in getnameinfo (sa=0x2e631c0, addrlen=<value optimized out>, host=0x7f05c0cf1cb0 "", hostlen=199, serv=0x7f05c0cf1be0 "", servlen=199, flags=<value optimized out>) at getnameinfo.c:223
#8  0x00007f05de285f4f in net::ReverseResolver::resolve (this=<value optimized out>, addr=...) at ../../src/net/reverseresolver.cpp:64
#9  0x00007f05de285ff0 in net::ReverseResolver::run (this=0x33037d0) at ../../src/net/reverseresolver.cpp:73
#10 0x00007f05de2861dd in net::ReverseResolverThread::run (this=0x2e3f210) at ../../src/net/reverseresolver.cpp:118
#11 0x00007f05dbca727e in QThreadPrivate::start (arg=0x2e3f210) at thread/qthread_unix.cpp:266
#12 0x00007f05dba1c971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#13 0x00007f05da2f191d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f05de76b760 (LWP 10285)):
[KCrash Handler]
#6  memcpy () at ../sysdeps/x86_64/memcpy.S:267
#7  0x00007f05d9d0c0b6 in QCA::MemoryRegion::MemoryRegion(QByteArray const&) () from /usr/lib/libqca.so.2
#8  0x00007f05d9d224c5 in QCA::Hash::update(QByteArray const&) () from /usr/lib/libqca.so.2
#9  0x00007f05de26b4ab in bt::SHA1HashGen::update (this=0x46539f0, data=0x7f05c0006e13 "%\207j\351\306P3g\341Z\234\203\343", len=16384) at ../../src/util/sha1hashgen.cpp:240
#10 0x00007f05de2a60e3 in bt::ChunkDownload::updateHash (this=0x4653930) at ../../src/download/chunkdownload.cpp:555
#11 0x00007f05de2a82e8 in bt::ChunkDownload::piece (this=0x4653930, p=..., ok=<value optimized out>) at ../../src/download/chunkdownload.cpp:127
#12 0x00007f05de2aebde in bt::Downloader::pieceReceived (this=0x7f05b00079e0, p=...) at ../../src/download/downloader.cpp:134
#13 0x00007f05de292315 in bt::Peer::packetReady (this=0x3651d00, packet=0x7f05b0244a00 "\a", len=<value optimized out>) at ../../src/peer/peer.cpp:283
#14 0x00007f05de29d248 in bt::PacketReader::update (this=0x42ddc10) at ../../src/peer/packetreader.cpp:141
#15 0x00007f05de2910d5 in bt::Peer::update (this=0x3651d00) at ../../src/peer/peer.cpp:538
#16 0x00007f05de296995 in bt::PeerManager::update (this=0x7f05b00934e0) at ../../src/peer/peermanager.cpp:144
#17 0x00007f05de2c88a4 in bt::TorrentControl::update (this=0x7f05b009d3d0) at ../../src/torrent/torrentcontrol.cpp:163
#18 0x00000000004289fb in kt::Core::update (this=0x2713810) at ../../ktorrent/core.cpp:1030
#19 0x0000000000431222 in kt::Core::qt_metacall (this=0x2713810, _c=QMetaObject::InvokeMetaMethod, _id=198, _a=0x7fff6ee7f8d0) at ./core.moc:167
#20 0x00007f05dbdb2b27 in QMetaObject::activate (sender=0x2713838, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7c2) at kernel/qobject.cpp:3280
#21 0x00007f05dbdac8f9 in QObject::event (this=0x2713838, e=0x7f05c0007000) at kernel/qobject.cpp:1183
#22 0x00007f05daee4fdc in QApplicationPrivate::notify_helper (this=0x24b0870, receiver=0x2713838, e=0x7fff6ee80000) at kernel/qapplication.cpp:4396
#23 0x00007f05daeeaaed in QApplication::notify (this=0x7fff6ee80330, receiver=0x2713838, e=0x7fff6ee80000) at kernel/qapplication.cpp:4277
#24 0x0000000000437d1a in kt::App::notify (this=0x48bb675, receiver=0x7f05c0007000, event=0x3ffb) at ../../ktorrent/app.cpp:97
#25 0x00007f05dbd9acdc in QCoreApplication::notifyInternal (this=0x7fff6ee80330, receiver=0x2713838, event=0x7fff6ee80000) at kernel/qcoreapplication.cpp:732
#26 0x00007f05dbdca6f2 in sendEvent (this=0x24b7870) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QTimerInfoList::activateTimers (this=0x24b7870) at kernel/qeventdispatcher_unix.cpp:602
#28 0x00007f05dbdc74c8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#29 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#30 0x00007f05d513c342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f05d51402a8 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f05d514045c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f05dbdc7193 in QEventDispatcherGlib::processEvents (this=0x2481320, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x00007f05daf97a4e in QGuiEventDispatcherGlib::processEvents (this=0x48bb675, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f05dbd99a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f05dbd99dec in QEventLoop::exec (this=0x7fff6ee802a0, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f05dbd9debb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x0000000000426a8b in main (argc=<value optimized out>, argv=<value optimized out>) at ../../ktorrent/main.cpp:176

Possible duplicates by query: bug 256348, bug 256345, bug 255263, bug 254562, bug 253893.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-11-13 18:31:39 UTC

*** This bug has been marked as a duplicate of bug 247984 ***