Bug 260359 - Segmentataaion fault when set the limit for down/up load
Summary: Segmentataaion fault when set the limit for down/up load
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-17 12:02 UTC by rkumaram
Modified: 2010-12-17 17:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rkumaram 2010-12-17 12:02:40 UTC
Application: ktorrent (3.3.4)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.30.10-105.2.23.fc11.i686.PAE i686
Distribution: "Fedora release 11 (Leonidas)"

-- Information about the crash:
I tried to limit the upload/download limit for t torrents  and got SEG fault

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a5780 (LWP 13626))]

Thread 4 (Thread 0xb14ffb70 (LWP 13667)):
#0  0x0037f424 in __kernel_vsyscall ()
#1  0x0078c356 in gettimeofday () from /lib/libc.so.6
#2  0x078a8b25 in bt::Now () at /usr/src/debug/ktorrent-3.3.4/libbtcore/util/functions.cpp:171
#3  0x078be26a in net::DownloadThread::update (this=0x9a80d50) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/downloadthread.cpp:65
#4  0x078bec68 in net::NetworkThread::run (this=0x9a80d50) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/networkthread.cpp:48
#5  0x06b0cc0e in QThreadPrivate::start (arg=0x9a80d50) at thread/qthread_unix.cpp:248
#6  0x008a58f5 in start_thread (arg=0xb14ffb70) at pthread_create.c:297
#7  0x007dafce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xb0afeb70 (LWP 13668)):
#0  0x0037f424 in __kernel_vsyscall ()
#1  0x008a9f85 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x06b0db77 in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#4  0x078bd9ad in net::UploadThread::update (this=0x9a810b0) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/uploadthread.cpp:73
#5  0x078bec68 in net::NetworkThread::run (this=0x9a810b0) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/networkthread.cpp:48
#6  0x06b0cc0e in QThreadPrivate::start (arg=0x9a810b0) at thread/qthread_unix.cpp:248
#7  0x008a58f5 in start_thread (arg=0xb0afeb70) at pthread_create.c:297
#8  0x007dafce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb00fdb70 (LWP 13669)):
#0  0x0037f424 in __kernel_vsyscall ()
#1  0x008a9f85 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x06b0db77 in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#4  0x078c210a in net::ReverseResolverThread::run (this=0xa0d28d0) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/reverseresolver.cpp:123
#5  0x06b0cc0e in QThreadPrivate::start (arg=0xa0d28d0) at thread/qthread_unix.cpp:248
#6  0x008a58f5 in start_thread (arg=0xb00fdb70) at pthread_create.c:297
#7  0x007dafce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77a5780 (LWP 13626)):
[KCrash Handler]
#6  memcpy () at ../sysdeps/i386/i686/memcpy.S:100
#7  0x07d5f336 in Private (sec=<value optimized out>, from=<value optimized out>, this=<value optimized out>) at /usr/include/bits/string3.h:52
#8  QCA::MemoryRegion::MemoryRegion (sec=<value optimized out>, from=<value optimized out>, this=<value optimized out>) at qca_tools.cpp:445
#9  0x07d77947 in QCA::Hash::update (this=0xa7d1ed0, a=@0xbfa4bd9c) at qca_basic.cpp:215
#10 0x078a705f in bt::SHA1HashGen::update (this=0xa64a988, data=0xb573b9e1 "4\332\310\17\372", len=16384) at /usr/src/debug/ktorrent-3.3.4/libbtcore/util/sha1hashgen.cpp:240
#11 0x078dfe8e in bt::ChunkDownload::updateHash (this=0xa64a918) at /usr/src/debug/ktorrent-3.3.4/libbtcore/download/chunkdownload.cpp:579
#12 0x078e0d7e in bt::ChunkDownload::piece (this=0xa64a918, p=@0xbfa4bf4c, ok=@0xbfa4bebf) at /usr/src/debug/ktorrent-3.3.4/libbtcore/download/chunkdownload.cpp:145
#13 0x078e7ad9 in bt::Downloader::pieceReceived (this=0xa33e188, p=@0xbfa4bf4c) at /usr/src/debug/ktorrent-3.3.4/libbtcore/download/downloader.cpp:126
#14 0x078cf87f in bt::PeerManager::pieceReceived (this=0xa2d0b08, p=@0xbfa4bf4c) at /usr/src/debug/ktorrent-3.3.4/libbtcore/peer/peermanager.cpp:677
#15 0x078cdfb7 in bt::Peer::packetReady (this=0xa4238a0, packet=0xa251290 "\a", len=14) at /usr/src/debug/ktorrent-3.3.4/libbtcore/peer/peer.cpp:268
#16 0x078d7e19 in bt::PacketReader::update (this=0xa0d5e60) at /usr/src/debug/ktorrent-3.3.4/libbtcore/peer/packetreader.cpp:141
#17 0x078cdcf9 in bt::Peer::update (this=0xa4238a0) at /usr/src/debug/ktorrent-3.3.4/libbtcore/peer/peer.cpp:462
#18 0x078d1cee in bt::PeerManager::update (this=0xa2d0b08) at /usr/src/debug/ktorrent-3.3.4/libbtcore/peer/peermanager.cpp:119
#19 0x0790370d in bt::TorrentControl::update (this=0xa2d01e8) at /usr/src/debug/ktorrent-3.3.4/libbtcore/torrent/torrentcontrol.cpp:150
#20 0x0806f703 in kt::Core::update (this=0x9cd94e0) at /usr/src/debug/ktorrent-3.3.4/ktorrent/core.cpp:849
#21 0x08075948 in kt::Core::qt_metacall (this=0x9cd94e0, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfa4c23c) at /usr/src/debug/ktorrent-3.3.4/i586-redhat-linux-gnu/ktorrent/core.moc:149
#22 0x06c145ea in QMetaObject::metacall (object=0x9cd94e0, cl=3705, idx=21, argv=0xbfa4c23c) at kernel/qmetaobject.cpp:237
#23 0x06c22da5 in QMetaObject::activate (sender=0x9cd94f4, m=0x6d23a24, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#24 0x06c74447 in QTimer::timeout (this=0x9cd94f4) at .moc/release-shared/moc_qtimer.cpp:134
#25 0x06c2af1e in QTimer::timerEvent (this=0x9cd94f4, e=0xbfa4c770) at kernel/qtimer.cpp:271
#26 0x06c1fc04 in QObject::event (this=0x9cd94f4, e=0xa108348) at kernel/qobject.cpp:1212
#27 0x02637c4c in QApplicationPrivate::notify_helper (this=0x9aa2ac8, receiver=0x9cd94f4, e=0xbfa4c770) at kernel/qapplication.cpp:4300
#28 0x0263e8ee in QApplication::notify (this=0xbfa4cac4, receiver=0x9cd94f4, e=0xbfa4c770) at kernel/qapplication.cpp:3704
#29 0x0315a4aa in KApplication::notify (this=0xbfa4cac4, receiver=0x9cd94f4, event=0xbfa4c770) at /usr/src/debug/kdelibs-4.4.3/kdeui/kernel/kapplication.cpp:302
#30 0x06c0f23b in QCoreApplication::notifyInternal (this=0xbfa4cac4, receiver=0x9cd94f4, event=0xbfa4c770) at kernel/qcoreapplication.cpp:704
#31 0x06c3e5fe in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#32 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:603
#33 0x06c3b267 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#34 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#35 0x00a86308 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00a899e0 in ?? () from /lib/libglib-2.0.so.0
#37 0x00a89b13 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x06c3af25 in QEventDispatcherGlib::processEvents (this=0x9a7fb50, flags={i = 36}) at kernel/qeventdispatcher_glib.cpp:412
#39 0x026f5ab5 in QGuiEventDispatcherGlib::processEvents (this=0x9a7fb50, flags={i = 36}) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x06c0d849 in QEventLoop::processEvents (this=0xbfa4ca34, flags={i = 36}) at kernel/qeventloop.cpp:149
#41 0x06c0dc9a in QEventLoop::exec (this=0xbfa4ca34, flags={i = 0}) at kernel/qeventloop.cpp:201
#42 0x06c1041f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x02637cf7 in QApplication::exec () at kernel/qapplication.cpp:3579
#44 0x080653c1 in main (argc=2, argv=0xbfa4ce94) at /usr/src/debug/ktorrent-3.3.4/ktorrent/main.cpp:172

Possible duplicates by query: bug 258765, bug 258248, bug 257314, bug 256822, bug 256348.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-17 17:25:00 UTC
[Comment from a bug triager]
This is fixed in the latest application version.
Merging with bug 247984. Thanks

*** This bug has been marked as a duplicate of bug 247984 ***