Bug 260253 - ktorrrent crashes
Summary: ktorrrent crashes
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-16 10:13 UTC by carokeh
Modified: 2010-12-16 18:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description carokeh 2010-12-16 10:13:15 UTC
Application: ktorrent (3.3.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-26-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
every time i was doing nothing more than surfing with firefox and dowloading with ktorrent in the beginning it only crashed once a while now everytime i start it..

The crash can be reproduced every time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0xb778b710 (LWP 1676))]

Thread 4 (Thread 0xb60f2b70 (LWP 1694)):
#0  0x003bc422 in __kernel_vsyscall ()
#1  0x08c15b86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x009ac982 in net::DownloadThread::waitForSocketReady (this=0x9c89000) at ../../libbtcore/net/downloadthread.cpp:188
#3  0x009aca4f in net::DownloadThread::update (this=0x9c89000) at ../../libbtcore/net/downloadthread.cpp:53
#4  0x009ad6b8 in net::NetworkThread::run (this=0x9c89000) at ../../libbtcore/net/networkthread.cpp:48
#5  0x02eed32e in QThreadPrivate::start (arg=0x9c89000) at thread/qthread_unix.cpp:248
#6  0x0015a96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x08c23a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xb553ab70 (LWP 1695)):
#0  0x003bc422 in __kernel_vsyscall ()
#1  0x0015f015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x02eee287 in QWaitConditionPrivate::wait (this=0x9c89398, mutex=0x9c8939c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x9c89398, mutex=0x9c8939c, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x009ac3a9 in net::UploadThread::update (this=0x9c89360) at ../../libbtcore/net/uploadthread.cpp:73
#5  0x009ad6b8 in net::NetworkThread::run (this=0x9c89360) at ../../libbtcore/net/networkthread.cpp:48
#6  0x02eed32e in QThreadPrivate::start (arg=0x9c89360) at thread/qthread_unix.cpp:248
#7  0x0015a96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x08c23a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb4d39b70 (LWP 1696)):
#0  0x003bc422 in __kernel_vsyscall ()
#1  0x08c15b86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x01412718 in ?? () from /lib/tls/i686/cmov/libresolv.so.2
#3  0x014108a3 in __libc_res_nquery () from /lib/tls/i686/cmov/libresolv.so.2
#4  0x034cbf73 in _nss_dns_gethostbyaddr2_r () from /lib/tls/i686/cmov/libnss_dns.so.2
#5  0x034cc0ca in _nss_dns_gethostbyaddr_r () from /lib/tls/i686/cmov/libnss_dns.so.2
#6  0x08c3a36b in gethostbyaddr_r () from /lib/tls/i686/cmov/libc.so.6
#7  0x08c3f5db in getnameinfo () from /lib/tls/i686/cmov/libc.so.6
#8  0x009b092b in net::ReverseResolver::resolve (this=0xa0de520, addr=...) at ../../libbtcore/net/reverseresolver.cpp:64
#9  0x009b09c3 in net::ReverseResolver::run (this=0xa0de520) at ../../libbtcore/net/reverseresolver.cpp:73
#10 0x009b0ac7 in net::ReverseResolverThread::run (this=0xa0b55c0) at ../../libbtcore/net/reverseresolver.cpp:118
#11 0x02eed32e in QThreadPrivate::start (arg=0xa0b55c0) at thread/qthread_unix.cpp:248
#12 0x0015a96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x08c23a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb778b710 (LWP 1676)):
[KCrash Handler]
#6  0x08bcafc6 in ?? () from /lib/tls/i686/cmov/libc.so.6
#7  0xbffb211c in ?? ()
#8  0x00ecf167 in QCA::Hash::update(QByteArray const&) () from /usr/lib/libqca.so.2
#9  0x0099618f in bt::SHA1HashGen::update (this=0x9e7c240, 
    data=0xb5543000 "\224\003\207R\373z\\$\216\252\376\376\216\277*\352\251e}\177\241\061\"\354\033Qg\033K\234\261rC\305\245~\366\306\367T\337l3\235\207\020j#\367v^G'\372^C\244\260\271\313\275:&\003\334W\364\345\300\302\322a\343t\030\n\003\vDv]z%B+\376|!U\267P\n\225\003\061\220\232+\335.%x!\365]\267i\371\375W\346\066\340\272\336\373S\343\225z\364\210\230G\377\346\027X\345\371\210e\340SZ]=%\333\205\305\370\303\215+\360", len=16384) at ../../libbtcore/util/sha1hashgen.cpp:240
#10 0x009ceb7e in bt::ChunkDownload::updateHash (this=0x9e7c1d0) at ../../libbtcore/download/chunkdownload.cpp:579
#11 0x009d040d in bt::ChunkDownload::piece (this=0x9e7c1d0, p=..., ok=@0xbffb225f) at ../../libbtcore/download/chunkdownload.cpp:145
#12 0x009d6af9 in bt::Downloader::pieceReceived (this=0x9e27ea8, p=...) at ../../libbtcore/download/downloader.cpp:126
#13 0x009be41f in bt::PeerManager::pieceReceived (this=0xb5765470, p=...) at ../../libbtcore/peer/peermanager.cpp:677
#14 0x009bcabf in bt::Peer::packetReady (this=0xa0b52a0, packet=0xb1e67308 "\a", len=16393) at ../../libbtcore/peer/peer.cpp:268
#15 0x009c6ba9 in bt::PacketReader::update (this=0xa0b4d78) at ../../libbtcore/peer/packetreader.cpp:141
#16 0x009bc409 in bt::Peer::update (this=0xa0b52a0) at ../../libbtcore/peer/peer.cpp:462
#17 0x009c0886 in bt::PeerManager::update (this=0xb5765470) at ../../libbtcore/peer/peermanager.cpp:119
#18 0x009f297d in bt::TorrentControl::update (this=0xb5762bf8) at ../../libbtcore/torrent/torrentcontrol.cpp:150
#19 0x08071a63 in kt::Core::update (this=0xb5702a20) at ../../ktorrent/core.cpp:849
#20 0x08077308 in kt::Core::qt_metacall (this=0xb5702a20, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbffb25dc) at ./core.moc:155
#21 0x02ff4c9a in QMetaObject::metacall (object=0xb5702a20, cl=3072, idx=21, argv=0xbffb25dc) at kernel/qmetaobject.cpp:237
#22 0x030033d5 in QMetaObject::activate (sender=0xb5702a34, m=0x31035a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#23 0x03054aa7 in QTimer::timeout (this=0xb5702a34) at .moc/release-shared/moc_qtimer.cpp:134
#24 0x0300b60e in QTimer::timerEvent (this=0xb5702a34, e=0xbffb2b10) at kernel/qtimer.cpp:271
#25 0x03000254 in QObject::event (this=0xb5702a34, e=0xb57432f8) at kernel/qobject.cpp:1212
#26 0x076a44dc in QApplicationPrivate::notify_helper (this=0x9cb0830, receiver=0xb5702a34, e=0xbffb2b10) at kernel/qapplication.cpp:4300
#27 0x076ab05e in QApplication::notify (this=0xbffb2e64, receiver=0xb5702a34, e=0xbffb2b10) at kernel/qapplication.cpp:3704
#28 0x00c7ef2a in KApplication::notify (this=0xbffb2e64, receiver=0xb5702a34, event=0xbffb2b10) at ../../kdeui/kernel/kapplication.cpp:302
#29 0x02fefa3b in QCoreApplication::notifyInternal (this=0xbffb2e64, receiver=0xb5702a34, event=0xbffb2b10) at kernel/qcoreapplication.cpp:704
#30 0x0301ed66 in QCoreApplication::sendEvent (this=0x9cb3734) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QTimerInfoList::activateTimers (this=0x9cb3734) at kernel/qeventdispatcher_unix.cpp:603
#32 0x0301b917 in timerSourceDispatch (source=0x9cb3768) at kernel/qeventdispatcher_glib.cpp:184
#33 idleTimerSourceDispatch (source=0x9cb3768) at kernel/qeventdispatcher_glib.cpp:231
#34 0x0126f5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x012732d8 in ?? () from /lib/libglib-2.0.so.0
#36 0x012734b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x0301b60f in QEventDispatcherGlib::processEvents (this=0x9c87e78, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#38 0x07764135 in QGuiEventDispatcherGlib::processEvents (this=0x9c87e78, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x02fee059 in QEventLoop::processEvents (this=0xbffb2dd4, flags=) at kernel/qeventloop.cpp:149
#40 0x02fee4aa in QEventLoop::exec (this=0xbffb2dd4, flags=...) at kernel/qeventloop.cpp:201
#41 0x02ff269f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#42 0x076a4577 in QApplication::exec () at kernel/qapplication.cpp:3579
#43 0x08067a51 in main (argc=5, argv=0xbffb3234) at ../../ktorrent/main.cpp:172

Possible duplicates by query: bug 258765, bug 258341, bug 257617, bug 257314, bug 256822.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-12-16 18:00:41 UTC

*** This bug has been marked as a duplicate of bug 247984 ***