Bug 255577 - Ktorrent crash during overnight
Summary: Ktorrent crash during overnight
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-29 12:50 UTC by bilal32
Modified: 2010-10-29 18:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bilal32 2010-10-29 12:50:28 UTC
Application: ktorrent (4.0.2)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.36-0.slh.1-aptosid-686 i686
Distribution (Platform): Debian unstable

-- Information about the crash:
Ktorrent runs normal during the day, but in the morning, there's a crash error message.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Bus error
[Current thread is 1 (Thread 0xb4c27710 (LWP 2775))]

Thread 5 (Thread 0xb2e21b70 (LWP 2785)):
#0  0xb53dbe16 in clock_gettime () from /lib/i686/cmov/librt.so.1
#1  0xb6a641ab in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0xb6a69405 in QTimerInfoList::updateCurrentTime (this=0x88bee34) at kernel/qeventdispatcher_unix.cpp:340
#3  0xb6a6944a in QTimerInfoList::timerWait (this=0x88bee34, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0xb6a672b8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb2e210cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0xb534d7da in IA__g_main_context_prepare (context=0x88bebc0, priority=0xb2e2114c) at /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/glib/gmain.c:2280
#6  0xb534dbf9 in g_main_context_iterate (context=0x88bebc0, block=<value optimized out>, dispatch=1, self=0x88be9c0) at /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/glib/gmain.c:2571
#7  0xb534e1c8 in IA__g_main_context_iteration (context=0x88bebc0, may_block=1) at /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/glib/gmain.c:2654
#8  0xb6a670af in QEventDispatcherGlib::processEvents (this=0x89a7098, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#9  0xb6a39ae9 in QEventLoop::processEvents (this=0xb2e21290, flags=) at kernel/qeventloop.cpp:149
#10 0xb6a39f3a in QEventLoop::exec (this=0xb2e21290, flags=...) at kernel/qeventloop.cpp:201
#11 0xb693c629 in QThread::exec (this=0x89a7198) at thread/qthread.cpp:487
#12 0xb783403e in utp::UTPServerThread::run (this=0x89a7198) at ../../src/utp/utpserverthread.cpp:44
#13 0xb693efbe in QThreadPrivate::start (arg=0x89a7198) at thread/qthread_unix.cpp:248
#14 0xb545c955 in start_thread () from /lib/i686/cmov/libpthread.so.0
#15 0xb5c77e7e in clone () from /lib/i686/cmov/libc.so.6

Thread 4 (Thread 0xa9532b70 (LWP 3152)):
#0  0xb78be424 in __kernel_vsyscall ()
#1  0xb5461482 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb5c84e64 in pthread_cond_timedwait () from /lib/i686/cmov/libc.so.6
#3  0xb693e8c1 in thread_sleep (ti=0x1) at thread/qthread_unix.cpp:398
#4  0xb693ea03 in QThread::msleep (msecs=50) at thread/qthread_unix.cpp:424
#5  0xb778fa62 in net::DownloadThread::update (this=0x88928b0) at ../../src/net/downloadthread.cpp:91
#6  0xb77903d8 in net::NetworkThread::run (this=0x88928b0) at ../../src/net/networkthread.cpp:48
#7  0xb693efbe in QThreadPrivate::start (arg=0x88928b0) at thread/qthread_unix.cpp:248
#8  0xb545c955 in start_thread () from /lib/i686/cmov/libpthread.so.0
#9  0xb5c77e7e in clone () from /lib/i686/cmov/libc.so.6

Thread 3 (Thread 0xa8d31b70 (LWP 3153)):
#0  0xb78be424 in __kernel_vsyscall ()
#1  0xb5461482 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb5c84e64 in pthread_cond_timedwait () from /lib/i686/cmov/libc.so.6
#3  0xb693e8c1 in thread_sleep (ti=0x1) at thread/qthread_unix.cpp:398
#4  0xb693ea03 in QThread::msleep (msecs=50) at thread/qthread_unix.cpp:424
#5  0xb778efb2 in net::UploadThread::update (this=0x8892cb8) at ../../src/net/uploadthread.cpp:89
#6  0xb77903d8 in net::NetworkThread::run (this=0x8892cb8) at ../../src/net/networkthread.cpp:48
#7  0xb693efbe in QThreadPrivate::start (arg=0x8892cb8) at thread/qthread_unix.cpp:248
#8  0xb545c955 in start_thread () from /lib/i686/cmov/libpthread.so.0
#9  0xb5c77e7e in clone () from /lib/i686/cmov/libc.so.6

Thread 2 (Thread 0xa8530b70 (LWP 3154)):
#0  0xb78be424 in __kernel_vsyscall ()
#1  0xb5460f7f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb5c84e0d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
#3  0xb693ffb7 in wait (this=0xa410a3c, mutex=0xa410a38, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0xa410a3c, mutex=0xa410a38, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb77937da in net::ReverseResolverThread::run (this=0xa410a30) at ../../src/net/reverseresolver.cpp:123
#6  0xb693efbe in QThreadPrivate::start (arg=0xa410a30) at thread/qthread_unix.cpp:248
#7  0xb545c955 in start_thread () from /lib/i686/cmov/libpthread.so.0
#8  0xb5c77e7e in clone () from /lib/i686/cmov/libc.so.6

Thread 1 (Thread 0xb4c27710 (LWP 2775)):
[KCrash Handler]
#6  0xb5c20b31 in memcpy () from /lib/i686/cmov/libc.so.6
#7  0xb77fe696 in bt::Chunk::readPiece (this=0x9ab87f0, off=0, len=16384, data=0xad6e7bd "") at ../../src/diskio/chunk.cpp:43
#8  0xb77b129a in bt::Packet::Packet (this=0xc179a10, index=9555, begin=0, len=16384, ch=0x9ab87f0) at ../../src/download/packet.cpp:85
#9  0xb77abb9f in bt::PacketWriter::sendChunk (this=0xc4065a0, index=9555, begin=0, len=16384, ch=0x9ab87f0) at ../../src/peer/packetwriter.cpp:195
#10 0xb77aa3dc in bt::PeerUploader::update (this=0xb4265d8, cman=..., opt_unchoked=7394) at ../../src/peer/peeruploader.cpp:83
#11 0xb77d0f38 in bt::Uploader::update (this=0x9adc080, opt_unchoked=7394) at ../../src/torrent/uploader.cpp:48
#12 0xb77d9bc1 in bt::TorrentControl::update (this=0x99b32f0) at ../../src/torrent/torrentcontrol.cpp:173
#13 0x0806b353 in kt::Core::update (this=0x88b1990) at ../../ktorrent/core.cpp:1023
#14 0x0807354d in kt::Core::qt_metacall (this=0x88b1990, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8062ec) at ./core.moc:167
#15 0xb6a407aa in QMetaObject::metacall (object=0x88b1990, cl=4096, idx=22, argv=0xbf8062ec) at kernel/qmetaobject.cpp:237
#16 0xb6a4f1bb in QMetaObject::activate (sender=0x88b19a4, m=0xb6b4f724, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#17 0xb6aa17d7 in QTimer::timeout (this=0x88b19a4) at .moc/release-shared/moc_qtimer.cpp:134
#18 0xb6a5709e in QTimer::timerEvent (this=0x88b19a4, e=0xbf8067f0) at kernel/qtimer.cpp:271
#19 0xb6a4bc54 in QObject::event (this=0x88b19a4, e=0xbf805f9c) at kernel/qobject.cpp:1212
#20 0xb5f845cc in QApplicationPrivate::notify_helper (this=0x88b5030, receiver=0x88b19a4, e=0xbf8067f0) at kernel/qapplication.cpp:4302
#21 0xb5f8b15e in QApplication::notify (this=0xbf806b40, receiver=0x88b19a4, e=0xbf8067f0) at kernel/qapplication.cpp:3706
#22 0x08079dac in kt::App::notify (this=0x1000, receiver=0xbf805f9c, event=0x0) at ../../ktorrent/app.cpp:97
#23 0xb6a3b4cb in QCoreApplication::notifyInternal (this=0xbf806b40, receiver=0x88b19a4, event=0xbf8067f0) at kernel/qcoreapplication.cpp:726
#24 0xb6a6a796 in sendEvent (this=0x88b7e34) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QTimerInfoList::activateTimers (this=0x88b7e34) at kernel/qeventdispatcher_unix.cpp:603
#26 0xb6a673b7 in timerSourceDispatch (source=0x88b7e68) at kernel/qeventdispatcher_glib.cpp:184
#27 idleTimerSourceDispatch (source=0x88b7e68) at kernel/qeventdispatcher_glib.cpp:231
#28 0xb534a305 in g_main_dispatch (context=0x88b7090) at /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/glib/gmain.c:1960
#29 IA__g_main_context_dispatch (context=0x88b7090) at /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/glib/gmain.c:2513
#30 0xb534dfe8 in g_main_context_iterate (context=0x88b7090, block=<value optimized out>, dispatch=1, self=0x88b3a50) at /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/glib/gmain.c:2591
#31 0xb534e1c8 in IA__g_main_context_iteration (context=0x88b7090, may_block=1) at /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/glib/gmain.c:2654
#32 0xb6a67075 in QEventDispatcherGlib::processEvents (this=0x8891640, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#33 0xb6042ed5 in QGuiEventDispatcherGlib::processEvents (this=0x8891640, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0xb6a39ae9 in QEventLoop::processEvents (this=0xbf806ab4, flags=) at kernel/qeventloop.cpp:149
#35 0xb6a39f3a in QEventLoop::exec (this=0xbf806ab4, flags=...) at kernel/qeventloop.cpp:201
#36 0xb6a3f16f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#37 0xb5f84667 in QApplication::exec () at kernel/qapplication.cpp:3581
#38 0x080692a1 in main (argc=3, argv=0xbf806f44) at ../../ktorrent/main.cpp:176

Reported using DrKonqi
Comment 1 Joris Guisson 2010-10-29 18:09:59 UTC

*** This bug has been marked as a duplicate of bug 247984 ***